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Thank you for purchasing the Smart
Loader Package SLP-D50/SLP-H21 for
Module Type Controller DMC50/AHC2001.
This manual contains information for
ensuring correct use of the SLP-D50/SLP-
H21.
This manual is prepared assuming that the
reader has an understanding of ISaGRAF.
This manual should be read by those who
develop and maintain applications for
equipment that use SLP-D50/SLP-H21.
As this manual is required for initialization,
changing the setup and troubleshooting,
this manual should be kept nearby for
handy reference.
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This product has been designed, developed and manufactured for general-purpose
application in machinery and equipment. Accordingly, when used in applications
outlined below, special care should be taken to implement a fail-safe and/or redundant
design concept as well as a periodic maintenance program.

• Safety devices for plant worker protection
• Start/stop control devices for transportation and material handling machines
• Aeronautical/aerospace machines
• Control devices for nuclear reactors

Never use this product in applications where human safety may be put at risk.

RESTRICTIONS ON USE

Ethernet® is a registered trademark of Xerox Corp.
ISaGRAF® is a registered trademark of ICS Triplex ISaGRAF.
Microsoft® is a registered trademark of Microsoft Corporation in the U.S. and
other countries.
Other company names and product names listed in this manual are registered
trademarks or trademarks of respective companies.

REQUEST

©2002 Yamatake Corporation ALL RIGHTS RESERVED

Ensure that this User's Manual is handed over to the user before the
product is used. 

Copying or duplicating this User's Manual in part or in whole is forbid-
den. The information and specifications in this User's Manual are sub-
ject to change without notice.

Considerable effort has been made to ensure that this User's Manual is
free from inaccuracies and omissions. 
If you should find any inaccuracies or omissions, please contact
Yamatake Corporation.

In no event is Yamatake Corporation liable to anyone for any indirect,
special or consequential damages as a result of using this product.



Unpacking
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Check the following items when opening the Smart Loader Package SLP-D50J50 for Module Type
Controller DMC50 or the Smart Loader Package SLP-H21J50 for Module Type Controller AHC2001:

1. Check the model No. to make sure that you have received the product that you ordered.
2. Check the contents of the package for any apparent physical damage.
3. Check the contents of the package against the Package List to make sure that all accessories are included

in the package.
After unpacking, handle the contents of the package carefully to prevent damage or loss.
If any damage is found or any of the package contents are missing, immediately contact your dealer.

● SLP-D50J50

Name Q'ty Contents

ISaGRAF v3.5x CD-ROM 1 This CD contains the ISaGRAF installer 
Install CD and ISaGRAF online manuals. They can

be  installed using a relevant installer.
SLP-D50 CD-ROM 1 This CD consists of six directories Install
Install CD CD (folders), "SLPD50", "Project", "Docs",

"Acrobat", "USB" and "ISaGRAF".
"Docs" contains the instruction manuals
for SLPD50/SLP-H21, as well as a set of
manuals for DMC50 and AHC2001 in the
PDF format in Japanese and English
languages.
Japanese and English manuals are
separately stored in the sub directory jpn
and enu, respectively.
"Project" contains an installer for the
sample projects.
"Acrobat" contains an installer for the
Acrobat reader used to read the PDF
documents contained in "Docs".
"USB" contains AHC2001 USB drivers.
"ISaGRAF" contains ISaGRAF related
patch software.
"SETUP.EXE" ("AcroReader
51_ENU.exe" for Acrobat) is found in the
directories other than "Docs" and "USB".
Run each of them to install the relevant
application or data files.
DMC50 project, as well as AHC2001
project with up to 64 I/O variable points
can then be edited.

Protection key 1 This protection key is connected to the
USB port of your computer.
With this protection key, up to 64 I/O
variables can be used.

Loader cable*1 1 This cable is used to connect DMC50.
ICS Triplex ISaGRAF 1 Before starting the installation, the user 
PRODUCT LINE (Japanese/ must thoroughly read two license 
SOFTWARE LICENSE English) agreements shown on the left and 
AGREEMENT "Important notice about ISaGRAF"of the 
SOFTWARE LICENSE 1 installation guide to fully understand their 
AGREEMENT (Japanese/ contents and agree with them.

English)

Installation guide 1 Before starting the installation, the user
must thoroughly read this guide to fully
understand its contents.

Customer Registration 1 After you install the software, please fill
Card out and return this card immediately.

· · · · · · · · · · · ·
· · · · · · · · · · · ·
· · · · · · · · · · · ·
· · · · · · · · · · · ·

· · · · · · · · · 
· · · · · · · · · 
· · · · · · · · · 
· · · · · · · · · 

Installation guide

· · · · · · · · · 
· · · · · · · · · 
· · · · · · · · · 
· · · · · · · · · 

*1 USB cable and D-DUB 9-pin RS-232C cross-cable necessary to connect the AHC2001
controller are not included in this package. The user must prepare these cables.
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● SLP-H21J50

Name Q'ty Contents

ISaGRAF v3.5x CD-ROM 1 This CD contains the ISaGRAF installer 
Install CD and ISaGRAF online manuals. They can

be  installed using a relevant installer.

SLP-H21 CD-ROM 1 This CD consists of six directories Install
Install CD CD (folders), "SLPD50", "Project", "Docs",

"Acrobat", "USB" and "ISaGRAF".
"Docs" contains the instruction manuals
for SLPD50/SLP-H21, as well as a set of
manuals for DMC50 and AHC2001 in the
PDF format in Japanese and English
languages.
Japanese and English manuals are
separately stored in the sub directory jpn
and enu, respectively.
"Project" contains an installer for the
sample projects.
"Acrobat" contains an installer for the
Acrobat reader used to read the PDF
documents contained in "Docs".
"USB" contains AHC2001 USB drivers.
"ISaGRAF" contains ISaGRAF related
patch software.
"SETUP.EXE" ("AcroReader
51_ENU.exe" for Acrobat) is found in the
directories other than "Docs" and "USB".
Run each of them to install the relevant
application or data files.
With the protection key combined, the
AHC2001 project with up to 256 I/O
variable points, as well as DMC50 project
can be edited.

Protection key 1 This protection key is connected to the
USB port of your computer.
With this protection key, up to 256 I/O
variables can be used.

ICS Triplex ISaGRAF 1 Before starting the installation, the user 
PRODUCT LINE (Japanese/ must thoroughly read two license 
SOFTWARE LICENSE English) agreements shown on the left and 
AGREEMENT "Important notice about ISaGRAF"of the 

SOFTWARE LICENSE 1 installation guide to fully understand their 
AGREEMENT (Japanese/) contents and agree with them..

English)

Installation guide 1 Before starting the installation, the user
must thoroughly read this guide to fully
understand its contents.

Customer Registration 1 After you install the software, please fill
Card out and return this card immediately.

· · · · · · · · · · · ·
· · · · · · · · · · · ·
· · · · · · · · · · · ·
· · · · · · · · · · · ·

*1 USB cable and D-DUB 9-pin RS-232C cross-cable necessary to connect the AHC2001
controller are not included in this package. The user must prepare these cables.

Installation guide

· · · · · · · · · 
· · · · · · · · · 
· · · · · · · · · 
· · · · · · · · · 

· · · · · · · · · 
· · · · · · · · · 
· · · · · · · · · 
· · · · · · · · · 



The Role of This Manual
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Ten different manuals in total are available for DMC50/AHC2001. Read each manual
according to your specific requirements. Following is a brief outline of each of the manuals.
To obtain manuals, contact Yamatake Corporation or your Yamatake dealer.

Module Type Controller DMC50 User's Manual "QuickStart"
Manual No. CP-SP-1092E

The user who operates DMC50 for the first time must read this manual
thoroughly. This manual is intended to help the user understand the
overview of the controller operation and basic operating procedures.

The manual describes the operation with various examples.  Read this
manual while using the smart loader package.

Module Type Controller DMC50 User's Manual "Installation and 
Configuration" Manual No. CP-SP-1139E

Thoroughly read this manual before designing or manufacturing the
equipment hardware using DMC50.

This manual consists of two parts, one for the control module and the other
for the communication module.It describes the installation, wiring,
specifications, and hardware troubleshooting of those controller.

Module Type Controller DMC50 User's Manual "Communications
Connection" Manual No. CP-SP-1093E

The user who uses the communication facilities of DMC50 must read this
manual thoroughly. This manual describes the communication facilities of
this controller, such as CPL communication and Ethernet communication.

Module Type Controller DMC50/AHC2001 User's Manual "Function
Block Reference" Manual No. CP-SP-1130E

Read this manual when the user designs a control system most suitable for
the user's application by utilizing DMC50 or AHC2001.

This manual describes the specifications of ISaGRAF functions and
function blocks essential to design a desired control system.

Smart Loader Package SLP-D50/SLP-H21 for Module Type Controller
DMC50/ AHC2001 User's Manual Manual No. CP-SP-1122E

This Manual.
This manual describes the operations and features of the smart loader
package SLP-D50/SLP-H21 for DMC50/AHC2001 as well as its installation
into a personal computer.  It also writes about important points
collaborating with ISaGRAF to build an application for the controller.
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SLP-D50J50 Installation Guide Manual No. CP-UM-5259E

This manual is supplied with a set of the ISaGRAH install CD and SLP-D50
install CD.

This manual describes how to install the smart loader package SLP-D50 for
the DMC50 into a personal computer.
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Module Type Controller AHC2001
Manual No. CP-UM-5225E

Thoroughly read this manual before designing or manufacturing the
equipment hardware using the AHC2001.

This manual describes the installation, wiring, specifications, and hardware
troubleshooting of the controller.

Module Type Controller AHC2001 User’s Manual
“Basic Operation” Manual No. CP-SP-1137E

Thoroughly read this manual before designing or manufacturing the
equipment hardware using the AHC2001.

This manual consists of two volumes, one for the control module and the
other for the communication module. It describes the installation, wiring,
specifications, and hardware troubleshooting of the controller.

Module Type Controller AHC2001 User’s Manual
“QuickStart” Manual No. CP-SP-1121E

The user who operates the AHC2001 for the first time must read this
manual thoroughly.  This manual is intended to help the user understand
the overview of the controller operation and basic operating procedures.

The manual describes the operation with various examples. Read this
manual while using the smart loader package.

SLP-H21J50 Installation Guide Manual No. CP-UM-5260E

This manual is supplied with a set of the ISaGRAH install CD and SLP-H21
install CD.

This manual describes how to install the smart loader package SLP-H21 for
the AHC2001 into a personal computer.

In addition to the manuals above, the "ISaGRAF User's Guide" is available as a user's

manual of ISaGRAF.
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Organization of This User's Manual

This manual is organized as follows:

Chapter 1. BEFORE STARTING OPERATION
Before starting operation of this software, thoroughly read this chapter.

This chapter describes a brief summary of features, system environment

requirements for operation, and system configuration.

Chapter 2. INSTALLATION
This chapter describes how to install this software.

Chapter 3. INVOKING AND EXITING SLP-D50, AND MAKING THE INITIAL SETUP
This chapter describes how to invoke and exit this software, and to make the initial

setup.

Chapter 4. STEPS TO OPERATE CONTROLLERS
This chapter describes the outline of the sequence necessary to operate the

DMC50/AHC2001 controllers using this software.

Chapter 5. CREATING NEW PROJECTS
This chapter describes how to create a project necessary for each  controller you

wish to set up.

Chapter 6. OPENING PROJECTS
This chapter describes how to open a project.

Chapter 7. SETTING UP THE PROJECT OPTIONS
This chapter describes how to identify the module type of each project and to set

up the communication to the module on which the contents of the project are set.

Chapter 8. PARAMETERS
This chapter describes "Parameters" , one of two kinds of data to be set on the

controller, that is, "Application program" and "Parameter".

Chapter 9. EDITING PARAMETERS
This chapter describes how to edit Parameters on the PC.

Chapter 10. WORKING WITH PARAMETERS ONLINE
This chapter describes how to access Parameters on the controller.

Chapter 11. EDITING APPLICATION PROGRAMS
This chapter describes how to edit  "Application program", one of two kinds of

data to be set on the controller, that is, "Application program" and "Parameter".
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Chapter 12. EDITING AND MONITORING THE ISAGRAF VARIABLES USING SLP-D50
This chapter describes how to edit the ISaGRAF variables and monitor variable

values using SLP-D50, one of "Application program" edit operations.

Chapter 13. COMPILING APPLICATION PROGRAMS (Make Applications)
This chapter describes how to compile the source code of an "Application

program" in order to generate the executable code.

Chapter 14. DOWNLOADING APPLICATIONS
This chapter describes how to transfer both the executable code that is compiled

from an "Application program" and "Parameters" from the PC to the

programmable controller.

Chapter 15. STARTING AND STOPPING APPLICATION PROGRAMS
This chapter describes how to start and stop the executable code of the

"Application program" on the programmable controller.

Chapter 16. ONLINE DEBUGGING OF APPLICATIONS
This chapter describes how to check whether or not the "Application program" and

"Parameters" are set and operate on the controller and as designed.

Chapter 17. CLOSING PROJECTS
This chapter describes how to close a project.

Chapter 18. MANAGING PROJECTS
This chapter describes how to manage  a project handled as one piece, such as

copying or deleting of a project.

Chapter 19. USER-DEFINED PARAMETER LIBRARY
This chapter describes how to create and manage User-defined Parameters, which

let the user  utilize data structures, such as structures or arrays in application

programs.

Chapter 20. GROUP MONITOR
This chapter describes how to monitor different kinds of data in one module, and

data in multiple modules that can be communicated at the same time, on the same

screen.

Chapter 21. TREND MONITOR
This chapter describes how to observe and record rough time series changes of

certain data.

Chapter 22. SAMPLING TRACE WIZARD
This chapter describes how to observe and record time series changes of certain

data synchronized with the control cycle.
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Chapter 23. INTEGER CONVERSION WIZARD
This chapter describes how to convert each data to integer in order to be accessed

from external systems that can not handle  non-integer data types (REAL or

TIME, etc.) used in DMC50.

Chapter 24. PATTERN WIZARD
This chapter describes how to automatically generate programs that produce one

SP pattern (profile) and events on this SP pattern.

Chapter 25. AHC2001 SPECIAL FACILITY
This chapter describes the facility, such as unit configuration setup and PLC link

format verification only used by the project for the AHC2001 controller.

Chapter 26. PATTERN FB SUPPORT FACILITY
This chapter describes the support facility for the pattern control using the pattern

FBs.

Chapter 27. OFFLINE CHARTS
This chapter describes the facility which enables the user to view the time series

graphs for data that were previously recorded by the trend monitor or sampling

trace.

Chapter 28. OTHER FEATURES
This chapter describes the features which are not described in other chapters.

Chapter 29. CAUTIONS
This chapter describes the cautions when using this software.



Terms Used in This Manual

The following terms are used in this manual.
In addition to the following terms, terms related to ISaGRAF are used without prior notice.  
For details about terms related to ISaGRAF, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.

AHC2001: AHC2001 is a module type controller. This AHC2001 controller uses the unit
configuration, different from DMC50.  CPU (main processor), AI, AO, DI, DO,
SCU (serial communication), and ENI (Ethernet) units are combined as required to
provide the user’s specific system.

AHC2001 project: AHC2001 project is a class of project which can be downloaded into AHC2001.

Application (code): Application (code) is the execution form of a project for the programmable
controller (DMC50 control module or AHC2001 controller).  Normally, an
application consists of an application program and Parameters.

Application program: Application program is an aggregate of the programs to be executed in one module
(programming units written according to the language specifications IEC61131-3
are combined).  An application program is created using ISaGRAF.

Board: In an AHC2001 project, a unit is called a "board" on the ISaGRAF I/O connection
editor.

CH200: CH200 is a high-resolution 2-loop type control module of the module type
controller DMC50.

CH400: CH400 is a high-resolution 4-loop type control module of the module type
controller DMC50.

CN200: CN200 is a Ni sensor 2-loop type control module of the module type controller
DMC50.

CN400: CN400 is a Ni sensor 4-loop type control module of the module type controller
DMC50.

COM module: COM module is the abbreviation for the communication module of the module
type controller DMC50.

Controller: A module of the DMC50 or the AHC2001 controller is referred to as controller in
this manual. (In the case of the AHC2001, multiple number of units including the
CPU unit are regarded as a controller.) If the word "controller" is used in this
document without any explanation, it refers to a module of the DMC50 or the
AHC2001 controller without specifying which.

CS200: CS200 is a special 2-loop type control module of the module type controller
DMC50.

CS400: CS400 is a special 4-loop type control module of the module type controller
DMC50.

CTRL module: CTRL module is the abbreviation for the control module of the module type
controller DMC50.

DMC50: DMC50 is a module type controller.  This DMC50, which is different from
AHC2001, is an all-in-one controller, that is,  I/O is built in the module.
Additionally, a combination of one or more control modules (CH200, CH400,
CS200, CS400) with one communication module (ME200, MR200) makes it
possible to communicate with  external systems.

DMC50 project: DMC50 project is a class of project which can be downloaded into DMC50.

FB: FB is an abbreviation of the ISaGRAF function block.

FUNC: FUNC is an abbreviation of the ISaGRAF function.

Function (Func): Function is a calculation block without internal state, which is used for the
programming in ISaGRAF.

viii
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Function block (FB): Function block is a calculation block with internal state, which is used for the
programming in ISaGRAF.

Indirect communication: Indirect communication is a communication to exchange data between a host
system and a DMC50 module through the COM module linked to that DMC50
module.  This is not available with the AHC2001 controller.

ISaGRAF: ISaGRAF creates and manages application programs, one of two kinds of the
project data.

ISaGRAF program management window:
This window manages the ISaGRAF application program sources of one project.
The window is activated from the [Edit] menu of the project window of SLP-D50.

ISaGRAF project management window:
This window is a main window of ISaGRAF and is activated from the main
window of SLP-D50.  This window operates on project groups, as well as
projects.

ISaGRAF Yamatake (Controller) Patch:
ISaGRAF Yamatake (Controller) Patch is a part of ISaGRAF customized for
Yamatake's controller.

Linked DMC50s: Linked DMC50s mean that  multiple DMC50 modules are linked  through the
connectors on the rear or by the extension cable.

Main window: This window is displayed when SLP-D50 is invoked.  This window is a MDI
parent window.

ME200: The ME200 is an Ethernet type communication module of the module type
controller DMC50.  In addition to Ethernet, this module also supports two
channels of RS-485 host communications.

Modbus connector: Modbus connector is Modbus communications router software.  (This software
controls the routing of the communication packets among ISaGRAF, SLP-D50,
and the controller.  The software is installed using the installer of  SLP-D50.)

Module address: Module address is an identifier given to a controller, and it is used by SLP-D50 to
communicate with the controller.  For DMC50, the module address is the rotary
switch No. on the module.  (Note that the rotary switch No. is represented in the
hexadecimal notation.)  This is fixed to 1 on AHC2001.

Module type: Module type is a controller type and indicates a hardware difference.  The DMC50
CTRL module consists of several module types, such as the high-resolution 2-loop
type (CH200), high-resolution 4-loop type (CH400), special 2-loop type (CS200),
and special 4-loop type (CS400), Ni sensor 2-loop type (CN200), Ni sensor 4-
loop type (CN400).  The DMC COM module consists of  the Ethernet type
(ME200) and RS-485 type (MR200).  The AHC2001 controller consists of only
one type, AHC2001.

MR200: MR200 is a RS-485 type communication module of the module type controller
DMC50.  This module supports one channel of RS-485 host communications.

Non-AHC2001 project: This project means those not used for the AHC2001 controller. Sample projects
supplied with ISaGRAF and DMC50 projects are non-AHC2001 projects. When
creating a new project, if the I/O configuration not applicable to the AHC2001
module type is specified, this project is also handled as non-AHC2001 project.
Note that non-AHC2001 projects cannot be downloaded into the AHC2001
module.

Non-DMC50 project: This project means those not used for the DMC50 controller. Sample projects
supplied with ISaGRAF and AHC2001 projects are non-DMC50 projects.  When
creating a new project, if  the I/O configuration not applicable to the DMC50
module type is specified, this project is also handled as non-DMC50 project.  Note
that non-DMC50 projects cannot be downloaded into the DMC50 module.

Parameter: Parameter is the general name of various settings that affect the operation status of
the controller and monitor data showing the operation status.  Parameters are
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classified into System Parameters, Calculation Parameters, Program Pattern
Parameters, User-defined Parameters, System Monitor Parameters, and
Calculation Monitor Parameters.  (The Parameter type definition of the User-
defined Parameter is expressed as User-defined type in this manual and SLP-
D50.)   Parameters are set and monitored using SLP-D50.  Note that ISaGRAF
uses the term "parameters" with other meanings:  (arguments of FB and FUNC,
and I/O board parameters)

POU (program organization unit):
POU is the generic name for the function, function block, and program.

Program: Program is a programming unit and is executed at the top level of the ISaGRAF
execution cycle.

Programmable controller: Programmable controller referred to in this manual is a control module of the
DMC50 or AHC2001 contrroller.  The application program can be downloaded
and executed on the controller.

Project: Project is an entity that manages the settings related to one controller. Actually a
project is a directory.  The last part of the absolute path of the directory is the
project name.  Application program source files and Parameter settings are stored
under this directory.

"Project" window: This window is a window of SLP-D50 used to set up a project.  This window is
displayed as a MDI child window.

Slot: Slot is an I/O board position in the ISaGRAF I/O connection editor.
In an AHC2001 project, the slot number is identical to the unit ID.

SLP-D50: SLP-D50 is a tool that creates and manages   Parameters, one of two kinds of the
project data.

SLP-D50 package: SLP-D50 package is Yamatake's smart loader package SLP-D50J50 for the
module type controller DMC50.  This package includes the installation guide,
ISaGRAF install CD, SLP-D50 install CD, loader cable, and two license
agreements.

SLP-D50/ISaGRAF: This expression refers to both SLP-D50 and ISaGRAF as a set.

SLP-H21 package: SLP-H21 package is Yamatake's smart loader package SLP-H21J50 for the
module type controller AHC2001. This package includes the installation guide,
ISaGRAF install CD, SLP-H21 install CD, protection key, and two license
agreements. When purchasing an optional loader cable (Yamatake’s model No.
81440793-001), the program for DMC50 can then be developed.

Type label: Type label is the label name of a Parameter type shown in the treeview of the
"Project" window.

Unit: This unit is an element making up the AHC2001 controller.  Seven kinds of units
are provided, CPU (main processor), AI, AO, DI, DO, SCU (serial
communication), and ENI (Ethernet).  Only the CPU unit can communicate with
SLP-D50 and only one CPU unit must exist in the entire system.  The unit is
shown as “board” on the ISaGRAF I/O connection editor.

Unit ID: Unit ID is an identification number given to the AHC2001 units.

Unit address: This unit address is a number showing the connection position of each AHC2001
unit.  Except for the CPU, 1, 2, … are assigned to the units starting from the unit
nearest to the CPU.  For the unit parameters (unit setup and unit status), the type
label name like “[n] unit parameter name” (n == unit ID) is shown in the “Project”
window.  This unit address is the same as the slot No. of the ISaGRAF I/O
connection editor.

V1: V1 is an abbreviation of SLP-D50 V1.* (* is a number less than 90). This is a
setup tool for DMC50 only.

V2: V2 is an abbreviation of SLP-D50 V2.* (* is a number less than 90) and V1.9*.
This is a setup tool for both AHC2001 and DMC50.



Conventions Used in This Manual
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The following conventions are used in this manual:

Handling Precaution
: Handling Precautions indicate items that the user should pay attention to

when handling SLP-D50 or IsaGRAF.

Note : Notes indicate useful information that the user might benefit by knowing.

: This indicates the item or page that the user is requested to refer to.

(1), (2), (3) : The numbers with the parenthesis indicate steps in a sequence or
indicate corresponding parts in an explanation.

[Open] button : Indicates a selection button in screens displayed on the personal
computer.

[File] : Indicates messages and menus displayed on the personal computer.
[Monitor]
[Save]

>> : This indicates the contents shown on the personal computer and unit, and
the unit status as a result of operation.

[Tab] key, [F4] key : Indicates keys on the keyboard.

[Ctrl] + [X] key : Indicates the operation of pressing the [X] key with the [Ctrl] key on the
keyboard held down.



Restrictions on Use
Unpacking
The Role of This Manual
Organization of This User's Manual
Terms Use in This Manual
Conventions Used in This Manual

Chapter 1. BEFORE STARTING OPERATION

1-1 Overview• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 1-1
■ Features • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 1-1
■ Major features added to and changed in SLP-D50V2.1 • • • • • • • • • • • • • • • • 1-2

1-2 System Environment Requirements for Operation• • • • • • • • • • • • • • • • • • • • • • • • • 1-3
■ System requirements • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 1-3
■ Hardware configuration (DMC50) • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 1-4
■ Hardware configuration (AHC2001) • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 1-4

1-2 System Configuration • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 1-5
■ System configuration diagram (DMC50) • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 1-5
■ System configuration diagram (AHC2001) • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 1-6

Chapter 2. INSTALLATION

■ Installing SLP-D50/ISaGRAF • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-1
■ Installing protection key driver • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-2
■ Installing AHC2001 USB driver • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-3

Chapter 3. INVOKING AND EXITING SLP-D50, AND MAKING THE INITIAL SETUP

3-1 Invoking SLP-D50 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 3-1
■ Selecting hardware to be edited • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 3-1
■ SLP-D50 main window • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 3-1

3-2 Making the Initial Setup • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 3-2
■ Setting up the paths • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 3-2

3-3 Exiting SLP-D50 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 3-4

Chapter 4. STEPS TO OPERATE CONTROLLERS

4-1 Project • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 4-1
4-2 Operating the DMC50 CTRL Module • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 4-2
4-3 Operating the DMC50 COM Module • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 4-3
4-4 Operating the AHC2001 Controller• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 4-4

Chapter 5. CREATING NEW PROJECTS

Contents

xii



xiii

Chapter 6. OPENING PROJECTS

6-1 Opening a Project• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 6-1
6-2 Reopening a Project • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 6-3

Chapter 7. SETTING UP THE PROJECT OPTIONS

7-1 Identifying the Module Type • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-2
■ DMC50 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-3
■ AHC2001 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-3

7-2 Setting Up the Communication Path • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-3
■ DMC50 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-4
■ AHC2001 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-4

7-3 Setting Up the Module Address • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-4
■ DMC50 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-5
■ AHC2001 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-5

7-4 Setting Up the Serial Communication• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-5
■ DMC50 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-6
■ AHC2001 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-6

7-5 Setting Up the TCP/IP Communication • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-6
7-6 Identifying the access limit level • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 7-7

Chapter 8. PARAMETERS

8-1 Classifications of Parameters• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 8-1
8-2 Selecting Parameters • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 8-4

■ Type and instance • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 8-4

Chapter 9. EDITING PARAMETERS

9-1 Online Data and Offline Data • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-2
9-2 Selecting a Cell • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-3
9-3 Editing Cell Data • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-4
9-4 Adding an Instance • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-6
9-5 Deleting an Instance • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-7
9-6 Adding Groups • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-8
9-7 Deleting Groups • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-9
9-8 Changing the Instance Name • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-10
9-9 Utilizing User-defined Types• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-11

■ Importing types from the library • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-11
■ Deleting a type • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-11
■ Editing a type • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-11
■ Exporting types to the library • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-12

9-10 Data Address of a Cell• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-13
9-11 Editing the Comment • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-14



xiv

9-12 Linearization Table Support Facility • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-15
■ Displaying the graph • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-15
■ Inserting a point • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-16
■ Deleting a point • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-16
■ Moving the decimal point position• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-17

9-13 Generating the Parameter Report • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-18
9-14 Copy & Paste (Successive Pastes) Feature • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-19

■ Area selection • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-19
■ Copy • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-20
■ Paste • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-20
■ Successive pastes• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 9-21

Chapter 10. WORKING WITH PARAMETERS ONLINE

10-1 Downloading Parameters • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 10-1
10-2 Uploading Parameters• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 10-2
10-3 Overwriting Parameters with the Uploaded Data • • • • • • • • • • • • • • • • • • • • • • • • 10-3
10-4 Changing the Parameter Display Mode• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 10-4
10-5 Monitoring Parameters • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 10-5

■ Starting and stopping monitoring • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 10-5
■ Status during monitoring • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 10-5
■ Switching parameters to monitor • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 10-5

10-6 Changing Parameter Data on the Module • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 10-6
10-7 Uploading All Parameters • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 10-7
10-8 Trend Monitoring for Parameters • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 10-8
10-9 System Status Bit Details • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 10-9

■ DMC50 project • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 10-9
■ AHC2001 project • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 10-10

Chapter 11. EDITING APPLICATION PROGRAMS

11-1 Roles of SLP-D50 and ISaGRAF • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 11-2
■ A role of ISaGRAF • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 11-2
■ Role of SLP-D50 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 11-2

11-2 Application Program Structure • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 11-4
11-3 Activating the "ISaGRAF Program" Window • • • • • • • • • • • • • • • • • • • • • • • • • • • • 11-5
11-4 Basic Procedure for Creating an Application Program • • • • • • • • • • • • • • • • • • 11-6

■ DMC50 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 11-6
■ AHC2001 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 11-7

11-5 Cautions about Writing Application Programs in ISaGRAF • • • • • • • • • • • • • 11-10
■ DMC50 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 11-10
■ AHC2001 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 11-17



xv

Chapter 12. EDITING AND MONITORING THE ISAGRAF VARIABLES USING SLP-D50

12-1 Activating the "ISaGRAF" Variable Declarations" Window • • • • • • • • • • • • • • 12-2
12-2 Edit Features (Offline) • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 12-4

■ Editing the boolean variables• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 12-4
■ Editing the integer and real variables• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 12-5
■ Editing the timer variables• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 12-7
■ Virtual I/O • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 12-9
■ Copy variables• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 12-9
■ Search • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 12-10
■ Setting the initial (default) values using the online monitor values • • • • 12-12
■ Setting the other fields in batch mode • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 12-14
■ Sort• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 12-15
■ Saving modifications • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 12-15

12-3 Monitoring Variables • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 12-16
■ Procedure • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 12-16

Chapter 13. COMPILING APPLICATION PROGRAMS (Make applications)

■ Limitations • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 13-2

Chapter 14. DOWNLOADING APPLICATIONS

Chapter 15. STARTING AND STOPPING APPLICATION PROGRAMS

Chapter 16. ONLINE DEBUGGING OF APPLICATIONS

Chapter 17. CLOSING PROJECTS

Chapter 18. MANAGING PROJECTS

18-1 Copying a Project • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 18-2
18-2 Changing the Name of Project • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 18-3
18-3 Deleting a Project • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 18-4
18-4 Archiving a Project • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 18-5
18-5 Documenting a Project • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 18-6
18-6 Uploading a Project • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 18-7

■ Outline• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 18-7
■ Data to be restored • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 18-7
■ Other cautions • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 18-9
■ Uploading a project with ISaGRAF • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 18-9
■ Uploading a project with SLP-D50 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 18-12



18-7 Restrictions on Project Access • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 18-13
■ Access restrictions on Parameters depending on the user level • • • 18-13
■ Access limits on project data for exclusive access • • • • • • • • • • • • • • • • 18-13

Chapter 19. USER-DEFINED PARAMETER LIBRARY

19-1 Activating the User-defined Type Library Management Window • • • • • • • • 19-2
19-2 Creating a New User-defined Parameter Type • • • • • • • • • • • • • • • • • • • • • • • • • • • 19-3
19-3 Editing a User-defined Parameter Type • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 19-4
19-4 "Edit User-defined Type" Window • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 19-5

■ Editing the type name and type label • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 19-5
■ Editing the attributes of each item for a parameter type definition • • • • 19-5
■ Adding a new item • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 19-6
■ Deleting an item • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 19-6
■ Saving the user-defined type definition • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 19-6

19-5 Exporting User-defined Parameter Definitions • • • • • • • • • • • • • • • • • • • • • • • • • • 19-7
19-6 Importing User-defined Parameter Definitions • • • • • • • • • • • • • • • • • • • • • • • • • • 19-8
19-7 Deleting User-defined Parameter Definitions • • • • • • • • • • • • • • • • • • • • • • • • • • • • 19-9
19-8 Using Registered User-defined Types • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 19-10
19-9 Exporting a User-defined Type from the Project to the Library • • • • • • • • 19-11

Chapter 20. GROUP MONITOR

20-1 Outline of Group Monitor Features • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-1
■ Project group common group monitor • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-1
■ Project local group monitor • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-1

20-2 Activating the Group Monitor • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-2
■ Activating the project group common group monitor • • • • • • • • • • • • • • • 20-2
■ Activating the project local group monitor • • • • • • • • • • • • • • • • • • • • • • • • • • 20-2
■ Activating the group monitor from the ISaGRAF variable declarations window • • • • • 20-3
■ Activating the group monitor from the group monitor itself • • • • • • • • • 20-3

20-3 Creating a Monitor List • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-4
■ Registering parameter data • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-4
■ Registering ISaGRAF variables • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-5
■ Automatic grouping • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-5
■ Saving and re-reading the monitor list • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-7

20-4 Monitor List Edit Features • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-8
■ Deleting monitor data• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-8
■ Cut & insert monitor data • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-8

20-5 Consistency Checking • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-9
20-6 Changing the Communication Path • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-10

■ Description of setting columns• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-10
■ Changing settings of multiple data • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-11

20-7 Changing the Display Format • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-12
20-8 Starting Monitor • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-13

xvi



xvii

20-9 Modifying the Controller's Data Immediately • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-14
20-10 Stopping the Monitor • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-15
20-11 Activating the Trend Monitor • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 20-16

Chapter 21. TREND MONITOR

21-1 Activating the Trend Monitor Window • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-2
■ Activating the trend monitor window from the project window • • • • • • 21-2
■ Activating the trend monitor window from the group monitor • • • • • • • 21-3

21-2 Setting Up the Trend Options • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-4
■ Write to CSV file • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-4
■ Directory for CSV logging • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-4
■ CSV core file name • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-4
■ Update time• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-5
■ Samples/file • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-5
■ Series selections • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-5
■ Axis selection • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-5
■ Scaling, offset • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-5
■ Series color• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-5
■ X-axis window view, window size • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-6
■ Y-axis min, max values • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-6
■ Save and open trend option file • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-6

21-3 Graph Drawing Features • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-7
■ Selecting a set of series for display • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-7
■ Zoom • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-7
■ Scroll • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-7

21-4 Logging to CSV File • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-8
21-5 Starting and Stopping the Trend Monitor• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-9
21-6 Editing Comments • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 21-10

Chapter 22. SAMPLING TRACE WIZARD

22-1 Activating the Sampling Trace Wizard • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 22-2
22-2 Setting Up the Sampling Trace • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 22-3

■ Setup items • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 22-3
■ Registering sampling data• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 22-5
■ Examples of trigger variable and sampling period in fixed times trace • 22-6
■ Setting up the options • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 22-7
■ Completing the setup • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 22-7

22-3 Online Features • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 22-9
■ Fixed times trace • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 22-9
■ Continuous trace • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 22-12

22-4 Actions to Take If the Sampling Trace Becomes Unnecessary• • • • • • • • • 22-14



Chapter 23. INTEGER CONVERSION WIZARD

23-1 Activating the Integer Conversion Wizard • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 23-2
23-2 Registering Conversion Data • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 23-3

■ Editing data in the "Integer Conversion Wizard" window • • • • • • • • • • • • 23-3
■ Display/Setup fields • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 23-5
■ Limitations • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 23-6
■ Setting up the options • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 23-8
■ Completing the setup • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 23-8
■ Accessing the I/F variables from the external systems • • • • • • • • • • • • • 23-10
■ HTML output of the settings • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 23-10

23-3 Actions to Take If the Integer Conversion Becomes Unnecessary • • • • • • • • 23-11

Chapter 24. PATTERN WIZARD

24-1 Limitations on Pattern Wizard • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-2
24-2 Activating the Pattern Wizard • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-3
24-3 Setting Up the Pattern Wizard • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-4

■ Setup items • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-4
■ Completing the setup • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-6
■ Components to be generated automatically • • • • • • • • • • • • • • • • • • • • • • • • • 24-6

24-4 Editing the Pattern Components • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-7
■ Editing the application program • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-7
■ Changing the pattern setting values • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-8
■ Editing the segment data • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-8
■ Adding a pattern • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-8
■ Deleting a pattern• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-8
■ Adding segments • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-9
■ Deleting segments• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-9

24-5 Controlling the Pattern Execution • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-10
24-6 Automatically Generated Components • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-11

■ Global variable definitions • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-11
■ Defined words • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-12
■ Program "YC_Cycle" • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-12
■ Program "YC_Pat" • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-13
■ Program "YC_Evt" • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 24-18
■ User-defined Parameter "SP Pattern Setup" • • • • • • • • • • • • • • • • • • • • • • • 24-19

24-7 Actions to Take If the Pattern Control Becomes Unnecessary • • • • • • • • • 24-22

Chapter 25. AHC2001 SPECIAL FACILITY

25-1 Unit Configuration Setup • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 25-2
■ Setting up with ISaGRAF I/O connection editor • • • • • • • • • • • • • • • • • • • • • • 25-2
■ Setting up with [Update Unit Configuration] feature • • • • • • • • • • • • • • • • • 25-3

25-2 PLC Link Support Feature • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 25-5
■ PLC link format verification • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 25-5

xviii



xix

Chapter 26. PATTERN FB SUPPORT FACILITY

26-1 Overview of Pattern FBs Associated Parameters • • • • • • • • • • • • • • • • • • • • • • • 26-2
26-2 Preparing for the Pattern Controls • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-3
26-3 Pattern Management Features • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-4

■ Creating new patterns • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-4
■ Adding patterns • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-5
■ Deleting patterns • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-7
■ Adding segments • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-8
■ Deleting segments• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-9
■ Editing a segment type • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-9
■ Adding events • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-10
■ Deleting events • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-12

26-4 Pattern Graph • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-14
■ Activating the pattern graph• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-14
■ Displaying a graph • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-14
■ Setting up the options • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 26-15

Chapter 27. OFFLINE CHARTS

27-1 Activating an Offline Chart Window • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 27-2
27-2 Importing Time Series Data from CSV Files • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 27-3
27-3 Setting Up Options • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 27-5
27-4 Time Shifting • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 27-6
27-5 Narrowing the Time Span • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 27-7

Chapter 28. OTHER FEATURES

28-1 Error Output Window • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 28-1
28-2 Stopping All Monitoring Operations • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 28-2
28-3 Active Communication Paths • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 28-3
28-4 User Level • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 28-4

■ Changing the user level • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 28-4
■ Checking the user level• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 28-4

28-5 Selecting a Database • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 28-5
28-6 Operators Edition • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 28-6

Chapter 29. CAUTIONS



 



Chapter 1. BEFORE STARTING OPERATION
1  -  1 Overview

This SLP-D50 Version 2.2 (hereafter referred to as SLP-D50V2.2) provides the setup and monitor capabilities for

the module type controller DMC50 and AHC2001.  The following lists up  the features provided by SLP-
D50V2.2

■ Features
The SLP-D50/ISaGRAF provides the functionalities for the DMC50/AHC2001
controller such as: 

• Setting and monitoring of controller H/W related and calculation related

Parameters, and utilization of such Parameters in programs.

• Definitions, settings, and monitoring of User-defined Parameters and utilization

of such Parameters in programs.

• Parameter reporting (HTML format) 

• Application program creation using ISaGRAF

• Application download to controller

• Application upload from controller

• Monitoring of a bundle of data using Group Monitor 

• Trend monitoring of Parameter elements and ISaGRAF variables (Graph

drawing and CSV logging) 

• Sampling tracing of Parameter elements and ISaGRAF variables (Continuous

or fixed times)

• Automatic generation of integer conversion programs  for access from external

systems

• Automatic generation of SP Pattern (profile) producing programs

• Linearization table support facility

• AHC2001 unit configuration setup and each unit setup

• Managing and editing facility for pattern (profile) control using pattern FBs

Handling Precautions
• When editing the AHC2001 project after SLP-D50/ISaGRAF has been

installed from the SLP-D50 package, up to 64 I/O variable points can be
used.

• When connecting to DMC50 after SLP-D50/ISaGRAF has been installed
from the SLP-H21 package, optional loader cable (model No. 81440793-
001) is required.
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■ Major features added to and changed in SLP-D50V2.2

• Project data access limitation

• Project archiving

• Sorting of ISaGRAF variables

• Assigning a field value of each ISaGRAF variables in batch mode

• HTML output of the Integer Conversion Wizard settings

• Optional color for each series of Trend Monitor and Sampling Trace

• Changed the executing condition of Upload All Parameters

• Support of COM port 5-8

• Support of ISaGRAF v3.50

• Support of a DMC50 CS type new RTD range

• Support of DMC50 Ni sensor type modules.
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1  -  2 System Environment Requirements for Operation

The following system environment is required to operate SLP-D50/SLP-H21:

■ System requirements

* For SLP-H21, two USB ports are needed.

OS Windows98, WindowsMe, Windows2000,
WindowsXP

Software A spreadsheet application that reads CSV
format files.  (for trend data analysis)
A browser/spreadsheet application that reads
HTML format files. (for display and edit  of
document outputs)

CPU IBM PC/AT compatible with Pentium or higher

CPU (200 MHz or faster is recommended.)

Hard disk Free disk space of 100 MB or more

Personal CD drive For installation

computer Memory 64 MB or more of free memory 

Serial port One channel or more of 9-pin serial ports

Ethernet Access through TCP/IP (used for the
communication with the DMC50 ME200
modules or the AHC2001 ENI unit)

USB* Access to the AHC2001 controller CPU unit.

Used to connect the protection key.

FEP A Japanese input system supporting the
Windows (Japanese version)

Display 640 X 480 or better display resolution (A reso-

Peripheral lution of 800 X 600 or better is recommended.)

devices Pointing device A mouse, or pointing device equivalent to

mouse



1-4

■ Hardware configuration (DMC50)
To set up a DMC50 using SLP-D50/ISaGRAF, connect the DMC50 controller to

the personal computer as shown below.

SLP-D50 can be connected to CTRL modules or COM modules.  ISaGRAF can

be connected to CTRL modules.  "DMC50C" is written on the model No. label on

the left side panel of CTRL modules while "DMC50M" is written there of COM

modules.

■ Hardware configuration (AHC2001)
To set up a AHC2001 using SLP-D50/ISaGRAF, connect the AHC2001
controller to the personal computer as shown below.

A D-SUB 9-pin cross-cable is required for the RS-232C cable. (Both the RS-

232C cable and USB cable are not included in the package.)

Note

For details about how to install the USB driver, 

refer to Chapter 2, INSTALLATION.

Chapter 1. BEFORE STARTING OPERATION

*  When using the ME200 module, it is possible to connect from the personal computer 
�through Ethernet.
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1  -  3 System Configuration

SLP-D50/ISaGRAF consists of the following software components.  Each software component is installed using

relevant installer.

For details about installation, 

refer to the description, ■ Installing SLP-D50/ISaGRAF (page 2-1).

• ISaGRAF ISaGRAF workbench.  This software edits application programs.

• SLP-D50 Parameter setup tool.  Normally, this software sets up Parameters.

• ISaGRAF Yamatake Patch* A portion of ISaGRAF customized for Yamatake's controller  

(This software is installed using the SLP-D50 installer.)

• Modbus connector* Modbus communication router software 

(Performs routing of the communication packets among ISaGRAF, SLP-
D50, and the controller.) 

* This software is installed using SLP-D50 installer.

After the above components have been installed, DMC50 and AHC2001 have the following system

configuration.

■ System configuration diagram (DMC50)
For the smart loader package SLP-D50J50 for DMC50, the following software

component is provided in addition to that of SLP-D50/ISaGRAF.

• Protection key driver
This protection key driver is installed to make the protection key facility valid.

When this driver is installed, up to 64 I/O variables points can be used.

For details about how to install the protection key driver,

refer to the description, ■ Installing protection key driver (page 2-2).
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■ System configuration diagram (AHC2001)
For the smart loader package SLP-H21J50 for AHC2001, the following two

software components are provided in addition to those of SLP-D50/ISaGRAF.

• Protection key driver
This protection key driver is installed to make the protection key facility valid.

When this driver is installed, up to 256 I/O variable points can be used.

For details about how to install the protection key driver, 

refer to the description, ■ Installing protection key driver (on page 2-2).

• AHC2001 USB driver
Use of this AHC2001 USB driver makes it possible to communicate with

AHC2001 through USB.

For details about how to install the AHC2001 USB driver,

refer to the description, ■ Installing AHC2001 USB driver (on page 2-
3).

Note

CBL232FFT02 is available for the RS-232C cross-cable.
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Chapter 2. INSTALLATION

It is absolutely necessary to install the SLP-D50/ISaGRAF.

When the SLP-H21 package is purchased, the protection key driver must also be installed.

When communicating with AHC2001 through USB, the AHC2001 USB driver must be installed.

■ Installing SLP-D50/ISaGRAF 

(1) Run [setup.exe] contained in the ISaGRAF install CD to install  "ISaGRAF

workbench v3.5x".  The english version should be installed although any

language version can be installed. .

(2) After ISaGRAF has been installed, install SLP-D50.

Run [Setup.exe] in the directory "Slpd50" contained in the SLP-D50 (SLP-
H21) install CD.

Handling Precautions
• Run [Setup.exe] in the directory “Slpd50” contained in the SLP-D50 install

CD. If “ISaGRAFv3.5x” has not been installed, the installation may be
aborted halfway. If this occurs, restart the installation again from the
beginning.

• Additionally, if the SLP-D50 has already been installed, the dialog box
showing the message, "This element already exists.  Do you want to
overwrite it?", will appear several times during installation. If this occurs,
click the [Overwrite all] button.

(3) After the installation has been completed, invoke SLP-D50 and make the

initial settings.

For details, 

refer to Chapter 3, INVOKING AND EXITING SLP-D50, AND
MAKING THE INITIAL SETUP.

(4) When necessary, install the ISaGRAF online manual using the "ISaGRAF

workbench v3.5x" installer.

(5) When necessary, copy the SLP-D50 online documents under the directory

"Docs" in the SLP-D50 (SLP-H21) install CD.
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■ Installing protection key driver
The protection key that allows using of up to 256 I/O variables is supplied with the

smart loader package SLP-H21J50 for AHC2001, and the protection key that

allows using of 64 I/O variables is supplied with the smart loader package SLP-
D50J50 for DMC50.  To make the protection key facility valid, it is absolutely

necessary to install the protection key driver.  To install the protection key driver,

follow the steps below after SLP-D50/ISaGRAF has been installed.

(1) Make sure that SLP-D50/ISaGRAF is not running.

(2) Run [Setup.exe] in the directory “ISaGRAF¥Sentinel” contained in the SLP-
H21 install CD. The installation process is completed automatically without

any messages.

(3) Select [Control Panel] → [Add/Remove Programs] → [Install/Remove]
tab.  Check that [Sentinel System Driver] is shown in the list box.

(4) Invoke SLP-D50 and select [Project] → [Open ISaGRAF Project
Management Window]. The ISaGRAF project management window will

appear.  In this window, select [Help] → [About SLP-D50] to display the

“About SLP-D50” dialog box.

In case of SLP-D50J50:

When “Maximum number of I/O variables: 65” is shown in this dialog,

up to 64 I/O variables can be used.

(Actual number of usable I/O variables is 64 even though 65 is

displayed.)

In case of SLP-H21J50:

When “Maximum number of I/O variables: 256” is shown in this dialog,

up to 256 I/O variables can be used.

Handling Precautions
• When the smart loader package SLP-D50J50 for DMC50 is used for

AHC2001, up to 64 I/O variables can be used.

• With the smart loader package SLP-H21J50 for AHC2001 or with the
smart loader package SLP-D50J50 for DMC50, programming cannot be
performed unless the protection key is mounted.
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■ Installing AHC2001 USB driver
To communicate with AHC2001 through USB, it is absolutely necessary to install

the AHC2001 USB driver.

Different installation procedures apply to Windows98, Me and Windows 2000, XP

as described below.

Follow the steps below to install the AHC2001 USB driver.

● Windows98, Me
(1) Power ON the personal computer and AHC2001.

(2) Set the SLP-D50(SLP-H21) install CD on the CD drive.

(3) Connect AHC2001 and personal computer with the USB cable.

>> The new hardware installation wizard is activated and [USB Device] will

appear.

(4) Click [Next].

(5) Select [Search for a better driver than the one your device is using now
(Recommended)] and click [Next].

(6) Check on [Specify a location], specify the directory “USB¥drivers¥Win98” in

the install CD, and then click [Next].
>> The message, “Windows driver file search for the device: Yamatake

AHC2001 USB Windows is now ready to install the best driver for this

device. ...”, will appear.

(7) Click [Next].
>> The driver installation is then started, and the message “Windows has

finished installing the driver you selected for your hardware device.” will

appear.

(8) Click [Finish].

Chapter 2. INSTALLATION



2-4

● Windows2000, XP
(1) Power ON the personal computer and AHC2001.

(2) Set the SLP- H21 install CD on the CD drive.

(3) Connect AHC2001 and personal computer with the USB cable.

>> The new hardware installation wizard is activated and [USB Device] will

appear.

(4) Click [Next].
>> The message, “The wizard will complete the installation for this device:

USB Device ”, will appear.

(5) To search for the driver, select [Search for a suitable driver for my device
(recommended)] and click [Next].

(6) Check on [Specify a location] and click [Next].

(7) In [Reference], specify the directory “USB¥drivers¥Win2000” in the install

CD, and then click [OK].
>> The message, “The wizard found a driver for the following device.

Yamatake AHC2001 USB”, will appear.

(8) Click [Next].
>> The message, “Yamatake AHC2001 USB Installation Disk…”, will appear.

(9) In [Reference], specify the directory “USB¥drivers¥Win2000¥ahc_usb.sys” in

the install CD, and then click [OK].
>> The driver installation is then started, and the message “Completing the

Found New Hardware Wizard.”, will appear.

(10) Click [Finish].

Handling Precautions
• In case of Windows XP, when a warning message regarding the

compatibility verification show up, click “Select Anyway” button to
continue installation.
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Chapter 3. INVOKING AND EXITING SLP-D50, AND MAKING THE INITIAL SETUP
3  -  1 Invoking SLP-D50 

From the [Start] menu of Windows, select [Programs] → [SLP] → [SLP-D50(DMC50)] to invoke SLP-D50.

>>  SLP-D50 is invoked.

■ Selecting hardware to be edited
The following "Target H/W Selection" dialog box will appear immediately after

the installation has been completed.

• [Target H/W for editing]

Select a hardware platform you wish to edit. When selecting an item other than

[All supported targets], only a project for the hardware platform with the

selected type can be created or edited until the selection is changed next time.

• [Show this dialog box at startup]

H/W to select hardware you wish to edit, select [Target H/W selection]  from

the [Global Options] menu in the SLP-D50 main window.

■ SLP-D50 main window

When [Show this dialog box at startup] is checked on in the "Target H/W

Selection" dialog box, the "Target H/W Selection" dialog box will appear. When

clicking [OK] button, the following SLP-D50 main window will appear.

If [Show this dialog box at startup] is not checked on, the SLP-D50 main window

will appear immediately after SLP-D50 has been invoked.
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3  -  2 Making the Initial Setup

3-2

First, make the initial setup after SLP-D50 has been invoked.

■ Setting up the paths
In the main window, select [Global Options] → [Path Configuration].
The "Path Configuration" window will appear.  First, set [ISaGRAF Directory]
and [Project Group Directory] before doing any other operations.

● Checking the ISaGRAF directory

Handling Precautions
• If ISaGRAF has not been installed, unless you planned to install SLP-

D50 operators edition, first install ISaGRAF.

• SLP-D50 operators edition only supports subset features of the SLP-
D50 standard edition, which do not require ISaGRAF. Unavailable
features are listed in 28-6   Operators Edition.

Unless the SLP-D50 operators edition was installed, check that the ISaGRAF

installation directory is specified in [ISaGRAF Directory].  If not specified, the

installation may have been aborted due to an error.  In this case, restart the

installation. If you installed the operators edition, leave it blank. 

Note
• This ISaGRAF installation directory is specified when installing ISaGRAF.

The default setting is "c:\isawin".  However, this must be the directory where

ISaGRAF has been actually installed.

The ISaGRAF directory includes sub-directories, such as "apl", "ark", "exe",

"com", "lib", and "tmp".
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● Setting up the project group directory
Specify a directory where projects are saved.  Since a project itself is a directory in

SLP-D50/ISaGRAF, specify a parent directory including project directories.  This

project group directory is used as the initial directory when opening a project.

Note
• The project group directory can also be set using ISaGRAF.  This setting is

performed in the project management window of the ISaGRAF workbench. 

For details, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.

• The project group directory is <ISaGRAF top directory>¥dmc50 when the

SLP-D50 package is installed, or <ISaGRAF top directory>¥ahc when the

SLP-H21 package is installed in the default settings. It can be changed.
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To exit SLP-D50, select [Exit SLP-D50] from the [Project] menu in the SLP-D50 main window, or select [X] on

the title bar.

Chapter 3. INVOKING AND EXITING SLP-D50, AND MAKING THE INITIAL SETUP

3 -  3 Exiting SLP-D50



Chapter 4. STEPS TO OPERATE CONTROLLERS
4  -  1 Project

To operate a controller, it is necessary to create, edit, and download a project having the module type of the

controller as attribute.

• A project handles two kinds of data, Parameters and the application program.

Both of data are needed to perform the control operation on the programmable

controller (DMC50 CTRL module and AHC2001 controller).

The DMC50 COM module needs only Parameters.

• For the programmable controller, edit the necessary Parameters and application

programs, and then compile the project (Make Application).  Download the

application  to set both data in the module.

• For the DMC50 COM module, set values of each Parameter and download

individual Parameter instances to complete the setup of the module.

For details about communication setup of the COM module, 

refer to Module Type Controller DMC50 User's Manual
"Communications Connection", CP-SP-1093E.

• Parameter can be edited only with SLP-D50.  

For details about Parameters, 

refer to Chapter 8, PARAMETERS.

• Normally, the application program is edited and compiled using ISaGRAF.

How to edit the application program is described in Chapter 11, EDITING
APPLICATION PROGRAMS.  How to compile the application program is

described in Chapter 13, COMPILING APPLICATION PROGRAMS.

• How to download the application is described in Chapter 14, DOWNLOADING
APPLICATIONS.

Subsequent sections show the diagrams until each of the DMC50 CTRL module, DMC50 COM module or

AHC2001 controller is operated.
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4  -  2 Operating the DMC50 CTRL Module

4-2

To operate the DMC50 CTRL module as a controller, it is necessary to create, edit, compile, and download a

project according to the steps shown in the following diagram:

Note
The user can create control logic by  freely combining function blocks and

functions to write applications.

Handling Precautions
SLP-D50 operators edition unable to edit application programs. 
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4  -  3 Operating the DMC50 COM Module

Among the DMC50 COM modules, both the ME200 (Ethernet type) and MR200 (RS-485 type) neither execute

ISaGRAF nor have the application concept.  To operate a module, it is necessary to create a project suitable for its

model, set up necessary Parameters, and download individual Parameters.  Additionally, after Parameters have

been downloaded, it is necessary to turn OFF the power to the module and turn it ON again to restart the module.

Handling Precautions
Even though Parameters in the controller are edited in the online mode,
Changes will not take effect until the power is turned OFF and  ON again.

Note
For details about COM module setup,

refer to Module Type Controller DMC50 User's Manual
"Communications Connection", CP-SP-1093E.
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4  -  4 Operating the AHC2001 Controller
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To operate the AHC2001 controller, perform the same steps as for the DMC50 CTRL module.

However, different from the DMC50 CTRL module, it is necessary for the AHC2001 controller to set up the

configuration of the I/O unit and the communications unit and the steps for this are added.

Handling Precautions
SLP-D50 operators edition unable to edit application programs.
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Chapter 5. CREATING NEW PROJECTS

To operate a controller, it is absolutely necessary to create a project having the module type suitable for the

controller.  If such a project has not been created, follow the steps below to create a project.

Handling Precautions
Project type you can create is limited by the selection of the hardware to be
edited. Check that the settings meet the controller you are using. For
details, refer to section 3-1, Selecting Hardware to Be Edited.

● Creating a project
(1) In the main window, select [Project] → [New Project] .

>>  As shown on the screen below, the currently set project group directory is

highlighted.  A new project will be created under this project group

directory.

(2) Click [OK] button.

>>  The "Project Definition" dialog box will appear.  
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(3) In this dialog box, make the settings in [Project Name] and [Module Type].
The following screen shows that [CH4001] is selected in [Project Name] and

[CH400 : CTRL Module(High Resolution 4 loop Type)] is selected in [Module
Type].

Note
Selecting [File] → [New] in the project management window of the ISaGRAF

can also be create a project.

Handling Precautions
The module type of the created project can be identified in the "Project
Options" dialog box, which is opened by selecting [Options] → [Project
Options] with the project window active.  
For details, 

refer to section 7-1, Identifying the Module Type (page 7-2).
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Chapter 6. OPENING PROJECTS
6  -  1 Opening a Project

To properly set up or monitor a controller, it is necessary to open a project the same as that of the application

downloaded into the controller.  Follow the steps below to open a project:

Handling Precautions
The type of the project to be opened is limited due to selection of the
hardware to be edited.  Therefore, before opening a project, it is necessary
to check that the module type of a project you wish to open meets the
selection setting of the hardware to be edited.
For details, refer to section 3-1, Selecting Hardware to Be Edited.

(1) In the main window, select [Project] → [Open Project].

>> A directory selection dialog box will appear as bellow.  

(2) Select a desired project name and click [OK] button.
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>>  The "Project" window for the specified project will appear.

The above screen shows the "Project" window for the project "Sample".

Handling Precautions
Note that the directory for the "Project Selection" dialog box is determined
by the project group directory.
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6  -  2 Reopening a Project

In the main window, select [Project] → [Reopen Project].  Up to five projects, which have been recently opened,

are listed up in a submenu.  Selecting a desired project in this list  will reopen it.
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Chapter 7. SETTING UP THE PROJECT OPTIONS

In SLP-D50, when selecting [Options] → [Project Options] with the project opened, the following "Project

Options" dialog box will appear.

In this dialog box, set up [Communication Path] and [Module Address].  Once the settings have been made,

these settings will be effective for this project until the settings are changed later.
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7  -  1 Identifying the Module Type

7-2

Identify whether or not the module type of the project is the same as the module type of the controller you wish to

communicate with.  If they are not the same, it is necessary to open another project having the same module type,

or to create a new project having the same module type.
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Identify the module type of 

the project shown in this field.



7  -  2 Setting Up the Communication Path

The communication path setting decides which communication path is used to communicate with the module.

The explanations are given separately for whether the controller is the DMC50 or the AHC2001.

■ DMC50
Complete this setting by referring to  the table below:

■ AHC2001
Complete this setting by referring to the table below:

Handling Precautions
• When choosing the USB path, the detailed setup is not needed.
• It may be required to install the USB driver for each USB port of a

personal computer to be connected.
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Path Description

Serial (direct) Choose this path when connecting the PC to DMC50
directly with the loader cable.

Serial (indirect) Choose this path when communicating  with a CTRL
module linked to a COM module that is directly connected to
the PC via its serial port (loader, RS-485).
When using the RS-485 port, a RS-232C/RS-485 converter
must be placed  between the PC and COM module.
Additionally, it is also necessary to set the protocol of the
RS-485 port to "Loader" in the System Parameters >
Communication Setup of the COM module.

TCP/IP (direct) This setting is solely available in  the project for the ME200
module.  Choose this setting  when connecting the PC to
the Ethernet port on the ME200 module through TCP/IP.

TCP/IP (indirect) Choose this path when the DMC50 CTRL module you wish
to communicate with is linked to a ME200 module and the
PC is connected to the Ethernet port on the ME200 module
through TCP/IP.

Path Description

Serial (direct) Choose this path when connecting the PC to AHC2001
directly with the RS-232C cable.

TCP/IP (direct) If the ENI unit is mounted on the AHC2001 controller,
choose this setting when connecting the PC to the Ethernet
port on the ENI unit through TCP/IP.

USB Choose this setting when connecting the PC to AHC2001
directly with the USB cable. Before using this path, it is
absolutely necessary to install the AHC2001 USB driver.
For details, refer to the description, ■ Installing AHC2001
USB driver (page 2-3).



7  -  3 Setting Up the Module Address
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The module address identifies the controller at the communication destination. The explanations are given

separately for DMC50 and AHC2001.

■ DMC50
According to the communication path and module type of the project, set the

module address as shown in the table below:

Handling Precautions
The rotary switch No. on the front of the module is expressed in
hexadecimal notation.  When setting up the module address, set it in
decimal notation  converted from the rotary switch No. .

■ AHC2001
The module address is fixed to 1.

Note

The station address for CPL communications with the AHC2001 controller is

set up by the parameter “CPU-RS232C Setup”.

Chapter 7. SETTING UP THE PROJECT OPTIONS

Communication Module type Module address setting value
path

Serial (direct) CTRL module Rotary switch No. on CTRL module.

COM module Rotary switch No. on COM module.

Serial (indirect) CTRL module Rotary switch No. on CTRL module.

COM module Set to "0".  (This setting is only valid  when
communicating to the COM module itself.)

TCP/IP (direct) CTRL module The module address cannot be set.

COM module Rotary switch No. on COM module.
(This setting is not available in projects for
modules other than the ME200 modules.)

TCP/IP (indirect) CTRL module Rotary switch No. on CTRL module.

COM module Set to "0".  (This setting is only valid when
communicating  to  the COM module itself.)



7  -  4 Setting Up the Serial Communication

This section describes how to set up the serial communication separately for DMC50 and AHC2001.

■ DMC50
(1) Select "Serial (direct/indirect)" in [Communication Path] and click the

[Property] button.  

>>  The "Serial Communications Setup" dialog box will appear.  In this

dialog box, the COM port on the PC can be set.

(2) Additionally, when selecting "Serial (indirect)", set [Communication Module
Addr] to the rotary switch No. of the COM module through which the

communication is performed.

Handling Precautions

The rotary switch No. on the front of the module is expressed in
hexadecimal notation.  
When setting the module address, set it in decimal notation converted
from the hexadecimal notation.

■ AHC2001
(1) Select "Serial (direct)" in [Communication Path] and click the [Property]

button.

>> The "Serial Communications Setup" dialog box will appear.

(2) Specify a COM port and transmission speed of the personal computer. At this

time, select the same transmission speed as that of the AHC2001 controller.

Note

A transmission speed of the serial port on the CPU unit of the AHC2001
controller is set using the parameter “CPU-RS232C Setup”. After the system

is invoked again, the settings become valid.
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7  -  5 Setting Up the TCP/IP Communication
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■ DMC50

(1) Select "TCP/IP (direct/indirect)" in [Communication Path] and click the

[Property] button.  

>>  The "TCP/IP Setup" dialog box will appear.

(2) In this dialog box, specify a host name (IP address) and IP port No. of the

COM module, through which the communication is performed.

Handling Precautions
To perform the communication with the specified destination, it is
absolutely necessary to make appropriate settings on the COM module
before starting the communication.
For details about communication settings of the COM module,

refer to Module Type Controller DMC50 User's Manual
"Installation and Configuration", CP-SP-1139E.

Additionally, when selecting "TCP/IP (indirect)", set [Communication Module
Addr] to the rotary switch No. on the COM module through which the

communication is performed.

Handling Precautions

The rotary switch No. on the front of the module is expressed in
hexadecimal notation.  
When setting the module address, set it in decimal notation converted
from the hexdecimal notation.

■ AHC2001
(1) Select "TCP/IP (direct)" in [Communication Path] and click the [Property]

button.

>> The "TCP/IP Setup" dialog box will appear.

(2) Specify an IP address (or equivalent host name) and IP port No. of the

AHC2001 controller, through which the communication is performed.

Handling Precautions

To perform the communication with the specified destination, it is
absolutely necessary to make appropriate settings on the ENI unit of
AHC2001 before starting the communication.
For details about communication settings of the ENI unit, 

refer to Module Type Controller AHC2001 User's Manual "Basic
Operation", CP-SP-1137E.
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7  -  6 Identifying the access limit level

If any level of access limit is applied for the project as explained in section 18-7, Restrictions on  Project Access, a

value other than “No limitation” is displayed in the Limit Level field of the “Project Options” dialog box. Access

limit levels are explained in the following table. Please refer to section 18-7, Restrictions on Project Access, to

remove the access limit.
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Limit Level Description

No limitation No access limitation is applied except for the
privatedata.

No access to ISaGRAF No editing and referencing of the ISaGRAF
programs is allowed.

+No download of Application No download of the Application Program is
allowed in addition that no access to ISaGRAF
is applied.

+No access to Parameters No access to Parameters in the project is
allowed in addition that No access to ISaGRAF
and No download of Application is applied.
(This does not disable the access to
Parameters on the controller by SLP-D50.)





Chapter 8. PARAMETERS
8  -  1 Classifications of Parameters

Parameters are roughly classified into ten groups, System Parameters, Calculation Parameters, System Monitor

Parameters, Calculation Monitor Parameters, User-defined Parameters, Program Pattern Parameters, Unit Setup,

Unit Status, Remote Data Shared Parameters, and Remote Data Shared Status. These Parameters are shown in the

top level of the treeview in the left portion of the "Project" window.

• System Parameters 
These Parameters  change the controller's basic operations.   I/O or other H/W related settings are included.  The

hardware configuration determines the  contents and the number of System Parameters.

• Calculation Parameters
These Parameters change the operations of the calculation blocks (function blocks or functions in ISaGRAF),

such as Yamatake's PID function blocks.  The user can use the desired number of Parameters when necessary.

• System Monitor Parameters 
These Parameters show the controller status.

• Calculation Monitor Parameters
These Parameters show the calculation results of the function blocks (calculations), which are changing

dynamically.

• User-defined Parameters 
The user can create these Parameters by selecting [Global Options] → [User-defined Type Library] →
[New].  These Parameters can be read or written using the access FBs (function blocks) in the ISaGRAF

programs.  The access FBs can access to User-defined Parameters as well as to all other Parameters.

• Program Pattern Parameters 
These Parameters contain the settings and status related to the pattern FBs.

The Program Pattern Parameters are not used in the SP Pattern generating feature by the Pattern Wizard.

• Unit Setup Parameters
This unit setup is data set for each unit of the AHC2001 controller.  Since all the inputs and outputs are

controlled by different units in AHC2001, the I/O setup including the AI and AO setup is not provided in the

System Parameters, but provided in the Unit Setup.  The Unit Setup Parameters are created automatically when

editing and saving the ISaGRAF I/O connection editor.

• Unit Monitor Parameters
This unit monitor is data to show the unit status of the AHC2001 controller.  These Parameters are not provided

on DMC50.  Since all the inputs and outputs are controlled by different units in AHC2001, the AI status, AO

status, DI status, and DO status are not provided in the system monitor data, but provided in the Unit Monitor

Parameters.  The Unit Monitor Parameters created automatically when editing and saving the ISaGRAF I/O

connection editor.
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• Remote Data Sharing Parameters
These Parameters are used for the feature that shares the data with the remote system. These parameters can be

utilized by the AHC2001 controller.

• Remote Data Sharing Monitor Parameters
These Parameters are used to monitor the status of the feature sharing the data with the remote system.

The following table shows the correspondence between the controller types and supported Parameter types.

For details about Parameters and access FBs,

refer to Module Type Controller DMC50 User's Manual "Installation
and Configuration", CP-SP-1139E, Module Type Controller AHC2001
User's Manual "Basic Operation", CP-SP-1137E and Module Type
Controller DMC50/AHC2001 User's Manual "Function Block Reference",
CP-SP-1130E.

For details about how to create an application program using ISaGRAF, 

refer to Chapter 11, EDITING APPLICATION PROGRAMS.

Chapter 8. PARAMETERS
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Handling Precautions
In ISaGRAF, the term "parameter" is used for the meanings different from
that of the Parameter described above.

One meaning of the "parameter" is an argument to functions and function
blocks.  Another meaning of "parameter" is the I/O board parameter, which
is not used in the DMC50/AHC2001 system. Note that the term
"Parameter" beginning with the capital "P" used in the rest of this manual is
the Parameter described in this section.

Chapter 8. PARAMETERS
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8  - 2 Selecting Parameters

To set up or monitor Parameter, select a Parameter instance you wish to work on in the treeview shown in the left

portion of the "Project" window.  (In the treeview, an instance must always be an end node.  If [Instance Header]
and [Instance Body] tabs are shown in the right portion of the "project" window when selecting a node in the

treeview, this ensures that an instance is selected.)

■ Type and instance
All Parameters consist of the type and instance.

The type specifies the attributes of Parameter while the instance contains the

actual data.

As for PID_A Options, for example, the Parameter type defines each item of the

PID_A Options.  Settings of group No. 1 of the PID_A Options  and settings of

group No. 2 of the PID_A Options are instances.

Therefore, the data that the user actually downloads or monitors is the instance.

Additionally, in the treeview, the child nodes of the type are the instances.

Each of the type and instance consists of a header and a body.

In the treeview, select a type or an instance of Parameter except for the System

(Monitor) Parameters, and then select the relevant tab to show the header and

body.

The following table shows each contents.  The only data that the user must set up

is the data of  instance bodies except for user-defined types.

Type Header Parameter type ID, type name, type size

Body Name, setting range, and data type, etc. of each item
that makes up the type.

Instance Header Top group ID, instance name, group size, and
number of groups in the instance
* The header is not shown in System Parameters

and System Monitor Parameters.

Body Actual setting values
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On the following screen, an instance of Parameter whose type is [AI setup
(standard inputs)] is selected:

The following describes the type header, type body, and instance body in this

order:

● Type header
When selecting [Type Header] on the control tab, the following three attribute

fields are shown:

Field Description

Type ID Identification number of the Parameter type.
The type ID is used as the type ID argument to the access FBs
when they access to Parameter elements.
Additionally, the type ID comprises the upper 12-bit value of the
32-bit data address when accessing to Parameter elements
though communication.  ("16#" denotes the hexadecimal
notation.)

Type Size Total bytes of items, the same as the group size.

Type Name Internal identification name of the Parameter type
The type name is not particularly used in the current version.
The type name is different from the type label shown in the
treeview.
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● Type body
The following attribute fields are shown for each item of a Parameter type.

The type body is selected by selecting a Parameter type label (such as AI Setup or

PID_A Options) in the treeview, and then clicking [Type Body] tab.

● Instance header
When selecting [Instance Header] on the control tab, the following four

attributes will be shown:

Handling Precautions
The instance header is not shown for the System Parameters and System
Monitor Parameters.

Field Description

Top Group ID Top group ID of the instance

Group Size Total bytes of items, the same as the type size.

Instance Name Instance name.  This is the same as the name shown in
the treeview.

Number of Groups How many groups that makes up the instance.
The calculation result of "Group Size" x "Number of
Groups" approximately indicates the  bytes occupied by
the instance.

Field Description

ID Item ID (starting from "1")

Item Name Item name

Type Data type defined in IEC61131-3.

MIN Minimum value (for integer or real numbers)

MAX Maximum value (for integer or real numbers)

Default Initial value when the instance is generated.

Unit Engineering unit of the item value

Disp Real type 0 to 9 Number of display digits below the
decimal point for  the decimal number
notation

-1 to -15 Number of significant digits * (-1) for
the auto notation (decimal number or
exponential notation)

-21 to -35 (Number of significant digits + 20) * (-
1) for the exponential notation

Others No display
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● Instance body
Actual Parameter values are stored in the "instance body".

In the instance body, Parameter values for the multiple channels and groups are

viewed together.  Item names of Parameter are written on the left and the upper

numeric values are group IDs that indicates the channel Nos., group Nos., or

control loop Nos.

(For I/O, such as AI and DI, the group IDs indicate channel Nos.  For the PID, the

group IDs indicate PID group Nos.)

A group ID is used as an argument to the access FBs and various calculation FBs

(PID calculation, etc.) for DMC50/AHC2001.  When accessing Parameter

elements through communication, a group ID occupies bit 8 to 19 out of bit 0 to 31

for a data address.

To know the Parameter address of a parameter element (cell data),

refer to section 9-10, Data Address of a Cell (page 9-13).
The instance body can be selected by selecting an instance in the treeview, and

then clicking [Instance Body] tab.

The following table shows the display format for each data type to be displayed in

the instance body:

Chapter 8. PARAMETERS

Data type Display format

BOOL True/False

DINT Decimal number

REAL Displayed with a fixed number of decimal places. the [Disp] field of
the type body specifies the number of digits below the decimal
point.

DWORD Hexadecimal number display (prefix "16#" is not shown.) 

INT Decimal number
(Implemented as "DINT" in the controller.  Additionally, referred to
as "DINT in the functional reference document.)

TIME This type is not supported for Parameter items.

STRING This is shown as alphanumeric characters.
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This chapter describes how to edit Parameters.

For basic information about Parameters,

refer to Chapter 8, PARAMETERS.  

For details about operations in the online mode,

refer to Chapter 10, WORKING WITH PARAMETERS ONLINE (page 10-4).
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9  -  1 Online Data and Offline Data

9-2

Two modes of Parameter data display are provided, online data display and offline data display.  The online data

and offline data are data of the same instance, but stored in different places.

The offline data is the master data saved in the PC.  The online data is the latest updated data from the controller.

When [Instance Body] shows the offline data, the background color of the item names becomes gray.  When the

online data is shown, the background color of the item names becomes yellow or orange.  

For details about how to change the display mode,

refer to section 10-4, Changing the Parameter Display Mode (page 10-4).

Handling Precautions
To show the latest updated data, upload Parameter manually or perform
the monitoring.  Additionally, if the displayed instance is changed when the
background color is orange, or if the display mode is changed from offline
to online, data is automatically uploaded.

Chapter 9. EDITING PARAMETERS



9  -  2 Selecting a Cell

Select a cell you wish to edit using the mouse in the grid of the instance body, and then click the left mouse button

again.  You can edit the Parameter element data in the selected cell.

The following screen shows the situation where  the PV Range Max for control loop No. 1 in PID_A Options is

selected:

9-3
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9  -  3 Editing Cell Data

9-4

Each cell in an instance body grid contains a Parameter element value, and accepts input depending on the

associated Parameter item's data type as follows:

In addition to above, there are cells whose value can be selected from combo  boxes.

● Input range of cell data (a Parameter element value)
To find the input range of cell data, display the type body of the instance type

being edited (parent node of the instance selected in the treeview), and see the

MIN and MAX values  in the row of the same item ID and item name as the

current cell data (Parameter element).

Chapter 9. EDITING PARAMETERS

Data type Input format

BOOL True (1, T), False (0, F) 

DINT Decimal integer

REAL Decimal number, exponential format (format like
"1.2E3")

DWORD IP address Value with a format of "A.B.C.D" is accepted.  (Each
of A, B, C, and D is a decimal numeric value ranging
from 0 to 255.) (Example: 192.168.0.3)

Others Hexadecimal number; binary, decimal, octal, and
hexadecimal numbers with IEC1131-3 prefix (2#,
10#, 8#, or 16#) 

INT Decimal integer

TIME This type is not supported for Parameter items.

STRING Alphanumeric characters.
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● Completing the cell edit
After changing the value, press the [ENTER] key or move the cursor to another

cell.  The change is completed.

If the input data is correct within the setting range, this value is immediately

reflected on  the storage location  regardless of whether the display mode is offline

or online.  That is, when the display mode is offline, this data is stored into the

database on the project; and when the display mode is online, this data is stored

into the connected controller.

If the entered data has incorrect type, if it is out of the range, or if it is written to

the write-protected data on the controller, the dialog box showing that error has

occurred will appear, and the data is not altered.

The following illustrates the diagram of  writing offline  and writing online, and

also an example of the error message that occurs if data is written to the write-

protected data using DMC50 controller:
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LOADER

MODULE
ADDRESS

AB

CDEF0123456
7

POWER

RUN
GREEN

LOW BATT

ALARM

ORANGE
RED

CONSOLE
UNIT

120

1

10BAST-T

Change the data value 
when the display mode 
is offline (background 
color of the item names 
is gray).

Data is written into the project 
database on the PC.

Data is written into the DMC50 
controller.

Change the data value 
when the display mode 
is online (background 
color of the item names 
is orange or yellow).

DMC50



9  -  4 Adding an Instance

9-6

When necessary, the user can add instances to Calculation Parameters, Calculation Monitor Parameters, User-

defined Parameters, and Pattern Monitor Parameters.

(1) In the treeview, right-click a Parameter type whose instances you wish to add, and then select [Add Instance].
>>  The "Add Instance" dialog box will appear.

(2) Set an instance name (character string with a size of 48 bytes or less including spaces), a group ID used for the

top group ID, and the number of necessary groups.  (A group ID can be set in a range of 1 to 4000.)

(3) Click [OK] button.

>>  An instance is then created.  The instance name can be edited in the treeview.

Handling Precautions
An instance can be set so that it is composed of multiple groups.
In that case, the instance includes multiple group IDs.
Additionally, group IDs must be unique within a Parameter type.
Therefore, note that same group IDs can not be duplicated between
instances that have been already created.

Instances that have already been created

Instance A

Instance B

NG�
(Group ID 7 is duplicated.)

OK�
(No duplicated group IDs exist.)

Instance to be added (1) Instance to be added (2)

1 2

7 8

3 4

6 7 5 6

A Parameter type
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9  -  5 Deleting an Instance

In the treeview, select the instance name of an instance you wish to delete. Click the right mouse button and select

[Delete Instance].  The instance you have selected will be deleted.

9-7
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9  -  6 Adding Groups

9-8

(1) To increase the number of groups of an instance that has already been created, left click to select the group in

the instance body grid where you wish to insert or add groups.

(2) Right click → [Add Group] → [Before] ([After]).
>>  The "Insert/Add Group" dialog box will appear.

(3) Input the number of groups you wish to add, and click [OK] button.

>>  Groups are inserted or added from the specified group ID.

Handling Precautions
• An instance can be set so that it is composed of multiple groups.

In this case, the instance includes multiple group IDs.
Additionally, group IDs must be unique within a Parameter type.  
Therefore, note that same group IDs can not be duplicated between
instances that have been already created.

• When groups are inserted, the existing groups having Nos. larger than
the insertion position are shifted rightward to increase their group Nos.
by the inserted number of groups.

Chapter 9. EDITING PARAMETERS

Instances that have already been created

Instance A

Instance B

NG�
(Group ID 5 is duplicated with the 
group ID of the instance B.)

OK�
(No duplicated group IDs exist.)

1 2

5 6

Addition of groups (1)

3 4 5

Addition of groups (2)

3 4

A Parameter type



9  -  7 Deleting Groups

To delete groups from an instance that has already been created, follow the steps below:

(1) In the instance body grid, left-click to select the column of a top group you wish to delete.

(2) Right click → [Delete Group].
>>  The "Delete Group" dialog box will appear.

(3) Input the number of groups you wish to delete, and click [OK] button.

>>  The groups are deleted from the specified group ID.

Handling Precautions
When groups in an instance are deleted, the existing groups having Nos.
larger than the deleted groups are shifted leftward to decrease their group
Nos. by the number of deleted groups.

9-9
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Instance A

Selects the column of group ID: 2 
in the body grid of the instance A, 
and deletes one group.

1 2
Instance B

3

2
Instance A

1

4 5

Instance B
4 5

Group ID: 2 is deleted from the instance. 
Group ID: 3 is shifted leftward and becomes group ID: 2.
The instances that are not selected are not influenced.



9  -  8 Changing the Instance Name
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In the treeview, select a desired instance and left click again.  The instance name can be edited.

Handling Precautions
This capability cannot be used for the System (Monitor) Parameters .
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9  -  9 Utilizing User-defined Types

■ Importing types from the library
Parameter types which have already been defined can be imported from the User-

defined type library to use them.

For details,

refer to section 19-8, Using Registered User-defined Types (page 19-
10).

Once a User-defined type has been imported, it can be handled in the same manner

as Calculation Parameters in addition to the following capabilities.

■ Deleting a type 
A User-defined type that has been imported to the project can be deleted.  In the

treeview, select a User-defined type you wish to delete.  Right click → [Delete
Type] to delete the selected type.

Handling Precautions
• When a type is deleted, all related instances are also deleted

automatically.

• Even though a type is deleted from a project, this does not affect the
User-defined type library, as well as other projects.

■ Editing a type
In the treeview, select a User-defined type you wish to edit, and right click →
[Edit Type].  The "Edit" window for the specified User-defined type will be

activated.

For details about "Edit" window,

refer to section 19-4, User-defined Type Edit Window (page 19-5).

Handling Precautions
When performing [Edit Type] for a User-defined type in a project, the
following side effects may occur to the instance values if the instances
of this type have already been created.

9-11
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*1 The Sampling Trace Wizard, Integer Conversion Wizard, group monitor, trend

monitor, external communication devices, or others, which accesses to the

Parameter addresses.

■ Exporting types to the library
For details,

refer to section 19-9, Exporting a User-defined Type From the Project
to the User Defined Library  (page 19-11).
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Edit operations Side effects

Changing of type label If any Parameter element of the same
Parameter type is already registered in a
monitor list of the group monitor, the label
name mismatch will occur in the consistency
checking of the group monitor.  (This label
name mismatch can be ignored.)

Changing of type name No effects.

Attribute field name If any Parameter element of the same
Parameter item is already registered in a
monitor list of the group monitor, item name
mismatch will occur in the consistency
checking of the group monitor.  (This item
name mismatch can be ignored.)

Data type Elements of the item are reset to the initial
(default) values of the new data type.

MIN Elements of the item are not changed.

MAX Elements of the item are not changed.

Default Elements of the item are not changed.

Unit No effects.

Disp For the real type data already registered in
the group monitor, the number of display
digits on the group monitor is not influenced
even though this setting is changed.
Correct the display digits on the group
monitor, or register the data again.

Deleting of existing item The values of the items not to be deleted are
not influenced.  However, since the item IDs
are shifted, it is necessary for the facilities
that use the item IDs to set up the data
again.  *1

Adding of new item The values of the existing items are not
influenced.
However, since the item IDs are shifted, it is
necessary for the facilities that use the item
IDs to set up the data  again.  *1

Editing of
existing
item
attribute



9  -  10 Data Address of a Cell

Select a cell on the instance body, whose Parameter address you wish to know, right click → [Cell Data
Address].  The Parameter address of the selected cell data (Parameter element) will be shown.

("16#" as the prefix of the address indicates hexadecimal notation.)

The Parameter address is used to access from external systems through communication.

For details,

refer to Module Type Controller DMC50 User's Manual "Installation and Configuration", CP-SP-
1139E, and Module Type Controller AHC2001 User's Manual "Basic Operation", CP-SP-1137E.

9-13
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9  -  11 Editing the Comment
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With the "Project" window active, select [Parameter] → [Comment], or right click → [Comment] on the type

body or instance body grid.  The comment about the Parameter type currently being displayed in the project can be

edited.

The contents of the comment written with this feature are automatically embedded within the report generated by

the Parameter reporting feature.

For details about Parameter reporting feature,

refer to section 9-13, Generating the Parameter Report (page 9-18).
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9  -  12 Linearization Table Support Facility

This linearization table support facility is a special edit facility that can be activated when [TBL/TBR Setup
(linearization table)] is the currently selected Parameter type.  This facility cannot be used for other Parameter

types.

■ Displaying the graph
• Open an instance body of the Parameter type "TBL/TBR Setup".  Right click on

the grid, and select [Line Graph] → [Show Graph] to display the graph.

• Every time any data on the instance is changed, the graph of the instance is

updated immediately.

• When editing the online data, the graph consisting of the online data is

displayed.  Additionally, [Online] is shown on the status bar.

• A line graph consists of data in a single instance.

In both the direct lookup and reverse lookup, odd item IDs are the X-axis data

and item IDs one larger than those item IDs are the corresponding Y-axis data.

This pair is called "point".

● Direct lookup
• The default setting is direct lookup.  When selecting [Options] →

[Reverse Lookup], the display is switched between direct lookup and reverse

lookup.

• Input values (x) and output values (y) of "table FB" y=TBL(x) are plotted on

the X-axis and Y-axis, respectively.

• On the graph, invalid points are shown in green and valid points are shown in

red.  The upper and lower limit values are shown by the red dotted lines.

9-15
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● Reverse lookup
• When selecting [Options] → [Reverse Lookup], the display is switched

between direct lookup and reverse lookup.

• Input values (y) and output values (x) of "reverse table FB" x =TBL(y) are

plotted on the Y-axis and X-axis, respectively.

• On the graph, invalid points are shown in green and valid points are shown in

red.  The upper and lower limit values are shown by the red dotted lines.

● Showing and hiding markers
• Select [Options] → [Marker].  It is possible to show or hide markers with  a

point No. and point coordinates.

■ Inserting a point
(1) Click to select a point on an instance body grid.

(Cell of X-axis data or Y-axis data)

(2) Right click → [Line Graph] → [Insert Point].  Set an X-axis value and a Y-

axis value of the point, and click [OK] button.  

>>  The point is then inserted at a position before the selected point.

Handling Precautions
This feature cannot be used when editing in the online mode.
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■ Deleting a point
(1) Select a point on the instance body.

(Cell of X-axis data or Y-axis data)

(2) Right click → [Line Graph] → [Delete Point].  

>>  The selected point is then deleted.

Handling Precautions
This feature cannot be used when editing in the online mode.

■ Moving the decimal point position
(1) Right click  on the instance body, and select [Line Graph] → [Move Decimal

Point Position].  
>>  The "Number of Decimal Places" dialog box will appear.

(2) Change the value and click [OK] button.  

>>  The decimal point positions for all values of the entire selected instance

will be changed.
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9  -  13 Generating the Parameter Report
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A report (HTML format) on all the Parameters in a project is generated.

The HTML file you have generated can be read directly and edited by Microsoft Excel® (Excel97 or later).

(1) With the "Project" window active, select [Edit] → [Generate Parameter Report].
>>  A dialog box with [Memo] field appears.

(2) Write such as project's summary and cautions in the [Memo] field.  This memo is loaded again next time

generating  report for the same project.

(3) Click [OK] button.

(4) Select a report file name (The file extension is ".htm".) 

(5) Click [Save] in the file selection   dialog box.

>>  The actual process is started. When the process is completed, A dialog box prompting you to activate a

browser will appear.  

(6) Click [OK] button. The contents of the report you have generated can be checked using the browser.

Chapter 9. EDITING PARAMETERS
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Handling Precautions
• The HTML file you have generated contains project name, creation

date, memo, Parameter list, comments for every Parameter type, and
offline setting value of each item of every instance.  
For details about the comment for Parameter types.

refer to section 9-11, Editing the Comment (page 9-14).

• To have all the current Parameter values of the module reflected on
the report, "Upload All Parameters" to overwrite the offline data with
the online data, and then execute this feature.  Here, if any problem
can arise when the previous offline data of the project is overwritten,
copy the project first before overwriting the data.
For details about how to upload all Parameters,

refer to section 10-7, Uploading All Parameters (page 10-7).

• Which Parameters are shown on the report may depend on the user
level.
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The Copy & Paste feature can copy multiple cell data on the "Project" window at a time and to paste such data in

the same or other "Project" window.  The Copy & Paste feature consists of three steps, Area selection, Copy, and

Paste (Successive Pastes).  The following describes each step in detail.

Note
Use of this feature also makes it possible to put a bundle of data that has been

copied from in the "Project" window, into the group monitor, Sampling Trace

Wizard, and Integer Conversion Wizard.  

For details,

refer to the descriptions of relevant features.

■ Area selection
To copy multiple cell data, it is first necessary to select an area to be copied.

There are four area selection methods as described in the following:

● Selecting a column (group)
(1) Open an instance body in the "Project" window.

(2) Click the group No. of a column (group) you wish to copy.

>>  The cells of the selected column (group) will be displayed in light gray.

● Selecting a row (item)
(1) Open an instance body in the "Project" window.

(2) Click the unit display column (column next to the item name) of a row (item)

you wish to copy.

>>  The cells of the selected row (item) will be displayed in light gray.

● Selecting all cells
(1) Open an instance body in the "Project" window.

(2) Click the unit display column (column next to the item name) of the group No.

row .

>>  All the cells of the instance will be displayed in light gray.

● Selecting specified area
(1) Open an instance body in the "Project" window.

(2) Click the cell at the upper left corner of an area you wish to copy.

(3) With the SHIFT key kept pressed, click the cell at the lower right corner of an

area you wish to copy.

>>  The cells of the selected area will be displayed in light gray.

9  -  14 Copy & Paste (Successive Pastes) Feature
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■ Copy
(1) Make sure that a desired area is selected using any area selecting procedures.

(2) Right click → [Copy] on the instance body grid.

>>  The cell data information of the selected area will be copied to the copy

buffer.

■ Paste
(1) After the cell data information of a desired area has been copied into the copy

buffer using the above copy procedure, click the cell at the upper left corner of

an area where you wish to paste the cell data.

(2) Right click → [Paste].
>>  The cell data values are pasted sequentially with the rectangular shape and

cell data of the source area kept in order.

The above screen shows an example that the items 1 to 3 of the group ID 1 and 2

are copied to the items 2 to 4 of the group ID 3 and 4.
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■ Successive pastes
(1) After the cell data information of a desired area has been copied into the copy

buffer using any copy procedure, click the cell at the upper left corner of an

area where you wish to paste the cell data.

(2) Right click → [Successive Pastes].
>>  The cell data values are pasted repeatedly for the number of specified

cycles with the rectangular shape and cell data of the source area kept in

order.



Chapter 10. WORKING WITH PARAMETERS ONLINE
10  -  1 Downloading Parameters

Follow the steps below to download individual instance body data of the selected Parameter instance.

(1) Make sure that the Parameter instance you wish to download is selected in the treeview and that [Instance
Body] tab is selected.

For details about Parameter instance,

refer to section 8-2, Selecting  Parameters (page 8-4).

(2) Select [Parameter] → [Download], or right click → [Download] on the instance grid.  The download is

started immediately after the section has been made.

Handling Precautions
• When the currently displayed data is the online data (the background

color of the item names in the instance body grid is yellow or orange,
which may vary between PCs), if the download operation is performed,
the data to be downloaded is not the currently displayed data but the
offline data (the background color of the item names is gray).  To display
the offline data, select [Parameter] → [Display Mode] → [Offline], or right
click → [Display Mode] → [Offline] on the instance grid.

• When new instances of  Calculation Parameters, Calculation monitor
Parameters, User-defined Parameters, or Pattern FB Monitor are
created, or when there are some additions of Pattern Setup or Segment
Setup, the added instances cannot be downloaded individually until the
application is downloaded.
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10  -  2 Uploading Parameters

10-2

Follow the steps below to individually upload the instance body data of the selected Parameter instance.

(1) Make sure that the Parameter instance you wish to upload is selected in the treeview and that [Instance Body]
tab is selected.

For details about Parameter instance,

refer to section 8-2, Selecting  Parameters (page 8-3).

(2) Select [Parameter] → [Upload],  or Right click → [Upload] on the instance grid.  The upload is started

immediately after the selection has been made.

When the upload is executed, uploaded Parameter values are stored into the PC as Parameter online data, and are

displayed.

The background color of the item names becomes yellow or orange.  To check the offline data, select [Parameter]
→ [Display Mode] → [Offline], or right click → [Display Mode] → [Offline] on the instance grid.  

For details about how to change the Parameter display mode, 

refer to section 10-4, Changing the Parameter Display Mode (page 10-4).

Handling Precautions
When  new instances of Calculation Parameters, Calculation monitor
Parameters, User-defined Parameters, or Pattern FB Monitor are created,
or when there are some additions of Pattern Setup or Segment Setup,  the
added instances cannot be uploaded individually until the application is
downloaded.
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10  -  3 Overwriting Parameters with the Uploaded Data

Select [Parameter] → [Overwrite with Uploaded Data], or right click → [Overwrite with Uploaded Data] on

the instance body .  The offline data of the currently selected instance body is overwritten by the online data.

The following screen shows that [Overwrite with Uploaded Data] is selected by right clicking on the instance

body.

10-3
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10  -  4 Changing the Parameter Display Mode

10-4

To change the display mode from online to offline or from  offline to online, select [Parameter] → [Display
Mode] → [Offline] ([Online]).  This operation is also performed by right clicking on the instance body.

Note
When the display mode is changed from offline to online, the Parameter instance

values are uploaded automatically.
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10  -  5 Monitoring Parameters

In SLP-D50, the operation that uploads Parameters continuously to update the online data is called "monitoring".

■ Starting and stopping monitoring
To start monitoring, select a Parameter instance you wish to monitor and select

[Online] → [Start Monitor].  To stop the monitoring, select [Online] → [Stop
Monitor].

■ Status during monitoring
The message, "Monitoring", will appear at the left portion of the status bar of the

"Project" window during monitoring.  The message, "Online", will appear while

other commands are running and the message, "Offline", will appear in the no

connection state.

Additionally, the ISaGRAF program operation status is shown in the 2nd field

from the left of the status bar.

In this field, relevant application name is shown while the application is running,

"Stopped" is shown while the application is stopped, and "Unknown" is shown if

the operation status is unknown, such as offline status.

Handling Precautions
It takes several seconds to grasp the application status after the
monitoring has been started.

■ Switching parameters to monitor
When selecting an instance of another Parameter type in the treeview during

monitoring, a Parameter instance to monitor is automatically switched to that

instance.
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10  -  6 Changing Parameter Data on the Module

10-6

When changing a cell (Parameter element) value in an instance while the online data is being displayed (the

background color of the item names is yellow or orange), this value will be reflected on the module.

For details about how to edit the cell data, 

refer to section 9-3, Editing Cell Data (page 9-14).
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10  -  7 Uploading All Parameters

Follow the steps below to upload the instance body data of all Parameters of a project by one action:

(1) With the "Project" window active, select [Online] → [Upload All Parameters].  The instance data of all

Parameters of the project will be uploaded.

(2) After the upload has been completed, the dialog box prompting you to confirm overwriting offline data will

appear for each instance.  If selecting [Yes] in this dialog box, the offline data is overwritten with the uploaded

data.  If selecting [Yes to All], the offline data will be overwritten with the uploaded data for all the remaining

instances.

Note
For details about online data and offline data, 

refer to section 9-1, Online Data and Offline Data (page 9-2).

Handling Precautions
• Even if any number of instances that are in the project do not exist in the

controller, the other  instances will be uploaded.

• If there is an instance that is in the controller having the same  type and
top group ID as of an instance  in the project, the instance data will be
uploaded for the number of groups that is smaller of the two instances.

• In case of AHC2001, Upload All Parameters will be performed except for
the Unit Monitor Parameters, as long as the unit configuration of the
project on the PC is as same as the downloaded project in the controller,
even if the unit configuration is not as same as the actual unit
configuration that is physically equipped.

• Upload All Parameters will be failed when there exist User-defined
Types or Segment Setups that are in the project  on the PC and that are
in the controller having the same Parameter Type ID but different
contents.
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10  -  8 Trend Monitoring for Parameters

10-8

Open the [Instance Body] tab, right click → [Trend Monitor].  The trend monitor for the currently displayed

instance will be activated.

For details about trend monitor,

refer to Chapter 21, TREND MONITOR.

Chapter 10. WORKING WITH PARAMETERS ONLINE



10  -  9 System Status Bit Details

System Status (DMC50) or system information (AHC2001) bit details of the connected controller can be shown

with the following steps.

■ DMC50 project
(1) Start Parameter monitoring by selecting [Online] → [Start Monitor] with the

"Project" window active.

(2) In the treeview of the "Project" window, left click to select the instance of

"System Status".

(3) Right click → [System Status] → [System Status Bit Details] on the

instance body grid to activate the System Status bit details monitor window.

>>  There are three tabs: System Alarms tab, AI Alarms tab, and AUX-IN

Alarms tab are shown. Check boxes are checked while the corresponding

alarms are being generated. 

For details about the System Status bits,

refer to Module Type Controller DMC50 User's Manual
"Installation and Configuration", CP-SP-1139E
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■ AHC2001 project
(1) Start Parameter monitoring by selecting [Online] → [Start Monitor] with the

"Project" window active.

(2) In the treeview of the "Project" window, left click to select the instance of

"System Info".

(3) Right click → [System Info] → [System Status Bit Details] on the instance

body grid to activate the System Info bit details monitor window.

>> There are three tabs:State of Operation, Error Status, and Alarm Status are

shown. Check boxes are checked while the corresponding alarms are being

generated.

Note
For details about the System Status bits,

refer to Module Type Controller AHC2001 User's Manual "Basic
Operation", CP-SP-1137E.
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Chapter 11. EDITING APPLICATION PROGRAMS

This chapter describes how to operate SLP-D50/ISaGRAF and the cautions on the use of ISaGRAF, which are

necessary to understand when creating an application program to be run on the programmable controller.

For details about general programming of ISaGRAF,

refer to ISaGRAF Version 3.5 USER'S GUIDE.
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11  -  1 Roles of SLP-D50 and ISaGRAF

11-2

■ A role of ISaGRAF

● To provide a programming environment for IEC61131-3 language
To run control operations on the programmable controller, it is absolutely

necessary to write an application program using ISaGRAF.

● To set up the unit configuration and connect I/O (For AHC2001 controller)
The I/O connector editor is used to set up the configuration of units to be

connected to AHC2001, and to connect the ISaGRAF variables and I/O channels.

Parameters (unit setup and unit status) corresponding to the unit configuration are

created automatically.

■ Roles of SLP-D50

● To set up I/O
It is possible to access the I/O of a controller through the I/O variables of

ISaGRAF.  The setting of each I/O is made using relevant Parameters in SLP-D50.

For details about the connections between the controller I/O and I/O variables , 

refer to the description, ● About I/O connection editor and I/O
assignments (page 11-7).

● To set up Calculation (Monitor) Parameters
When using Yamatake's calculation blocks, such as PID_A and UP_PID in an

application program written with ISaGRAF, it is necessary to edit the

corresponding  Calculation (Monitor) Parameters with SLP-D50.

● To enhance programmability with User-defined Parameters
If it is desirable to use  arrays or structures, which are not available in ISaGRAF,

create appropriate User-defined Parameter types and their instances with SLP-D50
and they are accessed from the ISaGRAF programs through the access function

blocks.

For details about the User-defined type,

refer to Chapter 19, USER-DEFINED PARAMETER LIBRARY and
section 9-9, Utilizing User-Defined Types (page 9-11).

● To supplement the ISaGRAF variable editor 
SLP-D50 also has a capability to edit the ISaGRAF variables, different from the

ISaGRAF dictionary.  This feature is used to edit the I/O variables, set the virtual

I/O, and show the locking status to supplement the limitations on ISaGRAF

dictionary and I/O connection editor.  Additionally, this feature is also used to

make the ISaGRAF variables available in another window, such as "Group

monitor" window.

For details,

refer to Chapter 12, EDITING AND MONITORING THE ISAGRAF
VARIABLES USING SLP-D50.
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● To supplement the unit configuration setup (For AHC2001 controller)
When SLP-D50 is connected to the AHC2001 controller in the online mode, the

configuration of the units currently connected to the controller is read to set up the

unit configuration.

● To automate programming
SLP-D50 provides three automatic program generation features: Sampling Trace

Wizard, Integer Conversion Wizard, and Pattern Wizard.

By setting up with the relevant wizard, each feature is programmed automatically.

For details, 

refer to  Chapter 22, SAMPLING TRACE WIZARD, 
Chapter 23, INTEGER CONVERSION WIZARD, and 
Chapter 24, PATTERN WIZARD.

Chapter 11. EDITING APPLICATION PROGRAMS
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11  -  2 Application Program Structure

In ISaGRAF, multiple programs are executed sequentially at intervals of the specified cycle time.  Additionally,

sub-programs (SP), function blocks (FB), and functions (FUNC) are called from each program as reusable units.

For details, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.

repeated at intervals 
of the cycle time. Program A

Program B

Program C

FB a

SP S

FB a

FUNC f
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11  -  3 Activating the "ISaGRAF Program" Window

• For the DMC50 communication modules (module type is ME200/MR200), ISaGRAF programs cannot be

created.

• If no project has been created, it is necessary to first create a project.

For details, 

refer to Chapter 5, CREATING NEW PROJECTS.

• If a project is not opened, open a project.  

For details, 

refer to Chapter 6, OPENING PROJECTS.

• If a project for the programmable controller (CTRL module: module type is CH400/200, CS400/200, or

CN400/200; AHC2001 controller: module type is AHC2001) has been opened, select [Edit] → [ISaGRAF]
→ [Edit Programs] to activate the "ISaGRAF program" window, allowing you to edit the application

program.

Note
By selecting [Options] → [Project Options] in the "Project" window, you can

identify the module type of the project.

• Setup Parameters for calculation blocks such as PID function blocks, and User-defined Parameters to be used in

the ISaGRAF application programs are set using SLP-D50.
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11  -  4 Basic Procedure for Creating an Application Program

The following shows a procedure example to create an application program for DMC50 and AHC2001 However,

it is also accepted to use other procedures.

For details, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.

Additionally, for details about cautions on each feature, 

refer to section 11-5, Cautions about Writing Application Programs in ISaGRAF (page 11-10).

■ DMC50
(1) Defining global variables

• Define global variables shared by multiple programs using the dictionary.

• To open the dictionary, select [File] → [Dictionary] in the program

management window.

• For details about how to use the dictionary, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.

• I/O variables are automatically defined when creating a project of DMC50.  If

the I/O has not been set up yet, set the I/O Parameters corresponding to the I/O

variables.

For details, 

refer to the description ● About I/O connection editor and I/O
assignments (page 11-10).

(2) Creating programs
• Create programs you wish to run at the beginning part of every cycle in "Begin"

section.  Create programs you wish to run at the last part in "End" section .  You

can select a programming language from FBD, Quick LD, ST, and IL.

• Create sequential procedures in "Sequential" section .  You can select a

programming language from SFC and FC.

• In the program management window, select [File] → [New].  The "New
Program" dialog box will appear.  Set a name, language, and style (Begin, End,

or Sequential), and then click [OK].  A new program will be created.

• Declare variables necessary only in a program as local variables.

• Write program logic in the specified language.

• The I/O of the DMC50 has been assigned to I/O variables.  Therefore, the I/O

can be accessed in programs.

• In addition to the standard ISaGRAF FBs and Funcs, other special calculations

for DMC50 can be used.

For details, 

refer to the description, ● About predefined function blocks and
functions (page 11-11).



11-7

Chapter 11. EDITING APPLICATION PROGRAMS

(3) Creating functions, function blocks, and sub-programs
• When a same series of calculations is performed repeatedly in programs,

putting the calculations in one of the above units will help you  easily view the

programs.

• Functions are used to write a mathematical or whatever operation that does not

have any states and returns only one value.

• Function blocks are used to write a mathematical or whatever operation that has

states or returns multiple values.

Handling Precautions
In ISaGRAF v3.5, it is not possible to write an application  where a
function block further calls other function blocks having states.
If such an application program is written, relevant warning messages
will appear during compiling.

• A sub-program is a child of a specific program as its name indicates.  Sub-

programs cannot be called from programs other than its parent program.

(4) Verifying the creations
• Verify the syntax of the source code by compiling the application program.  

For details, 

refer to Chapter 13, COMPILING APPLICATION PROGRAMS.

• Transfer the compilation results to the controller by downloading the

application program.  

For details, 

refer to Chapter 14, DOWNLOADING  APPLICATIONS.

• Check the execution status during debugging in the online mode.  

For details, 

refer to Chapter 16, ONLINE DEBUGGING OF APPLICATIONS.

Handling Precautions
Even though a part of the programming results can be examined by the
ISaGRAF simulation feature,  programs that use the function blocks
designed for DMC50 and Parameters may not operate correctly. To
check the application behavior on an actual controller with real outputs
disconnected, use the virtual I/O.

For details, 
refer to the description, ■ Virtual I/O (page 12-9).

■ AHC2001
The unit configuration setup, I/O variation declaration, and I/O connection

procedures are added to those of DMC50.

(1) Setting up the unit configuration
• Open the I/O connection editor, select units from the “Select board/equipment”

list starting next to the CPU, and assign them sequentially into the slots without

making empty slots in between.  (CPU and power supply units are excepted.)
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For details,
refer to the description, ● About I/O connection editor and I/O
assignments (page 11-17).

• Additionally, when connected to the AHC2001 controller in the online mode,
select [Online] → [Update Unit Configuration] in the “SLP-D50 Project”
window to automatically make the configuration of currently connected units
reflected on the project.
For details,

refer to section 25-1, Unit Configuration Setup (page 25-2).

(2) Defining global variables (including I/O variables)
• Define global variables shared by multiple programs using the dictionary.

• To open the dictionary, select [File] → [Dictionary] in the “Program
Management”window.

• For details about how to use the dictionary, refer to ISaGRAF Version 3.5
USER'S GUIDE.

• No I/O variables of AHC2001 are defined when creating a project. Create
necessary variables using the [Quick declaration] feature of the dictionary.
For details,

refer to the description, ● About dictionary (page 11-19).

(3) Editing the I/O connection and unit setup
• Open the I/O connection editor and connect each channel of the set I/O unit to

relevant I/O variable.

• To set up the operation of each unit, edit the Unit Setup Parameters having the
same No. as the slot No. of the I/O connection editor in the “Project”window
of SLP-D50.  (Note that there may be units without Unit Setup.)
Additionally, for AI and AO units, the channel No. of the unit corresponds to
the group ID of the Unit Setup Parameter.
For details,

refer to the description, ● About I/O connection editor and I/O
assignments (page 11-17).

(4) Creating programs
• Create programs you wish to run at the beginning part of every cycle in "Begin"

section.  Create programs you wish to run at the last part in "End" section. You
can select a programming language from FBD, Quick LD, ST, and IL.

• Create sequential procedures in "Sequential" section.  You can select a
programming language from SFC and FC.

• In the “Program Management”window, select [File] → [New]. The "New
Program" dialog box will appear.  Set a name, language, and style (Begin, End,
or Sequential), and then click [OK].  A new program will be created.

• Declare variables necessary only in a program as local variables.

• Write program logic in the specified language.

• After you define the I/O of AHC2001 as I/O variables and connect each of
them to a channel of a unit, you can use the I/O in programs.
For details,

refer to the description, ● About I/O connection editor and I/O
assignments (page 11-17).

Chapter 11. EDITING APPLICATION PROGRAMS
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• In addition to the standard ISaGRAF FBs and Funcs, other special calculations

for AHC2001 can be used.

For details,

refer to the description, ● About predefined functions and function
blocks (page 11-17).

(5) Creating functions, function blocks, and sub-programs
• When a same series of calculations is performed repeatedly in programs,

putting the calculations in one of the above units will help you easily view the

programs.

• Functions are used to write a mathematical or whatever operation that does not

have any states and returns only one value.

• Function blocks are used to write a mathematical or whatever operation that has

states or returns multiple values.

Handling Precautions

In ISaGRAF v3.5, it is not possible to write an application where a
function block further calls other function blocks having states.
If such application program is written, relevant warning messages will
appear during compiling.

• Subprograms cannot be called from programs other than its parent program.

(6) Verifying the creations
• Verify the syntax of the source code by compiling the application program.

For details,

refer to Chapter 13, COMPILING APPLICATION PROGRAMS.

• Transfer the compilation results to the controller by downloading the

application program.

For details,

refer to Chapter 14, DOWNLOADING APPLICATIONS.

• Check the execution status during debugging in the online mode.

For details,

refer to Chapter 16, ONLINE DEBUGGING OF APPLICATIONS.

Handling Precautions

Even though a part of the programming results can be examined by the
ISaGRAF simulation feature, programs that use the function blocks
designed for AHC2001 and Parameters may not operate correctly.  To
check the application behavior on an actual controller with real outputs
disconnected, use the virtual I/O.

For details,

refer to the description, ■ Virtual I/O (page 12-9).

Chapter 11. EDITING APPLICATION PROGRAMS



11-10

Chapter 11. EDITING APPLICATION PROGRAMS

11  -  5 Cautions about Writing Application Programs in ISaGRAF

■ DMC50
When editing the DMC50 projects using the ISaGRAF with Yamatake's Patch
applied, there are differences and cautions described below when compared to the
original ISaGRAF v3.5x.

● About I/O connection editor and I/O assignments
• It is not possible to add or delete an I/O board to/from  any slot, and also not

possible to assign or unassign I/O variables to/from I/O channels.

• The analog input I/O variables AI_1 to AI_4 correspond to AI standard
channels 1 to 4.  These AI channels are set up by "AI Setup (standard inputs)"
in the System Parameters.

• The analog input I/O variables AIOPT_1 to AIOPT_4 correspond to AI option
channels 1 to 4.  These AI channels are set up by "AI Setup (option inputs)" in
the System Parameters.

• The analog input I/O variables AUXIN_1 and AUXIN_2 correspond to
AUX_IN channels 1 and 2.  These AUX_IN channels are set up by "AUX-IN
Setup" in the System Parameters.

• The analog output I/O variables AO1 to AO4 correspond to AO channels 1 to 4.
These AO channels are set up by "AO Setup (basic)" in the System Parameters.

• The digital input I/O variables DI_01 to DI12 correspond to DI channels 1 to
12.  With the current version, there are no settings to these DI channels.

• The digital output I/O variables DO_01 to DO_16 correspond to DO channels 1
to 16.  These DO channels are set up by "DO Setup (basic)" in the System
Parameters.

• The analog output I/O variables TP_01 to TP16 correspond to TP channels 1 to
16.  These TP channels are set up by "TP Setup (DO)" in the System Parameters.

Handling Precautions
• The real ← → virtual board switch will not take effect.  Toggle the

real/virtual switch in SLP-D50.
For details, 

refer to the description, ■ Virtual I/O (page 12-9).

• The TP channels uses the same real output ports as those used by
the DO channels.  Therefore, the same channels of DO and TP
cannot be used at the same time.  A TP channel is enabled/disabed
by the output type setting of the DO Setup (basic) for the
corresponding channel.

● About the dictionary
• When editing the I/O variables, operations other than changing of the network

address cannot be performed.

• The I/O variables must be edited using SLP-D50.  
For details, 

refer to Chapter 12, EDITING AND MONITORING THE ISAGRAF
VARIABLES USING SLP-D50.

• A global variable starting its name with "Y?_" must not be declared.  Such
variables are used by the automatic programming features.  (?=A ..z) 

• A network address greater than or equal to "A000 (HEX)" must not be assigned
to any user defined variable.  This address space is used by the automatic
programming features. 
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• Initial values can be assigned for the retained variables.

● About user created Programs, Function Blocks, and Functions

• About the default program "Control"
As a project is created, a blank program "Control" (language is FBD) is created
automatically.  This program is provided only as reference.  You can delete this
program or change the name to write a desired program.

• The following names must not be used for the program, function block, and
function name:  ARCREATE, ARREAD, ARWRITE, DAY_TIME, F_CLOSE,
F_EOF, F_ROPEN, F_WOPEN, FA_READ, FA_WRITE, FM_READ,
FM_WRITE, PID, SEMA, STACKINT.  The above words are internally
reserved keywords for ISaGRAF.

• A name beginning with "YC_" must not be used for the program, function
block, and function names.  The automatic programming features have a
priority to use such names.

• Reserved keywords used by ISaGRAF and predefined function and function
block names must not be used for variable names, program names, function
names and function block names created by the user.  If such names are used,
the compilation errors may occur.

● Cautions about editing SFC programs
• When forming simultaneous sequences in SFC, the transition symbol for the

divergence condition must be located before the divergence point, and the
transition symbol for the converging condition must be located after the
convergence point.  Even though this rule is violated, the ISaGRAF compiler
does not detect any compile error, and faulty operation will occur during the
execution.  Strictly observe the chart.

● About predefined function blocks and functions
The following function blocks and functions are listed in the standard ISaGRAF,
but cannot be used for DMC50:

• Array operation functions (ARCREATE, ARREAD, ARWRITE) 

• Binary file management (F_ROPEN,  F_WOPEN,  F_CLOSE,  F_EOF,
FA_READ,  FA_WRITE,  FM_READ,  FM_WRITE) 

• I/O operation (OPERATE) 

• Others (sema, stack_int, day_time)

Handling Precautions
When the above FBs and Funcs are used in the ST or IL language,
they can be compiled and downloaded.  However, the correct
operation cannot be guaranteed.  Therefore, do not use the FBs and
Funcs quoted above.

Incorrect syntax Correct syntax

Diverging  condition

Converging condition
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Calculation blocks added for DMC50
The following lists the calculation blocks added for DMC50.  

For details about arguments of each calculation block, 

refer to Module Type Controller DMC50/AHC2001 User's Manual
"Function Block Reference", CP-SP-1130E.

• PID operations (PID_A, UP_PID, RA_PID, PID_CAS) 

• Parameter access FBs (par_bool, par_int, par_real, paw_bool, paw_int,

paw_real)

Handling Precautions
Note that the type ID, group ID, and item ID are passed as arguments
to each Parameter access FB.  The type ID is the same as that of the
Parameter type header.  The group ID and item ID are the same as the
column No. and row No. of the Parameter instance body tab,
respectively.
For details about System Parameters, 

refer to [Parameter Reference Manual].

• Selectors and multiplexers (mux8real, sel_bool, sel_real, sel_tmr)

• Linearization table (tbl, tbr) 

• Other function blocks (ded, lead_lag, mav, psvc, ramp_gen, zone7) 

• Other functions (ana_dp, bin3dec, bin8dec, lim_hi, lim_hlo, lim_lo, scal_cnv) 

• Pattern FBs (ptn_main, ptn_sub, ptn_evr, ptn_tev, ptn_mode) 

Handling Precautions

In the list box of the ISaGRAF language editor, you can select both
functions and function blocks added for DMC50 and AHC2001.
A calculation block (*) that runs only on either controller is checked
when the application is downloaded.  If such calculation block is
detected during downloading, the download error occurs.
* “Psvc” is specially designed for DMC50.  The communication FBs

(h_close, h_write, h_read, h_open) are specially designed for AHC2001.

▼
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● About how to use functions and function blocks designed for DMC50
Functions and function blocks designed for DMC50 can be used in programs.

However, note that several calculations, such as PID operations need the group

IDs of the Calculation Parameters and Calculation Monitor Parameter specific to

those calculation blocks as their arguments.

For details, 

refer to the description of each calculation block in Module Type Controller
DMC50/AHC2001 User's Manual "Function Block Reference", CP-SP-
1130E.

The following describes how to create Calculation Parameters and how to use

them:

(1) Create instances of the Calculation (Monitor) Parameter types associated with

the calculation block you wish to use.  When the calculation block is "PID_A",

create instances of three types as PID_A options, PID_A constants, and PID_A

monitor.  

For details about necessary Parameter types, 

refer to the description of each calculation block in Module Type
Controller DMC50/AHC2001 User's Manual "Function Block
Reference", CP-SP-1130E.

(2) Create an instance of the required number of groups, or create multiple

instances of one group.  How the instance is divided must follow the

specification of each calculation block if such specification exists (TBL, TBR).

If no specification exists, the instance should be  divided according to the

meaning difference.

For details about how to edit Parameters, 

refer to Chapter 9, EDITING PARAMETERS.

(3) When necessary, change the setting values of each Calculation Parameter.

(4) Place a desired calculation block on your program and specify a valid group ID

as one of the arguments.  If the group ID is represented by a variable, it is

possible to change the value during operation.
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● About how to edit Parameters of the project currently being edited
To edit Parameters of the project which contains the program you are editing in

ISaGRAF, select [Tools] → [SLP-D50] → [Edit Parameters].  When SLP-D50
is activated, rearrange the associated "Project" window on top of the "MDI"
window.

● About compiler options
To download an application program into DMC50, it is absolutely necessary that

"ISA68M" is selected.  "ISA68M" is the default value when creating a project.

Additionally, if "ISA68M" is not selected, a relevant warning message will appear

during compilation.

● About run-time options

• Cycle trigger

The [Trigger cycles] check box must be checked to make the cycle timing

setting effective.  With the default setting, this check box is checked.

If this check box is not checked, a compile error will occur during compilation.

• Cycle timing

This determines the control cycle time of the DMC50.  Since the sampling time

of the DMC50 analog input is 50 ms, it is preferable to set a multiple of 50 ms.

With the default setting, the cycle timing is set at 100 ms.  If a value less than

50 ms is specified, a compile error will occur.

• Retained variables

This setting is not used.  Variables, for which the retain attribute is set, are

retained as long as the memory area allows.
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● Link setup
• Target Slave Number

This target slave number must be the same as the rotary switch number on the

module corresponding to the project.  

Changing the value of "Module Address" in the dialog box activated by

selecting [Options] → [Project Options] with the project window active in

SLP-D50 automatically alters this setting.

• Communication port

In SLP-D50 package, [DMC50] can be selected.  In SLP-H21 package,

[modcon] can be selected.  Other settings cannot be selected.

● Debugger
• When activating the debugger in ISaGRAF, ISaGRAF will enter the debug

mode.  Other ISaGRAF windows, which will be opened after that, will start

monitoring automatically.  Note that, however, the "Project" window opened in

SLP-D50 does not start  monitoring automatically.

• Selecting [Download] starts the download of  the ISaGRAF application

program; all System Parameters, Calculation Parameters, User-defined

Parameters, and Program Pattern Parameters, which have been set up by SLP-
D50.

Handling Precautions
With a download issued from the ISaGRAF debugger, even though the
application has been edited after the last compilation (Make
Application), it can be downloaded without error or warning.  Therefore,
use of the application download feature in SLP-D50, which can check
this condition, is recommended.

• With the current version, [Update application] and [Realize update] menus

cannot be run.

• By selecting [Options] → [Parameter], the communication time out and cyclic

refresh duration can be specified.  When one communication request is issued

to DMC50, the response time "h" is approximately calculated as follows:

h >  Cycle time (This time is specified in the run-time option as cycle

timing.) 

+ Packet round trip time (1ms X send/receive packet size in bytes) 

+ CPU processing time (DMC50&PC)

A multiple of the above value becomes the fastest response time if multiple data

monitors, such as SLP-D50 trend monitor and ISaGRAF dictionary, are opened

on the PC,  or if multiple communication paths are active at the same time on

DMC50, like host communication through the COM module and SLP-D50
communication through the loader port.

Note
A communication time out value of 2000 ms or longer and a cyclic refresh

duration of 1000 ms or longer are strongly recommended.
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● Lock variable monitor
ISaGRAF v3.5 has a monitoring feature for the device value of each I/O variable

in lock state. In our implementation the value is always 0 or False.

● Simulator
• With the current version, outputs of the function blocks designed for DMC50

always become "0".  To perform the simulation on the functions and  function

blocks designed for DMC50 and the simulation of timing, it is recommended to

debug on the module using the virtual I/O.  

For details about virtual I/O, 

refer to the description, ■ Virtual I/O (page 12-9).

• All accesses from SLP-D50/ISaGRAF, functions and function blocks to

Parameters in simulation are not supported.

● Library
The I/O configurations, I/O complex equipments, I/O boards, C language

functions, C language function blocks and  conversion functions cannot be edited.

Handling Precautions
After registering the functions and function blocks written in the IEC
language into the library, it is necessary to compile them on the library
to use them in programs.  At that time, make sure that "ISA68M" is
specified in the compiler options.

● Password protection
The password feature cannot be used.

● Others
The application symbols file and resource definition file cannot be used.
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■ AHC2001
When editing the AHC2001 projects using the ISaGRAF with Yamatake's Patch

applied, there are differences and cautions described below when compared to the

original ISaGRAF v3.5.

● About I/O connection editor and I/O assignments
• It is possible to select a unit of the AHC2001 controller from the board library

in the "Select board/equipment" dialog box.  Select a unit and assign it to each

slot. At this time, from the position near the CPU unit, assign units to the slot

No. 1, 2, and so on.

Handling Precautions

• Assign units sequentially without any blank slots.

• DI/DO units having the description “(common)”, like 32-point input unit
(common) are put when activating the update feature of the unit
configuration in the online mode through the AHC2001 controller
since the update feature of the unit configuration cannot recognize the
DI/DO units in detail.  This does not hinder the software development.
However, if it is necessary that such units are recorded as formal unit
types, actually used units must be assigned.

• To make the edit results valid in the controller main unit, the
compilation and download must be performed after editing and
saving.

Note

In addition to use of the I/O connection editor, the unit configuration can be

set up automatically from the configuration of the AHC2001 controller

currently being connected in the online mode.

For details, 

refer to section 25-1, Unit configuration setup (page 25-2).
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• When clicking [Save] after the units have been assigned, Unit Parameters (Unit

Setup Parameters, Unit Monitor Parameters) corresponding to each unit are

created automatically.  At this time, the "Update Unit Setup Values" dialog box

will appear. Update the set values of the Unit Setup Parameters with the

following set values.

• Values already set up in the project (Values before updating the unit

configuration)

• Values set up in the controller (AHC2001)

• Default Values

Handling Precautions

When setting using the online data, it is absolutely necessary that
appropriate settings have been performed so that the unit can be
connected to AHC2001.

Handling Precautions
• There may be some units having only either the Unit Setup Parameters

or Unit Monitor Parameters.  In the project window tree view, the label
name becomes “[n] Unit Parameter name”.  (n == unit address == slot
No. on I/O connection editor)

• When restoring the Unit Setup values from the previous values of the
project or from the values in the controller, values of a unit is set with the
values of the corresponding unit that has the same sequence No.
among units of the same unit type in each configuration.

Note

The parameters are edited in the “Project”window of SLP-D50.

• I/O variables have not been declared or connected in advance. After you declare

I/O variables using the [Quick declaration] feature of the dictionary, connect

each I/O variable to a channel of an I/O unit using the I/O connection editor.
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● About the dictionary
• When necessary, declare the I/O variables. When using the quick variable

declaration of ISaGRAF, the variables can be declared together.

Handling Precautions
• When using the version information of ISaGRAF, the number of

available I/O variables is shown.  If I/O variables exceeding this
quantity are declared, the compilation error may occur.
(64 I/O variables for the SLP-D50 package and 256 I/O variables for
the SLP-H21 package)

• Do not use the following declaration and assignment.  Such variables
and address space are used by the automatic programming features.
A global variable starting its name with "Y?_" must not be declared.
(?=A ..z)

A network address greater than or equal to "A000 (HEX)" must not be
assigned to any user defined variable. 

• Initial values can be assigned for the retained variables.

● About user created Programs, Function Blocks, and Functions
• About the default program "Control"

As a project is created, a blank program "Control" (language is FBD) is created
automatically.  This program is provided only as reference. You can delete this
program or change the name to write a desired program.

• The following names must not be used for the program, function block, and
function names: ARCREATE, ARREAD, ARWRITE, DAY_TIME,
F_CLOSE, F_EOF, F_ROPEN, F_WOPEN, FA_READ, FA_WRITE,
FM_READ, FM_WRITE, PID, SEMA, STACKINT.  The above words are
internally reserved keywords for ISaGRAF.

• A name beginning with "YC_" must not be used for the program, function
block, and function names. The automatic programming features have a priority
to use such names.

• Reserved keywords used by ISaGRAF, and predefined function and function
block names must not be used for variable names, program names, function
names, and function block names created by the user. If such names are used,
the compilation errors may occur.
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● Cautions about editing SFC programs
• When forming simultaneous sequences in SFC, the transition symbol for the

divergence condition must be located before the divergence point, and the

transition symbol for the converging condition must be located after the

convergence point.  Even though this rule is violated, the ISaGRAF compiler

does not detect any compile error, and faulty operation will occur during the

execution. Strictly observe the chart below.

● About predefined function blocks and functions
The following function blocks and functions are listed in the standard ISaGRAF,

but cannot be used for AHC2001:

• Array operation functions (ARCREATE, ARREAD, ARWRITE)

• Binary file management (F_ROPEN, F_WOPEN, F_CLOSE, F_EOF,

FA_READ, FA_WRITE, FM_READ, FM_WRITE)

• I/O operation (OPERATE)

• Others (sema, stack_int, day_time)

Handling Precautions

When the above FBs and Funcs are used in the ST or IL language,
they can be compiled and downloaded. However, the correct operation
cannot be guaranteed.  Therefore, do not use the FBs and Funcs
quoted above.

Incorrect syntax

Conversing condition

Correct syntax

Diverging condition
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Calculation blocks added for AHC2001
The following lists the calculation blocks added for AHC2001.

For details about arguments of each calculation block,

refer to Module Type Controller DMC50/AHC2001 User's Manual
"Function Block Reference", CP-SP-1130E.

• PID operations (PID_A, UP_PID, RA_PID, PID_CAS)

Handling Precautions

In the AHC2001 controller, the PID operation is synchronized with the
analog input cycle. Therefore, according to the cycle time setting and
Analog I/O Update Time setting, the operation cycle and PID operation
of ISaGRAF are executed once every one cycle, once every two cycles
(initial setting), or once every four cycles.
For details,

refer to Module Type Controller AHC2001 User's Manual "Basic
Operation", CP-SP-1137E.

• Parameter access FBs (par_bool, par_int, par_real, paw_bool, paw_int,

paw_real)

Handling Precautions

Note that the type ID, group ID, and item ID are passed as arguments
to each Parameter access FB.  The type ID is the same as that of the
Parameter type header.  The group ID and item ID are the same as the
column No. and row No. of the Parameter instance body tab,
respectively.
For details about System Parameters,

refer to Parameter Reference Manual.

• Selectors and multiplexers (mux8real, sel_bool, sel_real, sel_tmr)

• Linearization table (tbl, tbr)

• Pattern FB (ptn_main, ptn_sub, ptn_evr, ptn_tev, ptn_mode)

• Communication FB (h_close, h_write, h_read, h_open, h_ioctl)

• Text string conversion Func, FB (hex2dec, dec2hex, hex_sum, dec16bin,

bin16dec)

• Other function blocks (ded, lead_lag, mav, ramp_gen, zone7)

• Other functions (ana_dp, bin3dec, bin8dec, lim_hi, lim_hlo, lim_lo, scal_cnv)

Handling Precautions

In the list box of the ISaGRAF language editor, you can select both
functions and function blocks added for DMC50 and AHC2001.  A
calculation block (*) that runs only on either controller is checked when
the application is downloaded.  If such calculation block is detected,
the download error occurs.

* The function block Psvc is specially designed for DMC50. 

The communication FBs (h_close, h_write, h_read, h_open) are specially designed for AHC2001.

▼
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● About how to use functions and function blocks designed for AHC2001
Functions and function blocks designed for AHC2001 can be used in programs.

However, note that several calculations, such as PID operations need the group

IDs of the Calculation Parameters and Calculation Monitor Parameter specific to

those calculation blocks as their arguments.

For details,

refer to the description of each calculation block in Module Type Controller
DMC50/AHC2001 User's Manual "Function Block Reference", CP-SP-
1130E.

The following describes how to create Calculation Parameters and how to use

them. (These procedures are the same as those of DMC50.)

(1) Create instances of the Calculation (Monitor) Parameter types associated with

the calculation block you wish to use. (When the calculation block is "PID_A",

create instances of three types as PID_A options, PID_A constants, and PID_A

monitor.)

For details about necessary Parameter types,

refer to the description of each calculation block in Module Type
Controller DMC50/AHC2001 User's Manual "Function Block
Reference", CP-SP-1130E.

At this time, create an instance of the required number of groups, or create

multiple instances of one group. How the instance is divided must follow the

specification of each calculation block if such specification exists (TBL, TBR).

If no specification exists, the instance should be divided according to the

meaning difference.

For details about how to edit Parameters,

refer to Chapter 9, EDITING PARAMETERS.

(2) When necessary, change the setting values of each Calculation Parameter.

(3) Place a desired calculation block on your program and specify a valid group ID

as one of the arguments. If the group ID is represented by a variable, it is

possible to change the value during operation.

● About how to edit Parameters of the project currently being edited
To edit Parameters of the project which contains the program you are editing in

ISaGRAF, select [Tools] → [SLP-D50] → [Edit Parameters].
>> When SLP-D50 is activated, rearrange the associated "Project" window on the

top of the "MDI" window.
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● About compiler options
To download an application program into AHC2001, it is absolutely necessary

that "ISA68M" is selected.  "ISA68M" is the default value when creating a project.

Additionally, if "ISA68M" is not selected, a relevant warning message will appear

during compilation.

• Upload options

In the AHC2001 project, the [Embed source code for upload] check box is

checked on by default for uploading.  When this check box is checked on, the

project can be restored by the upload feature of the project.

For details,

refer to section 18-6, Uploading a project (page 18-7).

● About run-time options
• Cycle trigger

The [Trigger cycles] check box must be checked to make the cycle timing

setting effective.  With the default setting, this check box is checked.  If this

check box is not checked, relevant compile error will occur during compilation.

• Cycle timing

This determines the control cycle time of AHC2001. In AHC2001, either 25

ms or 50 ms can be set.  If a value other than this value is set, a compile error

will occur.

• Retained variables

This setting is not used.  Variables, for which the retain attribute is set, are

retained as long as the memory area allows.

● Link setup
• Target Slave Number

The default target slave number is “1”.  A value other than “1” must not be set.

• Communication port

In the SLP-D50 package, only [DMC50] can be selected while only [modcon]
can be selected in the SLP-H21 package. 

● Debugger
• When activating the debugger in ISaGRAF, ISaGRAF will enter the debug

mode.  Other ISaGRAF windows, which will be opened after that, will start

monitoring automatically.  Note that, however, the "Project" window opened in

SLP-D50 does not start monitoring automatically.

• Selecting [Download] starts the download of the ISaGRAF application

program; all System Parameters, Calculation Parameters, User-defined

Parameters, and Program Pattern Parameters, which have been set up by SLP-
D50.

Chapter 11. EDITING APPLICATION PROGRAMS



11-24

Handling Precautions

With a download issued from the ISaGRAF debugger, even though the
application has been edited after the last compilation (Make
Application), it can be downloaded without error or warning. Therefore,
use of the application download feature in SLP-D50, which can check
this condition, is recommended.

• With the current version, [Update application] and [Realize update] menus

cannot be run.

• By selecting [Options] → [Parameter], the communication time out and cyclic

refresh duration can be specified. When one communication request is issued to

AHC2001, the response time "h" is approximately calculated as follows:

h > Cycle time (This time is specified in the run-time option as cycle timing.)

+ Packet round trip time (1ms x send/receive packet size in bytes) 

+ CPU processing time (AHC2001 & PC)

A multiple of the above value becomes the fastest response time if multiple data

monitors, such as SLP-D50 trend monitor and ISaGRAF dictionary, are opened

on the PC, or if multiple communication paths are active at the same time on

AHC2001, like SLP-D50 communication through the loader (USB) port and

host communication through the SCU unit.

Note

A communication time out value of 2000 ms or longer and a cyclic refresh

duration of 1000 ms or longer are strongly recommended.

● Lock variable monitor
ISaGRAF v3.5 has a monitoring feature for the device value of each I/O variable

in lock state. In our implementation the value is always 0 or False.

● Simulator
• With the current version, outputs of the function blocks designed for AHC2001

always become "0". To perform the simulation on the functions and function

blocks designed for AHC2001 and the simulation of timing, it is recommended

to debug on the module using the virtual I/O.

For details about virtual I/O,

refer to the description, ■ Virtual I/O (page 12-9).

• All accesses from SLP-D50/ISaGRAF, functions and function blocks to SLP-
D50 project data in simulation are not supported.

● Library
The I/O configurations, I/O complex equipments, I/O boards, C language

functions, C language function blocks, and conversion functions cannot be edited.

Handling Precautions

After registering the functions and function blocks written in the IEC
language into the library, it is necessary to compile them on the library
to use them in programs. At that time, make sure that "ISA68M" is
specified in the compiler options.
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● Password protection
The password feature cannot be used.

● Others
The application symbol file and resource definition file cannot be used.
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Chapter 12. EDITING AND MONITORING THE ISAGRAF VARIABLES USING SLP-D50

These features are provided as supplemental features of the dictionary and I/O connection editor of ISaGRAF.

This feature is used to supplement the limitations on the ISaGRAF dictionary and I/O connection editor, such as

editing of the I/O variables, setting of virtual I/O, displaying of the lock status, and to put ISaGRAF variables into

other windows, such as group monitor.

Handling Precautions
• It is not supported to edit and monitor message string variables and

defined words.

• The monitor feature for the simulation are not supported.

• It is not allowed to add and delete the I/O variables, change their names
or types, arrange the I/O boards, and connect the I/O variables.

• Modifications cannot be saved if using the SLP-D50 operators edition.

• Monitoring of variables are available for the SLP-D50 operators edition if
the application program's variable allocation information match that of
the application in the controller. Note that Uploading Project does not
restore this information.
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12  -  1 Activating the "ISaGRAF Variable Declarations" Window

12-2

With the "Project" window opened in SLP-D50, select [Edit] → [ISaGRAF] → [ISaGRAF Var Decls].  The

"Select ISaGRAF POU" dialog box will appear.

Select "Global Vars" or each POU (program, function block, function, or sub-program) in the project.  The

"Variable Declarations" window will be activated, allowing you to edit the boolean variables, integer/real

variables, or timer variables of each unit.  The [I/O Connections] tab will be displayed only when "Global Vars" is

selected, showing the relationship among the I/O channels, I/O variables, and directly represented variables.
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12  -  2 Edit Features (Offline)
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When the monitoring operation is not performed, [Offline] is shown on the status bar,  the background color of the

item Nos. and field names is gray. This indicates that the operation is in the offline edit mode.  The contents you

have edited will take effect in the controller after the edited contents are saved and compiled (Make Application)

and then the application is downloaded.

■ Editing the boolean variables
In SLP-D50, the following edit operations can be performed for the boolean

variables.  Modifications will not be saved until [File] → [Save] is selected. It is

further necessary to compile and download the application in order for the

modifications to take effect in the controller.

● Adding a variable
• To add a variable, right click → [Add Variable] on the grid.  A variable having

a temporary name is added to the bottom row.

• In SLP-D50, constants cannot be added.  Constants can be added in ISaGRAF.

• I/O variables cannot be added.  If necessary for AHC2001, use ISaGRAF.

● Deleting a variable
• To delete a variable, move the mouse pointer to a variable row on the grid you

wish to delete, and right click → [Delete Variable].

• I/O variables cannot be deleted.  If necessary for AHC2001, make a deletion

using ISaGRAF.

● Editing fields
• For I/O variables, the Variable Name and I/O attribute cannot be edited, but the

Addr(address), True/False str, Rtn (retain attribute), Default value, (for

AHC2001, only False can be set) and Comment can be edited.

• For other variables, the Variable Name, Addr(address), True/False str, Rtn

(retain attribute), Default value, and Comment can be edited.

Note
The following table shows the list of each field name, the name of its counterpart

in the ISaGRAF dictionary, and write modes during offline editing and

monitoring.

For details about each field, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.
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Handling Precautions
• The data type of a boolean variable is  BOOL type.  When a boolean

variable is dragged into another window of  SLP-D50, "BOOL" will be
shown.

• Global variables whose name begins with "Y?" must not be used.
Such variables are used by the automatic programming features.
(?=A..z)

• Network addresses over "A000 (HEX)" must not be assigned  to user
defined variables.  Such address values are used by the automatic
programming features.

• Since the current value and lock are online attributes, they cannot be
edited in the offline mode.

• For both the default value and current value, 1 or T can be used as a
literal (constant expression) equivalent to True, and 0 or F can be
used as a literal equivalent to False.

■ Editing the integer and real variables
In SLP-D50, the following edit operations can be performed for the integer and

real variables.  Modifications will not be saved until [File] → [Save] is selected.

It is further necessary to compile and download the application in order for the

modifications to take effect in the controller.
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Field name Field name in Write mode
the ISaGRAF (Enabled: Write enabled, Disabled: Write disabled)

dictionary Offline editing Monitoring

Variable name Name I/O variables Disabled Disabled

Other variables Enabled

I/O Attribute Disabled Disabled

Addr Network address Enabled Disabled

False string Value (False) Enabled Disabled

True string Value (True) Enabled Disabled

Rtn Retain Enabled Disabled

Default Set to true at init Enabled Disabled

Cur Val Value Disabled Enabled

Lock Lock/Unlock Disabled I/O variables Enabled

Other variables Disabled

Comment Comment Enabled Disabled
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● Adding a variable
• To add a variable, right click → [Add Variable] on the grid.  A variable having

a temporary name is added to the bottom row.

• In SLP-D50, constants cannot be added.  Constants can be added in ISaGRAF.

• I/O variables cannot be added.  If necessary for AHC2001, use ISaGRAF.

● Deleting a variable
• To delete a variable, move the mouse pointer to a variable row on the grid you

wish to delete, and right click → [Delete Variable].

• I/O variables cannot be deleted.  If necessary for AHC2001, make a deletion

using ISaGRAF.

● Editing  fields
• For I/O variables, the Variable Name and I/O attribute cannot be edited, but the

Addr (address), Unit, Disp (display format), Rtn (retain attribute), Conv

(conversion), Default value (only 0 can be set for AHC2001), and Comment

can be edited.

• For other variables, the Variable Name, Addr (address), Unit, Disp (display

format), Rtn (retain attribute), Conv (conversion), Default value, and Comment

can be edited.

Note
The following table shows the list of each field name,  the name of its counterpart

in the ISaGRAF dictionary, and write modes during offline editing and monitoring.

For details about each field, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.

Chapter 12. EDITING AND MONITORING THE ISAGRAF VARIABLES USING SLP-D50

Field name Field name in ISaGRAF Write mode
dictionary (Enabled: Write enabled, Disabled: Write disabled)

Offline editing Monitoring

Variable name Name I/O variables Disabled Disabled

Other variables Enabled

I/O Attribute Disabled Disabled

Addr Network address Enabled Disabled

Datatype Format (Integer/Real type) Enabled Disabled

Disp Format Enabled Enabled

Unit Unit Enabled Enabled

Rtn Retain Enabled Disabled

Conv Conversion Enabled Disabled

Default Initial value Enabled Disabled

Cur Val Value Disabled Enabled

Lock Lock/Unlock Disabled I/O variable Enabled

Other variables Disabled

Comment Comment Enabled Disabled
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Handling Precautions
• The data type of an integer variable is  DINT type while the data type

of a real variable is REAL type.  When any of these variables are
dragged into another window of  SLP-D50, they are shown as "DINT"
and "REAL" respectively.

• Global variables whose name begins with "Y?" must not be used.
Such variables are used by the automatic programming features.
(?=A..z)

• Network addresses over "A000 (HEX)" must not be assigned to user
defined variables.  Such address values are used by the automatic
programming features.

• Since the current value and lock are online attributes, they cannot be
edited in the offline mode.

• The literals (constant expression) used for the current value and
default value are the same as in ISaGRAF.  For details about literals
(constant expressions) that can be used in ISaGRAF,

refer to ISaGRAF Version 3.5 USER'S GUIDE.

■ Editing the timer variables
In SLP-D50, the following edit operations can be performed for the timer

variables.  Modifications will not be saved until [File] → [Save] is selected. It is

further necessary to compile and download the application in order for the

modifications to take effect in the controller.

● Adding a variable
• To add a variable, right click → [Add Variable] on the grid.  A variable having

a temporary name is added to the bottom row.

• In SLP-D50, constants cannot be added.  Constants can be  added in ISaGRAF.

● Deleting a variable
• To delete a variable, move the mouse pointer to a variable row on the grid you

wish to delete, and right click → [Delete Variable].

● Editing fields
• For each variable, the Variable Name, Addr(address), Rtn (retain attribute),

Default value, and Comment can be edited.

Chapter 12. EDITING AND MONITORING THE ISAGRAF VARIABLES USING SLP-D50
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Note
The following table shows the list of each field name, the name of its counterpart

in the ISaGRAF dictionary, and write modes during offline editing and

monitoring.

For details about each field, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.

Handling Precautions
• The data type of a timer variable is  TIME type.  When a timer

variable is dragged into another window of SLP-D50, "TIME" will be
shown.

• Global variables whose name begins with "Y?" must not be used.
Such variables are used by the automatic programming features.
(?=A..z)

• Network addresses over "A000 (HEX)" must not be assigned to the
user defined variables.  Such address values are used by the
automatic programming features.

• Since the current value and lock are online attributes, they cannot be
edited in the offline mode.

• The literals (constant expression) used for the current value and
default value are the same as in ISaGRAF (expression like "T#10s").
In addition,  positive integer values can also be used.  However, such
values are interpreted as values in ms. (e.g. 10 = T#10ms).  
For details about literals  (constant expressions) that can be used in
ISaGRAF, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.
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Field name Field name in Write mode
the ISaGRAF (Enabled: Write enabled, 
dictionary Disabled: Write disabled)

Offline editing Monitoring

Variable name Name Enabled Disabled

I/O Attribute Disabled Disabled

Addr Network address Enabled Disabled

Rtn Retain Enabled Disabled

Default Initial Value Enabled Disabled

Cur Val Value Disabled Enabled

Lock Lock/Unlock Disabled Disabled

Comment Comment Enabled Disabled
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■ Virtual I/O
When editing global variables, the I/O connection tab is also shown.  For the

DMC50 project, select the mode column in any row of the board , and right click

→ [Virtual I/O - Real I/O Switch] on it to switch the board between the virtual

I/O and real I/O.  The board, on which the virtual I/O has been set, will be

disconnected from the real I/O of the controller.

Handling Precautions
• After the virtual/real I/O switching has been done, select [File] →

[Save], compile the program (Make Application), and download the
application.  The modifications will then take effect in the controller.

• For the AHC2001 project, switch the board between the virtual I/O and real

I/O using the ISaGRAF I/O connection editor.

■ Copy variables
Using this feature, it is possible to copy variables data from the "ISaGRAF
Variable Declarations" window, and then such data can be put into the group

monitor, Sampling Trace Wizard, or Integer Conversion Wizard at one time.  To

copy the variables data, two actions, "Area selection" and "Copy", are needed.

The following describes how to perform these two actions.

Note
For details about how to put the copied data into a specific window, refer to the

relevant feature's description.

● Area selection 
To copy multiple variables data, it is first necessary to select an area you wish to

copy.

(1) In the "ISaGRAF Variable Declarations" window, open the data type tab

containing the data you wish to copy.

(2) Click the variable No. cell in the top row of a set of variables you wish to copy.

(3) With the [SHIFT] key kept pressed, click the variable No. cell of the bottom

row of variables you wish to copy.

>>  The entire variables rows of the selected area will be displayed in light

gray.

Chapter 12. EDITING AND MONITORING THE ISAGRAF VARIABLES USING SLP-D50
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● Copy
(1) Make sure that a desired area is selected using the area selecting procedure.

(2) Right click → [Copy] on the grid.

>>  The variables data of the selected area will be copied to the copy buffer.

■ Search
A variable is searched for within a tab.

Chapter 12. EDITING AND MONITORING THE ISAGRAF VARIABLES USING SLP-D50
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● Search conditions
The following table shows the search conditions.  Search conditions are specified

in the "Search" dialog box.  Items of the active search conditions are combined

with AND operations.

Chapter 12. EDITING AND MONITORING THE ISAGRAF VARIABLES USING SLP-D50

Condition item name Description

Keyword If this setting is not blank, the keyword search is performed using the specified
string.  
The keyword search can also be performed using the regular expression.  
(→ [Regular Expression])

Where to search Select where the search is performed, either in variable names or in comments.

Match Case Select whether or not the keyword search is case-sensitive.
This will not be used for the regular expression search.

Regular Exp. Check this check box to perform the keyword search using the regular
expression.  PERL compatible regular expression except for bracket expression
can be used.
*  The regular expression search is case-sensitive.

Example 1. ^YP_ A string beginning with "YP_" is searched for.
Example 2. SP$ A string ending with "SP"  is searched for
Example 3 ^A[IO][0-9]+ A string beginning with "AI" or "AO", such as AI10,

AO2, and then followed by numbers is searched for.
Example 4 ^[^A][^IO] A string neither beginning with "AI" nor "AO" is

searched for.
Example 5. ^Y[A-z0-9]+ A string beginning with "Y" and then followed by at

least one alphanumeric character is searched for.
Example 6. [Aa][Ii] A string including "Ai", "AI", "ai", or "aI" is searched

for.
Example 7. A\+B A string including "A+B" is searched for.

Attributes Select a range of attributes of a variable to be searched for from "All", "Input",
"Output", and "Constant" under OR conditions.

Retain Select a retain attribute to be searched for from "All", "Retain", and "Non-retain".

Address (NA=HEX) When this setting is not blank, this address setting in hexadecimal notations
defines  the lower and upper limit of an address to be searched for.

Wrap around The search is started from the next row currently selected.
If any variable meeting the search conditions is not found until the last row with
this check box selected, the search will be continued from the top.
However, if any variable meeting the search conditions is not found in all the
variables, relevant error occurs.
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● Searching procedure
The following shows the searching procedure:

(1) In the "ISaGRAF Variable Declarations" window, open the data type tab

containing a variable you wish to search for.

(2) Click to set a position where you wish to start searching.

(3) Right click → [Search] on the grid.

>>  The "Search" dialog box will appear.

(4) Specify search conditions.  (Refer to ● Search conditions.) 

(5) Click [Next].
>>  The search is started from the next row of the selected row.  If a variable

meeting the search conditions is found, this variable row gets selected

automatically.  Therefore, when clicking [Next] again, another variable

next to this variable meeting the search conditions is to be searched for.

■ Setting the initial (default) values using the online monitor values
This feature is used to set the initial (default) value of each variable in the project

to the current value on the controller after the application has been downloaded

and after the value of each variable on the controller has been changed.  This

feature is performed by means of two methods:  setting the value of each variable

in the selected area;  setting the value of each of the only variables meeting a

search condition.  The following describes how to perform each operation.

Handling Precautions
To secure  changes, it is necessary to save the modifications after
editing.  
For details, 

refer to ■ Saving modifications (page 12-15).

● Setting  the initial value of each variable in the selected area.
(1) In the "ISaGRAF Variable Declarations" window, open the data type tab

containing variables you wish to set their initial value.

(2) Monitor the variables.  

For details, 

refer to section 12-3, Monitoring  Variables (page 12-16).

(3) After making sure that the value of each variable on the controller is reflected

on the current value field, stop the monitoring.

(4) Select an area of the variables you wish to set the initial value using the area

selection procedure of the copy feature.

For details, 

refer to ■ Copy Variables (page 12-9).

Chapter 12. EDITING AND MONITORING THE ISAGRAF VARIABLES USING SLP-D50
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(5) Right click → [Set Values] → [Overwrite Init Value with Monitored Value]
on the grid.

>>  The initial value of each variable in the specified area will be overwritten

with the current values.

(6) To secure changes , save the modifications.

● Setting the initial value of each of the only variables meeting a search condition

(1) In the "ISaGRAF Variable Declarations" window, open the data type tab

containing variable(s) you wish to set the initial value.

(2) Monitor the variables.  

For details, 

refer to section 12-3, Monitoring Variables (page 12-16).

(3) After making sure that the value of each variable on the controller is reflected

on the current value field, stop the monitoring.

(4) Select a variable at which you wish to start searching for setting initial values.

(5) Right click → [Search] on the grid.

(6) Set a condition for variables you wish to search for following the procedure

described in  ■ Search.

(7) To confirm the change for each found variable, click [Monitored Value] of

[Overwrite a Field value with a] in the "Search" dialog box, and select [Yes
] on the confirmation dialog box shown next.  

Click [Next] to search for the next variable meeting the search condition. 

(8) To change the initial value of every variable meeting the search condition in

the same tab at once, click [Monitored Value] of [Overwrite a Field value
with a], and select [Yes to All] on the confirmation dialog box shown next.

Starting from the selected variable, for all the variables that meet the search

condition, their initial values are altered.

Handling Precautions
If [Wrap around] is unchecked in the search conditions, the variable
search and initial values setting are only performed until the variable at
the bottom row.

(9) To secure changes, save the modifications.
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■ Setting the other fields in batch mode
Fields other than the initial value can be set in batch mode. This feature is

performed by means of two methods: setting a field value of each  variable in the

selected area; setting a field value of each of the only  variables meeting a search

condition. The following describes how to perform each operation.

Handling Precautions
To secure changes, it is necessary to save the modifications after
editing.
For details, 

refer to ■ Saving modifications (page 12-15).

● Setting a field value of each variable in the selected area.
(1) In the “ISaGRAF Variable Declarations” window, open the data type tab

containing variables you wish to set their field value.

(2) Select an area of the variables you wish to set a field value using the area

selection procedure of the copy feature.

For details, 

refer to ■ Copy Variables (page 12-9).

(3) Right click → [Set Values] → [With a specified Value] on the grid.

>>  The “Set Values” dialog box will be shown.

(4) Select a field that you wish to change the value, and assign a new value to it.

>>  The field value of each variable in the specified area will be overwritten

with the assigned value.

(5) To secure changes, save the modifications.

● Setting a field value of each of the only variables meeting a search condition
(1) In the “ISaGRAF Variable Declarations” window, open the data type tab

containing variable(s) you wish to set their field value.

(2) Select a variable at which you wish to start searching for setting field values.

(3) Right click → [Search] on the grid.

(4) Set a condition for variables you wish to search for following the procedure

described in ■ Search.

Chapter 12. EDITING AND MONITORING THE ISAGRAF VARIABLES USING SLP-D50
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(5) To confirm the change for each variable, click [Specified Value] of

[Overwrite a Field Value with a] in the “Search” dialog box, and select [Yes]
on the confirmation dialog box shown next. Click [Next] to search for the next

variable meeting the search condition.

(6) To change a field value of every variable meeting the search condition in the

same tab at once, click [Specified Value] of [Overwrite a Field Value with
a] in the “Search” dialog box, and select [Yes to All] on the confirmation

dialog box shown next. Starting from the selected variable, for all the variables

that meet the search condition, their field values are altered.

Handling Precautions
If [Wrap around] is unchecked in the search conditions, the variable
search and the field value setting are only performed until the variable
at the bottom row.

(7) To secure changes, save the modifications

■ Sort
This is a feature that a sorting operation is performed for all the variables in a tab.

The following shows the sorting procedure.

(1) In the “ISaGRAF Variable Declarations” window, open the data type tab where

you wish to perform a sorting operation. 

(2) Right click → [Sort] on the grid.

>>  The “Sort variables” dialog box will be shown.

(3) Select a field name as a sort key and a sorting order: ascending or descending.

>>  The sort operation will be performed for all the data in the selected tab.

■ Saving modifications
Select [Save] → [File] to save modifications.

Handling Precautions
To make modifications reflected on the controller, select [Compile]
(Make Application in ISaGRAF) after saving, and then download the
application code.
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12  -  3 Monitoring Variables

■ Procedure
(1) Select [Online] → [Start ISaGRAF Variables Monitor] to start monitoring

variables (boolean, integer/real, and timer).

• "Monitoring" is shown on the status bar during monitoring.  The background

color of the item Nos. and field names becomes orange or yellow.  The current

values and lock attributes of variables can be monitored.

• The current value and lock attribute can be changed during monitoring.

However, the lock attribute is valid only for I/O variables.  Once an output

variable is locked, the current value displayed is the one successively written by

a program if written; the actual output value, however, is the one at the time of

locking, or the one written from the ISaGRAF debugger or from the variable

monitor if written.  To check whether or not the values have actually been

written by the ISaGRAF debugger or variable monitor, monitor the System

Monitor Parameter (AO Status, DO Status, and TP Status) corresponding to the

I/O variable.

• The display format for the current value of an integer/real variable (number of

digits and base) depends on the Disp field setting.  (After the setting has been

changed, it takes effect immediately.) 

• The current value can be changed using the literals (constant expression) that

can be used in ISaGRAF.

(Expressions like T#10s and 16#0001.  

For details, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.)
For boolean variables, it is possible to specify "1" or "T" instead of "True", and

"0" or "F" instead of "False".

(2) Select [Online] → [Stop ISaGRAF Variables Monitor] to stop monitoring

the variables (boolean, integer/real, timer).

Handling Precautions
Monitoring during simulation is not supported.



Chapter 13. COMPILING APPLICATION PROGRAMS
(Make applications)

• To execute an application program edited by ISaGRAF on the controller, save the modifications, compile the

project (Make application in ISaGRAF), and then download the application code.

Note
In the Parameter setup of the SLP-D50 project, changes are secured immediately.

• To compile the application program from SLP-D50 (Make application), make the "Project" window active and

select [Edit] → [Compile].

• To compile the application program using ISaGRAF, select [Make] → [Make application] in the ISaGRAF

program management window.

13-1



13-2

■ Limitations
● DMC50

• If "ISA68M" is not specified in Targets of the compiler options, relevant

warning message will appear.  If the Trigger cycles or the Cycle timing over

"50 ms" is not specified in the run-time option, relevant error will appear.

Additionally, if the size of the generated code is 50100 bytes or more, the

compilation error will appear.

For details, 

refer to ● About compiler options and 

● About run-time options, in section 11-5 (page 11-14).

● AHC2001
• If "ISA68M" is not specified in Targets of the compiler options, relevant

warning message will appear. If the Trigger cycles or the Cycle timing “25 ms”

or “50 ms” is not specified in the run-time options, relevant error will appear.

Additionally, if the size of the generated code is 256000 bytes or more, the

compilation error will appear.

For details,

refer to the description, ● About compiler options and 

● About run-time options (page 11-23).

Chapter 13. COMPILING APPLICATION PROGRAMS )MAKE APPLICATION)
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• Newly created Parameter instances, the values of Parameters set in the offline mode, and a compiled (by Make

Application) application will not take effect until they are downloaded into the controller.

• To download the application, select [Online] → [Download Application] in SLP-D50 with the "Project"

window active, or select [File] → [Download] in the ISaGRAF debugger.  When downloading the application

using SLP-D50, the application, which is currently running, is stopped (upon the confirmation by the user), and

then the new application is downloaded.

>>When downloading of the application is started, the following dialog box will appear.

For [What is to be downloaded], normally select [All], and select [ISaGRAF programs only] if you wishes the

Parameter settings in the controller not to be overwritten when you have changed only the ISaGRAF programs of

the project that had already been downloaded in the controller.
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>> When the application is downloaded successfully, the following message will appear.

• On the ISaGRAF debugger, select [File] → [Download].  It takes a moment after the progress status reaches

99% on the debugger screen.  The Parameters are downloaded using SLP-D50 during this period.  At that time,

make sure that the download progress bar is moving in the "SLP-D50" window.  When the application has been

downloaded successfully, the following dialog box will appear:

Handling Precautions
The edit operation using SLP-D50 must not be performed during
downloading.

• After the application is downloaded, the retained variables are initialized.

• If the upload option of the compiler options is selected, the source program of the project can also be

downloaded. (This requires recompilation.)

• The application can be downloaded only to the programmable controller (DMC50 CTRL module, AHC2001
controller).

Handling Precautions
For details about the size of application that can be downloaded,

refer to Module Type Controller DMC50 User's Manual "Installation
and Configuration", 
CP-SP-1139 and Module Type Controller AHC2001 User's Manual
"Basic Operation", CP-SP-1137E.



Chapter 15. STARTING AND STOPPING APPLICATION PROGRAMS

• Selecting [Online] → [Stop Application] will stop the currently running application code.

• Selecting [Online] → [Start Application] will start the application code.

• Even though [Start Application] is commanded after [Stop Application] has been commanded, the Parameter

values are not initialized and the values when the application is stopped are retained.

However, the analog output values (AO Status) and digital output values (DO Status) of the first output after

restarting depend on the AO Setup and DO Setup, respectively.  (AHC2001 does not have DO Setup)

Additionally, the values of the ISaGRAF variables with the retain attribute become the initial values at the

restart by downloading , and become the values of the time when the application has been stopped previously, at

other restarts .

For details,

refer to Module Type Controller DMC50 User's Manual "Installation and Configuration", CP-SP-
1139E and Module Type Controller AHC2001 User's Manual "Basic Operation", CP-SP-1137E.

Handling Precautions
When the application is stopped, the ISaGRAF debugger shows the
message, "No Applications".  Note that, however, the stopped condition
cannot be distinguished from the undownloded condition.
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Chapter 16. ONLINE DEBUGGING OF APPLICATIONS

This chapter describes how to check the operation of an application after it has been downloaded into the

programmable controller.

● Checking the execution status of the ISaGRAF program
• Activate the ISaGRAF debugger and open the program editor window for a

program written in graphical languages.  In this window, the execution status of

the program is shown graphically.

• Using the ISaGRAF debugger, the execution can be stopped  and restarted

every cycle.

• For details about operations, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.

● Monitoring and checking the ISaGRAF variable status and locking the I/O variables
• Activate the ISaGRAF debugger, and open the program editor window for a

program written in the LD or FBD language.  In this window, the values of the

variables currently being used can be monitored or changed, and the I/O

variables can be locked.

• Activate the ISaGRAF debugger, and open the dictionary.  The ISaGRAF

variables (global and local) can be monitored and changed, and the I/O

variables can be locked.

• Activate the ISaGRAF debugger, and open the I/O connection editor.  The I/O

variable values can be monitored, changed, or locked.

• For details about ISaGRAF debug features, 

refer to ISaGRAF v3.5 User's Guide.

• From the "Project" window of SLP-D50, activate the "ISaGRAF Variables

Declarations" window for a specified POU/Global variables.  When the

monitoring is started, the variables of this POU/Global variables can be

monitored or changed, or the I/O variables can be locked.

For details, 

refer to Chapter 12, EDITING AND MONITORING THE ISAGRAF
VARIABLES USING SLP-D50.

● Monitoring and changing the Parameter data values
• In the "Project" window of SLP-D50, open an instance body of Parameter you

wish to view.  The Parameter data can be monitored or changed using the

Parameter online operations.  

For details, 

refer to Chapter 10, WORKING WITH PARAMETERS ONLINE.

● Grouping of data for monitoring and changing values
• A group monitor feature is used to monitor or change the ISaGRAF variables

and Parameter elements, Parameter elements of different types, and the data of

different modules on one screen.

For details, 

refer to Chapter 20, GROUP MONITOR.
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● Measuring the time series changes of data values
• A trend monitor is used to measure rough changes of the ISaGRAF variables

and Parameter element values.  

For details, 

refer to Chapter 21, TREND MONITOR.

• A sampling trace is used to precisely measure changes of the ISaGRAF

variables and Parameter element values, synchronized with the control cycle

time of the controller.

For details, 

refer to Chapter 22, SAMPLING TRACE WIZARD.

Chapter 16. ONLINE DEBUGGING OF APPLICATIONS



Chapter 17. CLOSING PROJECTS

Selecting [Close Project] with the "Project" window active will close the working project.  At this point, the

following dialog box will appear.

When clicking [Yes] in this dialog box, the modifications that have been made after the project has been opened

can be saved.  However, when selecting  [No], the modifications will be discarded and the contents at the time of

opening the project will be restored.

Handling Precautions
Note that the feature that restores the contents to those at the time of
opening the project cannot be used when opening the project from
ISaGRAF.
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Chapter 18. MANAGING PROJECTS

In addition to the basic edit features, the following operations can be performed for projects.  The operations using

ISaGRAF and SLP-D50 are described separately.

The ISaGRAF project management window referenced in the following description is activated by selecting

[Project] → [Open ISaGRAF Project Management Window] in the SLP-D50 main window.
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18  -  1 Copying a Project

18-2

* If the project directory you have copied is copied again using Explorer of

Windows, an error may occur.  If this occurs, copy the project again using

Explorer.

Chapter 18. MANAGING PROJECTS

ISaGRAF Copy a project in the project management window of ISaGRAF.
The project is copied with a different name in the same project
group.
The version No. can be reset.
A file name not meeting the "8+3" format is converted into a short file
name with a "~" embedded.

SLP-D50 Select [Project] → [Copy Project] in the SLP-D50 main window to
copy a project.
The project is copied with a different name in the same project
group.
The version No. can be reset.
A file with a long name can be copied as it is.



18  -  2 Changing the Name of a Project
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ISaGRAF Change the name of a project in the project management window of
ISaGRAF.
Only the path of the project directory is changed.

SLP-D50 This feature is not supported.



18  -  3 Deleting a Project
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ISaGRAF Delete a project in the project management window of ISaGRAF.
The project directory and its contents are deleted.

SLP-D50 Select [Project] → [Delete Project] in the SLP-D50 main window to
delete a project.
The project directory and its contents are deleted.



18  -  4 Archiving a Project

*1 For details, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.

*2 If an archived project is restored and this project directory is copied using

Explorer of Windows, an error may occur.  If this occurs, copy the project

again using Explorer.

*3 Once the access limitation is applied for a project, even after the archive file of

the project is unarchived, the access limitation is still applied. To remove the

access limitation, the key for removing it is further needed.

For details about the access limitation, 

refer to section 18-7, Restrictions on Project Access (page 18-13).
*4 The file extension of an archive file created by SLP-D50 is .cpj, and the file

extension of an archive file created by ISaGRAF is .pia. These two files are not

compatible. Unarchiving an archive file should be done by the method paired

up with the method by which the archive file is created.
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ISaGRAF Archive a project in the project management window of ISaGRAF.  
*1

All files under the project directory are archived.  However, a file
name not meeting the "8+3" format is restored to a short file name
with "~" embedded. *2,*4

SLP-D50 Select [Project] → [Archive Project] → [Create Project Archive] ] in
the SLP-D50 main window to archive a project. Select [Project] →
[Archive Project] → [Restore Project from an archive] in the SLP-D50
main window to  unarchive a project. 
Files with a long name can be restored with their original name.
You can archive a project where the access limitation is already
applied, and you can also set a password (archive key) for an
archive itself. *3, *4



18  -  5 Documenting a Project
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ISaGRAF This feature is provided on the [Project] menu of the project
management window of ISaGRAF.
The description and correction history of the project can be edited.
Using the print capability, it is possible to print the source data of the
dictionaries and programs, correction history, cross-reference and
address mapping of the ISaGRAF variables.
For details, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.

SLP-D50 Using the Parameter report feature, the setting values of all
Parameters, Parameter comments, and a comment for the report
itself can be output in HTML format.
For details, 

refer to section 9-13, Generating the Parameter Report 
(page 9-18)

Settings in the Integer Conversion Wizard can be output in HTML
format.
For details, 

refer to Chapter 23 INTEGER CONVERSION WIZARD.



18  -  6 Uploading a Project

Even though no source project exists on the PC, the project can be restored under certain limitations.

■ Outline
Project upload feature is used to restore a project from the settings stored in the

controller.

However, all projects cannot be restored.  The following table shows the

conditions under which projects can be uploaded:

■ Data to be restored 
The following table shows the data values to be restored and cautions about

handling.

• In a project restored by uploading, the information about upper and lower limit

values of User-defined types will be lost from the original project.

• For Parameter data values, the initial values of the database are assigned for

(System and Calculation) Monitor Parameters, and the current values are

assigned for other Parameters.

To set all Parameter values to the current values, do "Upload all Parameters"

after the project has been uploaded.  

For details about how to upload all Parameters, 

refer to section 10-7, Uploading All Parameters (page 10-7).

18-7

Programmable When the upload Upload the project from the project manage-
controller information about ment window of ISaGRAF.
(CTRL module, the application The Parameters setup and application
AHC2001 program is stored: program source can be restored.

controller) When selecting [Project] → [Upload Project] in 
SLP-D50, only the Parameters setup can be
restored and a blank program is generated
automatically as the application program
source.

When the upload The project cannot be uploaded using 
information about ISaGRAF.
the application When selecting [Project] → [Upload Project] in
program is not SLP-D50, only the Parameters setup can be
stored: restored and a blank program is generated

automatically as the application program
source.

COM module This feature is not supported.

Chapter 18. MANAGING PROJECTS



18-8

*1 To restore the source files of ISaGRAF programs, it is necessary that [Embed
source code for upload] must have been checked in the ISaGRAF compiler

options.

Handling Precautions
Note that storing of the embedded source files may consume
controller's memory.

*2 To restore the sampling trace settings and Integer Conversion Wizard settings,

it is necessary that [Embed source code for upload] must have been checked

in the ISaGRAF compiler options and also that upload options must have been

checked  in the relevant Wizard.

Chapter 18. MANAGING PROJECTS

ISaGRAF program source files Source information when the 

ISaGRAF variable initial values downloaded code is compiled.   *1

System Parameters, Remote Data Current values when uploaded.
Sharing Parameters, Calculation 
Parameters, User-defined Parameters, 
and Unit Setup Parameters

System Monitor Parameters, Remote Initial(default) values. (values are not 
Data Sharing Monitor Parameters, uploaded.)
Calculation Monitor Parameters, and 
Unit Monitor Parameters

User-defined type Parameter type body Item names, item data types, and 
setting values display attributes are restored to the

setting values downloaded in the
controller.
However, the MIN, MAX, initial, and unit
values become the system default
values.

MIN, MAX, and initial values of SP1 and The setting values shown on the left
SP2 of Segment Setups in Program can be edited by the user.  However,
Pattern Parameters these edited values cannot be restored

by uploading the project.
These values become the system default
values.

Sampling trace settings and Integer Setting values at the time when 
Conversion Wizard settings compiled.   *2

Group monitor lists, trend monitor These values cannot be restored.
settings, Parameter comments, report 
comments, and decimal point information 
of TBL/TBR Setups

Application code These values cannot be restored.

Variable allocation information These values cannot be restored.
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■ Other cautions 
• To restore the ISaGRAF program source files and variable initial values, it is

necessary that the application is running on the controller.

• After the project has been uploaded, to monitor the application running on the

controller, it is necessary to compile the application again.  Here, do not change

the setting values of the compiler options  from the ones specified for the

compilation of the currently running application.  Changing of settings may

cause the variable allocation to be changed, resulting in incorrect monitoring.

• Whether the variable allocation is the same or different is judged by checking

whether the CRC of the symbol table is the same or different.

• Any Parameters monitoring or group monitor monitoring for variables with  a

network address assigned  can be done without compilation since such

monitoring does not depend on the variable allocation.

■ Uploading a project with ISaGRAF
If the upload information is stored in the module when uploading the project from

ISaGRAF, both the ISaGRAF application program source and Parameter settings

can be restored.  To do so, follow the steps below:

(1) Open the project management window of ISaGRAF and select [Upload
Project].
>>  The dialog box showing the message, "Preparing for an Upload. Press

OK and wait for a moment", will appear.  

(2) Click [OK] button and wait for a while.

>>  The "Project Options" dialog box will be shown over SLP-D50 main

window. In case of the dialog box not shown, try finding "Slpd50" on the

Windows taskbar. If you find it, click it to show up the dialog box. 

(3) In this dialog box, set the communication path of the module in which a project

you wish to upload is stored.

For details about how to set up the communication path, 

refer to Chapter 7, SETTING UP THE PROJECT OPTIONS.

(4) Click [OK] button.

>>  The "Upload Project" dialog box will appear.

(5) If the module address of the communication destination specified in the

"Project Options" dialog box is not "1", click the [Setup] button and enter the

module address in [Target Slave Number] again.  (Here, enter this in the

decimal notation.)

Handling Precautions

• For the AHC2001 controller, set the module address to "1".

• The communication port is shown as "DMC50" for the SLP-D50
package or "modcon" for the SLP-H21 package.

Chapter 18. MANAGING PROJECTS
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(6) In the "Upload Project" dialog box, click the [Run] button.

>>  The application program upload process is started.

Chapter 18. MANAGING PROJECTS
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Handling Precautions
If the information about ISaGRAF program source does not exist in the
connected controller, the message, "No source available or
Communication failure. Cannot upload" is shown, and the process is
aborted.

The reason for this message is that the project downloaded into the controller has

no upload setting selected in the compiler options. Even in this case, only

Parameters setup can be uploaded.  

For details, 

refer to section ■ Uploading a project with SLP-50 (Page 18-11).

(7) If an embedded source exists, a project directory is created with the specified

name after the embedded source of the application program has been uploaded.

(8) Click the [Close] button in the "Upload Project" dialog box.

>>  The message, "Hereupon the SLP-D50 project data will be uploaded",
will appear.

(9) Click [OK] button to start the upload process of the Parameters setup.

Chapter 18. MANAGING PROJECTS
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■ Uploading a project with SLP-D50
When the project is uploaded with SLP-D50, only the Parameters setup can be

restored and a blank program is generated automatically as the application

program source.  To do so, follow the steps below:

(1) Select [Project] → [Upload Project] in the SLP-D50 main window.

(2) Specify the project name of the upload destination and click [OK] button.

(3) If a project that does not exist is specified, relevant warning message is shown

and a blank project is created.  If the project already exists, the application

program is not changed.

(4) Restore the Parameters setup from the module.
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■ Access restrictions on Parameters depending on the user level
User level that is needed to access data is predefined for each item of all the

Parameters except for User-defined Parameters, depending on their speciality. The

user level of  SLP-D50 is 0 at start up. To view or modify the value of an item

whose user level is set to 1, you must change the user level of SLP-D50 to 1.

For details about user level,

refer to section 28-4, User Level (page 28-4).

■ Access limits on project data for exclusive access 
This feature allow the user to have the exclusive access on a project. Each of the

three levels of access limitation determines the data to be hidden for unauthorized

users.

● Setting access limits on the project data
(1) Select [Project] → [Limit Access to Project Data] → [Set Access Limits to

Project Data] to activate the project directory selection dialog box, and choose

a project.

>>  The “Set Access Limits to Project Data” dialog box will appear.

(2) Select one of [Limit Level] to limit unauthorized access to the project data.

For details about the limit level,

refer to section 7-6, Identifying the access limit level (page 7-7).

18  -  7 Restrictions on Project Access

ISaGRAF This feature is not supported in the ISaGRAF for DMC50/AHC2001.

SLP-D50 There are two kinds of restriction on project access. One is a system
defined access restriction on Parameters depending on the user
level. Another is user settable access limitation on the project data
enabling  exclusive access to the project.



18-14

(3) Check or not check [Do not backup CSV files for restoration]. Check this in

case you do not need restoring the CSV files at the time you restore the project

after you set the access limits on the project.

(4) Assign a text string in [Key]. This is a decryption key used for restoring a

project from the project where the access limits are set. Decryption of the

project requires the key. You MUST NOT forget the key. There are no

backdoors for restoration.

(5) Selecting [OK] starts the operation.

>> The operation will be finished when a dialog box specifying the completion

appears.

● Removing access limits on the project data
(1) Select [Project] → [Limit Access to Project Data] → [Restore Project

Data] to activate the project directory selection dialog box. Choose a project

and click [OK].

(2) A dialog box for confirmation will be shown. Selecting [OK] starts the

operation.

>>The operation will be finished when a dialog box specifying the completion

appears.

Handling Precautions

In case of openning an access limited project via an old version of
SLP-D50 such as v2.1.9 or older,

a) for a project where “No access to ISaGRAF” is specified, 
there will be no programs shown in the ISaGRAF program
management window;

b) for a project where “+No download of Application” is specified, 
compilation of the project will not overwrite the existing execution
program.

c) for a project whre “+No access to Parameters” is specified, 
the project can be opened by SLP-D50, but no Parameters will be
shown.
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Chapter 19. USER-DEFINED PARAMETER LIBRARY

If the user wishes to gather multiple data or handles data having the repetition structure, the user can define a User-

defined Parameter type to easily use such data.

(ISaGRAF does not directly support the structure and array.)

However, since a User-defined Parameter data is accessed through a special function block, the access time

becomes longer than that to access a normal ISaGRAF variable.

Therefore, if many User-defined Parameters are used, the execution time becomes longer, too.  The User-defined

Parameters should be used while measuring the run-time cycle timing (this run-time cycle timing is output on the

ISaGRAF debugger screen).

The following sections describe how to use the User-defined Parameters.

19-1



19  -  1 Activating the User-defined Type Library Management Window

19-2

On the SLP-D50 main window, select [Global Options] → [User-defined Type Library] to activate the User-

defined Type Library Management dialog box.

When the User-defined Type Library Management dialog box is activated, User-defined Parameter types that have

already been registered in the library are shown in the list box.

Handling Precautions
ID Nos. shown on the above screen are the administration Nos. of the
system, and is not the type IDs to be used as an argument to the access
FBs.
A type ID is put on a User-defined type when it is imported to a project.
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19  -  2 Creating a New User-defined Parameter Type

(1) To create a new User-defined Parameter type, click the [New] button in the "User-defined Type Library
Management" window.

>> The "Edit User-defined Type" window will appear.

(2) In the "Edit User-defined Type" window, edit the type name, type label, and definition of each type item.

For details about edit contents, 

refer to section 19-4, "Edit User-defined Type" Window (page 19-5).

19-3
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19  -  3 Editing a User-defined Parameter Type

19-4

(1) To edit an existing User-defined Parameter type in the library, activate the "User-defined Type Library
Management" window, select a desired type you wish to edit in the list box, and click the [Edit] button.

>> The "Edit User-defined Type" window will appear.

(2) In the "Edit User-defined Type" window, edit the type name, type label, and definition of each type item.

For details about edit contents, 

refer to 19-4, "Edit User-defined Type" Window (page 19-5).
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19  -  4 "Edit User-defined Type" Window

In the " Edit User-defined Type" window, the Parameter type attributes can be edited as described below.

■ Editing the type name and type label
• The current version of SLP-D50 does not use type names, but this type name

must be set.  A name with up to 16 alphanumeric characters beginning with

"U_" can be used for the type name.

• The type label is used as the display label in the "Project" window.  A character

string having a size of 48 bytes or less including spaces can be used for the type

label.

■ Editing the attributes of each item for a parameter type definition
The following describes the fields for each item to be registered for a User-defined

type.

* In the current version of the controller, this field is not used for the range check

during the execution.

19-5
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Field name Description
Item name A character string having a size of 48 bytes or less including spaces

can be used for the item name.

Datatype Select a desired data type from the combo box.  DINT (32-bit signed
integer), REAL (real number = Single precision floating point
number), or BOOL (true/false value) can be used.

MIN This value is used as the minimum value of the input range when
writing the data using SLP-D50.
This value needs to be set when the data type is DINT or REAL *

MAX This value is used as the maximum value of the input range when
writing the data using SLP-D50.
This value needs to be set when the data type is DINT or REAL. *

Default This value is only used as the default value when generating a new
instance.

Unit This is the display unit of the data and is shown next to the item
name when a [Instance Body] tab is selected.

Disp This is used only when the data type is REAL (real number).
This value indicates the number of display digits under the decimal
point.  When other data type is selected, keep this field blank or set
this field to "0".
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■ Adding a new item
Right click → [New Item (Before/After)] on the edit grid .  One row will be

added  before or after the currently selected row.

The number of items that can be defined is in a range of 1 to 58.

■ Deleting an item 
Right click → [Delete Item] on an item row of the edit grid you wish to delete.

This row will be deleted.

■ Saving the user-defined type definition
After all items have been edited, click the [OK] button.  The contents you have

edited are then saved, allowing you to use the edited User-defined Type.

However, if the modifications have any problem, relevant error will appear in the

text window at the lower portion of the "Edit" window.  Correct the contents while

referring to the error message, and then click the [OK] button again.
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19  -  5 Exporting User-defined Parameter Definitions

If you wish to use User-defined Parameters you have created in the SLP-D50 system installed on other PC, follow

the steps below.

Note
The User-defined Types used in each project can be used in other SLP-D50 system

if the relevant project is copied.

(1) In the SLP-D50 main window, select [Global Options] → [User-defined Type Library].  
>>  The "User-defined Type Library Management Window" window will appear.

User-defined Parameters that have already been defined will be listed up in the User-defined Type list
box.

(2) Click to select a Parameter type you wish to export.  Clicking  Parameter types with the [Ctrl] key kept pressed

to select multiple Parameter definitions.

(3) Click the [Export] button.  

>>  The " Export User-defined Type" dialog box will appear.

(4) Specify a directory where you export the selected User-defined Parameters.

(5) Click the [OK] button.  

>>  A folder named "backup" is made under the specified directory.  The information about User-defined

Types will be stored into this directory.
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19  -  6 Importing User-defined Parameter Definitions

19-8

To use the User-defined Parameters created in other SLP-D50 system, follow the steps below.

Note
The User-defined Types used in each project can be used in other SLP-D50 system

if the relevant project is copied.

(1) Export the User-defined type definitions you wish to use using the export feature of another SLP-D50 system

where the definitions are created .

(2) In the SLP-D50 main window on the import side, select [Global Options] → [User-defined Type Library]
→ [Import].
>>  The "Import User-defined Type" dialog box will appear.

(3) Select the "backup" directory made by the export feature of another SLP-D50 system and click the [OK]
button.

If the "backup" directory results from the export of User-defined Parameters, or is a copy of this directory, all

definitions are then imported from this directory.
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19  -  7 Deleting User-defind Parameter Definitions

(1) In the SLP-D50 main window, select [Global Options] → [User-defined Type Library].  The "User-
defined Type Library Management" window will appear.

(2) The User-defined Parameters that have already been defined will be listed up in the User-defined Type list

box.  Click to select a Parameter type you wish to delete.  Clicking  Parameter types with the [Ctrl] key kept

pressed to select multiple Parameter definitions.

(3) Click the [Delete] button.  The specified User-defined Types will be deleted.
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Chapter 19. USER-DEFINED PARAMETER LIBRARY



19  -  8 Using Registered User-defined Types

19-10

To use a User-defined Type that has been defined and registered in the library in the project, follow the steps

below:

(1) In the treeview of the "Project" window, select [User-defined Type], and right click → [Import  Type from
Library].
>>  The " Import User-define Type from Library " dialog box will appear.

(2) Select only one User-defined Type you wish to import and click [OK] button.

>> The " Parameter Type ID Setting" dialog box will appear.  

(3) Assign an ID that is not used in the current project (clicking the spin button will show only IDs not in use), and

then click [OK] button.

(4) A type label for the newly imported User-defined type will be added to a portion under "User-defined

Parameters" in the treeview.  Create an instance with an appropriate size to use this User-defined Type.

For details about how to create an instance, 

refer to Chapter 9, EDITING  PARAMETERS.

Handling Precautions
• To access the User-defined Parameters from the ISaGRAF application

program, the access function blocks are used.  The type ID is a numeric
value ranging from 16#801 to 16#9FF ("16#" represents the
hexadecimal notation) and used as an argument to the access FB.
Select a type label name in the treeview of the project window, and open
the [Type Header] tab.  The type name and type ID will be shown,
allowing you to check the correspondence with the type label.

• The type ID of the User-defined Type is a unique No. in each  project.

• For details about access FBs, 
refer to Module Type Controller DMC50/AHC2001 User's Manual
"Function Block Reference", CP-SP-1130E.

Chapter 19. USER-DEFINED PARAMETER LIBRARY



19  -  9 Exporting a User-defined Type from Project to Library

To return a copy of definition in the project to the User-defined type Library, select a User-defined Type in the

treeview of the "Project" window → Right click → [Export Type to Library].
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Chapter 20. GROUP MONITOR
20  -  1 Outline of Group Monitor Features

This group monitor is used to monitor multiple Parameter type data or ISaGRAF variables at one sight.

Furthermore, if the communication is possible, the data of multiple projects can be monitored on one screen.

Two scopes of group monitor are provided .  One is the normal group monitor used to register and monitor the data

of any projects in the project group.  The other is the project local group monitor used to register and monitor the

data of only one project.

Handling Precautions
It is absolutely necessary that the addresses are assigned to the data to be
monitored by the group monitor.  For all Parameters , addresses are
assigned automatically.  For each ISaGRAF variable to be monitored by
the group monitor,  an address other than "0" (network address) must be
assigned, and then the application must be compiled and downloaded to
the controller prior to monitoring. 

■ Project group common group monitor 
This group monitor is used to register and monitor the data of any  projects in the

project group.  However, if the project name for the registered data is changed, the

data cannot be monitored.

To monitor such data again, it is necessary to register the data again.

■ Project local group monitor 
This group monitor is activated from the "Project" window.  Only the data of this

project can be registered and monitored.  Monitor list files can be saved into only

the project directory.  However, even though the project name is changed, it is not

necessary to register the data again.
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20  -  2 Activating the Group Monitor

20-2

■ Activating the project group common group monitor
In the SLP-D50 main window, select [Project] → [Group Monitor] → [New].
The project common group monitor window will appear.  Using the [Window]
menu, redisplay the window appropriately.

Note
• Multiple group monitors can be used at the same time.

• If monitor list files have already been saved, selecting [Project] → [Group
Monitor] → [Open...] opens a specified monitor file at the same time when the

group monitor is activated.

■ Activating the project local group monitor
With the "Project" window active in SLP-D50, select [Online] → [Group
Monitor] → [New].  The project local group monitor window will appear.  Using

the [Window] menu, redisplay the window appropriately.

Note
• Multiple group monitors can be used at the same time.

• If monitor list files have already been saved, selecting [Online] → [Group
Monitor (Project Local)] → [Open...] opens a specified monitor file at the

same time when the group monitor is activated.  In this case, only the monitor

list files in the project directory can be selected.
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■ Activating the group monitor from the ISaGRAF variable declarations window
With the “ISaGRAF variable declarations” window active in SLP-D50, select

[Online] → [Group Monitor (Project Local)] → [New]. The project local group

monitor window will appear. Using the [Window] menu, redisplay the window

appropriately.

Note

If monitor list files have already been saved, selecting [Online] → [Group
Monitor (Project Local)] → [Open...] can open a specified monitor file at the

same time when the group monitor is activated. In this case, only the monitor list

files in the project directory can be selected.

■ Activating the group monitor from the group monitor itself
With the “Group Monitor” window active in SLP-D50, select [File] → [New]. The

group monitor window will appear. Using the [Window] menu, redisplay the

window appropriately.

Note

If monitor list files have already been saved, selecting [File] → [Open with a
New Window] can open a specified monitor file at the same time when the group

monitor is activated.

Handling Precautions
If the new group monitor is activated from the project local group monitor,
that new group monitor is also project local. Therefore, reading or writing
the monitor list files will be limited in the project directory.
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20  -  3 Creating a Monitor List

■ Registering parameter data

Handling Precautions
• In a monitor list, the number of data items of one project is limited to 50.

• Registration will not be preserved until saving the monitor list.

● Registering data using Drag & Drop
(1) Display both the "Project" window and "Group Monitor" window in the SLP-

D50 window.

(2) In the "Project" window, open the instance body of Parameter including an

element you wish to monitor.

(3) Drag a desired element cell onto the group monitor grid; that is,  this element is

registered in the group monitor.

The following screen shows that the "1ch" data of the AI Status is registered in the

group monitor.

● Registering data using Copy & Insert 
(1) Open the "Project" window in the SLP-D50 window and open the instance

body of Parameter including an element you wish to monitor.

(2) Select a rectangular data area you wish to register, and then copy the selected

data to the copy buffer.  

For details, 

refer to section 9-14, Copy & Paste Feature (page 9-20).

(3) Make the "Group Monitor" window active.  Left click a row where you wish

to insert the data, and Right click → [Insert] → [Before] ([After]) to insert the

copied data.
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■ Registering the ISaGRAF variables

Handling Precautions
A feature that directly registers the data from the ISaGRAF dictionary is not
supported.

● Registering data using Drag & Drop
(1) Open both the "ISaGRAF Variable Declarations" window and "Group

Monitor" window in the SLP-D50 main window.

(2) Click a ISaGRAF variable row you wish to monitor, and then drag the data

toward the group monitor grid.

● Registering data using Copy & Insert 
(1) Open the "ISaGRAF Variable Declarations" window in the SLP-D50

window.

(2) Select ISaGRAF variable rows you wish to monitor, and copy them to the copy

buffer.  For details, 

refer to ■ Copy variables (page 12-9).

(3) Make the "Group Monitor" window active.  Left click a row where you wish

to insert the data, and Right click → [Insert] → [Before] ([After]) to insert the

copied data.

■ Automatic grouping
When the ISaGRAF variables are named in the specified format, it is possible to

register elements of a Parameter instance and the corresponding ISaGRAF global

variables (boolean, integer/real)into the group monitor at a time.

The naming rule is "Ptypeid_grpid_desc".  The following values must be

specified for "typeid", "grpid", and "desc", respectively:
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• typeid
Parameter type ID of Parameter you wish to group together in the hexadecimal

notation.  (Example: PID_A Monitor = 203) 

• grpid
Group ID of Parameter you wish to group together in the decimal notation.

• desc
Up to 16 characters can be used for a variable name used in ISaGRAF.

Meaningful name can be given using alphanumeric characters for the remaining

length.

Handling Precautions
The instances of the User-defined Parameters, and Program Pattern
Parameters cannot be specified.  Additionally, the ISaGRAF variables are
limited to the global boolean variables and integer/real variables.

(1) Activate the group monitor and select [File] → [Auto Grouping].  
>>  The following dialog box will appear:

(2) Specify a project name in the current project group, and a type ID and group/ch

No. (group ID) of Parameter you wish to register into the group monitor.

(3) Click [OK] button

>> The grouping is performed with the specified type ID and group ID.  



In the following screen example, each element for group No. 1 of PID_A Monitor

and the ISaGRAF variables whose name begins with "P203_1_" are registered into

the group monitor:

(4) Left click to select duplicated data and/or unnecessary data, and right click >

[Delete]  to delete them in order to leave only necessary data.  (On the above

screen, SP of the PID_A Monitor and ISaGRAF variable P203_1_SP,  and AT

input of the PID_A Monitor and ISaGRAF variable P203_1_MAN  are

duplicated respectively, in a sense they refer to the same data.  Since the SP

and Auto/Man settings must be writable to change their values, delete SP and

AT of the PID_A monitor, which are Read-Only data.)

■ Saving and re-reading the monitor list
The list of the data monitored using the group monitor can be saved in a monitor

list file (file extension: .mon) by selecting [File] → [Save].   By opening the saved

monitor list file, it is possible to read the monitor list again.

Handling Precautions
When using the project local group monitor, monitor list files are saved
into the project directory.
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■ Deleting monitor data
Left click an unnecessary item, and right click → [Delete].

Handling Precautions
The current version does not support the deleting of an area and
multiple selections.  However, when using the cut feature described in
the following, it is possible to delete multiple rows.

■ Cut & insert monitor data
(1) Select a row you wish to move by left clicking it.  Furthermore, click another

row with the [SHIFT] key kept pressed to select multiple rows.

(2) Cut the selected rows by right clicking → [Cut].

(3) Insert the cut rows:  select a row where you wish to insert the cut rows, and

Righ clik → [Insert] → [Before] ([After]).

20  -  4 Monitor List Edit Features
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20  -  5 Consistency Checking

To check whether or not the updated project settings, such as address assignments,  are reflected on the monitor list

read from a monitor list file, select [File] → [Consistency Checking].  The consistency between the original data

of the project and the data in the "Group Monitor" window is checked.

>>  The check results will be shown in the "Error Output" window.

The following screen shows an error output example of the consistency checking:

Note
If any error is found, correct the data by referring to the output error message.
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■ Description of setting columns 
When the monitor is not started, the following communication path for each

monitor item can be changed.

Handling Precautions
The serial port, TCP/IP address, and IP port to be used for each
connection are the values stored in each project.

20  -  6 Changing the Communication Path

Column Meaning
Setting

DMC50 AHC2001
Address of  COM 
module

CA When communicating through the COM 
module, specify the rotary switch No. of 
the COM module.

Always specify �0�.

Destination 
module address 
for communication

MA Specify the rotary switch No. of the 
module.

Always specify �1�.

Communication 
device

Dev When communicating through the 
Ethernet port of the ME200, specify "1 = 
TCP/IP", otherwise, specify "0 = serial".

When communicating through the 
RS232C port of the CPU unit or the 
serial port of the SCU unit, specify �0 = 
Serial�.  When communicating through 
the ENI unit, specify "1 = TCP/IP".  
When communicating through the USB 
port of the CPU unit, specify "2 = USB".
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■ Changing settings of multiple data
(1) Select a data row you wish to change by left clicking it.  Additionally, click

another row with the [SHIFT] key kept pressed to select multiple rows.

(2) Display the "Communication Path Setup" dialog box.  Do this by right clicking

→ [Change Communication Path].

(3) Set communication path attributes (CA, MA, dev).  According to the

description in the previous section, complete the settings and click [OK] button.
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The settings of the dragged and copied data in their source projects are used for the default display format.  For the

DINT (INT) and REAL type data, however, the display format can be changed in the same manner as described for

monitoring of the ISaGRAF variables.

(1) Click to select a data row of which  display format you wish to change.  Additionally, click another row with

the [SHIFT] key kept pressed to select multiple rows.

(2) Right click → [Change Display Format].  The "Change Display Format" dialog box will appear.

(3) Select a display format from the combo box and click [OK] button.

Handling Precautions
If DINT (INT) and REAL type data are both selected, only the display
formats of the data with the data type the same as that in the top row will
be changed.

20  -  7 Changing the Display Format
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20  -  8 Starting Monitor

(1) With the "Group Monitor" window active, select [Online] → [Start Group Monitor].

(2) The message, "Monitoring", will appear on the status bar at the lower portion of the "Group Monitor" window

during monitoring.  At the same time, the background color of the item Nos. and field names becomes yellow

or orange.

(3) Additionally, when the communication between each item and the module is succeeded, the cells of the fields

indicating this communication path are displayed in yellow or orange, and the current value in each cell of the

value column will be successively updated.  If there are items where the values are not updated for some

reasons, their field cells indicating the communication path are displayed in white.
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20  -  9 Modifying the Controller's Data Immediately

Entering the data in a value field during monitoring will change the monitored data in the controller immediately.

Here, the literals (constant expressions) that are available in ISaGRAF can be used.  Furthermore, "1" and "T" can

be used instead of "True", and "0" and "F" can be used instead of " False".
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20  -  10 Stopping the Monitor

Select [Online] → [Stop Group Monitor] to stop the monitor.  When the monitor is stopped, the message,

"Offline", will appear on the status bar.  At the same time, the background color of the item Nos. and field names is

also returned to gray.
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20  -  11 Activating the Trend Monitor

Trend monitor can be performed for the data listed in the "Group Monitor" window.

Select [Online] → [Trend Monitor] to display the "Trend Monitor" window.  With the default settings, 8 lines of

data in the "Group Monitor" window starting from the top row are assigned to the series 1 to 8 in the trend

monitor.

However, this operation does not apply to the case where there is a trend option file (.trn) corresponding to the

monitor list file.

For the data displayed in the group monitor, any of them can be assigned to a series using the trend monitor

options.  For details about trend monitor, 

refer to Chapter 21, TREND MONITOR.



Chapter 21. TREND MONITOR

This trend monitor provides two features.  One draws the trend graph of the data whose address have already been

assigned, as is the case with the group monitor.  The other logs the data to a CSV file.  Here, up to eight monitor

data can be selected for one trend monitor.  (In SLP-D50, each monitor data is called a "series".)

Additionally, multiple trend monitors can be activated at the same time.

Handling Precautions
• Addresses are automatically set for all Parameters.  When a network

address (MODBUS address) other than "0" is assigned for an ISaGRAF
variable, the monitoring of this variable can be performed.
After an address has been assigned for an ISaGRAF variable, it is
necessary to compile the project (Make Application) and download the
application in order for the address setting to take effect.
For details about how to compile the application (Make Application), 

refer to Chapter 13, COMPILING PROJECTS (Make Applications).
For details about how to download the application, 

refer to Chapter 14, DOWNLOADING APPLICATIONS.

• For the BOOL type data, "True" is converted into "1" and "False" is
converted into "0".  The DWORD type data is converted into the DINT
type data, and the TIME type data is converted into the integer value in
ms.  As a result, the above data is displayed and logged in decimal
notation.
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21  -  1 Activating the Trend Monitor Window
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■ Activating the trend monitor window from the project window
Select a Parameter instance in the treeview, and select [Parameter] → [Trend
Monitor], or right click → [Trend Monitor] on the instance body.  The trend

monitor for the instance will be activated.  The simultaneous monitoring can be

performed with eight elements selected out of all elements in the instance.

The following screen shows that the opened "Trend Monitor" and "Project"
windows are tiled.  "Project name: Type label name (or trend option file name)" is

shown on the title bar of the "Trend Monitor" window.

The core name of the CSV file is shown on the graph title.

Note
Adjust the position of the MDI child windows using the [Window] menu.

Chapter 21. TREND MONITOR
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■ Activating the trend monitor from the group monitor
Register ISaGRAF variables or Parameter elements you wish to monitor into the

"Group Monitor" window.  

For details,

refer to section 20-3, Creating a Monitor List (page 20-4).
With the "Group Monitor" window active, select [Online] → [Trend Monitor].
The "Trend Monitor" window will be activated.

With one trend monitor, eight data are selected from all data in the monitor list of

the group monitor, and then the simultaneous monitoring of such data can be

performed.
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21  -  2 Setting Up the Trend Options
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Options for all or individual series can be set up in the "Trend Options" window as described below.  Changing an

option  will take effect immediately even during monitoring.

(Some options cannot be changed during monitoring.  The details are described in the following.)

To open the "Trend Options" window, select [Options] → [Detail Options] with the trend monitor active.

■ Write to CSV file
This check box sets whether writing of the trend data into the CSV file is enabled

or disabled.  This check box cannot be set during monitoring.

■ Directory for CSV logging 
Specify a directory into which the CSV file is written.  Files named according to

the naming rule described in the following item, ■ CSV core file name, are

automatically saved into this specified directory.  This setting cannot be made

during monitoring.

■ CSV core file name 
Specify the core name of CSV files to be saved automatically.

SLP-D50 will automatically save CSV files with a file name where a suffix "N"

(0, 1, 2,....) is automatically added after this core name.

The maximum number of samples per data to be saved in one file is 16,000.

Every time the number of samples exceeds this limit,  data will be saved into a file

with a new suffix.  (Example: Log name: log, Actual CSV file name: log0.csv,

log1.csv,...)

The CSV file core name cannot be changed during monitoring.

Chapter 21. TREND MONITOR
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■ Update time 
Set the update time by clicking the button of the [spin edit] labeled "Update

Time".  A value ranging from 0 sec. to 5 sec. in units of 200 ms, a value ranging

from 1 sec. to 59 sec. in units of 1 sec., a value ranging from 1 min. to 59 min. in

units of 1 min., or 1 h. can be specified.

Handling Precautions

• The above value is expected value.  The actual update time may vary
depending on the display status of other windows, load status of
Windows, and execution status of the controller.
The update time cannot be changed during monitoring.

• If the actual update time is shorter than 10 ms. while the update time
setting is "0" or communications are carried out to the AHC2001
controller via a USB port, a same time stamp may be put on multiple
samples of update data.

■ Samples/file
Set how many samples are stored in a file. When the number of samples stored in

a file reaches this number, the next file with a name given by the rule specified in

■ CSV core file name will be created, and the samples to follow will be stored

in this new file.

■ Series selections 
A trend monitor allows up to eight series to be monitored .  In each combo box for

a series,  names of each candidate data are listed up in the format, like "item name

'-' channel (group) No. (* "0" for ISaGRAF variable)".

With the default settings, items are selected sequentially from those having lower

channel(group) numbers.  When necessary, change the items.

Additionally, if all of 8 series are not needed for the trend monitor, select [Not
Used] for series not to be monitored.  This may reduce the communication load,

the size of the logging CSV file, and the memory space for storing data for graph

drawing.  However, these settings cannot be made during monitoring.

■ Axis selection 
Select whether the left or right axis is used for each series.

■ Scaling, offset 
You can apply scaling factor and offset shown in the following formula to each

series value before displaying them.  (This rule does not apply to the values

written into CSV files.)

However, these settings cannot be made during monitoring.

Displayed value = Scaling factor X Measured value + Offset

■ Series Color
The color currently assigned to each series is shown. Click the color to change the

color of the selected series.
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■ X-axis window view, window size 
Select the window display or full-time display for the X-axis (time-axis).

When the [Window View] check box is checked, only the newly updated samples

during the seconds specified in [Window Size] are displayed on the graph.

(These settings do not affect the values written into CSV files.)

■ Y-axis min, max values
With the default settings, Y-Axis Minimum and Maximum values are

automatically determined by the minimum and maximum sampled values.

If the [Manual] check box is checked, you can set Y-axis Min, Max values.

(These settings do not affect the values written into CSV files.)

■ Save and open trend option file 
You can save the trend options into a file (file extension: trn).

Once the settings have been saved to a file, these settings can be used later by

reading it.

Handling Precautions
• When activating the trend monitor from a group monitor, an option file

having the same base part as that of the monitor file is read
automatically.  When activating the trend monitor from an instance
display, SLP-D50 prompts you to read the default option file
determined by the Parameter type if it exists. (You may change the
file at that time.)

• When activating the trend monitor from a project local group monitor,
the trend option file can be loaded/saved from/in the project directory.
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21  -  3 Graph Drawing Features

In the "Trend Monitor" window, select  [Options] → [Graph ON].  The trend graph drawing is toggled between

draw and no draw.

Handling Precautions
When the trend graph is drawn continuously, it will gradually consume
memory.

■ Selecting a set of series for display 
A set of series you wish to display at the same time can be selected using eight

series check boxes in the lower portion of the "Trend Monitor" window.  This

feature is used if it is difficult to view the graph when all the series are displayed at

the same time.

Handling Precautions
• When the series is set at "not used", this series cannot be selected.

• When you hold the mouse over this check box for a while, relevant
series name will appear.

• If this check box is unchecked, the drawing time will increase only
slightly.  By displaying the full-time data after the drawing has been
stopped, you may see the entire graph.  This unchecking may prevent
the timeout caused by the increased drawing time while monitoring for
a long time.

■ Zoom
With the left mouse button kept pressed, draw a rectangular around a chart area

you wish to enlarge, and this portion will be enlarged.

Here, drag the mouse from the upper left corner to the lower right corner.  When

dragging the mouse from the upper right corner to the lower left corner, the zoom

will be cancelled.

■ Scroll
With the right mouse button kept pressed, drag the mouse on the chart.  The chart

will be scrolled to the reverse direction.

Handling Precautions
Use this feature after the drawing has been stopped by the zoom
feature.
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21  -  4 Logging to CSV File
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In the "Trend Monitor" window, select [Options] → [CSV Logging ON] to toggle the CSV logging switch.  If the

[CSV Logging ON] menu is checked, select [Online] → [Start Trend Monitor], and the logging to the CSV file

will be started.
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21  -  5 Starting and Stopping the Trend Monitor

Selecting [Online] → [Start Trend Monitor] will start trend monitoring with the settings specified in the [Options]
menu.  The message, "Monitoring", will appear on the status bar at the lower left portion of the "Trend Monitor"
window while the trend monitoring is being performed continuously.

When selecting [Stop Trend Monitor] , the message, "Offline", will appear on the status bar.
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21  -  6 Editing Comments
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You can write down comments for the current chart. Comments are saved to a file with the base name of the "CSV

core file name" specified in the "Trend Options". It can be reread when the CSV file is imported in the offline chart

later. The steps to write down or review comments are as follows:

(1) Select [Offline] → [Edit Comment] on the trend monitor window, or right click → [Edit Comment] on the

series data legend on the right part of the trend monitor window.

>> The "Edit Comment" dialog box appears

(2) Write down comments if necessary, and click [OK] to complete the modifications, or click [Cancel] to cancel

the modifications.

>> Comments are saved in a file with the base name of the "CSV core file name"
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Chapter 22. SAMPLING TRACE WIZARD

• The sampling trace is a feature that traces the values of data (ISaGRAF variables and Parameter elements) of the

working project at intervals of sampling time synchronized with the cycle time of the controller.

• This feature is a kind of the automatic programming features.  Only the programmable controller can use this

feature.  After the settings have been made (changed),  you must compile and download the application for the

changes to take effect in the controller.

Handling Precautions
Only the online features are available in the SLP-D50 operators edition.
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22  -  1 Activating the Sampling Trace Wizard

22-2

With the "Project" window active, select [Edit] → [Auto Programming] → [Sampling Trace Wizard] to activate

the Sampling Trace Wizard.
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22  -  2 Setting Up the Sampling Trace

To run the sampling trace, at first, make the settings shown in the table below.

The setup items are classified by three tabs: Sampling conditions, Sampling points, and Trigger conditions.  Set up

the items in this order.

■ Setup items

22-3
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Setup item Setting range Description Online actions
Sampling Period Fixed times A period of time for sampling Monitoring only

Continuous

Num of Sampling 1 or more and 16 or less Number of points for sampling Monitoring only
Points

Num of Samples 1 or more Number of samples per a sampling Monitoring only
/Point point for fixed times trace.

Basis of the ring buffer length for 
continuous trace  *1

Enable/Disable Flag Enable/Disable Select whether the sampling trace is The sampling trace can
enabled or disabled. be enabled or disabled.
This setting can be changed when online When this setting is 
monitoring. disabled, the CPU time

can be saved.

Sampling Time N times of the control Data sampling time. Monitoring only
cycle time (1 to 100) *  Do not change the control cycle time 

during tracing.  Doing so may cause 
incorrect display.

Sampling Points ISaGRAF global Sampled data. Monitoring cannot be 
variables (integer/real, Drag and Drop, or Copy and Paste performed.
BOOL type), Parameter ISaGRAF variables from "ISaGRAF (The setting made in 
items  other than char Variable Declarations" windows of the offline mode is 
acter string items SLP-D50; or Parameter elements from displayed.)

the "Project" window to set the sampling 
data.  *2, *3

System/User Trigger System variable/User Select whether an automatically Monitoring cannot be 
Variable variable generated or manually created performed.

variable is used for sampling trigger (The setting made in
the offline mode is
displayed.)

Trigger Variable ISaGraf global BOOL Variable used for sampling trigger. Monitoring cannot be 
variable with a network If "System Trigger Variable" is selected, performed.
address this variable is declared automatically. (The setting made in 

If "User Trigger Variable" is selected, the offline mode is 
drag and drop a global BOOL type displayed.)
variable from the "ISaGRAF Variable 
Declarations" window of SLP-D50 to 
set the trigger variable.

CONTINUE TO NEXT PAGE
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*1 Ring buffer length = DIV (Number of samples - 1, DIV (49, Number of points)) + 1

*2 The sampling for the DWORD data is performed, converted into DINT type data.

*3 When displaying or writing the real type data, the number of digits below the decimal point is the same as

the number of digits of the registration data source.  The number of digits is displayed in the [DP] field of

the sampling points tab.
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Setup item Setting range Description Online actions
Trigger Variable True (1)/False (0) Trigger Variable Value This value can be 
Value (The initial value is set when editing in changed in the online 

the offline mode.) mode.
Trigger Mode The execution of the sampling trace is Monitoring only

controlled by a combination of the 
trigger variable value and trigger mode.

Start on the rising edge The sampling trace is started at the 
of trig var rising edge of the trigger variable and 

executed continuously while the trigger 
variable is ON.  When [Fixed times] is 
selected, the sampling trace is stopped 
when the actual number of samples 
reaches the setting.

Start on the falling edge The sampling trace is started at the  
of trig var falling edge of the trigger variable and 

executed continuously while the trigger 
variable is OFF.  When [Fixed times] is
selected, the sampling trace is stopped 
when the actual number of samples 
reaches the setting.

Around the time of This setting can be made only when the
rising edge of trig var fixed times trace is selected.

During the period such that the time of 
the rising edge of the trigger variable is 
put at the center, the sampling is 
performed specified times (number of 
samples - number of samples/2) while 
the trigger variable is OFF.  The sampl-
ing is performed specified times 
(number of samples/2) while the trigger 
variable is ON.

Around the time of This setting can be made only when the
falling edge of trig var fixed times trace is selected.

During the period such that the time of 
the falling edge of the trigger variable is 
put at the center, the sampling is 
performed specified times (number of 
samples - number of samples/2) while 
the trigger variable is ON.  The sampl-
ing is performed specified times 
(number of samples/2) while the trigger 
variable is OFF.

Stop on the rising edge This setting can be made only when the
of trig var fixed times trace is selected.

The sampling is performed specified 
times (the number of samples) until the
trigger variable becomes ON.

Stop on the falling edge This setting can be made only when the
of trig var fixed times trace is selected.

The sampling is performed specified 
times (the number of samplings) until 
the trigger variable becomes OFF.



22-5

■ Registering sampling data
● Registering sampling data using Drag & Drop

(1) Enter the number of sampling data in the [Num of Sampling Points] field of

the [Sampling Conditions] tab of the Sampling Wizard.

(2) Display the [Instance Body] tab of the "Project" window, or the variable tab of

the "ISaGRAF Variable Declarations" window where the data you wish to

register exists, and also display the [Sampling points] tab window of the

Sampling Trace Wizard at the same time.

(3) Drag the cell of data you wish to register to a grid row of the [Sampling
points] tab.  Then the dropped data in the row is registered.

The following screen shows that an ISaGRAF variable is registered as a sampling

point.

● Registering sampling data using Copy & Paste (overwrite)
(1) Enter the number of sampling points in the [Num of Sampling Points] field of

the [Sampling Conditions] tab of the Sampling Wizard.

(2) Display the [Instance Body] tab of the "Project" window or the variable tab

of the "ISaGRAF Variable Declarations" window where the data you wish to

register exists.

(3) Select a set of data you wish to register, and copy the data to the copy buffer.

(For details about Parameter data copy, 

refer to 9-14 Copy & Paste Feature (page 9-20).
For details about ISaGRAF variable data copy, 

refer to ■ Copy variables (page 12-9).
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(4) Select a grid row of the [Sampling Points] tab you wish to register the data in,

and right click → [Paste(Overwrite)].
>>  Only the number of copied data overwrites rows by pasting from the

specified row.

■ Examples of trigger variable and sampling period in fixed times trace

● Starting at rising edge of the trigger variable

● Stopping at rising edge of the trigger variable

● Around the time of rising edge of the trigger variable

Chapter 22. SAMPLING TRACE WIZARD

Trigger variable

Sampling period
Num of samples specified

Completed when the buffer is full.

Trigger variable

Sampling period
Num of samples specified

Trigger variable

Sampling period
Num of samples specified

Stopped before the buffer �
becomes full.�
(Sampled data before �
 this stop are valid.)
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■ Setting up the options
In addition to the general setup, the following options setup is also provided.

From the [Options] menu, select [Detail Options] to open the "Trace Options"

dialog box and make the settings.

● Upload option
Specify whether or not the settings of the Sampling Trace Wizard will be stored to

the controller.  If the application code is generated  and downloaded with both this

option and [Embed source code for upload] of the compiler option checked, the

settings of the Sampling Trace Wizard will be restored when the project is

uploaded  as well as other project source information.

Handling Precautions
This option may affect the size of the execution code as well as the
embedded source code for upload.

■ Completing the setup
(1) Make sure the settings are what you intend. Select [Trigger Conditions] tab

on the setup screen and click the [OK] button.

>> A confirmation dialog box will appear.

(2) Click the [OK] button.

Handling Precautions
In order for the settings to take effect in DMC50, it is necessary to compile
and download the application program.

Chapter 22. SAMPLING TRACE WIZARD
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● Components to be generated automatically
The following table shows the components that are generated automatically by the

Sampling Trace Wizard:

Chapter 22. SAMPLING TRACE WIZARD

Name Description Cautions
Program Cycle time obtaining This program must be located at the 
YC_Cycle program beginning of the Begin section.

Program Program that performs the Do not edit this program.
YC_Trace sampling trace.  This To change the execution order in the

program is executed at the same calculation cycle, select [File]
top level of the calculation → [Arrange Programs] in the 
cycle in the same manner ISaGRAF program management 
as described for other user window.
programs. However, this program must be

located after "YC_Cycle".
If this program is deleted, the
sampling trace will not work.  If this
program is deleted, run the
Sampling Trace Wizard again to
regenerate the program.

ISaGRAF global Variables necessary for Do not edit this program. 
variables whose execution of the YC_Trace Additionally, do not use a network 
name begins or online features. address of "A000 (HEX)" or over for 
with "YT_" the ISaGRAF variables.

If these variables are deleted
accidentally, run the Sampling Trace
Wizard again to regenerate the
variables.

Sampling trace A User-defined Parameter Do not edit this program.
buffer type and its instance If this program is deleted, the

sampling trace will not work.
If this program is deleted, run the
Sampling Trace Wizard again to
regenerate the program.



22  -  3 Online Features

This section describes the online features of the Sampling Trace Wizard.

The online features for the fixed times trace may slightly differ from those for the continuous trace.  The following

describes both features separately.

■ Fixed times trace
● Putting the Sampling Trace Wizard in the online mode 

While the message, "Offline", is shown on the status bar, select [Online] →
[Online Mode] to put the Sampling Trace Wizard in the online mode.  

In the online mode, the message, "Online", will appear on the status bar.

● Starting and stopping the trace
• By controlling the value of the trigger variable, the trace operation can be

started or stopped according to the settings made in the trigger mode.

• In the Sampling Trace Wizard, click the [Trigger Variable Value] lamp of the

[Trigger Conditions] tab during the online mode to change the value of the

trigger variable.

(Lamp ON indicates "True"; lamp OFF indicates "False".) 

• When the Sampling Trace Wizard is in the online mode, the message, "Trace
Running", is shown in the trace status field on the status bar while the trace is

running.

• When the trace is completed and the buffer is filled with trace data,  "Trace
Done" is shown in the trace status field.
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● Displaying the trace results
• If the trace status is "Trace Done" when the Sampling Trace Wizard is in the

online mode, select [Online] → [Display/Log trace result] to display the trace

results.

• The trace results are shown on the trend monitor with each sampling point

assigned to a series.

• If the number of sampling points exceeds "8", select [Display/Log trace
result] several times to open multiple trend windows.  By changing the display

series data in each window, the trace results of all data can be shown.

• The drawing method can be changed by changing the trend options other than

the update time setting.

• To change the trend options beforehand, make the settings when opening the

"Trend Monitor" window.  

For details about trend options, 

refer to section 21-2, Setting Up the Trend Options (page 21-4).
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● CSV Logging of Trace Results
• If the trace status is "Trace Done" when the Sampling Trace Wizard is in the

online mode, select [Online] → [Display/Log trace result] to activate a trend

monitor, and the trace results will be logged.

• All the sampling points will be logged at each sampling timing in the order of

the points listed in the [Sampling Points] tab, regardless of which data is

selected as series data, different from displaying the trace result.

However, if the trend option [CSV Logging ON] is not selected, the logging is

not performed.

• Change [Directory for CSV logging] and [CSV core file name], and then

select [CSV Logging ON] again to do a rewrite to a file.

• Other trend options do not affect the logging.

• To change the trend options beforehand, make the settings when opening the

"Trend Monitor" window.  

For details about trend options, 

refer to section 21-2, Setting Up the Trend Options (page 21-4).

● Automatic display of trace results
• When using this feature, the trace results are drawn automatically every time

the trace status is changed from "Trace Running" to "Trace Done".

• When the Sampling Trace Wizard is in the online mode, select [Online] →
[Start auto display/log trace result] to activate a trend monitor showing the

results, and necessary preparations will be performed.

After that, every time the trace status is changed from "Trace Running" to

"Trace Done", the results will be displayed in the "Trend Monitor" window.

• If the number of sampling data exceeds "8", the display series can be changed

by changing the trend options setup.  However, more than eight points cannot

be drawn at the same time.

• The drawing method can be changed by changing the trend options other than

the update time setting.

• The automatic display mode will not be cancelled until [Stop auto display/log
trace result] is selected from the [Online] menu, until the mode is changed to

the offline mode, or until an error such as overrun occurs.

• To change the trend options beforehand, make the settings when opening the

"Trend Monitor" window.  

For details about trend options, 

refer to section 21-2, Setting Up the Trend Options (page 21-4).
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● Automatic CSV logging of trace results
• When the Sampling Trace Wizard is in the online mode, select [Online] →

[Start auto display/log trace result] to activate a trend monitor for result

display/logging, and necessary preparations will be performed.

After that, every time the trace status is changed from "Trace Running" to

"Trace Done", the trace results will be logged by the "Trend Monitor" window.

• All the sampling points will be logged at each sampling timing in the order of

the points listed in the [Sampling Points] tab, regardless of which data is

selected as series data, different from the automatic display of the trend results.

However, if the trend option [CSV Logging ON] is not selected, the logging is

not performed.

• Change [Directory for CSV logging] and [CSV core file name], and then

select [CSV Logging ON] again to do a rewrite to a file.

• Other trend options do not affect the logging.

• The automatic logging mode will not be cancelled until [Stop auto display/log
trace result] is selected from the [Online] menu, until the mode is changed to

the offline mode, or until an error such as overrun occurs.

• To change the trend options beforehand, make the settings when opening the

"Trend Monitor" window.  

For details about trend options, 

refer to section 21-2, Setting Up the Trend Options (page 21-4).

■ Continuous trace
● Putting the Sampling Trace Wizard in the online mode

When the message, "Offline", is shown on the status bar, select [Online] →
[Online Mode] to put the Sampling Trace Wizard in the online mode.  At the

same time, the message, "Online", will appear on the status bar and a trend

monitor will be activated.

● Starting and stopping the trace
• By controlling the value of the trigger variable, the trace operation can be

started or stopped according to the settings made in the trigger mode.

• In the Sampling Trace Wizard, click the [Trigger Variable Value] lamp of the

[Trigger Conditions] tab during the online mode to change the value of the

trigger variable.

(Lamp ON  indicates "True"; lamp OFF indicates "False".) 

• When the Sampling Trace Wizard is in the online mode, the message "Trace
Running" is shown in the trace status field on the status bar while the trace is

running.  The trace data display/logging is started at the same time.

If the trace is being performed when the Sampling Trace Wizard is put into the

online mode, the trace data display/logging is started immediately.

• If the obtaining of the sampling results from the controller to the PC through the

communication cannot keep up with the sampling speed on the controller, an

overrun error may occur and the tracing will be stopped automatically.

If this occurs, reduce the number of sampling points or make the sampling time

longer.
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• To stop the trace, operate on the trigger variable.  When the trace is stopped, the

message "Offline" will appear on the status bar.

● Displaying the continuous trace
• When the Sampling Trace Wizard is put in the online mode, the "Trend

Monitor" window that assigns the sampling points as series data will be

activated.

• When the Sampling Trace Wizard is in the online and the trace is started, the

continuous drawing of the trace data is started.  The continuous drawing will be

performed until the trace is stopped, until the Sampling Trace Wizard is put in

the offline mode, or until an error such as overrun occurs.

• The simultaneous drawing of more than eight series is not supported.  The

selected drawing can be performed using the series selections in trend options.

• Trend options other than the update time setting can be changed.

However, the trend options have the same limitations on the setting data during

the continuous trace data is being updated , as those during the normal trend

monitoring.

• To change the trend options beforehand, make the settings when opening the

"Tend Monitor" window.  

For details about trend options, 

refer to section 21-2, Setting Up the Trend Options (page 21-4).

● CSV logging of continuous trace
• When the Sampling Trace Wizard is put in the online mode, the "Trend

Monitor" window that assigns the sampling points as series data will be

activated.

• When it is detected that the trace is being performed in the online mode, the

obtaining and logging of the sampling data are started immediately.  The

continuous logging will be performed until the trace is stopped by changing the

trigger variable, until the Sampling Trace Wizard is put in the offline mode, or

until an error such as overrun occurs.

• All the sampling points will be logged at each sampling timing in the order of

the points listed in the [Sampling Points] tab, regardless of which data is

selected as series data, different from the continuous trace display.

• If the trend option [CSVLogging ON] is not selected, the logging cannot be

performed.

• If the setting in [Directory for CSV logging] or [CSV core file name] is

changed, it will be applied to the next continuous logging.

(These settings cannot be changed during tracing.) 

• Other trend options do not affect the logging.  

For details, 

refer to section 21-2, Setting Up the Trend Options (page 21-4).
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Delete the following automatically generated components:

Chapter 22. SAMPLING TRACE WIZARD

Name Description
Program YC_Trace Select this program in the "ISaGRAF Program

Management" window and select [File] → [Delete] to
delete it.

Program YC_Cycle Delete this program only when the pattern control
automatically generated by the Pattern Wizard is not
used.  How to delete this program is the same as that
for "YC_Trace".

ISaGRAF global variables Delete all the variables whose name begins with "YT_" 
whose name begins with using the ISaGRAF dictionary or the ISaGRAF 
"YT_" Variable Declarations window of SLP-D50.

Sampling trace buffer In the treeview of the "Project" window in SLP-D50,
select the type label "Sampling trace buffer" from the
User-defined Type, and right click → [Delete Type].
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• This Integer Conversion Wizard is a feature of automatic generation of integer conversion programs used to

exchange integer data with external systems that can handle only integer values.

• This feature is a kind of the automatic programming features.  Only the programmable controller can enable this

feature.  After the settings have been made (changed),  you must compile and download the application for the

changes to take effect in the controller.

• External systems access the conversion I/F integer variables of the DINT type (integer type of ISaGRAF).  For

details, 

refer to Module Type Controller DMC50 User's Manual "Installation and Configuration", CP-SP-
1139E, and Module Type Controller AHC2001 User's Manual "Communications Connection", 
CP-SP-1138E.

Handling Precautions
Saving modifications is not supported in the SLP-D50 operators edition.

23-1

External system

External system

Integer data is written to the I/F integer variable.

Integer data is read from the I/F integer variable

Begin: YC_IcnvB (I/F integer variable 
→ Conversion actual data) 

Calculations using conversion actual data

End: YC_IcnvE (Conversion actual data -> I/F
interger variable )�

One calculation cycle



23  -  1 Activating the Integer Conversion Wizard
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With the "Project" window active, select [Edit] → [Auto Programming] → [Integer Conversion Wizard] to

activate the Integer Conversion Wizard.
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23  -  2 Registering Conversion Data

As the Integer Conversion Wizard is activated, the following window will appear.

The user can register data (conversion actual data) to be converted into integer data, by drag&drop or copy&insert

of the desired ISaGRAF global variables and Parameter elements from the "ISaGRAF Variable Declarations"

window of SLP-D50 and the [Instance Body] tab of the "Project" window, respectively.

■ Editing data in the "Integer Conversion Wizard" window
● Adding an item (Drag & Drop) 

(1) Left click to select a row where you wish to insert an item.  Right click →
[New Item (Add before)] or [New Item (Add after)] to put a blank row

before or after the specified row.

(2) Drag and drop the data (conversion actual data) to be converted into integer

data in a blank row from the "Project" window or "ISaGRAF Variable
Declarations" window.

● Adding an item (Copy & Insert) 
(1) Copy one or multiple data (conversion actual data) you wish to convert into

integer data  from the "Project" window or "ISaGRAF Variable
Declarations" window to the copy buffer.

For details about Parameter data, 

refer to section 9-14, Copy & Paste Feature (page 9-20).
For details about ISaGRAF variable data, 

refer to ■ Copy variables (page 12-9).
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(2) Left click to select a row where you wish to insert an item.  Right click →
[Insert] → [Before]([After]) to register the copied data before or after the

specified row.

● Deleting an item
Left click to select a data item row you wish to delete.  Right click >  [Delete Item]

to delete the selected data item.

Handling Precautions
The current version of SLP-D50 does not support deleting the multiple
items.  However,  using the cut feature described in the following, it is
possible to delete multiple rows.

● Cutting & Inserting an item
(1) Left click to select a start data row you wish to move.   To cut multiple data

rows, click the last row with the [SHIFT] key kept pressed.

(2) Right click → [Cut] to cut the selected data.

(3) Subsequently, left click to select a row where you wish to insert the data in the

same manner as described in the above description for Adding an item (Copy

& Insert).  Right click → [Insert] → [Before]([After]) to insert the cut data

before  or after the specified row.

● Editing fields
For each registered conversion data, fields such as I/F variable name, I/F NA,

scale, R/W, and comment can be edited.

● Reassigning the addresses 
Right click → [Reassigning Addresses] at any location on the grid.  The I/F

variable addresses of all data items registered in the Integer Conversion Wizard

are  reassigned from "E001 (HEX)" in the ascending order of the grid ID numbers.
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■ Display/Setup fields
It is necessary to set up the registered data on such as conversion method in the

"Integer Conversion Wizard" window.  The following table shows the display

items in the Conversion Wizard:

* Note that the comment of the I/F variable in the dictionary is overwritten by this setup.
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Field name Setting range Edit Description
Parameter Disabled This field is a Parameter type label when the 
type conversion actual data is a Parameter element, 
(POU name) while it is a POU name when the conversion

actual data is an ISaGRAF variable.  (The field
shows "Global" when the conversion actual
data is a global variable.)

Item Name Disabled This field is an item name when the conversion 
(Var Name) actual data is a Parameter element, while it is a

variable name when the conversion actual data
is an ISaGRAF variable.

ch Disabled This field is a group ID when the conversion
actual data is a Parameter element.  (The field
shows "0" when the conversion actual data is
an ISaGRAF variable.

PA 0x0000000 → 0xFFFFFFFF Disabled Parameter address of conversion actual data
Datatype BOOL, INT, DINT, TIME, Disabled Data type of conversion actual data

DWORD, REAL
Default Setting range specified for each Refer to the Initial(Default) value to be set for the 

type description conversion actual data when the R/W attribute
is R/W.  This value is specified using the
ISaGRAF literals (constant expressions) that
can be used for the conversion actual data type.
For read-only data , this default value is not
used, but the initial(default) value of the
conversion actual data is used.

I/F Var Name Automatically set; begins with Enabled Conversion I/F variable name, which is an 
"YZ_" ISaGRAF variable whose data type is always

the DINT type.  I/F variable name will be "YZ_"
+ PA of the conversion actual data  for a
Parameter element; "YZ_" + variable name of
the conversion actual data for an ISaGRAF
variable".

I/F NA 0xE001 → 0xEFFF Enabled Network address of the Conversion I/F variable
Scale Positive integer Enabled REAL    Give a magnitude of real-number value

as a unit of the conversion I/F variable,
in the form of 10^(- scale).
Select a scale in a range of -30 to 30.
(Example: Scale =1→10^(-1)=0.1)

TIME     Unit of conversion I/F variable 
0 : 1 ms
1 : 10 ms
2 : 100 ms 
3 : 1 sec.
4 : 1 min.
5 : 1 h.

R/W R (Read Only) Enabled When "ReadOnly" is selected, the conversion 
/RW (Read Write) will be performed only for the read from the

controller to the host, and the initial value of the
conversion actual data is used as the initial
value.

Comment Automatically set Enabled For the ISaGRAF variable, the comment in the
dictionary is used.  For the Parameter element,
the Parameter label, item name, and channel
No. are put together to make a comment of the
I/F variable.  *
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■ Limitations
• ISaGRAF variables other than the global variables cannot be converted.

Additionally, the character string type data conversion is also not supported.

• Data conversion may include a rounding error.

When the conversion actual data is REAL type, the value is rounded off.  When

the conversion actual data is TIME type, the value is rounded down.

Example 1: If the REAL type value is "14.225" and the scale is "2", the

converted integer value becomes "1423".

Example 2: If the TIME type value is "T#10h43s123ms" and the scale is "4"

(the unit is 1 min.), the converted integer value becomes "10h x

60 = 600".

• The following table shows the valid conversion range from the conversion

actual data to the I/F integer:

*1 This is the Parameter type in SLP-D50.  These data type do not exist in the

ISaGRAF variables.  They are implemented as DINT in the controller.

*2 This data type is converted with the bit image retained.
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Conversion actual data type Valid conversion range 
(SLP-D50) of conversion actual data

REAL -2,147,483,647 X 10^(-S) or more and less than
2,147,473,647.5 X 10^S ("S" shows the scale
parameter.) 

TIME "T#0s" or more and less than "T#24h" (Full
range) 

BOOL False and True (Full range)

DINT Full range

INT  *1 Full range

DWORD  *1 Full range  *2
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• Valid conversion range from I/F integer to conversion actual data

*1 If the conversion actual data is a Parameter element, the data is also limited by

the setting range of the data in addition to the above limitations.

*2 This is the Parameter type in SLP-D50.  These data type do not exist in the

ISaGRAF variables.  They are implemented as DINT in the controller.

*3 This data type is converted with the bit image retained.

• As the number of conversion data is increased, the calculation time is getting

increased.

The load per data is about 500 µs. for the R/W data, and about 200 µs. for the

ReadOnly data.

• When the Integer Conversion Wizard is activated first, the program

"YC_IcnvB" that converts the I/F variable data into the conversion actual data

is located at the beginning of the "Begin" section.  The program "YC_ICnvE"

that converts the conversion actual data into the I/F variable data is located at

the last of the "End" section.  After that, however, program execution order

should be controlled by the user.  For details about how to change the program

execution order, 

refer to ISaGRAF Version 3.5 USER'S GUIDE.
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Conversion actual data type Valid conversion range of I/F variable
REAL Full range *1

TIME The value becomes smaller than "T#24h", that
is, in the TIME type data range if the I/F integer
is within the valid range as shown below.
Note that a converted value for an I/F integer
beyond the valid range is not guaranteed.

BOOL 0 or 1   *1 

DINT Full range   *1

INT   *2 Full range   *1

DWORD   *2 Full range   *3

Scale Valid range

0 "0" or more and "86399999" or less

1 "0" or more and "8639999" or less

2 "0" or more and "863999" or less

3 "0" or more and "86399" or less

4 "0" or more and "1439" or less

5 "0" or more and "23" or less
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■ Setting up the options
In addition to the general setup, the following optional setup is also provided.

● Optimization
The writing from the conversion I/F integer variable to the conversion actual data

and the reading from the conversion actual data to the conversion I/F integer

variable are optimized individually.

(available only for DMC50)

Handling Precautions
When the optimization is applied, a larger amount of the ISaGRAF
variable area is consumed compared to that when this switch is
disabled.

● Enable/disable flag
The writing to the conversion actual data and the reading from the conversion

actual data are individually made enabled or disabled.

This setting specifies the default behavior, and can be controlled by changing the

ISaGRAF variables "YZ_WriteEnable" (network address F200) and

"YZ_ReadEnable" (network address F201) , respectively, during execution.

● Initialization of conversion actual data
For all the registered write data (R/W attribute is RW), the user can set whether or

not the conversion actual data will be initialized with the I/F integer variable

values if the "Write Action Enabled" flag is set at True.  If the initialization is not

set, the values of the conversion actual data are preserved until the next write

operation is performed.  The initialization can be controlled by changing the

ISaGRAF variable "YZ_DoInit" (network address F202) during execution.

● Upload option
Specify whether or not the settings of the Integer Conversion Wizard will be

stored into the controller.  If the application code is generated and downloaded

with both this option and [Embed source code for upload] of the compiler

option checked, the settings of the Integer Conversion Wizard will be restored

when the project is uploaded as well as other project source information.

Handling Precautions
This option may affect the size of the execution code as well as the
embedded source code for upload.

■ Completing the setup
Make sure the settings are what you intend. Click the [OK] button in the Integer

Conversion Wizard window.  A confirmation dialog box will appear.  Click the

[OK] button.  In order for the setup to take effect in the controller, it is necessary to

compile and download the application program.
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● Components to be generated automatically
The following table shows the components that are generated automatically by the

Integer Conversion Wizard.

These automatically generated items must not be edited until they are no longer

needed.
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Name Description Cautions
Program For each conversion data, which is not set 
YC_ICnvB ReadOnly, the conversion I/F variable value

is converted and copied into the conversion
actual data according to the scale parameter
in every ISaGRAF execution cycle. 
When the Integer Conversion Wizard is first
executed in the project, this program is
generated at the beginning of the "Begin:"
section.  
The order will not be changed implicitly by
the 2nd or later wizard executions.

Program For each conversion data, the conversion 
YC_ICnvE actual data value is converted and copied

into the conversion I/F variable according to
the scale parameter in every ISaGRAF
execution cycle.  When the Integer
Conversion Wizard is first executed in the
project, this program is generated at the last
of the "End:" section.

ISaGRAF global YZ_{PA of conversion Parameters
variables whose actual data} 
name begins Example (YZ_0E100001)

with "YZ_" YZ_{Variable name of ISaGRAF
variables's
conversion actual data} 
Example (YZ_AI_1)

To change the execution order in the
same calculation cycle, select [File] →
[Arrange Programs] in the ISaGRAF
program management window.

To change the execution order in the
same calculation cycle, select [File] →
[Arrange Programs] in the ISaGRAF
program management window.

When executing the Wizard again after
the addresses have been changed with
the dictionary or SLP-D50's ISaGRAF
Variable Declarations window, these
global variables are overwritten with the
address settings specified in the Wizard.
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■ Accessing the I/F variables from external systems
• Compiling and downloading the application after the setup has been made

makes the I/F integer variables first valid in the controller.  Individual

conversion actual data can be accessed through the CPL communication

protocol specifying an address of the corresponding I/F variable .

For details, 

refer to Module Type Controller DMC50 User's Manual
"Communications Connection", CP-SP-1193E.

Here, make sure that the specified scale setting is correctly applied.

• Note that, for the data to which R/W mode is assigned as the R/W attribute, the

initial values specified in the Integer Conversion Wizard will be the initial

values of the conversion actual data.

■ HTML output of the settings
In the “Integer Conversion Wizard” window, Selecting [File] → [Export] will

output the settings in HTML format.
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Delete the automatically generated components.  The following table shows how to delete such items:

23  -  3 Actions to Take If the Integer Conversion Becomes Unnecessary

Name Description
YC_ICnvB Select relevant program in the ISaGRAF program 

YC_ICnvE management window, and select [File] → [Delete].

ISaGRAF global variables Delete all the variables whose name begins with "YZ_"
whose name begins with using the ISaGRAF dictionary or the ISaGRAF 
"YZ_" Variable Declarations window of SLP-D50.
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• Pattern Wizard automatically generates a program that produces a SP pattern (such as temperature profile) and a

program that produces events on each segment.

• This feature is a kind of the automatic programming features.  Only the programmable controller can use this

feature.  After the settings have been made (changed), you must compile and download the application for the

changes to take effect in the controller.

• In addition to this feature, a new pattern producing (profiling) feature using the pattern FBs is also provided.

Use of the pattern FBs makes it possible to perform the more complicated controls compared to those using the

Pattern Wizard.  The pattern feature using the pattern FBs has various capabilities, such as generation and

synchronization of multiple patterns, recovery operation in case of power failure, and high-speed pattern

generation, which are not provided in the Pattern Wizard.  

For details, 

refer to Chapter 26, PATTERN FB SUPPORT FACILITY.

Handling Precautions
This feature is not available in the SLP-D50 operators edition.
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24  -  1 Limitations on Pattern Wizard
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• The Pattern Wizard generates a program that produces only one series of SP.

• It is necessary that the user must write a code making the association  between the self-generating data used in

the automatically generated programs and the data used in your programs (PV and MV values  for input, SP and

event values for output, and some others).

For details, 

refer to section 24-4, Editing the Pattern Components (page 24-7).

• Note that reexecuting Pattern Wizard will clear and overwrite all the modifications to the automatically

generated components (pattern segments, or etc)  done after the last Pattern Wizard execution.  Most setup data

can be changed without use of the Pattern Wizard.  

For details, 

refer to section 24-4, Editing the Pattern Components (page 24-7).

• The SP pattern produced in the program generated by the Pattern Wizard may include a time lag of about three

control cycles when transiting between a ramp and soak.  Therefore, make sure that this still satisfies the

specification if the program is used for the high-speed SP pattern producing application.

• Since any automatic recovery capability after a power failure has occurred is not provided, the execution will be

restarted from the segment No.1.
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24  -  2 Activating the Pattern Wizard

With the "Project" window active, select [Edit] → [Auto Programming] → [Program Pattern Wizard] to

activate the Pattern Wizard.
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24  -  3 Setting Up the Pattern Wizard
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In the Pattern Wizard, the following items are set up one by one:

■ Setup items
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Field Setting Range Description Means to change after
completion of Wizard setup

Num of Segments 1 to 100 The number of allowable seg- Up to 100 segments per pattern 
ments per pattern. can be created using the group 
The number of segments to be add or delete functionality of 
used actually is set using the SLP-D50.
Num of Effective Segs. After the number of segments

has been changed, it is necessary
to download the application.

Num of Patterns 1 to 40 The number of patterns to be This value can be changed using 
created. the instance adding functionality 

of SLP-D50.
After the number of patterns has
been changed, it is necessary to
download the application.

Num of Effective 1 to Number of seg- The number of effective seg- This value can be changed by 
Segs ments ments for each pattern changing the value of the

ISaGRAF variable "YP_MSeg_?"
("?" indicates the pattern No.).
This value can be edited online.

The Way of Setting SP + RampRate + The ramp is defined using ramp This value cannot be changed.
Segments SoakTime / SP + Time rate or time.  When the ramp is 

defined using the ramp rate, one 
segment represents  a ramp and 
soak pair.  When the ramp is 
defined using time, a ramp and 
soak is represented by each 
individual segment.

Ramp Rate Unit  * °C/h, °C/min, °C/s Specify  the unit of ramp rate. This value cannot be changed.
(This setup item will be present 
only when the ramp is defined 
using ramp rate.)

Soak Time Unit  * h, min, s Specify the unit of soak time. This value cannot be changed.
(This setup item will be present 
only when the ramp is defined 
using time.)

Time Unit  * h, min, s Specify the unit of soak and ramp This value cannot be changed.
time.
(This setup item will be present 
only when the ramp is defined 
using time.)

Use of PV Start Yes/No Check this check box to use the This value can be changed by 
PV start. changing the value of the

ISaGRAF variable "YP_PVstart".
(0: Disabled, 1: Enabled)
This value can be edited online.

PV Start Search Search in ramp-up Specify where to search a start This value can be changed by 
segs/Search in ramp- segment of the PV start: in ramp- changing the value of the 
down segs up segments, or in ramp-down ISaGRAF variable 

segments. "YP_RF_PVstart".
(This setup item will be selectable (0: Search in ramp-up segs, 
only when the PV start is used.) 1: Search in ramp-down segs)

This value can be edited online.

CONTINUE TO NEXT PAGE
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Field Setting Range Description Means to change after
completion of Wizard setup

SP Bias Bias value commonly added to This value can be changed by 
the SP values of all segments. changing the value of the

ISaGRAF variable "YP_SBI".
This value can be edited online.

Guaranteed Soak Guaranteed soak is Check this item to set the G. Soak This setup item can be edited 
applied in each seg- value in each segment; uncheck later only when checked in the 
ment or not used. not to use G.Soak.  * Wizard.

G.Soak value common to all "No Use/Use" will be switched by
segments cannot be specified. changing the value of the 
If you would like to disable ISaGRAF variable 
G.Soak action on particular seg- "YP_GSoakUse".
ments, assign "0" to the G. Soak (0: not used, 1: set in each seg)
value of these segments. This value can be edited online.

G. Soak Time s G. Soak time common to all This value can be altered by 
segments.  * changing the value of the 
The G. Soak time cannot be set ISaGRAF variable " 
for each segment. YP_GSTime".

This value can be edited online.

PID Group PID group is set in Check this item to set a different "Common to all/For each seg-
each segment or PID group No. for each segment. ment" can be switched by 
common in all changing the value of the 
segments. ISaGRAF variable

"YP_PIDSetUse".
(0: common in all, 
1: set in each seg)
This value can be edited online.

Set PV Events in Yes/No Check this item to produce PV This value cannot be changed.
Each Segment. events in each segment.

Set Time Events in Yes/No Check this item to produce time This value cannot be changed.
Each Segment. events in each segment.

Num of (PV) 0 to 50 The number of PV events This value cannot be changed.
Events  * (except for  the number produced in each segment.

of PV events that (This setup item is editable only 
leads to "the number when "Set PV events in each 
of PV events + the segment" is checked.)
number of time 
events X 2 > 50".)

PV Event Type  * PV High/PV Low/ PV event type of each PV event This value can be changed by 
Deviation High/ to be generated changing the value of the 
Deviation Low/Absolute (This setup item will be present ISaGRAF variable 
Deviation High/Absolute only when "Set PV events in each "YP_EVTyp_?" ("?" represents 
Deviation Low/SP segment" is checked and the any event No.).
High/SP Low/MV number of PV events in each (0: PV High, 1: PV Low, 
High/MV Low segment is set to "1" or more.) 2: Deviation High, 3: Deviation

Low, 4: Absolute  Deviation High,
5: Absolute Deviation Low, 6: SP
High, 7: SP Low, 8: MV High, 9:
MV Low)
This value can be edited online.
The correspondence between
the numeric value and event type
is not described in the variable
comments.  However, this
correspondence can be seen in
the  source code of "PVEVT".

CONTINUE TO NEXT PAGE
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■ Completing the setup 
Make sure the settings are what you intend. Click the [OK] button on the last page

of the Pattern Wizard.

In order for the settings to take effect in the controller, it is necessary to edit the

generated components, and compile and download the application program.

■ Components to be generated automatically 
The following table shows the components that are generated automatically by the

Pattern Wizard.

For details, 

refer to section 24-7, Automatically Generated Components (page 24-
22).

* In the explanations about BOOL variables above, the setting values noted as "0" and "1" mean "True" and
"False", respectively.

Field Setting Range Description Means to change after
completion of Wizard setup

Event Hysteresis  * The hysteresis of the upper and This value can be altered by 
lower limit alarm to be set for changing the value of the 
each PV event. ISaGRAF variable 
The unit is the same as that of "YP_EVHys_?" ("?" represents 
the PV value. any event No.).
(This setup item will be present This value can be edited online.
only when "Set PV events in each
segment" is checked and the 
number of PV events in each 
segment is set to "1" or more.)

Event On Delay 0 sec. or more On-delay time of the PV event This value can be altered by 
Time  * to be set for each PV event. changing the value of the 

(This setup item will be present ISaGRAF variable 
only when "Set PV events in "YP_EVDLY_?" ("?" represents 
each segment" is checked and any event No.).
the number of PV events in each This value can be edited online.
segment is set to "1" or more.)

Number of Time 0 to 25 Number of time events in each This value cannot be changed.
Events (except for the number segment

of time events that (This setup item will be editable 
leads to "the number only when "Set time events in 
of PV events" + each segment" is checked.)
"the number of time 
events" x 2 > 50").

Classification Name Description
Global variables Variable names Variables related to the pattern and 

beginning with event generations necessary to be
"YP_" accessed by other programs or through

communications.

Defined words Definition names Constant values used in the programs.
beginning with "YP_"

Programs YC_Cycle Cycle time obtaining program

YC_Pat SP pattern producing program

YC_Evt Event producing program

User-defined SP Pattern Setup Parameter where the setting values of
Parameter each segment is stored.
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To operate the pattern producing program, it is necessary to add some code and do some settings after components

have been generated by the Pattern Wizard.

■ Editing the application program
It is necessary to create programs other than the automatically generated programs

according to the following description.

● Programs in "Begin" section
• Assigning a value to YP_PV

When using the PV start or PV events, it is necessary to write a code that

assigns an actual PV value to the global variable YP_PV.

• Assigning a value to YP_MV 

When using the event type MV High/Low for the PV event, it is necessary to

write a code that assigns an actual MV value to the global variable YP_MV.

● Programs in "End" section
• Using YP_SP

Since the SP value generated by the SP pattern producing program "YC_Pat" is

assigned in  the global variable "YP_SP", it is necessary to write a code that

copies this value to the SP argument to the control calculation to be used (such

as PID_A).

• Using YP_PIDSet 

Since "YC_Pat" sets the PID group No. in the global variable "YP_PIDSet"

when [Set the PID Group in each segment] is checked, it is necessary to write a

code that copies  this value to the PID group argument to the control calculation

to be used (such as PID_A).

• Using YP_EV_On? 

When using one or more PV events, the event outputs are output to the global

boolean variables "YP_EV_On? (?=1, 2, ...)".  Therefore, it is possible to write

an exception handler using these values.

• Using YP_TEV_On?

When using one or more time events, the event outputs are output to the global

boolean variables "YP_TEV_On? (?=1, 2, ...)".  Therefore, it is possible to

write an exception handler using these values.

24-7
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■ Changing the pattern setting values
It is possible to change the pattern setting values mapped in the ISaGRAF global

variables.

• To change the values to be used at the start time of the first execution after the

application has been downloaded, change the initial(default) values.  In order

for the initial values to take effect in the controller, it is necessary to compile

and download the application.

• Basically, the pattern setting values mapped in the ISaGRAF global variables

can be changed online.

For details, 

refer to the description, ■ Global variable definitions (page 24-11).

■ Editing the segment data
The patterns and segments are respectively represented by the instances and

groups of a User-defined Parameter type, "SP Pattern Setup".

A pattern No. is the value that is "the top group ID of an instance divided by 100 +

1".  A group No. is  the value that is 1 plus the remainder of the group ID of a

group minus 1  divided by 100.

The segment data can be changed through the normal online/offline editing of

Parameter.

For details about how to edit Parameters, 

refer to Chapter 9, EDITING PARAMETERS and 

Chapter 10, WORKING WITH PARAMETERS ONLINE.  

For details about contents of each segment data, 

refer to  ■ User-defined Parameter "SP Pattern Setup" (page 24-19).

■ Adding a pattern 
• Right click → [Add Instance] on the type label name "SP Pattern Setup"

under the User-defined type in the treeview of the "Project" window to add a

pattern.  Here, the top group ID must be a value that is "a multiple of 100 + 1

(like 101, 201, ...)".  Additionally, specify the number of groups equal to 100 or

less as the number of necessary segments.  Give a name for the instance to

identify the pattern.

• To make the added pattern available in the controller, it is necessary to

download the application.

■ Deleting a pattern
• To delete a pattern, select the instance indicating the pattern you wish to delete

in the treeview, and right click → [Delete Instance].

• In order for the deletion to take effect in the controller, it is necessary to

download the application.

Chapter 24. PATTERN WIZARD
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■ Adding segments
• Select an instance name where you wish to add segments under the User-

defined Type label "SP Pattern Setup" in the treeview of the "Project" window.

Next, open the [Instance Body] tab, and right click → [Add Group] on this tab

to add segments.

Here, make sure that the number of groups of the instance is 100 or less.

(The last group ID of the same instance must be the next multiple of 100 or

less.  Example: If the top group ID is 101, the last group ID  is  200 or less.)

• Once the segments have been added, to specify the actual number of segments

to be used  , set  the global integer variable "YP_Mseg_?" ("?" represents the

pattern No. = the top group ID of the instance / 100 + 1).

• To make the added segments available in the controller, it is necessary to

download the application.

■ Deleting segments 
• In the same manner as adding segments, display the instance body representing

a pattern.

After clicking on a segment (group) , right click → [Delete Group] on the

instance body .

• Once the segments have been deleted, to specify the actual segments to be used

, set the global integer variable "YP_Mseg_?" ("?" represents the pattern No. =

the top group ID of the instance / 100 + 1).

• In order for the segments deletion to take effect in the controller, it is necessary

to download the application.

Chapter 24. PATTERN WIZARD
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● Changing the mode
The pattern execution can be controlled by changing the value of the global integer

variable "YP_Mode" during execution.  When changing like, 0 = READY, 1 =

RUN, and 2 = HOLD, the mode is transited to relevant mode.

For details, 

refer to the description, ■ Program "YC_Pat" (page 24-13).

• READY 

The pattern operation is not performed.

If the PV start is enabled, the SP value of the segment that is searched with the

PV value is assigned in "YP_SP";  otherwise the SP value of the segment No. 1

is assigned in "YP_SP".

• RUN 

The pattern operation is being performed. 

The soak or ramp operation is performed.  The calculated SP value is stored in

"YP_SP".

• HOLD 

The pattern operation is stopped.

The elapsed time is stopped.  Additionally, the value of "YP_SP" is not

changed.

● Changing the pattern No.
The pattern No. can be changed by modifying the value of the global integer

variable "YP_Pat" in the READY mode.  (The pattern No. is the value that the top

group ID of an instance of the User-defined Type "SP Pattern Setup" / 100 + "1".)

Chapter 24. PATTERN WIZARD
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■ Global variable definitions 
The following global variables are automatically generated by the Pattern Wizard:

The addresses are not allocated automatically.

You must assign the addresses yourself to such variables, if necessary(0 to 9FFF

(hexadecimal value)).

Handling Precautions
Do not change the values of the variables with R/W attribute specified
as "R"in the following table during the operation in the controller.
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Variable name Type R/W Description
YP_PVstart BOOL RW PV start is (False: Disabled, True: Enabled)

YP_RF_PVstart BOOL RW Where to find PV start segment 
(False: ramp-ups, True: ramp-downs)

YP_GSoakUSE BOOL RW G.Soak value is .
(False: not used, True: set in each segment)

YP_PIDSetUse BOOL RW PID number is .
(False: common in all segments, True: set in each segment) 

YP_EV_On_?(?=1,2···) BOOL R ?-th PV event value(True: ON)

YP_TEV_On_?(?=1,2···) BOOL R ?-th Time event value(True: ON)

YP_SP REAL R SP value (produced by the pattern generation program)

YP_PV REAL RW PV value.  This value is necessary for calculation of the PV
start, G. Soak, and PV event.
A value must be assigned to this variable in a user program.

YP_MV REAL RW MV value.  This value is necessary for calculation of the MV
event.
A value must be assigned to this variable in a user program.

YP_Mode DINT RW Operation mode (0: Ready, 1: RUN, 2: Hold) 
This mode must be set within a user program or through
communication.
For details about control flow, 

refer to section 24-5, Controlling the Pattern Execution
(page 24-10).

YP_Pat DINT R(W) Current pattern number.   This value can be changed in the
READY mode.
If the setting is changed in a mode other than the READY
mode, it does not take effect.

YP_Seg DINT R Current segment Number.

YP_CurSegSP REAL R Current segment's SP

YP_SBI REAL RW SP bias (Common to all segments)

YP_CurSegIncln REAL R Current segment ramp rate (ramp-up/down temperature
change per unit time)

YP_PIDSet DINT R(W) PID Constants group ID of the current segment.
This value can be changed when the "YP_PIDSetUse" is
"True".

YP_GSoak REAL R G. Soak value of the current segment

YP_FVDat_?(?=1,2···) REAL R ?-th PV event threshold of the current segment

YP_EVTyp_?(?=1,2···) REAL RW ?-th PV event type of the current segment
(0: PV High, 1: PV Low, 2: Deviation High, 3: Deviation Low,
4: Absolute e Deviation High, 5: Absolute Deviation Low, 6:
SP High, 7: SP Low, 8: MV High, 9: MV Low)

YP_EVHys_?(?=1,2···) REAL RW ?-th PV event hysteresys of the current segment

YP_Mseg?(?=1,2···) DINT RW Number of effective segments for the ?-th pattern

CONTINUE TO NEXT PAGE
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■ Defined words
The following defined words are used as constants in the programs automatically

generated by the Wizard:

■ Program "YC_Cycle"
This program is used to obtain the cycle time of the controller.  This program is

located in the "BEGIN" section.

Chapter 24. PATTERN WIZARD

Variable name Type R/W Description
YP_CTime TIME R Elapsed time used for the ramp rate calculation during ramp

operations if the ramp is specified as time.
Soak elapsed time during soak operations both if the ramp is
specified as time and specified as ramp rate.

YP_CTimeR TIME R Ramp elapsed time

YP_CirSegTime TIME R Time setting of the current segment

YP_CYCLE TIME R Control cycle time

YP_CurSegCnt TIME R Elapsed time of the current segment

YP_EVDLY_?(?=1,2···) TIME RW Event on-delay time of the PV event No. ?

YP_GSTime TIME R G. Soak time

YP_GSCnt TIME R G. Soak elapsed time

YP_PAT_TYPE Type ID of "SP Pattern Setup"

YP_ITM_SP Item ID of "SP"

YP_ITM_INC Item ID of "Ramp rate"
This is created only when the setting method is
"RampRate + SoakTime".

YP_IM_TIME Item ID of "Time" 

YP_ITM_GS Item ID of "Guaranteed Soak"

YP_ITM_PID Item ID of "PID Group"

YP_ITM_EV_? Item ID of "Event? Threshold" where ? is a PV event
No.  These words are created as many as the number
of  PV events.

YP_ITM_TEVON_? Item ID of "Time Event ? ON Time" where ? is a time
event No. These words are created as many as the
number of time events.

YP_ITM_TEVOFF_? Item ID of "Time Event ? OFF Time" where ? is a time
event No. These words are created as many as the
number of time events.
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■ Program "YC_Pat"

● Sub-programs of "YC_Pat"
"YC_Pat" is a program that produces an SP value according to the settings.  

The calculated SP value is written to the global variable "YP_SP".

Chapter 24. PATTERN WIZARD

Sub-program name Remarks
Get Set Point GETSP

Get Ramp-up(down) GETINCL This is created only when "SP + 
Rate RampRate + SoakTime" is selected

for the segment setting method.

Get Soak Time GETTIME The comment becomes "Get Time"
when "SP + Time" is selected for the
segment setting method.

Get Guaranteed Soak GETGS

Get PID Group Number GETPID

Get the Effective MAXSEG
Number of Segments

Get Start Segment STSEG
for PV Start
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● Local variables of "YC_Pat"
The following table shows the variables locally used in the pattern generation

program.  The user does not need to access these variables.  However, the

variables are listed for your reference.
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Variable name Data type Description
YP_Reset BOOL True in the Ready mode

YP_Start BOOL Pattern execution is started.

YP_End BOOL Pattern execution is completed.

YP_Trans BOOL This variable is used several times as mode
transition conditions.

YP_Soakflg BOOL This variable is the flag showing whether or
not the soak operation is being performed
after the ramp has been completed.
This variable is created only when
"RampRate + SoakTime" is selected.

SoakChk BOOL This variable is created only when the ramp
is set by ramp rate.
This variable is a flag to determine whether
or not performing G. Soak operation.

YP_PatBak DINT Pattern No. value backup
(Used to check whether or not any change
is made.)

YP_tmpPID DINT PID group No. of the current segment
(temporary variable when reading)

YP_baseSP REAL Base SP value used to calculate the SP
value at the elapsed time

YP_CurSegSPbak REAL SP value backup of the current segment
(Used to check whether or not any change
is made.)

YP_SBIBak REAL SP bias value backup
(Used to check whether or not any change
is made.)

YP_CurSegInclbak REAL Ramp rate value backup of current segment
(Used to check whether or not any change
is made.)
This variable is created only when
"RampRate + SoakTime" is selected.

YP_tlrnc REAL If the absolute deviation between the target
SP and current SP is this value or less, the
current SP is written to the target SP value.
This variable is created only when
"RampRate + SoakTime" is selected.

YP_PrevSegSP REAL SP of the previous segment

YP_CurSegTimebak TIME Time backup of the current segment
(Used to check whether or not any change
is made.)

YP_XTime TIME Base time for calculation of ramp rate.
Ramp rate is recalculated when changing
the segment, segment SP, segment time,
and/or SP bias.
Time of the current segment minus elapsed
time of the current segment at the time of
recalculation
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● Procedures
The following illustrates the overall control flow  of the pattern generation

program "YC_Pat".

The READY, RUN, and HOLD modes used in the following description are

represented by the value of the global variable "YP_Mode".  (0: READY, 1:RUN,

2: HOLD)

READY mode procedure
This procedure is executed every control cycle when YP_Mode is READY.

(1) When using the PV start, the start segment No. is obtained automatically by the

sub-program "StSeg".  If the PV start is not used, the start segment is set to "1".

(2) The sub-program "GetSP" assigns the SP value of the segment in "YP_SP".

(3) When a PID group is set in each segment, the sub-program "GetPID" gets it

from each segment setting, and sets the variable "YP_PIDSet" to the value.

▼

READYmode procedure

G. Soak procedure

SP value calculation

Pattern completion procedure

To SP value calculation

The mode is set to other �
than the READY mode and �
the current segment is "1".

Completion of �
pattern execution

To the next segment Reset is triggered Turned from ramp �
to soak.�
�

The mode is set to other than �
the READY mode and �
the current segment is not "1".

Segment transition procedure Reset procedure G. Soak pre-procedure

To READY mode procedure To READY mode procedureTo G. Soak procedure To G. Soak procedure

* Only when the ramp is specified as ramp rate:

READY mode

Chapter 24. PATTERN WIZARD
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G. Soak procedure
This G. Soak procedure is performed when "YP_Mode" is changed from READY

to RUN, the segment transition occurs in the RUN mode, operation is turned from

ramp to soak if the ramp is specified as ramp rate.

(1) If the SP bias has been changed, the SP value is recalculated.

(2) When G. Soak operation is used, the G. Soak value is obtained by "GetGS".

When the G. Soak operation is not used, a transition occurs to the SP value

calculation procedure.

(3) If the G. Soak procedure completion conditions (*0) are satisfied , a transition

occurs to the SP value calculation procedure.

(*0   G. Soak procedure completion conditions)

G.Soak time is elapsed while the absolute deviation between the segment SP

and PV has been kept within the G. Soak value range continuously, or the G.

Soak value is set at "0".

SP value calculation 
When "YP_Mode" is a mode other than the READY mode, the following

procedure is performed.  When "YP_Mode" is the READY mode, a transition

occurs to the reset procedure.

A. If the segment setting method is  SP + RampRate + SoakTime

A-1. If the pattern No. has been changed, it is returned to the auto generated

value.  (Pattern No. for operation can be changed only in the READY

mode.)

A-2. The soak time is obtained by "GetTime", the SP is obtained by "GetSP",

and the ramp rate is obtained by "GetIncl".

A-3. When the ramp conditions (*1) are "True", the ramp operation is started:

(1) The soak flag "YP_Soakflg" is set to "False". 

(2) The soak elapsed time "YP_CTime" is reset.

(3) In the HOLD mode, the ramp elapsed time "YP_CTimeR" is stopped

and the operation of this cycle is ceased.  In the RUN mode, the ramp

elapsed time is started.

(4) The following actions are performed in the RUN mode:

•   If the SP value or the ramp rate or the SP bias has been changed,

the base SP is set again, the ramp elapsed time is reset, and

restarted.

•   The SP value is set.  (SP = base SP (+/-) (ramp elapsed time) X
(ramp rate)) 

(*1)  Ramp conditions

The SP value is changed. 

(Segment No. ≠ 1 or ramp rate ≠ 0), and the absolute deviation

between the target SP and actual SP is larger than the absolute

amount of increase (decrease) of SP for one cycle.

▼
▼
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A-4. When the ramp conditions are "False" and the soak conditions (*2) are
"True", the soak operation is performed:

(1) When the operation is transited from ramp operation to soak
operation, the G. Soak check flag is set to "True". 

(2) The soak flag "YP_Soakflg" is set to "True".

(3) The ramp elapsed time "YP_CTimeR" is reset.

(4) In the HOLD mode, the segment/soak elapsed time is stopped.  In the
RUN mode, the segment/soak elapsed time is started.

(5) The SP value is set.  (SP = SP setting value of segment + SP bias) 

(*2)  Soak conditions

The soak time ≠ 0 and the soak elapsed time "YP_CTime" is
smaller than the soak time.

A-5. When both the ramp conditions and soak conditions are "False",  a
segment transition occurs.  ("YP_Trans" is set to "True".)  However, when
the pattern operation has already  executed the specified number of
effective segments, the pattern operation is ceased.  ("YP_End" is set to
"True".)

A-6. When a PID group is set in each segment, the variable "YP_PIDSet" is set
to this value by "GetPID".

B. If the segment setting method is SP + Time

B-1. If the pattern No. has been changed, it is returned to the auto generated
No.  (Pattern No. for operation can be changed only in the READY
mode.)

B-2. The soak time is obtained by "GetTime" and the SP is obtained by
"GetSP".

B-3. When the segment non-transition conditions (*3) are "True", operations
for the current segment is performed:

(1) In the HOLD mode, the segment elapsed time is stopped and the
operation of this cycle is ceased.  In the RUN mode, the segment
elapsed time is started.

(2) The following actions are performed in the RUN mode:

•  If the SP value or the time or the SP bias is changed, the base SP is
set again, the base time for the ramp rate calculation is calculated
again, and the elapsed time for the ramp rate calculation is reset and
restarted.

•   The SP value is set as:  (When segment No. = 1, SP = SP setting
value of segment + SP bias; when the segment No. ≠ 1 and the
absolute deviation between the target SP and base SP is larger than
the absolute amount of increase (decrease) of SP for one cycle, SP
= base SP + (target SP + SP bias - base SP) X (elapsed time for
ramp rate calculation) / (base time for ramp rate calculation);  when
this deviation is smaller, SP = SP setting value of the segment + SP
bias.)

(*3)  Segment non-transition conditions
Time setting of the segment ≠ 0 and the segment elapsed time
"YP_CurSegCnt" is smaller than the time setting.

Chapter 24. PATTERN WIZARD
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B-4. When the segment non-transition conditions are "False", a segment
transition occurs.
("YP_Trans" is set to "True".) 
However, when the pattern operation has already executed the specified
number of effective  segments, the pattern operation is completed.
("YP_End" is set to "True".) 

B-5 When a PID group is set in each segment, the variable "YP_PIDSet" is set

to this value by "GetPID".

Pattern completion procedure 
The operation mode "YP_Mode" is set to HOLD (2).

Segment transition procedure
• The segment elapsed time "YP_CurSegCnt" is reset. 

• The segment No. is incremented.

Reset procedure
The segment elapsed time "YP_CurSegCnt" is reset. 

G. Soak pre-procedure 
The soak elapsed time "YP_CTime" is reset.

■ Program "YC_Evt" 
● Sub-programs of "YC_Evt" 

● Local variables of "YC_Evt"
No variables other than the temporary variables are generated.

● Procedures
The following shows the overall procedure of the event producing  program

"YC_Evt":

▼
▼

▼
▼
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Sub-program name Remarks
Get PV event value PVEVT These are created only when the PV

event generation is selected.

Get PV event setting GETEV
value

Time event producer TEVT These are created only when the
time event generation is selected.

Get time event ON GetTON
duration

Get time event OFF GetTOFF
duration
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PV events producing
When the mode is not the READY mode, the following actions are performed as

many as the number of PV events specified.

When the mode is the READY mode, all the event output boolean variables

"YP_EV_On_?" are set to "False".

(1) The event threshold is obtained by "GetEV".

(2) The evaluation is done by the upper and lower limit FB having the hysteresis.

(3) The on-delay is applied by the on-delay timer FB.

Time events producing 
When the mode is not the READY mode, the following actions are performed as

many as the number of time events specified.

When the mode is the READY mode, all the time event output boolean variables

"YP_EV_On_?" are set to "False".

(1) The time event ON duration is obtained by "GetTON".

(2) The time event OFF duration is obtained by "GetTOFF".

(3) The time event producing is performed by "TEV".

■ User-defined Parameter "SP Pattern Setup"
The User-defined Parameter "SP Pattern Setup" where one group represents one

segment and one instance represents one pattern is automatically generated.

However, the definition in the case where the ramp is set with ramp rate is

basically different from the definition in the case where the ramp is set with time.

The following describes each definition:

● Setup when the ramp is set with ramp rate.
• One pair of ramp and soak is set in one segment (one Parameter group).

• The master settings on the PC and the controller settings can be modified using

the Parameter edit features (offline/online).  

For details about how to write to Parameters, 

refer to Chapter 9, EDITING PARAMETERS and 

Chapter 10, WORKING WITH PARAMETERS ONLINE.

▼
▼
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SP REAL Soak SP value

Ramp-up/down rate REAL Ramp SP change rate

Time DINT Soak time  (The time unit is the value
specified in the Wizard.)

G. Soak REAL G. Soak setting value.  (The unit is the
same as that of SP.)  When this value is
"0", the G. Soak operation is not
performed.

PID group DINT PID group No.

Event ? Threshold (? = 1, 2, ...) REAL PV event threshold of PV event No. ?

Time Event ? ON Duration DINT Time event ON duration of time event
No. ?

Time Event ? OFF Duration DINT Time event OFF duration of time event
No. ?  (To make the OFF event
disabled, specify the duration longer
than the segment time.)
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• SP value changes in the period of one segment:

The SP value is changed with ramp-up/down rate setting where the previous

segment's SP setting is  the start point and the current segment's SP setting is

the target point.  Subsequently, the soak operation is performed with the current

segment's SP setting for a period of the soak time setting.

Additionally, the soak operation is performed with the 1st segment's SP setting in

the 1st segment.  The ramp-up/down rate setting of the 1st segment will not be

used.

● Setup when the ramp is set with time.
• The ramp and soak are set in individual segments (Parameter groups).

• The master settings on the PC and controller settings can be changed using the

Parameter edit features (offline/online).  

For details about how to write to  Parameters, 

refer to Chapter 9, EDITING PARAMETERS and 

Chapter 10, WORKING WITH PARAMETERS ONLINE.
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Soak Time

Current segment's �
SP setting

Previous segment's �
SP setting

Ram
p 

Rat
e�

�
�

SP REAL Same as the previous segment's SP:
Soak SP
Different from the previous segment's
SP: Ramp operation target SP

Time DINT Soak/Ramp time
(The time unit is the value specified in
the Wizard.)

G. Soak REAL G. Soak setting value.  (The unit is the
same as that of SP.)  When this value is
"0", the G. Soak operation is not
performed.

PID group DINT PID group No.

Event ? Threshold (? = 1, 2, ...) REAL PV event threshold of PV event No. ?

Time Event ? ON Duration DINT Time event ON duration of time event
No. ?

Time Event ? OFF Duration DINT Time event OFF duration of time event
No. ?  (To make the OFF event
disabled, specify the duration longer
than the segment time.)
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• SP value changes in the period of one segment:

The SP value is changed with a ramp where the previous segment's SP setting is

the start point and the current segment's SP setting is the target point so that the

SP becomes the target point in the period of the current segment's Time setting.

Additionally, the soak operation is performed with  the 1st segment's SP setting in

the 1st segment.

Ram
p 

Rat
e 

A

Next segment's �
Time setting�
�

Previous segment's �
SP setting

Current segment's �
SP setting

Next segment's �
SP setting

Ramp rate A = �
  (Current segment's SP - Previous segment's SP)�
  /(Current segment's Time)
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24  -  7 Actions to Take If the Pattern Control Becomes Unnecessary

24-22

If the pattern control becomes unnecessary, delete the automatically generated components.  The following table

shows how to delete them.

Chapter 24. PATTERN WIZARD

Name Description
Program YC_Pat After selecting relevant program in the 

Program YC_Evt "ISaGRAF program management" window,
select [File] → [Delete]  to delete it.

Program YC_Cycle Delete this program only when the sampling
trace feature is not used.
Deleting it can be done in the same manner as
described for "YC_Pat" and "YC_Evt".

Defined words whose name Delete all the defined words whose name 
begins with "YP_" begins with "YP_" using the  ISaGRAF

dictionary.

ISaGRAF global variables whose Delete all variables whose name begins with 
name begins with "YP_" "YP_" using the ISaGRAF dictionary or the

ISaGRAF Variable Declarations window of
SLP-D50.

User-defined Parameter SP In the treeview of the "Project" window in SLP-
Pattern Setup D50, select the type label "SP Pattern Setup",

and right click → [Delete type].
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This chapter describes the facility only used by the project for the AHC2001 controller.
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25  -  1 Unit Configuration Setup
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The AHC2001 controller consists of a CPU unit that performs control operations, and I/O units (AI, AO, DI, DO)

and communication units (SCU, ENI) combined as required.  For the project you are editing, it is necessary to set

the same unit configuration as is used actually for the controller.

Note
It is allowed that an actual configuration has excess units at the end compare to the

project’s configuration.  This configuration is used to remotely monitor the system

with the communication unit connected temporarily.

After setting up the unit configuration, you can assign I/O variables to I/O unit channels with the ISaGRAF I/O

connection editor.

(Here, you must manually declare I/O variables and assign I/O variables to I/O unit channels.)

For details,

refer to the description, ● About I/O connection editor and I/O assignments (page 11-17) and 

● About the dictionary (page 11-19).
Additionally, even though I/O variables are not assigned, the Unit Monitor Parameters to monitor the status are

generated automatically.

Furthermore, for each unit, a Unit Setup Parameter to change the behavior of the unit might be generated

automatically depending on the type of unit.

The set values are edited with SLP-D50 in the same manner as described for normal Parameters.

The unit configuration can be set up in any of the following two manners:

• By using the ISaGRAF I/O connection editor

• By using the [Update Unit Configuration] feature that will upload the unit configuration of the actual AHC2001

controller

Handling Precautions
In order for the setup to take effect in the controller, it is necessary to
compile and download the application program.

The following describes above two procedures in detail.

■ Setting up with ISaGRAF I/O connection editor
Refer to the description, ● About I/O connection editor and I/O
assignments (page 11-17).
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■ Setting up with [Update Unit Configuration] feature
Follow the steps below.

(1) Connect necessary units on the AHC2001 controller.  When the connection is

changed, turn OFF the power and turn it ON again to make such changes

effective.

(2) Connect the AHC2001 controller and personal computer with the cable.

(3) Set the project options according to the actual communication path.

For details,

refer to section 7-2, Setting Up the Communication Path (page 7-3).

(4) With the “Project”window active, select [Online] → [Update Unit
Configuration].

(5) After the information about unit configuration has been read, the following

dialog box will appear.  Click [OK].

>> The I/O connection information of ISaGRAF will then be updated.  After

that, the following "Update Unit Setup Values" dialog box will appear.
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(6) Update the set values of the Unit Setup Parameters with the following set

values.

• Values already set up in the project (Values before updating the unit

configuration)

• Values set up in the controller (AHC2001)

• Default Values

Handling Precautions

• When the unit configuration is set up with this feature, DI/DO units
with a description like “… (common)” are assigned on the I/O
connection editor since the details other than I/O points of DI/DO units
cannot be recognized.  This does not hinder the software
development.  However, when formal unit types are needed for
recording, actually used DI/DO units must be substituted for such
units using the I/O connection editor.

• There may be some units having only either the Unit Setup
Parameters or Unit Monitor Parameters.
In the project window tree view, the label name becomes “[n] Unit
Parameter name”.  (n == unit address == slot No. on I/O connection
editor)

• When restoring the Unit Setup values from the previous values of the
project or from the values in the controller, values of a unit is set with
the values of the corresponding unit that has the same sequence No.
among units of the same unit type in each configuration.
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25  -  2 PLC Link Support Feature

This PLC link support feature is a special feature that functions as the edit support feature when the Parameter type

is [PLC Link Basic Setup] or [Discrete Device Setup].  This PLC link support feature cannot be used with other

Parameter types.

■ PLC link format verification

• Open the instance body tab with the Parameter type set at [PLC Link Basic
Setup] or [Discrete Device Setup].  Right-click [PLC Link] → [Check
Syntax] on this grid to activate it.

• The verification on all of PLC Link Setup and Discrete Device Setup is then

started.  The verification results are shown in the [PLC Link Syntax check]
dialog box.

Handling Precautions

• PLC Link Check Syntax cannot be run when the display data is the
online data.

• This verification is not run automatically.  Verification should be done
prior to download the application.

• Even though no errors are found as a result of this verification, an
error may occur in the PLC link during operation.  The cause of this
symptom is that actually connected units and effective address range
are not known correctly at the time of verification.

25-5
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Chapter 26. PATTERN FB SUPPORT FACILITY

In addition to the SP pattern producing capability using the Pattern Wizard, new pattern producing capability using

the pattern FBs is also provided.  Use of this new feature makes it possible to perform the more complicated

controls compared to the Pattern Wizard.  Pattern generation using the pattern FBs support various functionalities,

such as generation of multiple patterns, synchronization, recovery operation in case of power failure, and high-

speed pattern producing, which are not provided in the Pattern Wizard.

For details, 

refer to Module Type Controller DMC50/AHC2001 User's Manual "Application Developer's Guide",
CP-SP-1134E.

This chapter describes the pattern FB support facility of SLP-D50.
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26  -  1 Overview of Pattern FBs Associated  Parameters
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For the pattern controls using the pattern FBs, a series of changes in SP is called "pattern", like the temperature

profile.

In addition, each step of the SP change in one pattern is called "segment".

Associated with the above concepts, three kinds of Parameters are provided for the pattern controls using the

pattern FBs, as "Pattern Setup", "Segment Setup", and "Pattern FB Monitor".

● Pattern Setup
"Pattern Setup" is a type of Parameter to make the common setup throughout one

pattern.  One group of the "Pattern Setup" instance is the setting for one pattern;

that is, this group ID indicates the pattern No.

● Segment Setup
"Segment Setup" is a type of Parameter  to make the setup for each segment in a

pattern.  When a pattern is produced , a Parameter type named "[n] Segment

Setup" is also generated.

[n] indicates the Segment Setup for the pattern of the pattern No. "n".

Each group of the "[n] Segment Setup" instance contains the settings of each

segment.  Here, the group ID represents the segment No.

Handling Precautions
The size of the "Segment Setup" may vary depending on the number
of events to be set.  
Particularly, if the number of segments to be used is estimated large,
the memory on the controller can be utilized efficiently by reducing the
number of unnecessary events.

● Pattern FB Monitor
The operation status of the pattern FB is output to the "Pattern FB Monitor" at real

time.

As in the way  the group ID of a group of "PID_A Monitor" is supplied to "PID_A

FB" as an argument, the group ID of a group of  "Pattern FB Monitor" is used as

an argument to call to a pattern FB.
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26  -  2 Preparing for the Pattern Controls

To operate the pattern controls using the pattern FBs, it is necessary to make preparations.  To do so, follow the

steps below:

(1) Open the "Project" window.

(2) Right-click → [Program Pattern] → [Prepare for Program Patterns] on the type label "Program

Pattern Parameters" in the treeview.

>> "Pattern Setup" and "Pattern FB Monitor" are generated as child nodes of "Program Pattern

Parameters".

The preparations are then completed.  Subsequently, create necessary number of patterns, segments for each

pattern, and Pattern FB Monitors to check the status of the pattern FB operations.  

For details, 

refer to section 26-3, Pattern Management Features (page 26-4).

26-3
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26  -  3 Pattern Management Features
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As the preparation for the pattern controls has been completed, you may start the procedures as described below:

■ Creating  new patterns
To create new patterns, follow the steps below:

(1) Left click to select [Pattern Setup] in the treeview of the "Project" window.

(2) Right click → [Program Pattern] → [Add Pattern].

(3) The "Add Pattern (Instance)" dialog box will appear.  Specify an instance

name, a top pattern No., the number of patterns (if you create multiple patterns

at the same time), the number of events (total number of necessary events per

pattern), and the number of segments (per pattern).
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(4) Click the [Initial Values] button.

>> The "Pattern Parameter Initial Values" dialog box will appear.

Selecting [Project] for [Source for Initial Values] allows you to set the initial

values of the Pattern Setup and the segment setting values to the initial values

of other patterns.

Set [Project Name] by specifying the name of the project that has the source

settings for the initialization.

Set [Top Patern Number] to a pattern No. of that project. Check [Pattern
Number Auto Incremented] check box  when creating multiple patterns.

If this check box is unchecked, all multiple patterns to be created are

initialized with the initial values of the pattern specified in [Top Pattern
Number] of the "Pattern Parameter Initial Values" dialog box.

On the contrary, if this check box is checked, all multiple patterns to be

created are initialized so that the pattern No. of the copy source is

automatically incremented, like j, j+1, j+2 as the pattern No. of the copy

destination is incremented as i,  i+1, i+2.

(5) When the setup has been completed, click [OK] button in the "Add Pattern

(Instance)" dialog box.

>> A "Pattern Setup" instance and "Segment Setup" instances are generated

as specified.
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■ Adding patterns
To add new patterns where some patterns have already been created, two kinds of

methods are provided as described in the following:

•   Adding patterns to an existing instance as groups

•   Adding patterns as another instance

Even though either method is used, the behaviors on the controller will be the

same.  They are different in the way of data management  in SLP-D50.

In the "Project" window, the settings of the patterns in the same instance are

shown on the same screen.

Additionally, it is also possible to insert or delete events to/from the all the

patterns in an instance, and to delete all patterns in an instance.

To handle newly adding patterns as the same block of the patterns that have

already been created, add patterns as groups.  To handle newly adding patterns as

a different block of the patterns to those that have already been created, add

patterns as an instance.

The following describes the two kinds of operating procedures:

● Adding patterns to an existing instance as groups.
(1) Open the "Instance Body" grid of the "Pattern Setup" that has already been

created.

(2) Left click any portion of the column of the pattern having the pattern No.

(group ID) where you wish to insert a pattern.

(3) Right click → [Program Pattern] → [Add Pattern] → [Before] ([After]).

(4) The "Insert/Add Pattern (Group)" dialog box will appear.  Since "Top Pattern

Number " is determined by the pattern No. you have clicked and [Before]
([After]) you have selected, specify remaining values, such as the number of

patterns, the number of events, and the number of segments.

(5) Subsequently, set the initial values in the same manner as described in the

section "Creating new patterns", and then click the [OK] button.

>> "Pattern Setup" groups and "[n] Segment Setup" instances are added as

specified.
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Handling Precautions
When patterns are added to a position before the existing patterns, the
pattern Nos. of the existing patterns of the same instance located after
the newly added patterns are shifted rightward to increase their pattern
No.s.  Additionally, if there are not enough unset pattern Nos. in the
back of the instance to accommodate added patterns, , no patterns will
be inserted.

● Adding patterns as another instance
(1) In the treeview of the "Project" window, left click to select "Pattern Setup"   in

the same manner as described for the section to create new patterns.

(2) Right click → [Program Pattern] → [Add Pattern].

(3) The "Add Pattern (Instance)" dialog box will appear.  Specify an instance

name, a top pattern number, the number of patterns (if you create multiple

patterns at the same time), the number of events (total number of necessary

events per pattern), and the number of segments (per pattern).  However,

patterns cannot be created if any pattern No. is duplicated with that of any

already created pattern.

(4) Subsequently, set the initial values in the same manner as described in the

section to create new patterns, and then click the [OK] button.

>>  "Pattern Setup" groups and "[n] Segment Setup" instances are added as

specified.

■ Deleting patterns
To delete patterns that have already been created, two kinds of methods are

provided as described in the following:

•   Deleting specified patterns  in an instance

•   Deleting patterns by specifying  an instance

The following describes the two kinds of operating procedures:

● Deleting specified patterns in an instance
(1) Open the "Instance Body" grid of the "Pattern Setup" that has already been

created.

(2) Left click any portion of the column of the pattern having the pattern No.

(group ID) you wish to delete.

(3) Right click → [Program Pattern] → [Delete Pattern].

(4) The "Delete Pattern" dialog box will appear.  Since  "Top Pattern Number" is

determined by the pattern No. you have clicked and [Before] ([After]) you

have selected, specify  the number of patterns to delete.

(5) After specifying the number of patterns, click the [OK] button.

>>  "Pattern Setup" groups and "[n] Segment Setup" instances are deleted as

specified.
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Handling Precautions
When patterns are deleted, the pattern Nos. of the existing patterns of
the same instance located after the deleted pattern are shifted leftward
to decrease their pattern No.s .  Additionally, note that this pattern
deletion method cannot be used to delete all patterns in an instance.
To do so, 

refer to the next description, ● Deleting patterns by specifying an
instance.

● Deleting patterns  by specifying an instance
(1) In the treeview of the "Project" window, left click to select an instance of the

"Pattern Setup" you wish to delete.

(2) Right click → [Program Pattern] → [Delete Pattern].

(3) A confirmation dialog box will appear.  Click [OK] button.

>>  The instance of "Pattern Setup" and the instances of "[n] Segment Setup"

are deleted as specified.

■ Adding segments
To add segments, follow the steps blow:

(1) Open the "Instance Body" grid of the "[n] Segment Setup"  where  n is a

pattern No. of an  already created pattern.

(2) Left click any portion of the column of the segment with the segment No.

(group ID) you wish to insert.

(3) Subsequently, right click → [Program Pattern] → [Add Segment] →
[Before] ([After]).
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(4) The "Insert/Add Segment" dialog box will appear.  Since [Top Segment No.]
is determined by the segment No. you have clicked and [Before] ([After]) you

have selected, specify the number of segments to be added.

(5) After that, click the [OK] button.

>>  Groups are added in the instance of  "[n] Segment Setup"  as specified.

■ Deleting segments
To delete segments, follow the steps blow:

(1) Open the "Instance Body" grid of the "[n] Segment Setup"  where n is a pattern

No. of an already  created pattern.

(2) Left click any portion of the column of the segment with the segment No.

(group ID) you wish to delete.

(3) Subsequently, right click → [Program Pattern] → [Delete Segment].

(4) The "Delete Segment" dialog box will appear.  Since  "Top Segment No." is

determined by the segment No. you have clicked and [Before] ([After]) you

have selected, specify the number of segments to be deleted.

(5) After that, click the [OK] button.

>>  Groups are deleted from the instance of "[n] Segment Setup" as specified.

Handling Precautions
The instance of "[n] Segment Setup" is not allowed to have  "0"
segments.  To delete a pattern itself, follow the steps described in the
sub-section Deleting patterns.

■ Editing a segment type
In a segment type, MIN, MAX, and Default values of SP and SP1(2) PID Group

Number, Unit and the number of digits(Disp) of real data can be changed.

Show the procedure as follows.

(1) In the treeview, left click to select the Segment Setup you wish to change the

settings.

(2) Subsequently, right click → [Program Pattern] → [Edit Segment Type].
>>  “Edit Segment Type” window will be shown.

(3) Change field values, and select [OK].
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■ Adding events
To add events to the patterns that have already been created, two kinds of methods

are provided as described in the following:

•   Adding events to a range of patterns

•   Adding events to all patterns in an instance

The following describes the two kinds of operating procedures.

● Adding events to a range of patterns
(1) Open the "Instance Body" grid of the "Pattern Setup" that has already been

created.

(2) Left click the item row of the even type (EVxx type) on the column of the top

pattern No. (group ID) in a range of patterns where xx is the event No. into

which you wish to insert events .

(3) Right click → [Program Pattern] → [Insert/Add Event] → [Before]
([After]).

(4) The "Insert/Add Event" dialog box will appear.  Since  [Top Pattern No.] is

determined by the pattern No. of the column you have left clicked first, and

[Event No.] is determined by the event No. of the row and [Before] or

([After]) you have selected, specify remaining values:  the number of patterns

and the number of events.
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(5) Click the [OK] button.

>>  The number of events you have specified will be reflected on  "Number of

Events" in the "Pattern Setup" and the event related items of the "[n]

Segment Setup" (EVxx Setup A and EVxx Setup B), under the constrains

described in the following "Handling Precaution".

Handling Precautions
• The number of events that have already been created in each pattern

is automatically reflected on the value in the item "Number of Events"
of the Pattern Setup.  If there are already set events of the same or
greater event Nos. as those to be added in a specified range of
patterns , the event Nos. of the already set such numbered events will
be shifted downward to increase their event No.s.

• If the specified event No. is not consecutive to the already set events
in each pattern of the specified pattern range, events are not added to
this pattern.  (For example, if you wish to add two events from event
No. 4 to a pattern, in which only events 1 and 2 have already been
set, the events will not be added to this pattern.)

● Adding events to all patterns in an instance
(1) In the treeview of the "Project" window, left click to select an instance of the

"Pattern Setup" you wish to add events.

(2) Right click → [Program Pattern] → [Insert/Add Event].

(3) The " Insert/Add Event " dialog box will appear.  The top pattern No. of this

instance and the number of instances are automatically assigned to "Top

Pattern number" and "Number of Patterns", respectively.  The first unset event

No. in the top pattern of the instance is also automatically assigned  to "Event

No.".  Therefore, specify "Number of Events".
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(4) Click the [OK] button.

>>  The number of events you have specified will reflect on "Number of

Events" in the "Pattern Setup" ,and items of "EVxx Threshold A" and

"EVxx Threshold B" in the "[n] Segment Setup"  where xx are event Nos.,

under the constraints described in the following "Handling Precaution".

Handling Precautions
• The number of events that have already been created in each pattern

is automatically reflected on the value in the "Number of Events" field
of the Pattern Setup.  If there are already set events of the same or
greater event Nos. as those to be added in a specified range of
patterns, the event Nos. of the already set such numbered events will
be shifted downward to increase their event No.s.

• If the specified event No. is not consecutive to the already set events
in each pattern of the specified pattern range, events are not added to
this pattern. (For example, if you wish to add two events from event
No. 4 to a pattern, in which only events 1 and 2 have already been
set, the events will not be added to this pattern.)

■ Deleting events 
To delete events from the patterns that have already been created, two kinds of

methods are provided as described in the following:

•   Deleting events from an range of patterns

•   Deleting events from all patterns of an instance

The following describes the two kinds of operating procedures:

● Deleting events from an range of patterns
(1) Open the "Instance Body" grid of the "Pattern Setup that has already been

created.

(2) Left click the item row of the even type (Evxx type) on the column of the top

pattern No. (group ID) in a range of patterns where xx is the event No. and

you wish to delete events.

(3) Right click → [Program Pattern] → [Deleve Event].

(4) The "Delete Event" dialog box will appear.  Since  "Top Pattern No." is

determined by the pattern No. you have clicked first and "Event No." is

determined by the event No. of the row you have clicked first (this can be

changed), specify remaining values:  the number of patterns and the number of

events.

(5) Click the [OK] button.

>>  The number of events you have specified will be reflected on  "Number of

Events" in the "Pattern Setup" and items of "EVxx Setting A" and "EVxx

Setting B"  in the "[n] Segment Setup" where xx are event Nos., under the

constraints described in the following "Handling Precaution".
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Handling Precautions
• The number of events that have already been created in each pattern

is automatically reflected on the value in the "Number of Events" field
of the Pattern Setup.  If there are already set events of the same or
greater event Nos. as those to be deleted in a specified range of
patterns, the event Nos. of the already set such numbered events will
be shifted upward to decrease their event No.s.

• Events specified by the event Nos. will be deleted even though there
are unset events of the specified event Nos. in the specified range of
patterns.(For example, if you wish to delete two events from the event
No.2 where only the event No.1 and No.2 have already be set, only
the event No.2 will be deleted.) 

● Deleting events from all patterns in an instance
(1) In the treeview of the "Project" window, left click to select an instance of the

"Pattern Setup" from which you wish to delete events.

(2) Right click → [Program Pattern] → [Delete Event].

(3) The "Delete Event" dialog box will appear.   The top pattern No. of this

instance and the number of patterns are automatically assigned to "Top Pattern

Number" and "Number of Patterns", respectively.  Here, specify "Event No."

and "Number of Events".

(4) Click the [OK] button.

>>  The number of events you have specified will be reflected on  "Number of

Events" in the "Pattern Setup" and items of "EV Setting A" and "EV

Setting B" in the "[n] Segment Setup" where xx are event Nos., under the

constraints described in the following "Handling Precaution".

Handling Precautions
• The number of events that have already been created in each pattern

is automatically reflected on the value in the "Number of Events" field
of the Pattern Setup.  If there are already set events of the same or
greater event Nos. as those to be deleted in a specified range of
patterns, the event Nos. of the already set such numbered events will
be shifted upward to decrease their event No.s.

• Events specified by the event Nos. will be deleted even though there
are unset events of the specified event Nos. in the specified range of
patterns. (For example, if you wish to delete two events from the
event No.2 where only the event No.1 and No.2 have already be set,
only the event No.2 will be deleted.)

Chapter 26. PATTERN FB SUPPORT FACILITY



26  -  4 Pattern Graph
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You can set up the SP changes in the Segment Setup, viewing them graphically by activating the pattern graph. 

■ Activating the pattern graph
To activate the pattern graph, follow the steps below:

(1) Open the "Instance Body" grid of "[n] Segment Setup"; that is, the segment

setup for pattern No. n.

(2) Right click → [Program Pattern] → [Show Graph] on the instance body

grid.

>>  The pattern graph for the specified Segment Setup will be activated.

■ Displaying a graph
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For SP1 and SP2 of the specified Segment Setup (hereafter referred to as "[n]

Segment Setup") in the pattern graph, the X-axis is used for the segment No. and

the Y-axis is used for the SP value to display a graph.

When the "[n] Segment Setup" instance is displayed in the offline mode, the

offline values are shown; when online mode, the online values are shown.

The display update timing is when a value is written to any cell of the "[n]

Segment Setup" instance or when the displayed instance grid is switched to the

"[n] Segment Setup" instance.

■ Setting up the options
The following describes the display options you can set for the pattern graph:

Handling Precautions
Modifications to option settings take effect by clicking [OK] in the
"Pattern Graph Options" dialog box.

• The changed option setting values are automatically used next time
editing the Segment Setup of the same pattern No..

● Axis Selection
When displaying the SP value, you may specify the left or right axis for the Y-

axis.  The axes are set individually for SP1 and SP2.  Additionally, the [Show]
check box sets whether or not the graph is displayed.  The [Marker] check box sets

whether or not the marker is displayed.

The marker display format is : segment No. (total elapsed time, SP value).
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● Axis Setup (X-Axis)
You may specify a segment No. range to be displayed.  When the [Auto] radio

button is selected, all the segments are displayed.

When the [Manual] radio button is selected, the segment range to be displayed is

determined by the specified lower limit and the number of segments.

When the [Auto (Position Only)] radio button is selected and only the number of

segments are specified, an area is displayed so that the cell a value is just written

in is at the center and the number of segments displayed is as specified.

● Axis Setup(Y-Axis Left,Right) 
You may specify a SP value display range.  When the [Manual] check box is not

checked, the display range is determined automatically.

When the [Manual] check box is checked, the range specified by the upper and

lower limits is displayed.
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Chapter 27. OFFLINE CHARTS

Offline charts enable you to view CSV files recorded by the Trend Monitor and also by the Sampling Trace

monitor. An offline chart can display up to eight series of recorded data at the same time. These data can be

collected from multiple CSV files.

Handling Precautions
If any modifications are made to recorded CSV files, these CSV files may
not be correctly imported to the offline chart. DO NOT APPLY ANY
MODIFICATIONS to recorded CSV files if you consider importing them into
the offline chart.
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27  -  1 Activating an Offline Chart Window
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Chapter 27. OFFLINE CHARTS

On the SLP-D50 main window, select [Project] → [Offline Chart Display] to activate an "Offline Chart"
window.

>> An offline chart window is displayed as bellow (Appearance is almost the same as the Trend Monitor

window):



27  -  2 Importing Time Series Data from CSV Files
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■ Importing time series data from a CSV file
One or more series of data from a CSV file to be drawn on the offline chart can be

imported with the following steps:

(1) Select [Offline] → [Import] on the offline chart window.

>> The "Select CSV file for import" dialog box appears.

Note
If there are any already imported data in the offline chart, these data

descriptions have been displayed in the associated series rows in the "Chart"

grid on the right part of the import dialog box.

(2) Select a CSV file where one or more time series data have been recorded by

Trend Monitor or Sampling Trace Wizard.

>> The "Select CHs for import" dialog box appears.

(3) Select one or more time series data (displayed as CH) from the "CSV file"

grid in the left part of the dialog box. Do this by checking the "Import" check

box for each channel. In the "CSV file" grid, you can also change the series

No. of chart  to which series each channel data is destined. 

(4) Click the [>>] button centered in the import dialog box.

>> "Chart" grid in the import dialog box shows what data will be assigned to

each series of the offline chart. "*" mark in the "Imported" column

indicates whether new data is destined to the associated series in the

current import session.

Handling Precautions
If there exist channels of data destined to series where data already
exist, the backgrounds of such series rows are displayed in red for
warning.
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(5) Edit the name of each series in the "Chart" grid when the name is duplicated

or whatever reasons exist. This modification is also allowed for already

existing series names.

(6) Edit the min. time of each series in the "Chart column" if you wish to set the

start time of this series data to 0 or whatever time value, considering relation

with the other series data.

(7) Click the [OK] button if you confirm the changes to be made, or click the

[Cancel] button to restart from the beginning.

(8) If there exists a trend option file associated with to the CSV file, the

confirmation dialog box appears to let you decide whether to overwrite the

current trend options with the settings in the file.

>> Desired channels are actually imported to the specified chart series, and

the import dialog box is automatically closed. It may take a while when

you tried to import large time series data.

(9) Click check boxes for series you wish to view on the offline chart window.

Note
Refer to 27-4 Setting Options to change the appearance of the

display (page 27-6).

■ Importing time series data from multiple CSV files
Repeat the import session for one CSV file as described above for the number of

necessary CSV files.
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27  -  3 Setting Up Options
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You can set up the display options for the offline chart. These options are the same as the ones in the "Trend

Options" window for the trend monitor with some limitations. To open the display options window for the offline

chart, select [Options] → [Detailed Options] on the offline chart window.

■ Options that cannot be selected
Mainly online related options cannot be selected : Update Time, Samples/File,

Write to CSV file, Selections of series data.

■ Options that can be selected but give limited effects
Offset, Scaling are only applied when each series data is imported from a file.

Note
For details about the display options, 

refer to 21-2 Setting Up the Trend Options (page 21-4).



27  -  4 Time Shifting
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Each series data can be time shifted forward or backward by the following steps.

Handling Precautions
To operate this feature correctly, time format of your Windows must set to
H:mm:ss or HH:mm:ss. "Time format" setting should be found in the
"Regional Options" in the "Control Panel" of your Windows.

(1) Select [Offline] → [Time Shift] on the offline chart window, or right click → [Time shift] on the series data

legend on the right part of the offline chart window.

>>  The "Time Shift" dialog box appears

(2) Select a series data to which time shifting will be applied.

(3) Select the time shift direction "+" or "-".

(4) Set the amount of time shift in the time edit box. 

Note
Here the time format is "hh:mm:ss", and the hours, mins, seconds are seperately

set. Click on each time unit number and click the spin button to increase or

decrease the number.

(5) Click [OK] button to complete the changes, or click [Cancel] button to cancel the changes.

Handling Precautions
If a part of a time series shifted backward reaches below 0, such part is
automatically deleted.
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27  -  5 Narrowing the Time Span

The time span for each data can be narrowed to a specified time region. This operation can be done for multiple

series of data at once as in the following steps:

(1) Choose one or more series you wish to narrow their time span by checking the check boxes of those series and

unchecking the check boxes of other series on the offline chart window.

(2) Specify the time region in the manner of zooming to a region.

Note
Here, the vertical span of the region will be ignored.

(3) Select [Offline] → [Narrow Time Span] on the offline chart window, or right click → [Narrow Time Span]
on the series data legend on the right part of the offline chart window.

>>  A confirmation dialog box appears 

(4) Click [OK] button to complete the changes, or click [Cancel] button to cancel the changes. 

>>  Time series data for the selected series are limited to the specified time region. Data outside this region are

deleted.
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27  -  6 Editing Comments
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You can write down comments for the current chart. Comments are displayed in the lower part of the window.  If

the chart is saved to a file, written comments are also saved in a associated file, and can be reread when the

associated CSV file is imported later. The steps to write down comments are as follows:

(1) Select [Offline] → [Edit Comment] in the offline chart window, or right click → [Edit Comment] on the

series data legend on the right part of the offline chart window.

>>  The "Edit Comment" dialog box appears

(2) Write down comments, and click [OK] button for the modifications to take effect, or click [Cancel] button to

cancel the modifications.

Handling Precautions
Comments modified will not be saved to a file until the "Saving Chart"
operation is performed. For details about "Saving Chart" , 

refer to section 27-7, Saving the Chart (page 27-9).
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27  -  7 Saving the Chart

To save the current chart, follow the steps below:

(1) Select [Offline] → [Save].
>>  The "Save As" dialog box appears.

(2) Select any existing CSV file or specify a new name in the "File name" edit field.

(3) Click [OK] button.

>>  The current chart is saved to a file, as well as the comments and trend options are saved to the associated

files, respectively. 

Handling Precautions
If there exists a file of the same name, a confirmation dialog box appears.

Note
Comments and trend options saved in files will be reread when the associated CSV

file is imported to the offline chart later.
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Chapter 28. OTHER FEATURES
28  -  1 Error Output Window

This window is invisible with the default settings.  If an error is detected such as in the group monitor consistency

checking or when online monitoring, relevant message will be output.

• Select [Window] → [Show/Hide Error Output Window] to change the display status.

• The contents of the "error output" window can be saved as a text file when selecting [File] → [Save] with the

window active.
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28  -  2 Stopping All Monitoring Operations

28-2

When performing monitoring operations in multiple windows of SLP-D50, select [Global Options] → [Stop All
Monitorings] to stop all monitoring operations completely.

However, note that monitoring operations by the ISaGRAF debugger cannot be stopped.
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28  -  3 Active Communication Paths

All the communication paths currently being connected from SLP-D50 are shown.  From the [Global Options]
menu, move the mouse pointer to [Active Communication Paths].  The list of communication paths currently

being connected will be shown.  Additionally, when selecting each communication path as menu item, you may

make the communication monitor displayed, not displayed, or disconnected.

Handling Precautions
SLP-D50 tries to keep a communication path until SLP-D50 exits once the
connection is established.  To allow another application to use the
communication path occupied by SLP-D50, select the relevant menu item
for the communication path to display a dialog box and click the [Close
Connection] button.
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28  -  4 User Level

28-4

With the default settings, the operation is performed at user level "0".  Some special Parameters cannot be

displayed and modified unless the user level is changed to "1".

For details,

refer to Module Type Controller DMC50 User's Manual "Installation and Configuration", CP-SP-
1139E, Module Type Controller AHC2001 User's Manual "Basic Operation", CP-SP-1137E and Module
Type Controller DMC50/AHC2001 User's Manual "Function Block Reference", CP-SP-1130E.

■ Changing the user level
• If nothing other than the error output window is displayed in the SLP-D50

main window, select [Global Options] → [Change User Level] to display the

"User Level Authentication" window.

• Change the user level to a desired level and click [OK] button.

(No passwords are specified for the user level "0" (operator level) and user level

"1" (engineer level).)

■ Checking the user level
In the SLP-D50 main window, select [Global Options] → [Change User
Level] to display the " User Level Authentication " window.

(If a window other than the error output window is opened in the main window,

the user level cannot be changed.)
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28  -  5 Selecting a Database

This is used when SLP-D50 is used specially.

With the default settings, “slpd50v22_e” (database for SLP-D50 v2.2) is specified in SLP-D50J50, and

slph21v22_e (database for SLP-H21 v2.2) is specified in SLP-H21J50.  Normally, it is not necessary to change

the database.
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28  -  6 Operators Edition

28-6

SLP-D50 operators edition is another installation of SLP-D50.  This can be installed by exiting installation prior

to install ISaGRAF Yamatake patch during the installation of SLP-D50.  The operators edition only supports

subset features of the SLP-D50 standard edition, where ISaGRAF is not required. 

The features that are not available by the operators edition are listed below:

• Activating the ISaGRAF project management window

• Compiling projects

• Activating the ISaGRAF program management window 

• Editing variables (Monitoring of variables can be done if the project  is already compiled and downloaded)

• Activating Pattern Wizard

• Setting of Sampling Trace Wizard (Online features are available)

• Setting of Integer Conversion Wizard

• Updating the unit configuration (in the case of AHC2001)

Chapter 28. OTHER FEATURES



Chapter 29. CAUTIONS

● An error occurs when copying a project using Explorer.
When copying a project using Explorer, an error message, [Unable to copy
XXXX~1.  File exists.], may appear.  If this occurs, copy the project again.

This occurs if files of a long file name and its short name with tilda  both exist.

This results from creating a long name file the same as the original long file name

after the project is copied, or archived by ISaGRAF where long name files have

been converted into short name files.

● Asynchronous socket error (case 1) 
The message [Asynchronous socket error] may appear while online transactions

are performed from SLP-D50 through TCP/IP, resulting from the sequential

occurrences of the following events: the power to the COM module is turned OFF

and ON, and then the online operation is restarted.

SLP-D50 tries to keep the TCP/IP connection that has been established once until

SLP-D50 exits or the connection is disconnected explicitly.

On the other hand, when the COM module is restarted, the previous connection is

not retained.  Therefore, if an actual access is made to the restarted COM module,

this error occurs.

When issuing online transaction again after this error occurs, SLP-D50
automatically attempts to connect again.

● Asynchronous socket error (case 2) 
If DMC50/AHC2001 operates normally, but the halfway of communication path

is disconnected or unstable when the online transactions are performed through

TCP/IP from SLP-D50, the error message [Asynchronous socket error] may

appear.

This error results from that Windows disconnects the communication line after it

retries the TCP/IP connection appropriate times but still gets no response.

In this case, the DMC50/AHC2001 does not recognize the disconnection and tries

to keep the connection for a period of time specified in "KeepAliveTime" (or sever

timeout of ENI setting in AHC2001).  Therefore, the access to the same IP port

cannot be made during this period.

The number of retry times by Windows can be changed by adding a value named

"MaxDataRetries" to the key "MSTCP in the Windows registry.

Even though the default value is "5", enter around 64.  For details, refer to

Microsoft's web site.

● Power control of PC (Power saving feature) 
If "Turn off monitor" is specified in the power control (power saving ) feature of

your PC and the time reaches the specified time during monitoring with SLP-D50,

this may cause incorrect operation.

To prevent such troubles, the "Turn off monitor" setting must be made inactive

during monitoring.
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● Infrared device
If any infrared device driver is installed in your PC and [Enable Infrared
Communication] is selected, this may cause incorrect operation during

monitoring using SLP-D50.

To prevent such troubles, the infrared communication must be made inactive

during monitoring.

● Data types used in SLP-D50/ISaGRAF
ISaGRAF utilizes BOOL (boolean type), DINT (representation in ISaGRAF is

integer type.  However, the actual type is double-precision integer type = 32-bit

integer), REAL (real-number type = 32-bit floating decimal point value in

conformity with IEEE754), TIME (timer type), and STRING (variable length

character string type) out of the data types specified in IEC61131-3.  SLP-D50
utilizes BOOL, DINT, REAL, INT (integer type = 16-bit integer), DWORD

(double-word type), and TIME type.  However, there are some limitations about

the utilization of types in  individual SLP-D50 features.  For details, refer to the

description of each feature.

The INT type is used only for the Parameter element, which is represented  in a

range of 16-bit integer value.  This data type is implemented on DMC50 as the

DINT type.

Therefore, INT type used in SLP-D50/AHC2001 is referred as "DINT" in

Module Type Controller DMC50 User's Manual "Function Block
Reference", CP-SP-1130E.

● Office XP and ISaGRAF
ISaGRAF may not run properly on the PC where the office XP is installed. Known

symptom is closing time of a window gets slow down to several tens of seconds. If

this is the case, please uninstall the office XP from the PC.

● Unclear points and questions about use of ISaGRAF
If any question about the programming using ISaGRAF arises, 

refer to ISaGRAF Version 3.5 USER'S GUIDE .  
However, if your question still cannot be solved, contact Yamatake's person in

charge.
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