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Ethernet® is a registered trademark of Xerox Corp.
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DMC50 and SLP-D50 are the trademarks of Yamatake Corporation.
Other company names and product names listed in this manual are registered
trademarks or trademarks of respective companies.
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Ensure that this User's Manual is handed over to the user before the
product is used.

Copying or duplicating this User's Manual in part or in whole is forbid-
den.  The information and specifications in this User's Manual are sub-
ject to change without notice.

Considerable effort has been made to ensure that this User's Manual is
free from inaccuracies and omissions.

If you should find any inaccuracies or omissions, please contact
Yamatake Corporation.

In no event is Yamatake Corporation liable to anyone for any indirect,
special or consequential damages as a result of using this product.

REQUEST

This product has been designed, developed and manufactured for general-purpose
application in machinery and equipment. Accordingly, when used in applications
outlined below, special care should be taken to implement a fail-safe and/or redundant
design concept as well as a periodic maintenance program.

• Safety devices for plant worker protection
• Start/stop control devices for transportation and material handling machines
• Aeronautical/aerospace machines
• Control devices for nuclear reactors

Never use this product in applications where human safety may be put at risk.

RESTRICTIONS ON USE



The Role of This Manual

i

Seven different manuals in total are available for DMC50. Read each manual according to your specific

requirements. Following is a brief outline of each of the manuals.

To obtain manuals, contact Yamatake Corporation or your Yamatake dealer.

Module Type Controller DMC50 User's Manual "QuickStart"
Manual No. CP-SP-1092E

This manual.

The user who operates DMC50 for the first time must read this manual
thoroughly.  This manual is intended to help the user understand the
overview of the controller operation and basic operating procedures.

The manual describes the operation with various examples.  Read this
manual while using the smart loader package.

Module Type Controller DMC50 User's Manual "Installation and 
Configuration" Manual No. CP-SP-1139E

Thoroughly read this manual before designing or manufacturing the
equipment hardware using DMC50.

This manual consists of two parts, one for the control module and the other
for the communication module. It describes the installation, wiring,
specifications, and hardware troubleshooting of those controller.

Module Type Controller DMC50 User's Manual "Communications
Connection" Manual No. CP-SP-1093E

The user who uses the communication facilities of DMC50 must read this
manual thoroughly.  This manual describes the communication facilities of
this controller, such as CPL communication and Ethernet communication.

Module Type Controller DMC50 User's Manual "Function Block
Reference" Manual No. CP-SP-1130E

Read this manual when the user designs a control system most suitable for
the user's application by utilizing DMC50.

This manual describes the specifications of ISaGRAF functions and
function blocks essential to design a desired control system.

Module Type Controller DMC50 User's Manual " Application
Developer's Guide" Manual No. CP-SP-1134E

This manual describes how to write practical application programs for the
DMC50. The person in charge of programming is encouraged to read this
manual thoroughly.

This manual describes the pattern function blocks, utilization of ISaGRAF,
and application examples.

This manual is intended for the user who has already read the separate
manual "QuickStart" and "Function Block Reference" thoroughly to fully
understand their contents.



ii

SLP-D50J50 Installation Guide Manual No. CP-UM-5259E

This manual describes how to install the smart loader package SLP-D50 for
the DMC50 into a personal computer.

Smart Loader Package SLP-D50 for Module Type Controller DMC50
User's Manual Manual No. CP-SP-1122E

This manual describes the operations and features of the smart loader
package SLP-D50 for DMC50 as well as its installation into a personal
computer. It also writes about important points collaborating with  ISaGRAF
to build an application for the controller.



This manual is organized as follows:

Chapter 1. INTRODUCTION
This chapter describes the relationship between DMC50 and SLP-D50 and the

preparations you must make before working on exercises.

Chapter 2. MAKING A SIMPLE TEMPERATURE CONTROLLER
This chapter describes basic operating procedures using an example, "Making a

simple temperature controller".

Chapter 3. ADDING CAPABILITIES TO THE TEMPERATURE CONTROLLER
This chapter describes how to add capabilities to the temperature controller made

in Chapter 2.

Chapter 4. ADVANCED OPERATION
This chapter gives you a brief summary of advanced features provided by SLP-
D50.

Organization of This User's Manual

iii



Contents

iv

The Role of This Manual
Organization of This User's Manual
Conventions Used in This Manual

Chapter 1. INTRODUCTION

1-1 Relationship between DMC50 and SLP-D50 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 1-2
1-2 Preparations • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 1-3

■ Preparing ISaGRAF and SLP-D50 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 1-3
■ Preparing a CTRL module• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 1-3
■ Setting up a module address • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 1-3

Chapter 2. MAKING A SIMPLE TEMPERATURE CONTROLLER

2-1 Determining the Specifications of the Temperature Controller • • • • • • • • • • • • 2-2
2-2 Creating a New Project • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-3

■ Invoking SLP-D50 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-3
■ Creating a new project • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-4
■ Setting up communication • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-6

2-3 Setting up the System Parameters• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-7
■ AI Setup (Analog input setup) • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-7
■ AO Setup (Analog output setup) • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-8
■ DI Setup (Digital input setup) • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-8
■ DO Setup (Digital output setup) • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-9

2-4 Setting up the Calculation Parameters • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-10
■ PID_A Options • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-10
■ PID_A Constants• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-11

2-5 Downloading and Monitoring the AI Setup Parameters • • • • • • • • • • • • • • • • • • • 2-12
■ Connecting the loader cable • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-12
■ Downloading the AI Setup Parameters • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-12
■ Online data of Parameters • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-12
■ Monitoring the AI status • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-12
■ Trend monitoring of the AI Status • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-14

2-6 Adding ISaGRAF Variables • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-15
■ Activating ISaGRAF• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-15
■ ISaGRAF variables to add • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-15
■ Activating the dictionary editor • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-16
■ Adding integer/real-type variables using the dictionary editor• • • • • • • • 2-16
■ Adding timer-type variables using the dictionary editor • • • • • • • • • • • • • • 2-17
■ Exiting the dictionary editor • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-18

2-7 Editing ISaGRAF Programs • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-19
■ Starting to write a program in the FBD editor • • • • • • • • • • • • • • • • • • • • • • • • • 2-19
■ Placing an FB box • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-19
■ Placing a variable box • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-20
■ Connecting the boxes • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-21
■ Saving the program • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-22



v

■ Verifying the program• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-22
■ Exiting the FBD editor • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-24
■ Creating another program • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-24
■ Editing the alarm output in the FBD editor program • • • • • • • • • • • • • • • • • • 2-25
■ Verifying the alarm output program• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-25

2-8 Generating an Application Code• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-26
■ Setting up the compiler options • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-26
■ Setting up the run-time options • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-26
■ Generating an application code• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-27

2-9 Downloading and Monitoring the Application • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-29
■ Downloading the application • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-29
■ Creating a new group monitor • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-29
■ Starting and stopping the group monitor • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 2-31
■ Activating the trend monitor form the group monitor • • • • • • • • • • • • • • • • • 2-32

Chapter 3. ADDING CAPABILITIES TO THE TEMPERATURE CONTROLLER

3-1 Adding an Eight Input SP(Set Point) Selector• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 3-2
3-2 Adding a PID Selector Based on an Analog Input• • • • • • • • • • • • • • • • • • • • • • • • • • 3-3
3-3 Adding a Manual Output Selector• • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 3-4

Chapter 4. ADVANCED OPERATION

■ Sampling Trace Wizard • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 4-1
■ Integer Conversion Wizard • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 4-1
■ Pattern Wizard • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • 4-1

Index



Conventions Used in This Manual
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The following conventions are used in this manual:

Handling Precaution
: Handling Precautions indicate items that the user should pay attention to

when handling the DMC50.

Note : Notes indicate useful information that the user might benefit by knowing.

(1), (2), (3) : The numbers with the parenthesis indicate steps in a sequence or
indicate corresponding parts in an explanation.

[Open] button : Indicates a selection button in screens displayed on the personal
computer.

[File] : Indicates messages and menus displayed on the personal computer.
[Monitor]
[Save]

[Tab] key, [F4] key : Indicates keys on the keyboard.

[Ctrl] + [X] key : Indicates the operation of pressing the [X] key with the [Ctrl] key on the
keyboard held down.

Ethernet® : This is shown as "Ethernet" in the context of the manual.

: This indicates the user's manual or the item that the user is requested to
refer to.



Chapter 1. INTRODUCTION

This manual, "QuickStart", is intended to help novice users, who use the module type controller DMC50 and

smart loader package SLP-D50 for the first time, understand the basic operating procedures. It is recommended to

use DMC50 and SLP-D50 actually while reading this manual, "QuickStart".

For details about operations, refer to relevant User's manuals.

In addition to this User's manual, the following User's manuals are provided:

• Module Type Controller DMC50 User's Manual "Installation and Configuration"

• Module Type Controller DMC50 User's Manual "Communications Connection"

• Module Type Controller DMC50 User's Manual "Function Block Reference"

• Module Type Controller DMC50 User's Manual "Application Developer's Guide"

• Smart Loader Package SLP-D50 for Module Type Controller DMC50 User's Manual 

• SLP-D50J50 Installation Guide

Each User's manual documented in PDF format is included in the CD-ROM supplied with the SLP-D50 package.

Additionally, ISaGRAF Version 3.4 USER'S GUIDE is also provided as an instruction manual for ISaGRAF.

When installing the ISaGRAF, select [ISaGRAF Documentation] to copy a document file in PDF format onto the

hard disk.

DMC50 provides two kinds of module: Control module for control and Communication module for

communication. This manual mainly describes the control module.

For details about communication module and communication, refer to the manual, 

"Communications Connection".

Hereafter, the control module is abbreviated to CTRL module and the communication module is abbreviated to

COM module in this manual.

1-1



1  -  1 Relationship between DMC50 and SLP-D50

1-2

A group of data for one DMC50 module is called "project".

The project of the CTRL module includes Parameters and programs. The project of the COM module includes

Parameters.

SLP-D50 is a software tool that manages projects. Use of SLP-D50 makes it possible to set Parameters and view

Monitor Parameters of DMC50.

ISaGRAF is a software tool that manages programs for the CTRL module.

ISaGRAF can be activated from SLP-D50. With ISaGRAF, you can edit and compile application programs, can

download one to the CTRL module, and can monitor the application  running on the CTRL module.

Note

For details about project, Parameter, program, and application,

refer to Terms used in this manual of Smart Loader Package SLP-D50
for Module Type Controller DMC50 User's Manual, CP-SP-1122E.

Chapter 1. INTRODUCTION



■ Preparing ISaGRAF and SLP-D50
Before working on  exercises given in this manual, install ISaGRAF and SLP-
D50 in your personal computer.

Note

For details about how to install the ISaGRAF and SLP-D50,

refer to Chapter 2 Installing SLP-D50/ISaGRAF of Smart Loader
Package SLP-D50 for Module Type Controller DMC50 User's Manual, CP-
SP-1122E.

■ Preparing a CTRL module
Use of an actual CTRL module hardware makes it possible to view the actual

monitor data and to set up Parameters in the online mode using SLP-D50.

Additionally, it is also possible to download applications, which you will build

with SLP-D50, into the CTRL module, and to monitor the operating status of the

application.

Note

For details about model No.s, installation, and wiring of the DMC50,

refer to Module Type Controller DMC50 User's Manual "Installation and
Configuration", CP-SP-1139E.

■ Setting up a module address
If you have a CTRL module, set relevant module address.

The module address is determined by the rotary switch when the power is turned

ON.

Turn OFF the power to the CTRL module, set the arrow mark of the rotary switch

to a position other than "0", and then turn ON the power again.

Handling Precaution

• Even though you change the rotary switch position while the power to the
module is ON, the active module address is not changed.

• When the module address is set at "0", the ISaGRAF application will not
start.

1  -  2 Preparations

1-3
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First, make a simple temperature controller.

You will follow the steps below to make a simple temperature controller:

2-1

Determine the specifications of the�
temperature controller.

Project already exists.

If you have a CTRL module available,�

If you have a CTRL module available,�

Invoke� SLP-D50.

Create a new project.

Set up the System Parameters and�
Calculation Parameters.

Open the project.

Download the AI setup Parameters.

Monitor the analog input status.�

Activate ISaGRAF.

Add ISaGRAF variables.

Generate an application code.

Exit ISaGRAF and SLP-D50.

Write programs for the PID control�
and alarm output using ISaGRAF.

Download the application.

Monitor the operating status of the�
application.

Chapter 2. MAKING A SIMPLE TEMPER-
ATURE CONTROLLER



2  -  1 Determining the Specifications of the
Temperature Controller

2-2

To make the specifications as simple as possible, the specifications are determined as follows:

Chapter 2. MAKING A SIMPLE TEMPERATURE CONTROLLER

Item Module address

Number of analog inputs 1 point

Type/Range of analog input 1 Linear 0 to 5V / 0 to 1200˚C

Number of analog outputs 1 point

Purpose of analog output 1 Control output

Type of analog output 1 Time proportional output

Time-proportioning cycle time 2 sec.
of analog output 1

Number of digital inputs 2 points

Purpose of digital input 1 AUTO/MANUAL transfer.
With ON, changes the control mode to
MANUAL.
With OFF, changes the control mode to AUTO.

Purpose of digital input 2 AT (auto-tuning) start and stop
Starts AT at the rising edge of this input.
Stops AT at the falling edge of this input.

Number of digital outputs 1 point

Purpose of digital output 1 Alarm outputs; upper limit alarm of analog input
(hysteresis and on-delay are provided.)

Number of set points 1

Number of PID groups and 1 group
alarm outputs

Control calculation PID_A calculation (Standard PID calculation)

Control action Reverse action

Project name "simple"



2  -  2 Creating a New Project

■ Invoking SLP-D50
From the [Start] menu of Windows, select [Programs] → [SLP] →
[SLP-D50(DMC50)]. SLP-D50 will start.

The SLP-D50 main window will appear.

2-3
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■ Creating a new project

Select [Project] → [New Project].
The "Project Group" dialog box will appear.

Click the [Dmc50] directory, and then click [OK]. The "Project Group" dialog

box will be closed, and then the "Project Definition" dialog box will appear.

Handling Precaution

If [Dmc50] cannot be found in the "Project Group" dialog box, click [Cancel]
to close the "Project Group" dialog box, and then set up the ISaGRAF
directory and project group directory.
For details about how to set up these directories,

refer to 3-2 Making Initial Setup of Smart Loader Package SLP-D50 for
Module Type Controller DMC50 User's Manual, CP-SP-1122E.

In this example, type "simple" in [Project Name]. To set [Module Type], click [▼]

at the right end of the field.

The list of module types will appear.

If you have a CTRL module available, select the same type as that of the CTRL

module.

If you do not have an CTRL module available, select [CH400].
Click [OK]. The "Project Definition" dialog box will be closed, and then a new

project will be created as specified.

Chapter 2. MAKING A SIMPLE TEMPERATURE CONTROLLER



It takes a while until the project creation is completed. When the project creation is

completed, the treeview will be shown in the left portion of the "Project" window.

Note

• For details about how to create a new project,

refer to Chapter 5 CREATING NEW PROJECTS of Smart Loader
Package SLP-D50 for Module Type Controller DMC50 User's Manual,
CP-SP-1122E.

• In the treeview,  +  or  -  shown on the left of type labels indicates the display

status of treeview layer.

+  indicates that other type labels are hidden under the displayed type label.

When clicking  + , the hidden type labels will be shown. On the contrary, when

clicking -  , the type labels of the lower layer will be hidden.

The lowest layer consists of instances. Click an instance name, and then click the

[Instance body] tab in the right portion of the window. A table of Parameter

element values will appear in the right portion of the window.

Handling Precaution

SLP-D50 screen shots used in the following descriptions are those with the
module type set at CH400:
Note that the actual appearances may vary depending on the module type.

2-5

Chapter 2. MAKING A SIMPLE TEMPERATURE CONTROLLER



2-6

■ Setting up communication
Select [Options] → [Project Options]. The "Project Options" dialog box will

appear.

Set [Module Address] to the decimal value the same as the rotary switch position

number of the CTRL module. Notice that, the rotary switch can have "A" to "F" in

hexadecimal notation. These values correspond to values ranging from "10" to

"15" for [Module Address].
Adjust the settings in [Communication Path] and [Property] to the real

connection configuration of the SLP-D50 and CTRL module. In this example,

connect the special loader cable supplied with the SLP-D50 package to the serial

port on the personal computer where the SLP-D50 is running, and to the loader

jack on the CTRL module.

Next, select [Serial(Direct)] for [Communication Path], and then click

[Property].
The "Serial Communications Setup" dialog box will appear.

For [COM Port], select the serial port name of the personal computer, to which

the loader cable is connected.

Click [OK].
The "Serial Communications Setup" dialog box will be closed, and then the

"Project Options" dialog box will be active again.

In the "Project Options" dialog box, click [OK].
The "Project Options" dialog box will be closed, and then the "Project" window

will be active again.

Note

The following table shows the correspondences between the rotary switch and

module address:

Chapter 2. MAKING A SIMPLE TEMPERATURE CONTROLLER

Rotary switch Module address

0 to 9 Same as rotary switch setting

A 10

B 11

C 12

D 13

E 14

F 15



2  -  3 Setting up the System Parameters

The System Parameters sets up the hardware input and output settings of the CTRL module.

In the treeview, click  +  on the left of [System Parameters] to show the type labels, such as [AI Setup] and 

[AO Setup].

Note

For details about how to set up the Parameters,

refer to Chapter 9 EDITING PARAMETERS of Smart Loader Package
SLP-D50 for Module Type Controller DMC50 User's Manual, CP-SP-
1122E.

■ AI Setup (Analog input setup)
The specifications of this temperature controller are that the number of analog

inputs is 1 point and the type/range of analog input 1 is linear 0 to 5V / 0 to

1200˚C. Therefore, make the settings according to these specifications.

In the treeview, click  +  of [AI Setup],  +  of [AI Setup (standard inputs)], and

[Instance] in that order.

Click the [Instance body] tab in the right portion of the window. A table of

analog input settings will appear.

In this table, columns [1] to [4] correspond to analog inputs 1 to 4, respectively.

To use only analog input "1", set column [1] to "True" and set column [2] to [4] to

"False" of the [Enable Input] row.

Since only analog input "1" is used in this example, Set up the column [1] only.

To use the linear 0 to 5V, set [Input Type] to "34".

"34" is the value for linear 0 to 5V.

To set the range to 0 to 1200, enter "0.0" for [Linear Input Scale Min] and

"1200.0" for [Linear Input Scale Max].

Handling Precaution

If the CS400/200 module is used, [AI Setup (special type)] is shown
instead of [AI Setup (standard inputs)].

2-7
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■ AO Setup (Analog output setup)
The specifications of this temperature controller are that the number of analog

outputs is 1 point, the type of analog output 1 is the time proportional output, and

the time-proportioning cycle time of analog output 1 is 2 sec. Therefore, make the

settings according to these specifications. In the treeview, click  +  of [AO Setup],
+  of [AO Setup (Basic)], and [Instance] in that order. Click the [Instance
body] tab in the right portion of the window. A table of analog output settings will

appear. In this table, columns [1] to [4] correspond to analog outputs 1 to 4,

respectively.

To set analog output 1 to a time proportional output, select "3" in column [1] of the

[Output Type] row. "3" is the value for the time-proportional current output.

To set the time proportioning cycle time to "2 sec.", enter "2" (s) in column [1] of

the [Time Proportioning Cycle Time] row.

Since analog outputs 2 to 4 are not used, set columns [2] to [4] in the table as

shown below to specify "0 mA output".

Select "0" for the [Output Type] row. "0" is the value for the current proportional

output (0 to 20 mA).

Select "0" for the [Output Not in Operating Mode] row. "0" is the value for the

preset output. Enter "0.0"(%) in the [Preset Output Value] row.

Handling Precaution

There are no System Parameter settings to realize the specification
"Purpose of analog output 1: Control output". This specification is realized
by writing a program in ISaGRAF.

■ DI Setup (Digital input setup)
There are no DI Setup Parameters.

Handling Precaution

There are no System Parameter settings to realize the specification
"Number of digital inputs: 1 point" and "Purpose of digital input 1: AT (Auto-
tuning) start and stop". There specifications are realized by writing a
program in ISaGRAF.
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■ DO Setup (Digital output setup)
The specifications of this temperature controller are that the number of digital

outputs is 1 point and the purpose of digital output is the alarm output. Therefore,

make the settings according to these specifications.

In the treeview, click  +  of [DO Setup],  +  of [DO Setup (Basic)], and

[Instance] in that order. Click the [Instance body] tab in the right portion of the

screen. A table of digital output settings will appear.

In this table, columns [1] to [16] correspond to digital outputs 1 to 16, respectively.

To use digital output 1 as an alarm output instead of a time proportional output for

the control, select "0" in column [1] of the [Output Type] row. "0" is the value for

the DO output.

Since digital outputs 2 to 16 are not used, set columns [2] to [16] in the table as

shown below to turn OFF outputs. Select "0" in the [Output Type] row. "0" is the

value for normal digital output. Select "0" in the [Output Not in Operating
Mode] row. "0" is the value for preset output. Enter "False" in the [Preset Output
Value] row. "False" represents OFF output.

Handling Precaution

There are no System Parameter settings to realize the specification "Type
of digital 1: Upper limit alarm of Process Variable". This specification is
realized by writing a program in ISaGRAF.
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The Calculation Parameters are settings related to function blocks of ISaGRAF.

In the treeview, click  +  on the left of [Calculation Parameters] to show the type labels, such as [PID Setup] and

[TBL/TBR Setup].

Note

For details about how to set up the Parameters,

refer to Chapter 9 EDITING PARAMETERS of Smart Loader Package
SLP-D50 for Module Type Controller DMC50 User's Manual, CP-SP-
1122E.

■ PID_A Options
The PID_A Options are used for the calculation of the "pid_a" function block.

(Later on, in the FBD program of ISaGRAF, a group ID of the PID_A Options

will be connected to the "PARA" input parameter of the "pid_a" function block.)

The specifications of this temperature controller are that the control calculation is

PID-A calculation (standard) and the control action is reverse action.

Therefore, make the settings according to these specifications.

In the treeview, click  +  of [PID Setup],  +  of [PID_A Options], and [Instance]
in that order. Click the [Instance body] tab in the right portion of the window. 

A table of PID_A Options settings will appear. In this table, column [1]
corresponds to group ID 1.

Select "0" as the reverse action in [Control Action]. Enter "0.0" in [PV Range
Min] and "1200.0" in [PV Range Max] matching with the range of analog input 1.
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■ PID_A Constants

The PID_A Constants are used for the calculation of the "pid_a" function block.

(Later on, in the FBD program of the ISaGRAF, a group ID of the PID_A

Constants will be connected to the "PID" input Parameter of the "pid_a" function

block.)

The specifications of this temperature controller define that the number of PID

groups is 1 group. Therefore, make the settings according to these specifications.

In the treeview, click  +  of [PID Setup],  +  of [PID_A Constants], and

[Instance] in that order. Click the [Instance body] tab in the right portion of the

window. A table of PID_A Constants settings will appear. In this table, column [1]
corresponds to group ID 1.

In this example, enter "20.0" in [Proportional Band], "60.0" in [Integral Time],
and "15.0" in [Derivative Time].

Chapter 2. MAKING A SIMPLE TEMPERATURE CONTROLLER



2  -  5 Downloading and Monitoring the AI Setup
Parameters

2-12

Even though any ISaGRAF programs have not been written, start the operation with the SLPD50 connected to the

CTRL module if you have a CTRL module available.

If you do not have a CTRL module available, skip the following description and go to section 2-6 Adding
ISaGRAF variables (on page 2-15):

■ Connecting the loader cable
Connect the D-Sub 9-pin connector of the loader cable to the serial port on the

personal computer (this port is normally indicated as [IOIOI]). Connect the mini-

plug connector to the loader jack on the front of the CTRL module.

■ Downloading the AI Setup Parameters
In the treeview, click [System Parameters], [AI Setup], and [AI Setup
(standard inputs)] in that order, or click [AI Setup (special type)] and

[Instance] in that order. After that, click the [Instance body] tab in the right

portion of the window. A table of analog input settings will appear.

Select [Parameter] → [Download]. The AI Setup (standard inputs) or AI Setup

(special type) Parameters are then downloaded into the CTRL module.

■ Online data of Parameters
The Parameters, which have been set up to now, are data on the personal computer

and are called "offline data". When SLP-D50 displays the offline data, the

background color of the instance body item names becomes gray.

On the contrary, the data on DMC50 is called "online data". When SLP-D50
displays the online data, the background color of the instance body item names

becomes yellow or orange.

To switch between the offline data and online data, select [Parameter] →
[Display Mode] → [Offline] or [Online].

Handling Precaution

If any Parameter element values of the instance body are changed in the
online mode, only the online data (Parameters on DMC50) is changed and
the offline data (data on the personal computer) is not changed.

To reflect the online data values to the offline data, select [Parameter] →
[Overwrite with the Uploaded Data].

On the contrary, to reflect the offline data values to the online data, select
[Parameter] → [Download].

■ Monitoring the AI Status
In the treeview, click [System Monitor Parameters], [AI Status], and

[Instance] in that order, and then click the [Instance body] tab in the right

portion of the window. A table of analog input status will appear.

When selecting [Parameter] → [Upload], the AI Status data is updated only

once.

To update the AI Status data continuously, select [Online] → [Start Monitor].
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Since the ISaGRAF application code has not been built yet, A confirmation dialog

box will appear. If such a dialog box appears, click [OK].

The AI Status data will then be updated continuously. If connecting a voltage

generator to analog input 1 of the CTRL module, changes in AI1 data can be

monitored as the input voltage is changed.

To stop the continuous data updates, select [Online] → [Stop Monitor].

Note

For details about how to connect the analog inputs,

refer to Module Type Controller DMC50 User's Manual "Installation and
Configuration", CP-SP-1139E.
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■ Trend monitoring of the AI Status
In the treeview, click [System Monitor Parameters], [AI Status], and

[Instance] in that order, and then click the [Instance body] tab in the right

portion of the window. A table of analog input status will appear.

Select [Parameter] → [Trend Monitor]. A dialog box will appear, allowing you

to specify a trend monitor options file. Click [Cancel]. The dialog box will be

closed, and then a "Trend monitor" window will appear.

Check the [Series 1] check box.

Selecting [Online] → [Start Trend Monitor] starts the drawing of the trend

monitor. Selecting [Online] → [Stop Trend Monitor] will stop the drawing of the

trend monitor.

Selecting [Window], and then [Cascade] or [Tile(Horizontal)] will place both the

"Project" window and "trend monitor" window so specified in the SLP-D50
main window.

Note

For details about trend monitor,

refer to Chapter 21 TREND MONITOR of Smart Loader Package SLP-
D50 for Module Type Controller DMC50 User's Manual, CP-SP-1122E.
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2  -  6 Adding ISaGRAF Variables

Realize a PID control capability and an alarm output capability of the temperature controller inside the CTRL

module using the ISaGRAF programs.

Before writing the programs, activate ISaGRAF to add ISaGRAF variables.

■ Activating ISaGRAF
In the SLP-D50 project window, select [Edit] → [ISaGRAF] → [Edit
Programs]. ISaGRAF is activated as a window outside the SLP-D50 window.

The "Program management" window of the [SIMPLE] project will appear.

The program named [Control] is shown in the End section of the "Program
management" window. However, note that this program is blank.

Note

For details about "Program management" window,

refer to A.3. Managing programs of ISaGRAF Version 3.4 USER'S
GUIDE.

Handling Precaution

The ISaGRAF after SLP-D50 has been installed may have differences and
points requiring attention when compared to the original ISaGRAF.
For details,

refer to 11-5 Cautions about Writing Application Programs in ISaGRAF
of Smart Loader Package SLP-D50 for Module Type Controller DMC50
User's Manual, CP-SP-1122E.

■ ISaGRAF variables to add
The following shows the data of the temperature controller, which have not been

handled in the System Parameter and Calculation Parameter setup:

• SP: Set point (Target value of control)

• EV: Event threshold (Value, at which the alarm is turned ON.)

• EV_HYS: Event hysteresis (Operation hysteresis value, used when the alarm is

turned OFF.)

• EV_DLY: Event delay (Delay time when the alarm is turned ON.)

You will add SP, EV, and EV_HYS to the ISaGRAF variables as real-type

variables.

You will add EV_DLY to the ISaGRAF variables as a timer variable.
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■ Activating the dictionary editor
In the "Program management" window, select [File] → [Dictionary].
The dictionary main window will appear. (This window is also opened by

clicking the Dictionary icon on the toolbar.)

Note

For details about dictionary editor,

refer to A.10 Using the dictionary editor of ISaGRAF Version 3.4
USER'S GUIDE

■ Adding integer/real-type variables using the dictionary editor
If [Global integers/reals], which lists variables such as AI_1 and AI_2 similar to

the one in the previous picture, is not shown, select [File] → [Other] → [Global
variables], and then click [Integers/Reals] tab.

[Global integers/reals] tab will be shown. (This is also shown by clicking the

Global icon on the toolbar and the [Integers/Reals] tab in that order.)

In the dictionary main window, select [Edit] → [New].
The Input dialog box for a variable will appear. Type alphanumeric characters in

[Name]. Enter a hexadecimal value in [Network Address]. Select [Internal] in

[Attributes] and [Real] in [Format]. Check the [Retain] check box. Set the

necessary items as shown on the following screen and click [Store]. The input
dialog box for the next variable will appear:
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The following table lists the integer/real-type variables to add:

After you have added all integer/real-type variables completely, click [Cancel].
The input dialog box will be closed, and then the dictionary main window will

be active again.

If the setting is made incorrectly, double-click a variable you wish to correct in the

dictionary main window. The input dialog box for the selected variable will

appear. Correct the contents, and then click [Store].

■ Adding timer-type variables using the dictionary editor
Click the [Timers] tab. The check dialog box showing the message, "Save
current modifications?", will appear. Click [Yes].
The "Global timers" tab will be active.

Select [Edit] → [New]. The input dialog box for a variable will appear.

Type alphanumeric characters in [Name]. Enter a hexadecimal value in [Network
Address]. Select [Internal] in [Attributes] and [Real] in [Format]. Check the

[Retain] check box. Set the necessary items as shown on the following screen and

click [Store]. The input dialog box for the next variable will appear:

The following table lists the timer-type variables to add:

After you have added all timer-type variables completely, click [Cancel].
The input dialog box will be closed, and then the dictionary main window will

be active again.
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Name Network Attribute Format Retain check
address box

SP 1000 Internal Real (Standard) Checked.

EV 2000 Internal Real (Standard) Checked.

EV_HYS 2001 Internal Real (Standard) Checked.

Name Network Attribute Retain check
address box

EV_DLY 2002 Internal Checked.
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If the setting is made incorrectly, double-click a variable you wish to correct in the

dictionary main window. The input dialog box for the selected variable will

appear. Correct the contents, and then click [Store].

■ Exiting the dictionary editor

Select [File] → [Exit]. A confirmation dialog box showing the message, "Save
current modifications?" will appear. Click [Yes]. The dictionary main window

will be closed, and then the "program management" window will appear again.
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2  -  7 Editing ISaGRAF Programs

After the ISaGRAF variables have been added, edit the ISaGRAF programs.

In the following description, the function block is abbreviated as "FB" and the function as "FUNC":

■ Starting to write a program in the FBD editor
In the "program management" window, double-click the program named

[Control]. The "FBD/LD editor" window for [Control] will appear.

Two kinds of toolbars are provided, FBD toolbar and LD toolbar.

The FBD toolbar contains the "Insert function block" icon that looks like a letter

"F" surrounded by a square. When the LD toolbar is shown, select [Options] →
[FBD toolbar]. (This operation results in the same as that the FBD toolbar display

icon is clicked.)

Note

For details about "FBD/LD editor" window,

refer to A.7 Using the FBD/LD editor of ISaGRAF User's Guide.

■ Placing an FB box
The following describes how to realize the PID control capability in the program

named [Control]. When clicking [▼] on the right of the "Insert function block"

icon, the list of FB types will appear. The list is shown in symbolic and alphabetic

order. In the list, click [pid_a] to select it, and click at an appropriate position in

the FBD/LD editor window again.

If the box position is incorrect, (1) click the select icon in case it is not selected,

(2) click the box and drag it, and (3) release the mouse button at an appropriate

position.

If the box size is incorrect, click the Zoom (-) or Zoom (+) icon to adjust the size.
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■ Placing a variable box
In the "FBD/LD editor" window, click the Insert variable icon. Click the mouse

button again so that the resulting variable box is placed to the left of [MODE]
parameter of the [pid_a] box. The "Select Variable" dialog box will appear.

Select [(Global)] for [Scope] and [Boolean] for variable type. Click [DI_01] in

the variable list, and then click [OK]. (The variable type is also selected by

clicking relevant icon.)

The [DI_01] box is then located on the left of the [pid_a] box in the "FBD/LD
editor" window. If the box position is incorrect, click the Select icon. Click the

box and drag it. Release the mouse button at an appropriate position.

The following table lists the variables whose boxes you place in the same manner

as described for [DI_01]:

If the scope is not set correctly in the "Select Variable" dialog box, the variable

names with a scope are not shown in the variable list.

[SP] is a variable, which is added using the dictionary editor. If [SP] is not shown

in the variable list even though the scope is set correctly, redo the operation stated

in section 2-6 Adding ISaGRAF variables (on page 2-15).

Variable box placement Variable scope Variable name
position

Left of MODE of pid_a (Global) Boolean-type DI_01

Left of SP of pid_a (Global) Integer/Real-type SP

Left of PV of pid_a (Global) Integer/Real-type AI_1

Left of PID of pid_a (Global) Integer/Real-type 1

Left of PARA of pid_a (Global) Integer/Real-type 1

Left of MONI of pid_a (Global) Integer/Real-type 1

Left of AT of pid_a (Global) Boolean-type DI_02

Left of MV_IN of pid_a (Global) Integer/Real-type AO_1

Right of MV of pid_a (Global) Integer/Real-type AO_1
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Additionally, the reason why several variable names are [1] in the above table is

that they are fixed values instead of variables. Click in the edit field below the

"Scope" label in the "Select Variable" dialog box, change the value to "1"

(alphanumeric value), and click [OK].

The variable boxes are now located around the [pid_a] box.

■ Connecting the boxes
Before connecting the [pid_a] box and variable boxes, check the specifications of

the Boolean-type input parameters of [pid_a] FB.

• MODE

When MODE is TRUE(= ON), the control mode is transferred to MANUAL.

When MODE is FALSE (= OFF), the control mode is transferred to AUTO.

The above specifications are the same as the specifications of digital input 1

determined in the specifications of the temperature controller.

Therefore, connect the boxes by normal lines instead of the lines with boolean

negation.
• AT

Auto tuning is started at the rising edge of AT.
Auto tuning is stopped at the falling edge of AT.
The above specifications are the same as the specifications of digital input 2
determined in the specifications of the temperature controller.
Therefore, the boxes are connected by normal lines instead of the lines with
boolean negation.
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Click the Draw connection line icon. Drag the mouse pointer from the right end

of the [DI_01] box to [MODE] of the [pid_a] box, and then release the mouse

button. A connection line is then drawn between the [DI_01] and [pid_a] boxes.

In the same manner as described above, connect other variable boxes to the

[pid_a] box. In this example, nothing is connected to [E_OK] of the [pid_a] box.

■ Saving the program
It is possible to save the current FBD program. Select [File] → [Save].
The "Update diary" dialog box will appear. Write an appropriate comment and

click [OK] or click [OK] without writing of any comment. The program is then

saved. (This operation is the same as that the Save icon is clicked.)

■ Verifying the program
When you have completed the program using the FBD/LD editor, it is possible to

check whether or not the program is written according to the FBD syntax.

After the program has been saved, select [File] → [Verify].
The "Code generator" window will appear. (This window is also opened by

clicking the Verify icon after the program has been saved.)

When selecting [File] → [Verify] without saving of the program, A confirmation

dialog box showing the message, "Save the modifications?", will appear.

Click [Yes]. The "Update diary" dialog box will appear.

Write an appropriate comment and click [OK] or click [OK] without writing of any

comment. The program is then saved and the "Code generator" window will

appear. (This window is also opened by clicking the Verify icon without saving of

the program.)

If any errors are found during code generation, lines of error notification will be

displayed followed by a line containing the string "Error(s) detected"; each error

notification line contains the name of the program an error occurs, the coordinates

of the error location in the "FBD/LD editor" window, and the error message.
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The following shows the causes of frequently occurred errors and their corrective

actions:

• There are input parameters of function blocks or variable boxes that are not

connected.

→ If necessary, connect the variables and function blocks properly. If the

variables or function blocks are not necessary, delete them from the FBD.

Additionally, carefully check the coordinates of the error detections since the

variables and function blocks may be hidden in a place that is out of sight in

the "FBD/LD editor" window.

• Data types of the connected variables and the corresponding parameters of

function blocks do not match.

→Connect the variables to function blocks indirectly by putting the data

conversion function blocks, [Boo], [Ana], [Real], [Tmr], or [Msg] between

them.

If no errors are found during code generation, the dialog box showing the message,

"No errors detected. Do you want to exit the code generator now?", will

appear. Click [Exit].
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■ Exiting the FBD editor
In the "FBD/LD editor" window, select [File] → [Exit].
The "FBD/LD editor" window will be closed, and then the "Program
management" window will appear again. (This operation is the same as that  X
at the upper right corner of the "FBD/LD editor" window is clicked.)

■ Creating another program
It is also possible to realize the alarm output capability in the [Control] program.

In the following description, the alarm output capability is realized as a new

program:

In the "Program management" window, click [File] → [New].
The "New Program" dialog box will appear. (This window is also opened by

clicking the Create new program icon.)

Set Name, Comment, Language, and Style as shown on the above screen, and

then click [OK]. The "New Program" dialog box will be closed, and then the

"Program management" window will appear again.

In the "Program management" window, [Event] program has been added to the

"Begin" section.

Note

For details about "Begin" section and "End" section,

refer to A.3.1 The components of a project, B.1.7 Execution rules of
ISaGRAF User's Guide.
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■ Editing the alarm output in the FBD editor program
In the "Program management" window, double-click the program name

[Event]. The "FBD/LD editor" window for [Event] will appear.

Subsequently, edit the [Event] program in the same manner as described for the

[Control] program.

The description of the subsequent operations is omitted. When the program has

been created, the "FBD/LD editor" window becomes as shown on the screen

below.

Only [H], [X], [EPS], and [QH] of the [lim_alrm] FB input/output parameters are

used for the upper limit alarm capability. [L] input parameter is not used for this

capability.  However, you must connect any dummy variable or constant such as

"0.0" to it, because an error occurs during code generation if nothing is connected

to an input parameter. [EV], [EV_HYS], and [EV_DLY] are variables, which

should have been added to the global integer/real-type and the global timer-type

variables using the dictionary editor.

If [EV], [EV_HYS], and [EV_DLY] are not shown in the variable list even though

the scope is set correctly, redo the operation stated in section 2-6, Adding
ISaGRAF variables (one page 2-15).

■ Verifying the alarm output program
In the same manner as described for the "Control" program, verify the "Event"

program and correct the "Event" program until no error occurs.

If no error occurs, select [File] → [Exit] in the "FBD/LD editor" window. The

"FBD/LD editor" window will be closed, and then the "Program management"
window will be active again. (This operation is the same as that  X at the upper

right corner of the "FBD/LD editor" window is clicked.)
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After the ISaGRAF program has been edited, generate an application code.

■ Setting up the compiler options
In the "Program management" window, select [Make] → [Compiler options].
The "Compiler options" dialog box will appear.

In [Targets], click [Select] or [Unselect] so that the [>] mark indicating the

selections are shown on the left of [SIMULATE] and [ISA68M].
Check the [Use embedded SFC engine] check box.

When necessary, it is possible to check the [Optimizer] check boxes.

In this example, however, uncheck all check boxes. (This operation can also be

performed by clicking [Default].)
When you have completed the settings, click [OK]. The "Compiler options"
dialog box will be closed and a confirmation dialog box showing the message, "All
the programs will be verified during next make command", will appear.

Click [OK]. The "Program management" window will be active again.

Note

For details about compiler options,

refer to A.13.2 Compiler options of ISaGRAF User's Guide.

■ Setting up the run-time options
In the "Program management" window, select [Make] → [Application run
time Options]. The "Application run time options" dialog box will appear.

Check on the [Trigger cycles] check box of [Cycle timing].
Always enter a multiple of 50 in [Cycle Timing(ms)]. In this example, enter

"100".

Check the [Detect errors] check box of [Run time errors].
In this example, enter "16" in [Nb stored errors].
Check [Real time] of [Starting mode].
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Keep [Memory] of [Retained variables] blank.

When you have completed the settings, click [OK].
The "Application run time Options" dialog box will be closed, and then the

"Program management" window will appear again.

Note

For details about run-time options,

refer to A.3.3 Running the code generation tools of ISaGRAF User's
Guide.

■ Generating an application code
In the "Program management" window, select [Make] → [Make application].
The "Code generator" window will appear.

If any errors are found during code generation, lines of error notification will be

displayed followed by a line with a string "Error(s) detected"; each error

notification line contains the name of the program an error occurs, the coordinates

of the error location, and the error message.

Double-click an error message portion. The "FBD/LD editor" window for the

program containing the error will appear.

If no errors are found during code generation, the dialog box showing the message,

"No errors detected. Do you want to exit the code generator now?", will

appear. Click [Exit]. The "Code generator" window will be closed, and the

"Program management" window will be active again.
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2  -  9 Downloading and Monitoring the Application

You have completed all the settings in the last section. If you have a CTRL module available, start the operation

with the SLP-D50 and CTRL module connected.

If you do not have a CTRL module available, skip the following description and go to Chapter 3 Adding
capabilities to the temperature controller:

■ Downloading the application
In the "Project" window of SLP-D50, select [Online] → [Download
Application]. A confirmation dialog box will appear. Click [OK].
The "Downloading" dialog box will appear. When the application has been

downloaded completely, the message, "Project successfully downloaded", will

appear. When clicking [OK], the "Downloading" dialog box will be closed.

■ Creating a new group monitor

In section 2-5, Downloading and monitoring AI Setup Parameters (on page
2-12), monitoring is performed with the project window. In the following

example, monitoring is performed with the group monitor allowing you to view

the ISaGRAF variables and Parameter elements all together:

(1) First, display the ISaGRAF variables in the SLP-D50 main window.

Select [Edit] → [ISaGRAF] → [ISaGRAF Var Decls].
The "ISaGRAF POU list" dialog box will appear.

Click [Global Vars], and then click [OK].
The "ISaGRAF variable" window will appear.

(2) Next, register the variables to the group monitor.

Select [Project] → [Group Monitor] → [New].
The "Group Monitor" window where no variables are registered will appear.

Select [Window] → [Tile(Horizontal)] so that the three windows are arranged,

or manually change the window sizes in the SLP-D50 main window to see the

windows easily.

Press the left mouse button at a variable or a Parameter element to monitor

from the "ISaGRAF variable" window or an instance in the "Project"
window. Drag it to a blank position in the "Group Monitor" window and

release the left mouse button.

This data element is then registered in the "Group Monitor" window.

In this example, register the following data elements in the "Group Monitor"
window:

First register [AI1] in [Instance] of [AI Status], [AO1] in [Instance] of [AO
Status], and [DO1] in [Instance] of [DO Status] from the "Project" window

to the Group Monitor.
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Register [SP], [EV], and [EV_HYS] in [Int/Real Variables], and [EV_DLY] in

[Timer Variables] from the "ISaGRAF variable" window (global of "simple").

Register [Proportional Band], [Integral Time], and [Derivative Time] in

[Instance] of [PID_A Constants] of [PID Setup] under the Calculation

Parameters from the "Project" window.

(3) When the variables have been registered to the group monitor, save the group

monitor list into a file.

Click the "Group Monitor" window to make it active. Select [File] → [Save].
The "Save As" dialog box will appear. In this example, name the file

"simple.mon". Click [Save]. The "Save As" dialog box will be closed.
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■ Starting and stopping the group monitor
Click the "Group Monitor" window to make it active. Select [Online] → [Start
Group Monitor] to put the group monitor in the online mode. The background

color of the item names become yellow or orange. In the online mode, entering a

value in [Value] column of a data element row will overwrite its value inside the

CTRL module.

Select [Online] → [Stop Group Monitor] to put the group monitor in the offline

mode. The background color of the item names become gray.
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■ Activating the trend monitor form the group monitor
Click  X at the upper right corner of the "ISaGRAF variable" window and

"Project" window to close them. Only the "Group Monitor" window is remained.

Select [Online] → [Trend Monitor]. The [Trend Monitor] window will appear.

Select [Window] → [Tile(Horizontal)].
Click the "Trend Monitor" window to make it active.

Check the [Series1(AI1)] and [Series4(SP)] check boxes.

Select [Online] → [Start Trend Monitor]. The drawing of the trend monitor will

be started.

Click the "Group Monitor" window to make it active.

Select [Online] → [Start Group Monitor]. The "Group Monitor" window will be

put in the online mode.
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This chapter adds capabilities to the simple temperature controller made in Chapter 2.

In the SLP-D50 main window, select [Project] → [Copy Project]. Select [simple] as a project you wish to copy

and specify a project name of copy destination. The project can then be copied.

Basically, procedure for editing programs is the same as that described in Chapter 2. Therefore, this chapter only

describes the key points without presenting procedural steps.

Handling Precaution

If you modify a program to implement a new capability, you must do Make
Application (compile), and then download the application to make the new
capability  available in the DMC50 module.
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3  -  1 Adding an Eight Input SP(Set Point) Selector
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• Add real-type retained variables from [SP1] to [SP8] and integer-type variable

[SPN] to the local variables of the "Control" program.

• Modify the "Control" program in FBD editor as shown on the screen below.

Connect the digital inputs 3 through 5 to [bin3dec] to convert them to an integer

of 0 to 7. Using [mux8real], select one SP from eight SPs.

Chapter 3. ADDING CAPABILITIES TO THE TEMPERATURE CONTROLLER



Add an instance with group IDs 2 through 8 of the PID_A Constants in Calculation Parameters.

Note

For details about how to add instances,

refer to 9.4 Adding an Instance of Smart Loader Package SLP-D50 for
Module Type Controller DMC50 User's Manual, CP-SP-1122E.

• Add real-type retained variables from [PID_Z1] to [PID_Z7] and [PID_ZH], and

integer-type variable [PID_ZN] to the local variable of the "Control" program.

• Modify the "Control" program in FBD editor as shown on the screen below.

Connect "AI_1" to [zone7] to convert it to an integer of 0 to 7. Add "1" to this

integer value and connect it to the "PID" parameter of [pid_a].
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3  -  3 Adding a Manual Output Selector
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• Add the real-type variable [MAN_MV] and Boolean-type variable

[MAN_MODE] to the ISaGRAF variables.

• Change the "Control" program in the FBD editor as shown on the screen below.

When [DI_01] is TRUE, the manual mode is then selected. When [DI_01] and

[DI_03] are TRUE, the manual outputs are increased. On the contrary, when

[DI_01] and [DI_04] are TRUE, the manual outputs are decreased.
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Chapter 4. ADVANCED OPERATION

Automatic ISaGRAF program generation features are provided on the SLP-D50 to reduce the burden of

programming in ISaGRAF. This chapter describes the outline of these features.

■ Sampling Trace Wizard
This sampling trace feature is designed to trace the values of the selected project

data (ISaGRAF variables and Parameter elements by sampling them) at intervals

of cycle time synchronized with that of the CTRL module.

Note

For details about Sampling Trace Wizard,

refer to Chapter 22 SAMPLING TRACE WIZARD of Smart Loader
Package SLP-D50 for Module Type Controller DMC50 User's Manual, CP-
SP-1122E.

■ Integer Conversion Wizard
This Integer Conversion Wizard is an integer conversion program automatic

generation feature that is designed to exchange integer data with the external

system that can handle only integers.

Note

For details about Integer Conversion Wizard,

refer to Chapter 23 INTEGER CONVERSION WIZARD of Smart
Loader Package SLP-D50 for Module Type Controller DMC50 User's
Manual, CP-SP-1122E.

■ Pattern Wizard
This Pattern Wizard automatically generates a program that produces an SP

pattern (e.g. temperature profile) and a program that produces events related to the

pattern.

Note

For details about Pattern Wizard,

refer to Chapter 24 PATTERN WIZARD of Smart Loader Package SLP-
D50 for Module Type Controller DMC50 User's Manual, CP-SP-1122E.
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