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NOTICE

©2009 Yamatake Corporation ALL RIGHTS RESERVED

Be sure that the user receives this manual before the product is used.

Copying or duplicating this user’s manual in part or in whole is forbid-
den. The information and specifications in this manual are subject to
change without notice.

Considerable effort has been made to ensure that this manual is free
from inaccuracies and omissions. If you should find an error or omis-
sion, please contact Yamatake Corporation.

In no event is Yamatake Corporation liable to anyone for any indirect,
special or consequential damages as a result of using this product.



Conventions Used in This Manual
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� To prevent injury to the operator and others, and to prevent property damage, the following types of safety

precautions are indicated:

� In describing the product, this manual uses the icons and conventions listed below. 

Use caution when handling the product.

The indicated action is prohibited.

Be sure to follow the indicated instructions.

Handling Precautions:
Handling Precautions indicate items that the user should pay attention to when
handling the CMC15G.

Note: Notes indicate information that might benefit the user.

: This indicates the item or page that the user is requested to refer to.

(1), (2), (3): Numbers within parentheses indicate steps in a sequence or parts of an
explanation.

[ABC] button: Indicates a selectable button on a personal computer screen.

[File], [Edit]: Indicates messages and menus displayed on the personal computer.

[AB] → [XYZ]: Indicates menu selection on a personal computer.

[Enter] key: Indicates keys on the keyboard.

[Shift]+[F5] key: Indicates the operation of pressing the [F5] key on the keyboard while the [Shift] key
is pressed.

>>: Indicates the result of an operation, details displayed on the personal computer or
other devices, or the state of the device after operation.

CAUTION Cautions are indicated when mishandling this product might result in

minor injury to the user, or only physical damage to the product.



ii

Safety Precautions

CAUTION
Use Yamatake Corporation's SurgeNon if there is the risk of power surges caused by light-
ning.
Failure to do might cause fire or faulty operation.

Prevent the total power consumption of all linked modules from exceeding 100 W.

Before wiring, removing or installing the CMC15G, be sure to turn the power OFF.
Failure to do so might cause faulty operation.

Do not disassemble the CMC15G.
Doing so might cause faulty operation.

Wire the CMC15G in compliance with established standards, using the specified power source
and recognized installation methods.
Failure to do so might cause electric shock, fire or device failure.

Do not allow wire clippings, metal shavings or water to enter the CMC15G case.
Doing so might cause fire or faulty operation.

Firmly tighten the terminal screws at the torque listed in the specifications.
Insufficient tightening of terminal screws might cause fire.

Do not use unused terminals on the CMC15G as relay terminals.
Doing so might cause electric shock, fire or faulty operation.

Do not block ventilation holes.
Doing so might cause fire or faulty operation.

Do not short-circuit the batteries, and do not get them wet. If short-circuited, they may over-
heat or catch fire.

Do not throw used batteries into fire or discard them as general garbage. When discarding
them, follow local rules and regulations.

When disposing of the CMC15G, dispose of it appropriately as industrial waste in accordance
with local bylaws and regulations.



The Role of This Manual
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Four different manuals are available for the CMC15G. Read them as necessary for your specific requirements. If a

manual you require is not available, contact Yamatake Corporation or its dealer.

User's Manual

CP-UM-5463JE

WARNING

CAUTION

WARNING

CAUTION

CMC15G Multifunction Gateway Communication Controller Installation
and Configuration No. CP-SP-1277E

Personnel in charge of design, manufacture, operation, and/or maintenance
of a system using this unit must thoroughly read this manual.

This manual also describes the installation, wiring, connections for
communication, all functions and settings of this unit with the
GatewayEditor, operating procedures, troubleshooting, and specifications.

CMC15G Multifunction Gateway Communication Controller
No. CP-UM-5463JE

This manual is supplied with the product. This manual describes the safety
precautions, installation and wiring.

CMC15G Multifunction Gateway Communication Controller Connection
Manual No. CP-SP-1278E

Personnel in charge of combine the CMC15G with PLCs made by other
manufacturers and dedicated board computers to build systems must
thoroughly read this manual.

This manual describes how to connect to PLCs, address maps that
correspond to PLCs, and other operations and settings required for making
applications using PLCs.

CMC15G Multifunction Gateway Communication Controller Logging
Function Manual No. CP-SP-1279E

This Manual.

Personnel in charge of design, manufacture, operation, and/or maintenance
of a system using logging function by CMC15GD001 advanced function
model must thoroughly read this manual.

This manual describes detailed instructions on logging functions, details
about LogViewer.



Organization of This User's Manual
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This manual is organized as follows:

Chapter 1. OVERVIEW
Survey of applications, features, model selection, functions and operation of the

CMC15G.

Chapter 2. LOGGING FUNCTION
Continuous trends, captured trends, data logs, event logs, and extended functions

Chapter 3. LOGVIEWER

How to install, start, quit, and operate the LogViewer

Chapter 4. LOG TABLES
Log tables and related file operations. Log tables store the log data from the

CMC15G.

Chapter 5. DISPLAYING WITH LOGVIEWER

Settings for displaying graphs and log lists with LogViewer

Chapter 6. ONLINE OPERATION
Instructions for online operation with LogViewer

Chapter 7. ENVIRONMENT CONFIGURATION
Adjustment of the environmental settings

Chapter 8. SPECIFICATIONS
General specifications and external dimensions of the CMC15G

Chapter 9. TROUBLESHOOTING
Problem diagnosis and treatment
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Chapter 1 OVERVIEW
1  -  1 Overview and Features

� Overview
The CMC15G is a communication controller designed to exchange data between

another manufacturer's PLC, a host station, and a Yamatake controller or flowme-

ter connected as a slave station. By setting simple communication parameters, data

can be shared between modules, indicator values can be recorded, etc.

A specially designed PC loader tool, GatewayEditor (model No.: SLP-G15J50), is

used to set up the communication parameters and to transmit the data to the

CMC15G.

For CMC15G setup:

CMC15G Multifunction Gateway Communication Controller Installation
and Configuration (CP-SP-1277E)

If the CMC15G advanced function model is used, data can be saved from connect-

ed modules (trend, data log, and event log) to the internal memory. To transmit

saved data from the CMC15G's internal memory, a special PC loader tool, the

LogViewer (model No. SLP-G15LGV), is used.
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� Features
• Powerful design support and debug functions during operation startup

The logging function of the CMC15GD01 advanced function model provides a

wide variety of triggers useful for analyzing and solving problems that occur at

the work site.

• Optimum for complex debugging
The CMC15GD01 advanced function model can read out the log data from

multiple modules. The status of the slave station and the status of the host station

can be saved at the same time.

• Visual analysis
The LogViewer allows easy determination of the time at which events occurred.

It visually presents the state of the trend data at the time recorded in the event

log in conjunction with each logging function.

• Long-term recording
Using the CMC15GD01 advanced function model's large-capacity internal

memory and real-time monitoring function of the LogViewer makes it possible

to record data for an extended period of time.

Chapter 1. OVERVIEW



1  -  2 Model Number Guide

� CMC15G

* To use the logging function, the CMC15GD01 advanced function model is

required.

� Smart Loader Package

* To use the logging function, the LogViewer (SLP-G15LGV) is required.

� Maintenance parts (option)

3
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Basic Model No. Function Module Option Specifications

CMC15G

S01 Basic model

D01 Advanced function model *

A Base module with connectors

000 None

Software name Model No. Note

Smart Loader Package SLP-G15J50 CD for Windows 2000/XP/Vista
(GatewayEditor) USB mini-B (5-pin) cable included

Smart Loader Package SLP-G15LGV CD for Windows 2000/XP/Vista
(LogViewer) *

Part name Model No. Note

Replacement battery 81446431-001



1  -  3 Function Overview
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� Trends
Handling Precautions
• To use the logging function, the CMC15GD01 advanced function

model and the LogViewer (SLP-G15LGV) are required.

� Continuous trend
This function reads numeric data from connected modules at constant intervals and

records the data. Data is saved in the internal memory of the CMC15G.This func-

tion can be used to monitor, at constant intervals, changes in value.

� Captured trends function
This function reads numeric data from connected modules at constant intervals and

records the data before and after a trigger occurs. Data is saved in the internal mem-

ory of the CMC15G. Numeric data from connected modules can be recorded for a

specified period of time before and after an error occurs. This function can be used

to retain waveform information before and after an alarm occurs, in order to ana-

lyze the information for maintenance purposes. 
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� Data logs
This function records data from connected modules in the internal memory of the

CMC15G whenever a change in a specified bit occurs. The status data for connect-

ed modules for one operation cycle can be saved at a specified time, such as when

the system batch process begins, or when an error occurs in a connected module.

� Event logs
This function monitors a specified bit periodically. If any change occurs in the bit,

the event type and time are recorded in the internal memory.
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� Extended functions
The CMC15GD01 advanced function model provides the extended functions

below, in addition to the functions of the basic model (CMC15GS01).

� Capture notification
• Notification that a capture exists

The CMC15GD01 notifies the user of capture table creation.

• Notification that capture memory is full

The CMC15GD01 notifies the user that new triggers cannot be accepted.

Chapter 1. OVERVIEW



Chapter 2 LOGGING FUNCTION
2  -  1 Continuous Trends

This function reads out numeric data from connected modules periodically and records it to the internal memory of

the CMC15G. The continuous trend function can be used to monitor, at constant intervals, changes in values.

� Description of operation
� Startup

Data read-out from connected modules is executed at specified intervals.

� Process
The following describes how information from connected modules is saved to the

internal memory:

(1) The continuous trends function is started up at intervals specified inside the

CMC15G.

(2) Numeric data is read out from the source.

(3) Data that has been read into the internal memory of the CMC15G is saved as a

record with date and time recorded.

(4) If the number of saved records exceeds the maximum, the latest record is writ-

ten over the oldest record.

Handling Precautions
• The maximum number of records that can be saved for one group can

be specified. However, the settings may need to be adjusted on
account of other groups or the entire log function, so that the usage
capacity of the internal memory does not exceed the maximum level.
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� Operation if an error occurs
• Cycle overrun

If the collection cycle is too short for the amount of data to be collected, a cycle

overrun occurs. If this occurs, treatment of the record is as described below. A

separating vertical line is displayed on the LogViewer.

• Collection device read-out communication error

If a communication error occurs while reading data due to a module fault, one

invalid record showing that data has not been collected is recorded. (This record

is displayed as "---" on the LogViewer.)

When there is successfully read data in the same group in which a communica-

tion error occurred, information showing the valid data is recorded in the invalid

record. (The total amount collected is displayed on the LogViewer.)

• Discontinuous data

If any of the following conditions arises, the record is not recorded during this

period. (A separating vertical line is displayed on the LogViewer.)

• The CMC15G is turned OFF.

• Read-out is stopped by a change in the enabled-disabled setting.

• The time is advanced by the date and time adjustment function or the online

date and time setting function.

� Display
The REC LED indicator functions as described below during continuous trend logging.
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Status Meaning
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2  -  2 Captured Trends

The captured trends function reads numeric data from connected modules periodically. When a trigger occurs, it

saves data from before and after the trigger to the internal memory of the CMC15G.

Waveform information from before and after the occurrence of an alarm is kept and can be used for analysis during

maintenance work.

� Description of operation
� Startup

Data is read from connected modules at specified intervals.

If a trigger is detected, the data written to the ring buffer before and after the occur-

rence is read from the buffer and saved.

There are two methods of starting the captured trends function, as described below.

• Trigger capture (OFF→ON):  Executed when the value of a specified bit

changes from OFF to ON.

• Trigger capture (ON→OFF):  Executed when the value of a specified bit

changes from ON to OFF.

� Process
The following describes the process of periodic data collection and saving of data

before and after an alarm occurs:

(1) The captured trends function is started up at intervals specified inside the

CMC15G.

(2) Data is read from the source.

(3) Data which has been read is written to the ring buffer with the date and time.

(4) If the specified bit is changed to ON (or OFF), the data in the amount of

[Number of pre-trigger records] is read from the ring buffer and saved.

(5) Data in the amount of [Number of post-trigger records] is read from the ring

buffer and saved.

Note
• The user can select whether or not past captured data should be overwritten if

the memory for captured data is full.
9
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Handling Precautions
• If a trigger occurs when the enabled-disabled setting is "disabled," it is

ignored.

• If a new trigger occurs when saving data after a trigger has occurred, the
new trigger is ignored.

• In addition to the memory area for captures, there is a separate memory
for the ring buffer.

• After the maximum number of captures have been saved, if the overwrite
save function is not set, the captured trends function will not operate until
recorded data is cleared.

• The settings for the number of captures and the number of saved records
should take other groups and the overall logging function into account, so
that the capacity of the internal memory is not exceeded.

Note
• If the data type of the trigger device is a word, changes in value are judged

according to the contents of bit 0 (the least significant bit).

Additionally, the bit that is initialized by trigger device initialization is bit 0

(the LSB) only.

� Display

The REC indicator functions as described below while the captured trends function

is active.

Note
• The REC LED indicator starts flashing in green (at 1 s intervals) when the

trigger of the captured trends function is activated. Note that this is not the

time at which the post-trigger data is saved.

• The REC LED indicator starts flashing green (at 200 ms intervals) when the

last trigger of the number of captures for the captured trends function is acti-

vated. Note that this is not the time at which the post-trigger data is saved

completely.

Chapter 2. LOGGING FUNCTION
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� Operation if an error occurs
• Trigger device read-out communication error

If a communication error occurs when reading data from the trigger device, the

trigger is not activated.

• Cycle overrun

If the collection cycle is too short for the amount of data to be collected, a cycle

overrun occurs. If this occurs, treatment of the record is as described below. A

separating vertical line is displayed on the LogViewer.

• Collection device read-out communication error

If a communication error occurs while reading data due to a module fault, one

invalid record showing that data has not been collected is recorded. (This record

is displayed as "---" on the LogViewer.)

When there is successfully read data in the same group in which a communica-

tion error occurred, information showing the valid data is recorded in the invalid

record. (The total amount collected is displayed on the LogViewer.)

• Discontinuous data

If any of the following conditions arises, the record is not recorded during this

period. (A separating vertical line is displayed on the LogViewer.)

• The CMC15G is turned OFF.

• Read-out is stopped by a change in the enabled-disabled setting.

• The time is advanced by the date and time adjustment function or the online

date and time setting function.

Chapter 2. LOGGING FUNCTION

Actual time

10:10:10 1 0 0 2 0 0 3 0 0

2 0 1 3 0 1

---

---

---

2 0 3 3 0 3

2 0 4 3 0 4

2 0 5 3 0 5

2 0 6 3 0 6

1 0 1

1 0 2

1 0 4

1 0 5

1 0 6

10:10:11

10:10:12

10:10:13

10:10:14

10:10:15

10:10:16

No. 1 No. 2 No. 3

←Data delay in Nos. 2 and 3

←Data received successfully 
    in Nos. 2 and 3 at 13 s.

Recorded time

Contents of record

10:10:10 1 0 0 2 0 0 3 0 0

2 0 1 3 0 1

2 0 3 3 0 3

2 0 4 3 0 4

2 0 5 3 0 5

2 0 6 3 0 6

1 0 1

1 0 2

1 0 4

1 0 5

1 0 6

10:10:11

10:10:12

10:10:14

10:10:15

10:10:16

No. 1 No. 2 No. 3

Data received successfully is 
recorded in 12 s row.

There is no record at 13 s.



2  -  3 Data Logs
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The data log function records information from the connected modules in the internal memory of the CMC15G
when a change in the bit is detected. Status data from the connected modules for one cycle is saved if a system batch

process is started or if an error occurs in the connected modules.

� Description of operation
� Startup

If a change in the bit of a specified connected module is detected, the data read-out

from the connected module is executed.

There are two kinds of trigger startup methods, trigger (OFF→ON) and trigger

(ON→OFF), as described below.

Trigger (OFF→ON):  Executed when the value of a specified trigger device is

changed from OFF to ON.

Trigger (ON→OFF ):  Executed when the value of a specified trigger device is

changed from ON to OFF.

� Process
The following describes how the settings for the connected modules are saved if a

process (trigger occurrence) for the system arises:

(1) The CMC15G monitors the bit periodically. If the bit is turned ON, the data log

function is started.

(2) Numeric value data is read from the specified device.

(3) The data which was read is saved to the internal memory of the CMC15G as

records with date and time data.

(4) If the number of saved records exceeds the maximum, the next record is over-

written onto the oldest record.

Note
• If the data type of the trigger device is a word, changes in value are judged

according to the contents of bit 0 (the least significant bit).

Additionally, the bit that is initialized by trigger device initialization is bit 0

(the LSB) only.
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Handling Precautions
• The maximum number of records that can be saved for one group can be

specified in the configuration process. However, the settings should take
other groups and the overall logging function into account, so that the
capacity of the internal memory is not exceeded.

� Operation if an error occurs
• Trigger device read-out communication error

If a communication error occurs when reading data from the trigger device, the

trigger is not activated.

• Collection device read-out communication error

If a communication error occurs while reading data due to a module fault, one

invalid record showing that data has not been collected is recorded. (This record

is displayed as "---" on the LogViewer.)

When there is successfully read data in the same group in which a communica-

tion error occurred, information showing the valid data is recorded in the invalid

record. (The total amount collected is displayed on the LogViewer.)

Chapter 2. LOGGING FUNCTION



2  -  4 Event Logs
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� Description of operation
� Startup

There are two startup methods, cyclic (auto) and cyclic (fixed).

• Cyclic (auto):  The execution interval is automatically determined from the

average process time.

• Cyclic (fixed):  The event log is executed at specified intervals.

� Process
Multiple bits registered for the processing are monitored periodically.

When the state (ON/OFF) of a specified bit changes, the device's type and the time

are recorded. There are three kinds of bit ON/OFF detection (events) as described

below.

• Trigger (OFF→ON):  Executed when the value of a specified trigger device is

changed from OFF to ON.

• Trigger (ON→OFF ):  Executed when the value of a specified trigger device is

changed from ON to OFF.

• Trigger (OFF→ON/ON→OFF):  A record is added to the event log at both the

start and finish of the trigger.

When multiple bits are monitored and a change occurs, the following describes

how the event and the date and time are saved:

Handling Precautions
• The maximum number of records that can be saved for one group can

be specified in the configuration process. However, the settings should
take other groups and the overall logging function into account, so that
the capacity of the internal memory is not exceeded.

Note
• If the data type of the trigger device is a word, changes in value are judged

according to the contents of bit 0 (the least significant bit).

Additionally, the bit that is initialized by trigger device initialization is bit 0

(the LSB) only.
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� Operation if an error occurs
• Cycle overrun

If the process is not completed within the specified cycle, the process is not run

again.

• Bit read-out communication error

If a communication error occurs in the bit read-out process, the bit's value is not

judged and no judgement results are recorded.

Chapter 2. LOGGING FUNCTION



2  -  5 Extended Functions

16

� Notification of capture and of full capture memory
Capture notification: At least one data record has been collected by the cap-

tured trends function.

Capture limit notification: The captured trends function cannot accept another trig-

ger.

Handling Precautions
The capture and capture limit statuses are retained until the project is
downloaded or the recorded data is cleared.

By monitoring the specified notification device, the status of the CMC15G can be

checked. When alarm status occurs, the bit is turned ON at the intervals specified

by the user (in "min" (minute)).

� Startup
The capture notification and capture limit notification function are started up at

specified intervals (in "min" (minute)).

� Process
A specified bit is turned ON at the intervals specified (in "min" (minute)) when the

relevant status occurs. The following describes the process for sending periodic

capture limit notification to the host station.

(1) The time is monitored at specified intervals for startup of the capture notifica-

tion and capture limit notification functions.

(2) The capture status is checked.

(3) If the memory for capture is full, the specified bit on the host station is turned

ON.

� Operation if an error occurs
• If a process is not completed within the specified cycle, the process is not started

again.

• If a communication error occurs when the notification device is turned ON (or

OFF), no notification is sent to the connected module.

Chapter 2. LOGGING FUNCTION
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Chapter 3 LOGVIEWER

3  -  1 Overview of LogViewer

� Function
LogViewer displays log tables collected by the CMC15G logging function (trends,

data logs and event logs). Collected log tables are managed on a project* basis.

* A project is a group of functional settings for the CMC15G.

For further detials,

User's manual No. CP-SP-1277E.

� System requirements

*1. Following OSs are not supported: Windows Me, Windows 98, Windows 95,

Windows XP 64-bit Edition, Windows Vista 64-bit Edition and Windows

Server (Windows 2000 Server, Windows Server 2003,Windows Home

Server,Windows Server 2008, etc.)

*2. If LogViewer is started up in a language environment other than Japanese, the

menu is displayed in English.

*3. To communicate with the CMC15G, the personal computer must have either

a USB port or COM port interface.

17

OS Windows Vista, Windows XP, Windows 2000 *1

Language *2 Japanese, English

CPU Pentium compatible CPU, 400 MHz or more

Memory (RAM) 512 MB or more

Hard disk drive Free space, 2 GB or more

Display SVGA (800 × 600) resolution or better, 16-bit color or better

CD-ROM drive Necessary only when installing LogViewer

Keyboard Necessary

Mouse Necessary

USB port *3 Necessary if connecting to the CMC15G with the USB
cable

COM (serial) port *3 Necessary if connecting to the CMC15G with the loader
cable



3  -  2 Installation, Removal, and Maintenance
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� Installing LogViewer

Handling Precautions
• Installing LogViewer does not install the USB driver for the CMC15G.

If you need to install the USB driver, execute setup.exe in the usb
directory of the CD-ROM.

(1) Insert LogViewer setup CD-ROM into the CD-ROM drive. Double-click [My
Computer] to open it.

(2) Move the mouse cursor onto the icon for the CD-ROM drive, press the right

mouse button, and select [Open] from the pop-up menu.

>> The contents of the CD-ROM are shown.

(3) Double-click Setup.exe

Chapter 3. LOGVIEWER
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>> The setup wizard screen will appear. The License Agreement screen will appear

during installation. Check the contents of the license agreement. If you agree

with the contents of the license agreement, click the [Yes] button. If you do not

agree, click the [No] button and installation will be cancelled.

>>Subsequently, a screen prompting you to input information will appear.

(4) Input a user name, company name, and serial number. The serial number is

printed on the label attached to the CD-ROM case. If the serial number is not

input accurately, the installation process will not continue.

(5) Follow the instructions on the screen to continue the setup.

Note
When installing LogViewer, files with a .gwl extension are registered as log

table files. To open a log table file, double-click the .gwl file to start LogViwer.

Chapter 3. LOGVIEWER
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� Uninstalling LogViewer
(1) From the [Start] menu, select [Control Panel].

>> The Control Panel window will appear.

(2) In Windows 2000, Windows XP, and Windows Vista, double-click

[Add/Remove Programs], [Add or Remove Programs], and [Programs
and Features], respectively.

>> A list of installed programs is displayed.

(3) Select [SLP-G15]. In Windows 2000, Windows XP, and Windows Vista, dou-

ble-click [Change/Remove], [Change/Remove], and [Uninstall/Change],
respectively.

>> LogViewer and the USB driver will then be removed.

Note
Project files created by the user, address selection palette favorites, etc. are not

removed.

Chapter 3. LOGVIEWER
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� LogViewer upgrade and maintenance
If the LogViewer setup.exe file is run after the LogViewer has already been

installed on the personal computer, instead of a general new installation, one of the

following two processes is started:

� Upgrade installation
If the setup.exe program is a newer version of the LogViewer, the currently

installed version will be removed, and the new version will be installed. 

No data is overwritten onto project files created by the user, address selection

palette favorites, etc.

� Maintenance 
If the setup.exe program is the same version as the installed LogViewer, it operates

in maintenance mode.

Repair

If any program files have been removed accidentally, this function restores the sys-

tem configuration to that of a new installation.

Remove

Executable files (LogViewer and USB drivers) of the LogViewer are removed.

Project files created by the user, address selection palette favorites, etc. are not

removed.

Handling Precautions
• If the installation destination folder or the program folder location for

the start menu, to which program icons are registered, is changed dur-
ing an upgrade, blank folders may remain. In this case, remove the
blank folders manually.

• If an installer program with a different version is run, the installation
information from the old version may remain in the [Add/Remove
Applications] (Add or Remove Programs) list. If Remove Programs is
executed for this old information, no program will be removed, but the
information will be deleted.

Chapter 3. LOGVIEWER
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� Starting LogViewer

To start up Logviewer, follow the steps below:

Click the Windows [Start] button in the lower left of the screen.

Select [All Programs] → [SLP] → [SLP-G15] → [LogViewer].

>> LogViewer then starts up and the Menu window appears.

Handling Precautions
Up to two instances of LogViewer can be run at the same time. If you
attempt to start a third instance, an error message will appear.

� Exiting LogViewer
To exit LogViewer, follow the steps below:

Click the [X] (close) button on the title bar. Or, to exit LogViewer from the menu,

select [Exit] from the [File] menu.

>> LogViewer will close.

Note
• By running two programs at the same time (concurrent operation), you can

open previous log tables where you saved files or compare log tables during

real-time monitoring.
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Start

Open log table

Trend pane

• Graphs
• Attributes
• Markers

• Lists
• Filters
• Jump

• Lists
• Filters
• Jump

Data log pane Event log pane

Read from CMC15G

Save log data

Refresh Real-time monitor Clear CMC15G log table

Output CSV file

Display

Output

Communications
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� Screen layout

� Menu
Available operations.

� Toolbar
A strip containing buttons related to the menus.

� Trend graph pane
Graphs of log table data read from the CMC15G. 

� Data log pane
Data logs from log tables read from the CMC15G.

� Event log pane
Event logs read from the CMC15G log tables.

� Menu and toolbar conventions
LogViewer functions are displayed on the menu and toolbar.

The following describes the conventions that are used.

*1. Accelerator keys access a menu when the combination of [Alt] + the specified

key is pressed. For example, pressing [f] while [Alt] is pressed displays the pull-

down File menu. 

*2. Shortcut keys directly execute a menu item. They consist of [Ctrl] + the speci-

fied key. For example, pressing [c] when [Ctrl] is pressed executes the copy

command.

Chapter 3. LOGVIEWER

Icon Icons indicate relevant functions in an easily understood way.
Clicking an icon on the toolbar will execute the corresponding
function.

Item name Item names are shown on the menu.

X Underlining indicates an accelerator key.*1

[Ctrl]+[X] Indicates a shortcut key combination.*2 
Omitted if no shortcut key is available.

Menu
Toolbar

Trend graph pane

Data log pane

Event log pane
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� Menus
� File menu

Chapter 3. LOGVIEWER

Menu Icon Submenu Description Shortcut key

File Open log table Opens a saved log table file [Ctrl] + [o]
(*.gwl)

Reopen log table Displays up to 10 of the most 
recently opened files, with their
pathname. Selecting a file 
opens it.

Save log table Saves the (active) open log [Ctrl] + [s]
table as a file.

Save log table as Saves the (active) open log 
table with a new name as a file.

Close log table Closes the (active) currently 
open log table.

Output CSV file Outputs the (active) open log 
table as a plain text file with 
comma-separated values.

Log table information Displays project information 
for the (active) currently open 
log table.

Exit Exits LogViewer.
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� Edit menu

Chapter 3. LOGVIEWER

Menu Icon Submenu Description Shortcut key

Edit Copy Copies the selected cell of the [Ctrl] + [c]
Data log, Event log, or Trend 
pane to the Windows clipboard.

Select all Selects all cells in the Data log, [Ctrl] + [a]
Event log, or Trend pane.

Copy graph Copies the displayed graph to [Ctrl] + [g]
the Windows clipboard.

Change color Changes the color of the 
selected graph line.

Graph comparison Saves the displayed graph as 
an image (shadow) in the back
ground. When the selection is 
canceled, the background
image disappears. 

Lock graph shadow Enables user to move 
background (shadow) and
foreground graphs together.

Jump to selection Moves the displayed graph to 
the time and date selected in 
the Data log pane or Event log 
pane.
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� Display menu

Chapter 3. LOGVIEWER

Menu Icon Submenu Description Shortcut key

View Window Trend group Switches between display and 
panes selection pane no display of the Trend group 

selection pane. 

Trend informa- Switches between display and
tion pane no display of the Trend 

information pane.

Data log pane Switches between display and 
no display of the Data log pane.

Event log Switches between display and
pane no display of the Event log pane.

Background color change Changes the background color
of the graph.

Black: black background, 
white lines, dark gray solid 
grid lines.

White: white background, 
black lines, light gray grid lines.

Grid display Switches between display and
no display of the graph grid lines.

Marker Data log Switches between display and
display no display of the data log

markers.

Event log Switches between display and
no display of the event log 
markers.

Cursor Cursor A Switches between display and 
display no display of cursor A.

Cursor B Switches between display and 
no display of cursor B.

Range setting Displays a dialog box for set- 
ting the data range and 2-axis
display for the current trend
group.

Vertical display of 2 axes If the current trend group is set 
for 2-axis display, switches 
between vertical display and 
overlapping display. 

Zoom in / Scale up Scales up the time (x) axis of 
zoom out horizontal axis the graph.

Scale down Scales down the time (x) axis 
horizontal axis of the graph.

Scale up Scales up the value (y) axis of
vertical axis the graph.

Scale down Scales down the value (y) axis 
vertical axis of the graph.
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� Communications menu

� Tool menu

� Help menu

Chapter 3. LOGVIEWER

Menu Icon Submenu Description Shortcut key

Communica- Upload all Uploads all log tables from the
tions CMC15G to the PC.

Refresh Uploads log tables created 
since the last upload from the 
CMC15G.

Real-time monitor Periodically reads data record-
ed on the CMC15G.

Clear CMC15G log tables Erases the log tables on the
CMC15G.

Clear CMC15G capture Erases captured data on the
data CMC15G.

Menu Icon Submenu Description Shortcut key

Tool Environment configuration Configures settings for com-
munication with the PC, etc.

Menu Icon Submenu Description Shortcut key

Help Help Shows the user's manual 
(PDF file).

Version information Displays the LogViewer ver-
sion number, etc.



Chapter 4 LOG TABLES
4  -  1 Overview

Data logged by the CMC15G is called a log table. Log tables can be read from the

CMC15G using LogViewer. Log tables read out from the CMC15G are saved in

binary format as *.gwl files. They can also be saved in CSV format.

LogViewer provides three ways to read log tables from the CMC15G, reflected in

the menu selections Upload all, Refresh, and Real-time monitoring. Also, you can

use LogViewer to clear log tables from the CMC15G. 

Chapter 6, ONLINE OPERATION.
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4-2-1 Opening a log table
� Screen layout

� Model
The model No. for which the log file was made.

� Comments
Shows user comments about the selected file.

� File name
Input/selection of a file name.

� File of type
Selection of the type of file.

� Open
Opens the file.

� Cancel
Closes the dialog box without opening the file.

� Procedure
Opening a saved log table file (*.gwl):

(1) Select [File] → [Open log table].
>> The [Open] dialog box is displayed.

(2) Select the file to open. To indicate the file name directly, type it into the File

name box.

(3) Click the [Open] button.

>> The specified log table file will be opened.

Note
• The initial folder when LogViewer is started for the first time is My

Documents¥LogViewer¥. Subsequently when LogViewer is started, the fold-

er that was selected the previous time becomes the default folder.

Chapter 4. LOG TABLES

Model

Comments

File name

File of type
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4-2-2 Saving a log table
� Screen layout

� Model
The model No. for which the log file was made.

� Comments
Shows user comments about the selected file.

� File name
Input/selection of a file name.

� File of type
Selection of the type of file.

� Save
Saves the file.

� Cancel
Closes the file without saving.

� Procedure
(1) Select [File] → [Save log table].
>>The currently selected log table is saved to a file.

Note
• If you try to save a log table that has not yet been saved to a file, the [Save

As] window will appear. Or follow the steps below:

(1) Select [File] → [Save as].
>>The [Save as] dialog box is displayed.

(2) Open the folder to which you wish to save the log table, and input a file name.

(Or, if you want to overwrite an existing file with the current log table, select

the name of the existing file.)

(3) Click the [Save] button

>> The log table is saved with the specified name.

Handling Precautions
• Do not use any characters in the file name that are found exclusively in the

Unicode character set. Doing so will prevent the file from being saved.

Note
• The initial folder when LogViewer is started for the first time is My

Documents¥LogViewer¥. Subsequently when LogViewer is started, the

folder that was selected the previous time becomes the default folder.

Chapter 4. LOG TABLES

Model

Comments

File name

File of type
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4-2-3 Closing a log table
� Procedure

(1) Select [File] → [Close log table].
>>The opened log table is saved and closed.

Note
• If you close a log table you are currently editing, the message below will

appear.

Chapter 4. LOG TABLES
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4-2-4 Outputting a log table as a CSV file
The contents of the currently displayed log table can be output to a CSV file. The

user can choose which log table contents to output and can specify the file name.

� Screen layout

� Output name
Enter a name to be used for the folder and file.

� Data to output
Select which data is to be output to the CSV file. Data groups are displayed in a tree

structure, organized by function. Following each function name (trend, captured

trend, data log, event log) the numbers in parentheses tell the number of groups

selected per total number of data groups.

� Save
Saves data.

� Cancel
Closes the window without saving data.

� Folder selection window
Select or create the destination folder for the CSV file.

� Procedure
(1) Select [File] → [Output CSV file].
>>The CSV file output window appears.

(2) Enter a name for the file you are going to output. (To overwrite an existing file,

select the name of that file.)

(3) Select the content to be output.

(4) Click the [Save] button.

>>A folder selection window appears.

Chapter 4. LOG TABLES
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(5) Select the output destination folder and click the [OK] button.

>>A new folder with the designated name is created under the selected folder, and

the CSV file is output to it.

Note
• The initial folder when LogViewer is started for the first time is My

Documents¥LogViewer¥. Subsequently when LogViewer is started, the

folder that was selected the previous time becomes the default folder.

� Data available for output
� Continuous trend

•  Header information

•  Data format

� Captured trend
•  Header information

•  Data format

� Data log
•  Header information

•  Data format

Chapter 4. LOG TABLES

Data group name xxxx

Starting time and date xxxx/xx/xx xx:xx:xx

Closing time and date xxxx/xx/xx xx:xx:xx

Period xxxx

Number of items xxxx

Time and date CH1 name CH2 name CH3 name ...

xxxx/xx/xx xx:xx:xx xxxx xxxx xxxx ...

... ... ... ... ...

Data group name xxxx

Occurred time and date xxxx/xx/xx xx:xx:xx

Starting time and date xxxx/xx/xx xx:xx:xx

Closing time and date xxxx/xx/xx xx:xx:xx

Period xxxx

Number of items xxxx

Time and date CH1 name CH2 name CH3 name ...

xxxx/xx/xx xx:xx:xx xxxx xxxx xxxx ...

... ... ... ... ...

Data group name xxxx

Number of items xxxx

Time and date CH1 name CH2 name CH3 name ...

xxxx/xx/xx xx:xx:xx xxxx xxxx xxxx ...

... ... ... ... ...
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� Event log
•  Header information

•  Data format

Note
• The time and date display format varies depending on the language environ-

ment settings of the OS, which are located in [Control Panel] → [Regional
and Language Options].

� Output file name conventions
CSV file names are automatically named according to the following rules, based on

the name entered by the user as the output name:

OutputName_FunctionName_Number_GroupName.csv

The function names are as follows:

"Number" is a 2-digit serial number for the data group, automatically added to the

information for each function.

In the case of captured trends, after GroupName there is an added number which is

automatically assigned for each trigger, and the time at which the trigger occurred,

so that the CSV file name is:

OutputName_FunctionName_Number_GroupName_TriggerNumber_DateTime.csv 

Examples:

TABLE_Trend_01_Temperature log.csv

TABLE_Trend_02_Pressure log.csv

TABLE_CaptureTrend_01_PV error_01_20080131235959.csv

TABLE_Datalog_01_Switching Operation.csv
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Time and date CH1 name CH2 name CH3 name ...

xxxx/xx/xx xx:xx:xx xxxx xxxx xxxx ...

... ... ... ... ...

Data group name xxxx

Number of items xxxx

Function Function Name

Continuous trend Trend

Captured trend Capture Trend

Data log Datalog

Event log Eventlog
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Handling Precautions
• If characters that cannot be used in file names are used for a data

group name, the characters are deleted. The following characters can-
not be used in file names:
\ / : * ? " < > ¦

• When the maximum number of lines for a file is exceeded:
If the total number of lines in a file is more than 65,536 (the maximum
number of lines that can be displayed in Excel), the file is automatical-
ly divided. At that time, "_n" is added to the end of the file name, where
n is an integer 1 or greater.

Example:
TABLE_CaptureTrend_01_PV error_01_20080131235959_1.csv
TABLE_CaptureTrend_01_PV error_01_20080131235959_2.csv

Chapter 4. LOG TABLES
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4-2-5 Viewing log table information
The information in the currently displayed log table can be viewed in list format.

� Screen layout

� Mfr. serial No.
Indicates the manufacturer's serial No. of the CMC15G.

� Project name
Displays the name of the project file downloaded to the CMC15G.

� Project comments
Displays comments on the project downloaded to the CMC15G. Line feeds in the

comment are displayed as single spaces.

� Last read date/time
Indicates the time and date at which the file was last read from the CMC15G.

� Trend number
Displays the data group number for the trend.

� Data log number
Displays the data group number for the data log.

� Event log number
Displays the data group number for the event

� Procedure
Select [File] → [Log table information].

>> The log table information window appears.

Chapter 4. LOG TABLES
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5 -  1 Trend Pane
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Graphed data for each log table can be displayed.

� Screen layout

� Trend group selection pane
Shows trend groups in tree format.

� Trend graph pane
Shows a graph of the data for the selected trend group.

� Trend information pane
Shows information regarding the data of the selected group.

Trend group
l ti

Trend graph Trend information
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5-1-1 Trend group selection pane
Displays trend-related data groups in a tree view style.

� Screen layout

� Title bar
Shows the project name for the displayed log table. Clicking the title bar toggles

the display of the trend group selection list on and off.

� Trend group
Shows the trend groups in a tree format.

The name of each data group is displayed on the top level.

For captured trend groups only, the second level shows the log record (item name

and time) for each trigger that occurred. 

The line of the selected item is highlighted. A graph of the selected trend group is

displayed in the Trend graph pane.

� Procedure
In the tree view, click the trend group you want to display.

>> Graphed data for the selected group is displayed in the Trend graph pane.

Chapter 5. DISPLAYING WITH LOGVIEWER

Trend group

Title bar



40

5-1-2 Trend graph pane
Displays a graph of the selected trend group.

� Screen layout

� Time (X) axis position
Changes the position of the time axis on the graph.

� Time axis ratio
Move the slider to adjust the number of time intervals per dot.

� Value (Y) axis position
Changes the position of the value axis on the graph. Not displayed if the value axis

slider is at the bottom.

� Value axis display ratio
Move the slider to adjust the value axis display ratio.

� Group information
Data group information is displayed as follows:

• NAME: The data group name

• TERM: Start date and time, End date and time

• CYCLE: Cycle length in seconds (and number of seconds per dot)

• Group name

Displays the group name for the selected trend.

• Start date and time

Shows the date and time (Month/Day/Year H:M:S) at which the trend group

data began to be collected.

• End date and time

Displays the end date and time (Month/Day/Year H:M:S) at which the dis-

played trend group data collection ended.

• Cycle

Indicates the collection period for the displayed trend group data. Also indi-

cates the period per dot as determined by the display ratio.

Time axis position Time axis ratio

Value axis
position
(Axis 2)

Value axis 
display ratio
(Axis 2)

Value axis
display ratio

(Axis 1)

Value axis
position
(Axis 1)

Group information
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� Graph
Shows the graphs for the log table for each data group. Shows only the data for

which the [Disp] check box is selected in the Trend information pane.

� Value (vertical/Y) axis 
• Value axis scale

Displays values for the log table selected in the Trend information pane, using

the specified grid scale count. To change the grid count, click [Tools] →
[Environment], and then set the "View Configuration."

• Value axis display ratio indicator

Indicates the display ratio of the value axis as a percentage.

� Time (horizontal/X) axis 
• Time axis scale

Displays the sampling time in YYYY/MM/DD, HH:MM:SS format. The time is

displayed in conformity to the grid width setting. To change the grid width, click

[Tools] → [Environment], and then set "View Configuration."

� Grid
Displays vertical and horizontal lines at the scale positions for the time axis and the

value axis. The grid is displayed when [View] → [Grid] is selected.

� Cursor
Displays up to two cursors. The values at the cursor position are shown in the

Trend information pane. A cursor is displayed if "Cursor A" or "Cursor B" is

selected under [View] → [Cursor]. When the cursor is first switched from invisible

to visible status it is shown at the center of the graph.

� Data log/event log marker
" " is shown at the time position of each item displayed in the Data log pane.

" " (OFF → ON) and " " (ON → OFF) markers are shown at the time posi-

tions for the items displayed in the Event log pane. Markers are displayed if "Data

Log" or "Event Log" are selected under [View] → [Marker].

Time axis scale

Grid

Event log marker

Cursor Data log marker

Value axis scale

Value axis
display ratio
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� Moving the graph display position
You can use the mouse or keyboard to move the graph display position. 

Position limits are as follows:

• Value (vertical) axis top: upper limit position of range setting

• Value (vertical) axis bottom: lower limit position of range setting

• Leftmost time (horizontal) axis: oldest time position

• Rightmost time (horizontal) axis: latest time position + screen size

� Operating the scroll bar
Change the portion of the graph that is displayed by dragging the rectangular tab

(scroll box) on the scroll bar.

• Value (vertical) axis scroll bar

To see a higher value position, drag the scroll box upward. To see a lower value

position, drag the scroll box downward.

• Time (horizontal) axis scroll bar

To see later times, drag the scroll box to the right. To see earlier times, drag the

scroll box to the left.

� Operating the keyboard or mouse
While the focus is on the graph, you can use the following keyboard and mouse

operations to change the display position of the y-axis or x-axis:

Note
• You can also use the Data log pane or Event log pane to move the graph dis-

play position.

Section 5-2, Log List.
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Y axis (value) movement Keyboard  or mouse

1 dot up or down [↑], [↓]

50 dots up or down [Shift] + [↑], [Shift] + [↓]

A quarter page up or down [Ctrl] + [↑], [Ctrl] + [↓]

A half page up or down [Ctrl] + [PageUp], [Ctrl] + [PageDown]

Unrestricted Drag

1/20 page up or down [Ctrl] + [Shift] + 1 mouse wheel increment 

X axis (time) movement Keyboard  or mouse

1 dot left or right [←], [→]

50 dots left or right [Shift] + [←], [Shift] + [→]

A quarter page left or right [Ctrl] + [←], [Ctrl] + [→]

A half page left or right [PageUp], [PageDown]

Unrestricted Drag

Unrestricted [Shift] + 1 mouse wheel increment 
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� Changing the graph display ratio
You can use the mouse or keyboard to change the scaling of the graph.

� Operating the track bar
The graph's display ratio can be adjusted by moving the slider (the rectangular han-

dle on the track bar).

• Vertical axis display ratio track bar

To increase the display ratio of the vertical axis (enlarge the display), move the

slider upward.

To decrease the display ratio of the vertical axis (shrink the display), move the

slider downward.

When the slider is at the bottom, the entire vertical axis is displayed.

The base point for enlargement or reduction is the bottom of the display frame.

• Horizontal axis display ratio track bar

To increase the displayed periods per dot (zoom out), move the slider to the

right.

To decrease the displayed periods per dot (zoom in), move the slider to the left.

When the slider is at the left end, the display cycle is 10 times the collection

interval.

� Operating the menu and toolbar
When the focus is on the graph in the Trend graph pane, the display ratio of the

graph can be changed using a menu command or a toolbar icon. The base point for

enlargement or reduction is the center point of the display frame.

• Enlarging the vertical axis 

To increase the display ratio of the y-axis and display more detail, click [View]
→ [Zoom in/zoom out] → [Scale up vertical axis] (or click on the tool-

bar).

• Reducing the vertical axis

To decrease the display ratio of the y-axis and display a wider range, on the main

menu click [View] → [Zoom in/zoom out] → [Scale down vertical axis] (or

click on the toolbar).

• Enlarging the horizontal axis 

To decrease the display cycles per dot and show more detail, click [View] →
[Zoom in/zoom out] → [Scale up horizontal axis] (or click ] on the tool-

bar).

• Reducing the horizontal axis

To increase the display cycle per dot and display a wider range, click [View] →
[Zoom in/zoom out] → [Scale down horizontal axis] (or click on the

toolbar).
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� Operating the mouse or keyboard
While the focus is on the trend graph, the mouse can be used as indicated below to

change the display ratio of the value axis or time axis of the graph.

When the focus is on a track bar, the keys can be used as indicated below to change

the display ratio of the value axis or time axis of the graph.

� Moving the cursor
The cursor can be moved using the keyboard or mouse. (The cursor is visible only

if [View] → [Cursor display] → "Cursor A" or "Cursor B" has been selected.)

� Operating the keyboard or mouse
When the focus is on cursor A or B, you can use the following keyboard or mouse

operations to move the cursor position:

Note
• If the trend graph is larger than the screen, the screen can be scrolled by mov-

ing the cursor outside of the screen.

� Copying graphs

To copy the displayed graph to the Windows clipboard as a bitmap image, click

[Edit] → [Copy graph]. You can then paste the image into a program such as Paint

and save it as a file.

If you have selected [Tool] → [Environment] and then "Copy graph with label"

from the "View Configuration" tab, legends are included on the bitmap.
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Function Display ratio of y-axis Display ratio of x-axis

Enlarge [Ctrl] + forward turn of mouse Forward turn of mouse wheel
wheel

Reduce [Ctrl] + backward of mouse Backward of mouse wheel
wheel

Function Display ratio of y-axis Display ratio of x-axis

Enlarge [↑] [→] [↑] [→]

Reduce [↓] [←] [↓] [←]

Movement Keyboard or mouse

1 dot left or right [←], [→]

50 dots left or right [Shift] + [←], [Shift] + [→]

A quarter page left or right [Ctrl] + [←], [Ctrl] + [→]

Unrestricted Drag

Legend
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� Comparing graphs
One graph can be superimposed on another one having a different time range in

order to visually compare the two graphs. Click [Graph comparison] to set one

graph as the basis of comparison (background image), which will be overlaid with

the other graph. You can use [Lock graph shadow] to move both graphs together. 

The procedure is as follows:

(1) Move the trend graph display to the position where the graph that will be the

basis of comparison (the background graph) is displayed. In the figure below,

the graph used as a basis is shown on the left.

(2) Click [Edit] and then [Graph comparison]. (To execute from the toolbar, click

.)

>> The graph changes to a lighter color, indicating that it is set as the back-

ground image.

(3) Move the trend graph display to the position of the graph to be compared.

(4) Scroll or use the mouse to drag this graph to the desired position over the back-

ground graph.

>>  You can use the move operation for the graph display position to move the

compared graph in the normal way.

Graph used as a basis
(locked as a graph shadow)

Graph to be compared
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>>  By adjusting the position, you can visually determine the differences

between the two graphs.

(5) Click [Edit] → [Lock graph shadow]. (To execute from the toolbar, click )

(6) You can now drag with the mouse and move the two graphs together.

Note
You can also use the Data log pane or Event log pane to move the graph dis-

play position.

Section 5-2, Log List.
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� Capture indication 

A red line is used to show the time at which a capture trigger was activated.

� Displaying data
� Data display range

The data ranges that can be displayed in graphs are as follows:

-3.402823466e+38 to -1.175494351e-38, 0,

+1.175494351e-38 to +3.402823466e+38

A denormalized floating-point number is displayed as 0.

Infinite (±∞) and nonnumeric data are not displayed as a trend graph and are repre-

sented by "---" in the Trend information pane.

� Display in case of error
If a communication error occurs, graph data is lost, and "---" is displayed for the

cursor value in the Trend information pane.

Capture trigger indication
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If any one of the phenomena below occurs, a vertical divider line appears in the

graph data. For the cursor value in the Trend information pane, the value that is in

effect upon resumption is displayed:

• Cycle startup overrun

• Power turned ON/OFF

• Collection stop/start due to toggling between enable/disable.

• Clock is set forward (advanced)

If the time is set back using the date-time adjustment function, a subsequent graph

may be superimposed on a previous one.
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5-1-3 Trend information pane
The information in each data record (corresponding to 1 GatewayEditor row) of the

selected group can be displayed.

� Screen layout

� Title
"Trend Information" is displayed. Clicking this title toggles the display of the listed

information on and off.

� Information table
• Display check box

Use the check boxes to make graphs of the item visible or invisible. All check

boxes are selected by default. Deselecting a check box makes the item invisible.

• Color

Shows the graph line color for each data item. To display the Color Settings win-

dow, double-click the cell or select it and press [F2]. Then select the desired

color and click OK. 

• Name

Displays the name of each data item.

• Current

Displays the latest position for each data item. The time of the latest position

(MM/DD/YYYY/HH/MM/SS) is shown in the fixed cells at the top, but only if

the real-time monitor is running.

• A

Shows the position of cursor A for each data item. The time for the cursor A

position (MM/DD/YYYY/HH/MM/SS) is shown in the fixed cells at the top.

Column A is displayed only if "Cursor A" is selected under [View] → [Cursor
display].

• B

Shows the position of cursor B for each data item. The time for the cursor B

position (MM/DD/YYYY/HH/MM/SS) is shown in the fixed cells at the top.

Column B is displayed only if "Cursor B" is selected under [View] → [Cursor
display].

• A-B

Shows the difference between the cursor A and cursor B positions for each data

item. The difference between the cursor position times (MM/DD/YYYY/HH/

MM/SS) is shown in the fixed cells at the top. Column A-B is displayed only if

both "Cursor A" and "Cursor B" are selected under [View] → [Cursor display].
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• A'

For each data item, while graph comparison is running, A' shows the position of

cursor A on the shadow (background) graph. The time (MM/DD/YYYY/HH/

MM/SS) for the cursor A position on the graph shadow is shown in the fixed

cells at the top. Column A' is displayed only if "Cursor A" is selected under

[View] → [Cursor display].

• B'

For each data item, while graph comparison is running, B' shows the position of

cursor B on the graph shadow. The time (MM/DD/YYYY/HH/MM/SS) for the

cursor B position on the graph shadow is shown in the fixed cells at the top.

Column B' is displayed only if "Cursor B" is selected under [View] → [Cursor
display].

• (A-A')

Shows the difference between the cursor A positions on the background (shad-

ow) and foreground graphs while graph comparison is running, for each data

item. The time difference between the respective cursor positions

(MM/DD/YYYY/HH/MM/SS) is shown in absolute terms in the fixed cells at

the top. Column A-A' is displayed only if "Cursor A" is selected under [View]

→ [Cursor display].

• (B-B')

Shows the difference between the cursor B positions on the background (shad-

ow) and foreground graphs while graph comparison is running, for each data

item. The time difference between the respective cursor positions

(MM/DD/YYYY/HH/MM/SS) is shown in absolute terms in the fixed cells at

the top. Column B-B' is displayed only if "Cursor B" is selected under [View] →
[Cursor display].

� Procedure
� Changing a graph line color

Do the following to change the color of a line on the displayed graph:

(1) Select the relevant cell from the Color column in the information table.

(2) Click [Edit] → [Change color], or select [Change color] from the pop-up

menu to open the Color Settings window. Alternatively, double-click the cell in

the Color column to open the window.

>> A color selection dialog box appears.

(3) Select the desired color and then click the [OK] button.

� Jumping to a cursor position
You can jump to a cursor position listed in the table in the Trend information pane

by doing the following:

(1) Select "Current" or an item in the "A" or "B" cursor column.

(2) Click [Edit] → [Jump to selection], or select [Jump to selection] from the

pop-up menu. Alternatively, you can double-click the current value or the cur-

sor "A" or "B" column in the fixed cells at the top to open the window.

>> The graph moves to the specified cursor position.
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5-1-4 Range configuration
With this function upper or lower limits can be set for the y-axis (value axis). For a

situation in which two axes are displayed, the user can specify which data is

assigned to which axis.

� Screen layout

� Fixed upper or lower limits check boxes
If the check boxes are not checked, the upper or lower values on the graph are

determined automatically by the maximum or minimum values of the data.

Checking the check box sets a fixed upper or lower limit for the axis.

� Upper or lower limit value
Sets the upper or lower display limit for the axis. The setting range is as follows:

-3.402823466e+38 to -1.175494351e-38, 0,

+1.175494351e-38 to +3.402823466e+38

� Data selection (axis 1)
Shows the items that are displayed on axis 1. Name, Max, and Min are displayed

for each item.

� Data selection (axis 2)
Shows the items that are displayed on axis 2. Name, Max, and Min are displayed

for each item.

� Move to axis 1 or move to axis 2
Move the selected item to the other axis using the two buttons between the

columns.
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� Procedures
� Setting the upper or lower limit value

Use the following steps to set an upper or lower limit value for an axis:

(1) Click [View] → [Range setting].

>> The Range setting window appears.

(2) Check the fixed upper limit or fixed lower limit check box.

(3) Enter a numeric value for the upper or lower limit setting.

(4) Click the [OK] button.

Handling Precautions
• The upper limit setting must be greater than the lower limit setting.

� Setting the display group
For a 2-axis display, use the following steps to allocate data groups to axis 1 or axis

2:

(1) Click [View] → [Range setting].

>> The Range setting window appears.

(2) Select the items you want to move to the other axis. Multiple consecutive items

can be selected by holding down the [Shift] key while clicking on the first and

last items. Multiple non-consecutive items can be selected by holding down the

[Ctrl] key while clicking on them.

(3) Click the appropriate double-arrow button to move items to the other axis.

(4) Click the [OK] button.

� Automatic updating of upper or lower limit value
If the fixed upper or lower limit value check box is unchecked, the upper or lower

limit value is automatically updated on the following occasions, and the graph is

automatically displayed with the new upper or lower limit:

• New data upload 

• [Update] button is pressed

• Data update by real-time monitor

Handling Precautions
• If the minimum value is larger than 0.0, the lower limit value is dis-

played as "0.0".

• If the maximum value is smaller than 0.0, the upper limit value is dis-
played as "0.0".

• If the minimum and maximum values are the same, 1.0 + the lower
limit value is used as the upper limit.
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5-1-5 Configuration of view
� Shared and individual settings

The view configuration screen allows configuration of shared view settings related

to trend graphs and of individual view settings pertaining to trend groups.

� Shared view settings
These items are shared by all data groups. To change the settings, click [View] or

[Tool] → [Environment]. Settings are stored separately for each Windows logon

user and are reflected again the next time LogViewer is started.

� Individual view settings
You can separately set individual view configuration items for each data group.

When switching to another group, the setting for that group is used. A configura-

tion file is stored for each log table file (with a .gwl extension), and is used when-

ever the .gwl file is read. For items whose state is not saved, the default setting is

used when the .gwl file is read.
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Item Remember last state

Trend graph Background mode (black/white) Yes

Grid line display Yes

Data log marker Yes

Event log marker Yes

Grid interval for time axis Yes

Number of grid lines on value axis Yes

Item Remember last state

Trend graph Graph comparison is enabled/disabled No

Lock graph shadow is enabled/disabled No

Upper/lower limit of value axis Yes

Time axis display position Yes

Time axis display ratio Yes

Value axis display position Yes

Value axis display ratio Yes

Cursor position No

Whether display is divided Yes

Vertical division ratio Yes

Trend Visible/invisible status for each data Yes
information item on each graph line.

Value axis to which data item belongs Yes

Data item color Yes
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When various captured trend data in the same data group is displayed, the individ-

ual view settings change as follows:
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Item Individual view settings

Trend graph Graph comparison is enabled/disabled Switched every capture

Lock graph shadow is enabled/disabled Switched every capture

Upper/lower limit of value axis Continues between captures

Time axis display position Switched every capture 

Time axis display ratio Switched every capture

Value axis display position Switched every capture

Value axis display ratio Switched every capture

Cursor position Switched every capture

Whether display is divided Continues between captures

Vertical division ratio Continues between captures

Trend Visible/invisible status for each Continues between captures
information data item on each graph line.

Value axis to which data item Continues between captures
belongs

Color of each data item Continues between captures



5  -  2 Log list

5-2-1 Data log pane
� Screen layout

� Title 
"Data Log" is displayed. Clicking this title toggles the log list on and off (visible/

invisible).

� Date and time
Shows when data was collected.

� Group name
Shows the data group name for the data log.

� Value
Shows the information contained in the data log.

Each data item is separated by ", " (comma and space) and is displayed in the for-

mat: Data name = Value.
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Log list

Title bar
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5-2-2 Event log pane
� Screen layout

� Title
"Event Log" is displayed. Clicking this title toggles the log list on and off (visible/

invisible).

� Date and time
Shows when the event occurred.

� Group name
Shows the data group name for the event log.

� Name
Shows the event name.

� Kind
Tells the kind of event.

• Information

• Warning

• Error

� Status
Tells the bit device status.

• ON (OFF → ON)

• OFF (ON → OFF)

Log list

Title bar
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5-2-3 Operation list
� Display filter

• Group name

• Name (event log only)

• Kind (event log only)

When you click in the fixed top cell of a list, "All" and filterable text is dis-

played in a drop-down list. Filterable text consists of all items that can be displayed

when a filter is not used for the column. For columns which are shown with a filter,

the top fixed cell characters are displayed in blue.

� Jump
You can use the following operation to move the currently displayed trend graph to

a specific target time position:

• Double-click the target item on the list

• While the item is selected, click [Edit] → [Jump to selection].
• While the item is selected, from a pop-up menu, select [Jump to selection].

When you execute jump, the marker displayed on the top of the trend graph (if it is

invisible, it automatically becomes visible) is filled in, and a broken vertical line is

displayed for the time. 

Handling Precautions
• If the specified time does not exist on the graph, the following status

occurs:

• If multiple cells are selected, the focussed cell among those selected
serves as the target of the jump.

• If the CMC15G date/time is adjusted during logging and the time is set
back, the same time may be represented already on a trend graph. If a
jump is executed under these conditions, the trend graph display
jumps to the rightmost time.
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Time before the first time on the Moves the trend graph to the starting
trend graph range position.

Time after the last time on the trend Moves the trend graph to the final 
graph range position and adds a marker at the

final position.



Chapter 6 ONLINE OPERATION
6  -  1 Communication Status Window
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Communication progress is displayed.

� Screen layout

� Processing type
The type of communication processing is shown. Processing types are:

• Read log table

• Clear log table

• Clear capture data

� Communication status
The execution status of the communication is displayed. It varies with the process-

ing type.

� Communication progress
Communication progress is shown by percent and bar graph.

� Cancel
When the [Cancel] button is pressed, communication processing stops.

Handling Precautions
• If a log table is protected with a password, the password must be

entered every time you connect to the CMC15G.
Section 6-7, Entering a Password.

• When a CMC15G project is invalid or the current project does not
have a data group (trend, data log, or event log) related to the log
table, an error message is displayed. 

• If a PC is not connected to the CMC15G, an error message is shown,
and a message saying "Unable to connect" is displayed in the
Communication status space.

Processing type

Communication
status
Communication
progress

Cancel



6  -  2 Uploading New Data

A log table that has been newly recorded in the internal memory of the CMC15G
can be uploaded. In addition, data can be added and a previously saved file can be

saved again.

Section 6-3, Refresh.

� Procedure
Do the following to upload a new log table:

(1) Click [Communications] → [Upload all].

>> If this command is executed while a log table is opened, the currently opened

log table is closed.

>> A communication status window appears and uploading of the log table

begins.

If communication ends normally, the communication status window closes.

The uploaded log table is displayed.

(2) If desired, save the table with [File] → [Save log table].

Handling Precautions
• If the data was not completely uploaded due to a cancellation com-

mand or communication error, the log table is not displayed.

59

PC

CMC15G

Read out

Record
Upload

Upload new data

Uploaded log table
is displayed.

DMC10

4

3

2

1

CH3

CH2

ALM

REC

CH

EV

RESET

USB

LOADER

RUN

4

3

2

1

POWER

CH1

17

16

15

12

RS-232C

CMC15G

11

13

14

RS-485

PLC Read out

Chapter 6. ONLINE OPERATION



6  -  3 Refresh
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You can refresh (update) a CMC15G log table that was previously saved to a file.

� Procedure
Do the following to update the log table:

(1) Open the log table that you want to update on the screen.

(2) From the main menu, click [Communications] → [Refresh].
>> A communication status window appears and reading of the log table begins.

If communication ends normally, the communication status window closes.

The updated log table is displayed.

(3) If desired, save the table with [File] → [Save log table].

Handling Precautions
• The log table cannot be updated if any of the following is true of the

open log table:
•  The file size in bytes exceeds the upper limit.

Section 7-3, File Configuration
•  The total number of captures of all captured trends exceeds 3,000.
•  The total number of data items in the data log exceeds 1,000,000.
•  The total number of data items in the event log exceeds 1,000,000.

• In any of the following cases, the log table cannot be updated because
the open log table and the log table on the CMC15G are determined to
be not identical:

•  The serial numbers of the tables differ.
•  The settings for the trend, data log or event log are different.
•  The number of settings for the trend, data log or event log are dif-

ferent.
• If the log table cannot be updated, save the currently open log table

and then click [Communications] → [Upload all].
• If the data was not completely uploaded due to a cancellation com-

mand or communication error, the data is not added to the existing log
table.

• If the data on the CMC15G is older than the data in the open log table
file, it is not read. Only new data adds and updates the existing file.
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6  -  4 Real-time Monitor

This function reads a log table stored in the internal memory of the CMC15G at a

specified time interval. If the size of the log table exceeds the preset upper limit, the

file is saved to the PC automatically. 

� Procedure
� To start monitoring immediately

(1) While no log table is open, click [Communications] → [Real-time monitor].
>> A communication status window appears and the information is read from

the CMC15G. If communication ends normally, the communication status

window closes.

The log table is read from the CMC15G at the interval specified in the

Environment configuration.

(2) If selection of the real-time monitor is canceled, reading at the specified interval

is stopped.

Handling Precautions
• If the real-time monitor is started while no log table is open, the data

read when the monitor starts becomes the initial data in a new log
table. Data that is on the CMC15G before the real-time monitor starts
is not read.

• The real-time monitor will stop operating if the file size reaches the
preset upper limit. The data will not be automatically saved.

� To save data automatically
(1) Click [Communications] → [Upload all].

>> A communication status window appears and the information on the

CMC15G is read. If communication ends normally, the communication sta-

tus window closes.

(2) Click [File] → [Save log table] to save the log table file.

(3) Click [Online] → [Real-time monitor].
>> The log table is read from the CMC15G at the interval specified in

Environment configuration, and when the preset file size upper limit is

reached, the file is saved automatically.
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Handling Precautions
• When you open a log table and start real-time monitoring, LogViewer

reads data continuously from the CMC15G, starting immediately after
the latest data in the log table. However, if data is missing because the
CMC15G is set to overwrite the oldest data in the internal memory,
there will be a gap in the data in the saved log table.

� Saving files automatically
If a log table exceeds the file upper limit, the data read from CMC15G is automat-

ically saved to a file. Exceeding the file size upper limit can occur in a number of

ways.

• The file size in bytes exceeds the upper limit.

Section 7-3, File Configuration.

• The total number of captures of all captured trends exceeds 3,000.

• The total number of data items in the data log exceeds 1,000,000.

• If the total number of data items in the event log exceeds 1,000,000, the file size

upper limit ranges from 10 MB to 1 GB, and the initial value is 100 MB.

For the correct settings,

Section 7-3, File Configuration.

The name used for the saved file is the user-specified file name plus the

time (year, month, day, hour, minute, and second), formatted as yyyymmd-

dhhmmss.

Example: XXXX20071231235959.gwl

Handling Precautions
• If any of the conditions below occur, real-time monitoring will stop with-

out saving data automatically. In that case, click [File] → [Save log
table as]. Note that if you do not manually save the data, the log table
on the CMC15G may be overwritten and lost.

• Real-time monitoring was executed while the log table file was
closed.

• A file with the same name already exists.
• The specified destination does not have enough space for the file.

• The total number of characters in the path and file name exceeds
255.

• During real-time monitoring, do not connect to another LogViewer
using the CMC15G's serial port.
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� Screen updating while data is read
The scroll bar range of the time axis is updated while data is read. Updating of the

graph and of the display at the scroll bar position may differ depending on the dis-

played position.

• If the time at the far right of the screen is later than the latest data:

A graph of the newly read data is continually created. The time axis display

position is not updated.

• If the time on the rightmost side in the screen matches the time of the latest data:

A graph of the newly read data is continually created as the older part of the

graph is pushed to the left. For the display position of the time axis, the time on

the rightmost side is changed to match the latest time.

• If the time at the rightmost side of the screen is earlier than the latest data:

The display is not updated because the newly read data is outside the field of

view. The time axis display position is also not updated.
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6  -  5 Clearing a Log Table on the CMC15G
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A log table on the CMC15G can be cleared by LogViewer. All continuous trend, captured trend, event log and data

log data is deleted. Communication error history and operation history are not deleted.

� Procedure
(1) Click [Communications] → [Clear CMC15G log tables].

>> A confirmation dialog box appears.

(2) Click [OK].

>> A communication status window appears and clearing of the log table

begins.

If communication ends normally, the communication status window closes.

Handling Precautions
• If log table protection is activated on the CMC15G, you must enter a

password to clear the log table.
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6  -  6 Clearing a Captured Trend on the CMC15G

LogViewer can clear captured trend data from the CMC15G.

� Procedure
(1) Click [Communications] → [Clear capture data in CMC15G].

>> A confirmation message box appears.

(2) Click [OK].
>> A communication status window appears and clearing of the captured trend

begins. If communication ends normally, the communication status window

closes.

Handling Precautions
• If log table protection is activated on the CMC15G, you must enter a

password to clear the captured trend data.
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6  -  7 Entering a Password
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If log table protection is activated on the CMC15G, a password screen appears when you attempt an online opera-

tion. The project cannot be modified online if the password does not match. This window does not appear if log

table protection is not turned on.

� Screen layout

� Entering a password
Enter the password for log table protection, which was previously set for the pro-

ject on the CMC15G. A maximum of 16 characters can be entered.

� OK
When you click the [OK] button, the password is checked against the one previous-

ly set on the CMC15G. If the password matches, the project can be operated

online.

� Cancel
Cancels the request for online operation.

Password
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Chapter 7 ENVIRONMENT CONFIGURATION
7  -  1 Communication Configuration

67

Communication configuration sets up the connection between the CMC15G and the PC.

� Screen layout

� Interface selection
Select the communication interface on the PC that is connected to the CMC15G.

• USB

• Serial port

The initial setting is USB.

� Communication port selection
If you set Serial port as the interface selection, select the COM port that is connect-

ed to the CMC15G. The initial value for the port is the port that is found first. If no

COM port is found, there is no initial value, and "---" is displayed.

Note
• The communication configuration is stored in a separate file for each Windows

logon user.

PC Interface selection

Communication port selection



Graph-related characteristics can be configured. The settings described in this section apply to all data groups.

� Screen layout

� Time axis grid width
Specify the grid width of the time (horizontal) axis in dots.

The setting range is 50 to 200, and the initial value is 100.

� Value axis scale count
Specify the scale count on the value (vertical) axis. The setting range is 2 to 20 and

the initial value is 10.

� Copy graph with label
If this box is checked, when a graph is copied to the clipboard, the data name and

line color information are added next to the graph.

Note
• The view configuration is stored in a separate file for each Windows logon user.

Time axis grid width

Value axis scale count

Copy graph with label

7  -  2 View Configuration
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7  -  3 File Configuration
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Parameters for file saving and real-time monitoring can be configured.

� Screen layout

� Upper limit of file size
Specify a file size limit in megabytes for saved read-out data. Automatic saving of

data during real-time monitoring will be governed by this limit. The setting range is

10 to 1000, with an initial value of 100.

� Real-time monitor cycle time
Specify the interval at which the real-time monitor should read data. The setting

range is 10 to 600 seconds, and the initial value is 10.

Note
• The file configuration is stored in a separate file for each Windows logon user.

Upper limit of file size (megabyte)

Real-time monitor cycle time (second)



Chapter 8 SPECIFICATIONS
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� Specifications
Item Specifications

Communications CH1 RS-232C, full duplex (half duplex protocol), cable length 15 m or less,
D-Sub 9-pin, max. transmission speed 115.2 kbps

CH2 RS-485, 5-wire system full duplex (half duplex protocol), cable length
500 m or less, 7-pin connector (5 pins used), max. transmission speed
115.2 kbps

CH3 RS-485, 3-wire system half duplex, cable length 500 m or less, con-
nector 7-pin connector (3 pins used), max. transmission speed 19.2 kbps

CH4 RS-485, 3-wire system half duplex, cable length 500 m or less, screw
terminals on the base, max. transmission speed 38.4 kbps

USB USB 2.0-based full speed (12 Mbps) mini-B, 5-pin

Digital signal Number of signals 4
I/O bus Function Outputs the logical sum (OR) of the same bus event outputs from each

DMC10.

General Rated power voltage 24 Vdc
specifications Operating power voltage 21.6 to 26.4 Vdc

Power consumption 3 W or less

Insulation resistance Min. 20 MΩ by 500 Vdc megger (between each I/O terminal and 24
Vdc power terminals)

Dielectric strength 500 Vac for 1 min. (between case and 24 Vdc power terminals)

Isolation All communications lines are isolated from power lines. Individual
communications channels are not isolated from each other. Individual
EV buses are not isolated from each other, but are isolated from
communications.

Built-in clock accuracy Within ± 40 s per month (reference value at 25 ˚C)

Memory backup Min. 5 years (at 25 ˚C)

Operating condition Ambient temp.: 0 to 50 ˚C. Ambient humidity: 30 to 90 % RH

Transport/storage Ambient temp.: –20 to +70 ˚C. Ambient humidity: 10 to 95 % RH
conditions Vibration resistance: Max. 4.9 m/s2

Impact resistance: Max. 392 m/s2 for screw mount
Max. 196 m/s2 for DIN rail mount

Package drop test: Drop height 60 cm, free fall

Screw tightening torque Power terminals and CH4 communication terminals: 0.8 to 1.0 N•m

Mounting DIN rail mount or screw mount

Materials Mask, case, base: polycarbonate

Color Mask: navy blue, Case: light gray, Base: light gray

Mass Approx. 200 g

Standards compliance EN61326

Accessories User's Manual (No.CP-UM-5463JE)

CH2, CH3 communication connector (handles both channels)

Maintenance parts Battery model No.: 81446431-001

Software Smart Loader Package (GatewayEditor) model No.: SLP-G15J50
Smart Loader Package (LogViewer) model No.: SLP-G15LGV
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� External dimensions
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� Diagnosis using the indicator status
The CMC15G's indicator lights notify the user if an error occurs.

� POWER indicator

� ALARM indicator

� RUN indicator

� REC indicator

ALM

RECRUN

POWER

CH1 RS-232C

POWER indicator

RUN indicator

ALARM indicator

REC indicator

Status Meaning Corrective action

Green CMC15G power is ON. —

Off CMC15G power is OFF. Turn ON the power.

Orange Backup battery voltage is low. Replace the backup battery.
User's manual No. CP-SP-

1277E Chapter 13, Maintenance.

Status Meaning Corrective action

Off The CMC15G is running normally. —

Red An error occurs in the self- If the ALARM indicator is lit red,
diagnosis. turn OFF the power and then turn

it ON again, or reset the CMC15G
with the RESET button. 
If the alarm still appears, contact a
Yamatake salesperson.

Status Meaning Corrective action

Off CMC15G functions have stopped. To change to RUN mode, use the
GatewayEditor.

User's manual No. CP-SP-
1277E 10-2-5, Operation mode
change (page 10-12).

Green CMC15G functions are running. —

Flashing The PC (SLP, etc.) is communica- To switch from through-communi-
green ting with the controller through cation mode to RUN mode, run

the CMC15G by loader through- ThroughComm.exe.
communication. User's manual No. CP-SP-

1277E 7-6, Loader through-
communication (page 7-10).

Status Meaning Corrective action

Off Not recording. —

Green Trend is being recorded. —

Flashing CMC15G notifies that the capture —
green table exists.
(1 s 
intervals)

Flashing CMC15G notifies that the capture —
green memory is full.
(200 ms 
intervals)
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� Error diagnosis using the CH1 to CH4 indicators
The indicators show whether there was a communication error.

Four indicators corresponding to the COM ports to which the modules are connect-

ed indicate the communication status of each module.

* For example, a communication request occurs when there is a periodic data

transmission or when a trigger device initiates module setup. Additionally, since

the CMC15G monitors trigger devices periodically, if a host station device is set

as a trigger device, it is normal for the indicator of the channel connected to the

host station to be flashing frequently.

CH

LOADER

4

3

2

1

RS 485

CH1 communication status

CH2 communication status

CH3 communication status

CH4 communication status

Status Meaning Corrective action

Off No communication If the indicator is not lit even
though there is a communication
request*, the communication
parameters may be incorrect.
Using GatewayEditor, check the
communication parameters for the
target channel.

Flashing Communicating —
green

Orange No response, or error in received Any of the following may be the 
message cause:

•  Wrong wiring
•  Wrong communication configu-

ration (station address, trans-
mission speed, parity, etc.)

•  The communication parameters 
(data address, data area, etc.) 
are incorrect. Depending upon 
the device, mode, and condi-
tions, it may not be possible to 
write data.

Using the GatewayEditor's Online
monitor, identify the module with
the communication error, and
check the wiring and the
communication configuration and
parameters.

User's manual No. CP-SP-
1277E 10-2-4, Online monitor
(page 10-10).
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� Corrective actions if an error occurs

Context Symptom Cause Corrective action
(activity)

General Data collection does not If the enabled-disabled setting If the REC indicator is not green
logging start. results in "disabled" status, the while the continuous trend or
functions data collection is not started. captured trends function is running,

the enabled-disabled setting has
disabled the process, or other set-
tings are incorrect.
Check the cycle(s) and enabled-dis-
abled setting.
Check also the trigger device in the
captured trends or data log.

All data is not collected The interval for data collection is Extend the collection interval.
completely. too short for the volume of data. If a CMC15G communication error

occurred, it can be checked using
the online monitor or communica-
tion error history.

All data is not collected If a power failure occurs, data is Check the operation history in
completely. handled discontinuously. GatewayEditor to see whether a

power ON (power turned OFF, and
then turned ON again) occurred.

When downloading with If the volume of internal memory Adjust the settings on the basis
GatewayEditor, the backup used by all logging functions of all groups or logging functions
memory size exceeded the exceeds the capacity of the so that internal memory usage
high limit, and the trans- CMC15G, downloading is not does not exceed the maximum
mission of configuration executed. level.
data to the CMC15G was The usage volume is indicated by
stopped. the color of the backup memory

usage ratio display in Gateway-
Editor. If the color is red, the mem-
ory usage exceeds the capacity.
Additionally, you can check the
number of bytes set for the memory
under the project information in
GatewayEditor.

Captured Even though triggers for all After a trigger starts up but before Change the conditions for trigger
trends captures are turned ON, its data has been saved, there is occurrence using an internal event
function the capture memory does another trigger. on the PLC or CMC15G.

not fill up. Triggers that are activated before Also, if you increase the number of
data saving is complete are ignored. records saved after the initial trig-

ger, more data can be obtained
even though the second trigger is
ignored.

LogViewer The real-time monitor The real-time monitor does not save Change the file name, remaining
stopped. data automatically if any of the capacity of the disk, or file path so

following conditions occurs: that the data is saved automatically.
• A file with the same name already
exists.

• There is insufficient space at the
file destination.

• The number of characters in the
full path name for the file exceeds
255 characters.
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Terms and Conditions
We would like to express our appreciation for your purchase and use of Yamatake products.
You are required to acknowledge and agree upon the following terms and conditions for your purchase of Yamatake
products (field instruments, control valves, and control products), unless otherwise stated in any separate document,
including, without limitation, estimation sheets, written agreements, catalogs, specifications and instruction manuals.

1. Warranty period and warranty scope
1.1 Warranty period

Yamatake products shall be warranted for one (1) year from the date of your purchase of the said products or the
delivery of the said products to a place designated by you.

1.2 Warranty scope
In the event that Yamatake product has any failure attributable to Yamatake during the aforementioned warranty
period, Yamatake shall, without charge, deliver a replacement for the said product to the place where you
purchased, or repair the said product and deliver it to the aforementioned place.
Notwithstanding the foregoing, any failure falling under one of the following shall not be covered under this
warranty:

(1) Failure caused by your improper use of Yamatake product
(noncompliance with conditions, environment of use, precautions, etc. set forth in catalogs, specifications,
instruction manuals, etc.);

(2) Failure caused for other reasons than Yamatake product;
(3) Failure caused by any modification or repair made by any person other than Yamatake or Yamatake's

subcontractors;
(4) Failure caused by your use of Yamatake product in a manner not conforming to the intended usage of that

product;
(5) Failure that the state-of-the-art at the time of Yamatake's shipment did not allow Yamatake to predict; or
(6) Failure that arose from any reason not attributable to Yamatake, including, without limitation, acts of God,

disasters, and actions taken by a third party.
Please note that the term "warranty" as used herein refers to equipment-only-warranty, and Yamatake shall not
be liable for any damages, including direct, indirect, special, incidental or consequential damages in connection
with or arising out of Yamatake products.

2. Ascertainment of suitability
You are required to ascertain the suitability of Yamatake product in case of your use of the same with your
machinery, equipment, etc. (hereinafter referred to as "Equipment") on your own responsibility, taking the
following matters into consideration:

(1) Regulations and standards or laws that your Equipment is to comply with.
(2) Examples of application described in any documents provided by Yamatake are for your reference

purpose only, and you are required to check the functions and safety of your Equipment prior to your use.
(3) Measures to be taken to secure the required level of the reliability and safety of your Equipment in your use

Although Yamatake is constantly making efforts to improve the quality and reliability of Yamatake
products, there exists a possibil i ty that parts and machinery may break down.
You are required to provide your Equipment with fool-proof design, fail-safe design, anti-flame
propagation design, safety design, or the like so that the said Equipment may satisfy the level of the
reliability and safety required in your use, whereby preventing any occurrence of physical injuries, fires,
significant damage, and so forth.

3. Precautions and restrictions on application
Yamatake products other than those explicitly specified as applicable (e.g. Yamatake Limit Switch For Nuclear
Energy) shall not be used in a nuclear energy controlled area (radiation controlled area).
Any Yamatake products shall not be used for/with medical equipment.
In addition,
you are required to conduct a consultation with our sales representative and understand detail specifications,
cautions for operation, and so forth by reference to catalogs, specifications, instruction manual , etc. in case that
you intend to use Yamatake product for any purposes specified in (1) through (6) below.
Moreover, you are required to provide your Equipment with fool-proof design, fail-safe design, anti-flame
propagation design and other designs of protection/safety circuit on your own responsibility to ensure the
reliability and safety, whereby preventing problems caused by failure or nonconformity.

(1) For use under such conditions or in such environments as not stated in technical documents, including
catalogs, specification, and instruction manuals

(2) For use of specific purposes, such as:
* Nuclear energy/radiation related facilities

[For use outside nuclear energy controlled areas] [For use of Yamatake Limit Switch For Nuclear Energy]
* Machinery or equipment for space/sea bottom
* Transportation equipment

[Railway, aircraft, vessels, vehicle equipment, etc.]
* Antidisaster/crime-prevention equipment
* Burning appliances
* Electrothermal equipment
* Amusement facilities

(3) Supply systems such as electricity/gas/water supply systems, large-scale communication systems, and
traffic/air traffic control systems requiring high reliability

(4) Facilities that are to comply with regulations of governmental/public agencies or specific industries
(5) Machinery or equipment that may affect human lives, human bodies or properties
(6) Other machinery or equipment equivalent to those set forth in items (1) to (5) above which require high

reliability and safety



4. Precautions against long-term use
Use of Yamatake products, including switches, which contain electronic components, over a prolonged period may
degrade insulation or increase contact-resistance and may result in heat generation or any other similar problem
causing such product or switch to develop safety hazards such as smoking, ignition, and electrification.
Although acceleration of the above situation varies depending on the conditions or environment of use of the
products, you are required not to use any Yamatake products for a period exceeding ten (10) years unless
otherwise stated in specifications or instruction manuals.

5. Recommendation for renewal
Mechanical components, such as relays and switches, used for Yamatake products will reach the end of their life
due to wear by repetitious open/close operations.
In addition, electronic components such as electrolytic capacitors will reach the end of their life due to aged
deterioration based on the conditions or environment in which such electronic components are used.
Although acceleration of the above situation varies depending on the conditions or environment of use, the
number of open/close operations of relays, etc.
as prescribed in specifications or instruction manuals, or depending on the design margin of your machine or
equipment, you are required to renew any Yamatake products every 5 to 10 years unless otherwise specified in
specifications or instruction manuals.
Field instruments (sensors such as pressure/flow/level sensors, regulating valves, etc.) will reach the end of their
life due to aged deterioration of parts.
For those parts that will reach the end of their life due to aged deterioration, recommended replacement cycles are
prescribed. You are required to replace parts based on such recommended replacement cycles.

6. Other precautions
Prior to your use of Yamatake products, you are required to understand and comply with specifications (e.g.,
conditions and environment of use), precautions, warnings/cautions/notices as set forth in the technical documents
prepared for individual Yamatake products, such as catalogs, specifications, and instruction manuals to ensure the
quality, reliability, and safety of those products.

7. Changes to specifications
Please note that the descriptions contained in any documents provided by Yamatake are subject to change
without notice for improvement or for any other reason.
For inquires or information on specifications as you may need to check, please contact our branch offices or sales
offices, or your local sales agents.

8. Discontinuance of the supply of products/parts
Please note that the production of any Yamatake product may be discontinued without notice.
For repairable products, we will, in principle, undertake repairs for five (5) years after the discontinuance of those
products. In some cases, however, we cannot undertake such repairs for reasons, such as the absence of repair
parts.
For field instruments, we may not be able to undertake parts replacement for similar reasons.
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